Subject: [IPP] Localizing Preset names - possible erratum for IPP Presets registration

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Fri, 26 Jan 2018 20:54:19 +0000

Greetings,

I have discovered a nuance with IPP Preset name localization that we might need to resolve. IPP Presets says this about localization:

4.1.1.1 preset-name (keyword | name(MAX))

This attribute provides a unique name for the Preset. Values can be localized using the message catalog provided at the URL specified by the “printer-strings-uri” Printer Description attribute [PWG5100.13]. 

This is really not correct. PWG 5100.13 (JPS3) section 9.1 "Message Catalog File Format", says that attribute names, enum values, and keywords can be localized using the Message Catalog. But name and text values are presumed to already be localized. So what this really ought to say is:

4.1.1.1 preset-name (keyword | name(MAX))

This attribute provides a unique name for the Preset. Keyword values can be localized using the message catalog provided at the URL specified by the “printer-strings-uri” Printer Description attribute [PWG5100.13]. Names are assumed to be localized already based on the language specified in the "attributes-natural-language" operation attribute specified in each IPP operation.

And we don't have any keywords registered...so maybe it should be further simplified to remove "keyword" and discussion of localization? Unfortunately, we don't have errata on Registrations currently. :/

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Sat, 27 Jan 2018 17:07:58 -0500

Smith,

I don't think an errata is necessary - we use this convention with a LOT of attributes so it should be obvious that localization happens with the keyword values and not the (presumably local) name values (which by definition are already localized...)

As for the lack of registered keywords, that is fine - this isn't a type2 keyword attribute so no registration is possible...

> On Jan 26, 2018, at 3:54 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Greetings,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer