Subject: [IPP] Updates to MFD Alerts for "warming-up" or "cooling-down"?

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 23 Jan 2018 21:53:55 +0000

Greetings,

In our November 2018 vF2F, we discussed an issue I raised about how IPP could convey via "printer-state-reasons" transient non-critical states such as "warming-up" or "cooling-down". It was suggested in the F2F minutes (http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20171115.pdf <http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20171115.pdf>) that we should consider an update to MFD Alerts:

https://ftp.pwg.org/pub/pwg/candidates/cs-pmpmfdalerts10-20120629-5107.3.pdf <https://ftp.pwg.org/pub/pwg/candidates/cs-pmpmfdalerts10-20120629-5107.3.pdf> 
https://ftp.pwg.org/pub/pwg/candidates/cs-pmpmfdalerts10-20120629-5107.3.doc <https://ftp.pwg.org/pub/pwg/candidates/cs-pmpmfdalerts10-20120629-5107.3.doc> 

I am willing to start updating this if that is the place to do it. But I wanted to confirm this as the appropriate direction. Is this what is needed? Or would simple registrations work just as well, at least for IPP?

Thanks for your thoughts,

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Wed, 24 Jan 2018 00:21:23 -0500

Hi Smith,

MFD Alerts is the highest priority major errata update!

It needs significant work on correcting the advice about Printer MIB alerts
(w/ their
separate severity object) versus IPP alerts (which use a severity suffix in
the same
string).  Also some missing scanner alerts (per Canon).

Also, I *forgot* to ever IANA register the Printer MIB updates (hundreds)
in 2012
when I left Samsung - OOPS!

Document needs to be poured into the new template (by hand cut-and-paste).

If you'd like to co-edit this errata update, I'd be delighted, but it's not
a small job.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Jan 23, 2018 at 4:53 PM, Kennedy, Smith (Wireless & Standards
Architec) <[email-masked]> wrote:

> Greetings,
>
> In our November 2018 vF2F, we discussed an issue I raised about how IPP
> could convey via "printer-state-reasons" transient non-critical states such
> as "warming-up" or "cooling-down". It was suggested in the F2F minutes (
> http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20171115.pdf)
> that we should consider an update to MFD Alerts:
>
> https://ftp.pwg.org/pub/pwg/candidates/cs-pmpmfdalerts10-
> 20120629-5107.3.pdf
> https://ftp.pwg.org/pub/pwg/candidates/cs-pmpmfdalerts10-
> 20120629-5107.3.doc
>
> I am willing to start updating this if that is the place to do it. But I
> wanted to confirm this as the appropriate direction. Is this what is
> needed? Or would simple registrations work just as well, at least for IPP?
>