Subject: [IPP] Interest in developing an "IPP for Dummies" document?

From: "Zehler, Peter" <[email-masked]>
Date: Wed, 3 Jan 2018 16:47:51 +0000

All,
I had some time and took a swing at some introduction text.  I added some initial text for description of IPP, model, encoding and transport as well as the associated references  I created a pull request (Update Intro.md #1).
Pete

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701
Email: [email-masked]<mailto:[email-masked]>
Office: +1 (585) 265-8755<tel:%2B1%20%28585%29%20265-8755>
Fax: +1 (585) 422-0238<tel:%2B1%20%28585%29%20265-8755>
Mobile: +1 (585) 329-9508<tel:%2B1%20%28585%29%20329-9508>

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 08 Jan 2018 11:57:11 -0500

Pete,

Thanks for taking a pass at this!

I like the intro text but don't think the historical background and detailed references belong here.

The references all belong in the document map appendix.

The historical background is interesting but I'm not sure the target reader (application/client developer) will necessarily find it useful for writing an IPP application/client.  For lack of a better analogy, this is supposed to be a car mechanic's manual and not The Art of Computer Programming.

> On Jan 3, 2018, at 11:47 AM, Zehler, Peter <[email-masked]> wrote:
> 
> All,
> Email: [email-masked]
> Office: +1 (585) 265-8755
> Fax: +1 (585) 422-0238
> Mobile: +1 (585) 329-9508
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 8 Jan 2018 19:27:12 +0000

Mike,
One of the things I need is a document that a manager or produce planner can read to move them away from Port 9100 and lpr to a proper protocol.  We have an implementers guide to help the application/client developer.  We don't have anything for the product decision makers
Pete
________________________________
From: [email-masked] <[email-masked]> on behalf of Michael Sweet <[email-masked]>
Sent: Monday, January 8, 2018 11:57:11 AM
To: Zehler, Peter
Cc: [email-masked]
Subject: Re: [IPP] Interest in developing an "IPP for Dummies" document?

Pete,

---

From: Michael Sweet <[email-masked]>
Date: Mon, 08 Jan 2018 16:08:32 -0500

Pete,

I think the various (IPP) certification programs have gone a long way towards making IPP support fairly ubiquitous - billions of mobile devices that only support IPP certainly make a strong business statement.  But I'll agree that we haven't been able to get the legacy protocols killed - a lot of customers and integrators spent years developing custom solutions based on them, making it hard to justify removing support from new products if it means alienating existing customers.

Anyways, if we also want to target PHBs I think that needs to happen in a separate document/white paper.  Ordinarily I'd suggest customer success stories and the like, but I know there has been resistance to outright evangelism/marketing by the PWG...  Let's talk a bit about this at the next IPP WG conference call.

> On Jan 8, 2018, at 2:27 PM, Zehler, Peter <[email-masked]> wrote:
> 
> Mike,