Subject: [IPP] Updated draft of IPP Job Save Password posted for review and discussion

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 6 Feb 2018 00:13:51 +0000

Greetings,

I have just posted an updated draft of IPP Job Save Password. It is available here:

   https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205.pdf <https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205.pdf> 
   https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205.odt <https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205.odt>
   https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205-rev.pdf> 
   https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205-rev.odt <https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20180205-rev.odt> 

Although I think that the changes I have made to produce this new draft have resolved some of the points of feedback from the last review on Dec. 14, 2017, these changes may still not have resolved these issues. Here are the minutes from the last meeting:

Comments from IPP mailing list:
Section 1: some mention of job-password being a Job Template attribute, but it is an operation attribute (which is correctly noted in subsequent sections
Section 4.2: Any password attribute needs to be protected, so these should be operation attributes and not Job Template...
Section 6: Will obviously need a lot of discussion of how to protect and handle the passwords.
Overall I'm still not sure about the use case for this, or how it would all work together. Is this an extension of "job-save-disposition", where the password would be used for the saved document? If so,I'd recommend that the attributes be called "job-save-password[-xxx]" to make that clearer, and add some discussion of that.
Also, how does a Client re-print the saved job? Resubmit-Job with "document-password"?
Maybe we need to refactor this: "job-save-accesses (1setOf collection)" attribute to provide credentials for saving to a URI like we do for document-access (INFRA) and destination-accesses (FaxOut).
Don't specify an IPP way to do the "allow another user to reprint the saved content", e.g. Smith saves to network storage and then grants access to Bob through an out-of-band interface
Encryption isn't a requirement, but access control *is*
Two use cases for save + reprint:
Using an IPP client to look at saved jobs and resubmit through IPP
Reprint through printer console (most common scenario for HP)
Reprint user may or may not be the person that submitted the original job

Please review the draft and come to discuss this in the session on Wednesday afternoon at the February 2018 vF2F.

Cheers,

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Tue, 06 Feb 2018 09:27:47 -0500

Smith,

Thanks for this, I will update the F2F slide accordingly...

FWIW, the current text still adds the save password to job-save-disposition which has the unfortunate security implication of exposing the password as part of the job ticket.  I also think we still need to better define the use cases and flow of information - not only for definition of the attribute(s) but for the security considerations.  Finally, I think our discussions on encrypted documents may overlap with this one... :/

> On Feb 5, 2018, at 7:13 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Greetings,
> 
> [email-masked] <mailto:[email-masked]>

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 6 Feb 2018 19:41:59 +0000

Hi Mike,

Responding below - feel free to reserve your responses until the session tomorrow.

Smith

> On Feb 6, 2018, at 7:27 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
> FWIW, the current text still adds the save password to job-save-disposition which has the unfortunate security implication of exposing the password as part of the job ticket.

Details like this are still difficult for me to follow. I'm working on writing an "IPP Attribute Design Principles and Design Patterns" document now (I've said I wanted to do this for a couple of years), to try to organize and grow my understanding in this area, and to document it for posterity because the implications of selecting an attribute's group is unfortunately quite obscure and very nuanced.

>  I also think we still need to better define the use cases and flow of information - not only for definition of the attribute(s) but for the security considerations.

Perhaps those can come out in the discussion, at least a more detailed list of aspects you feel need to be covered but aren't currently.

>  Finally, I think our discussions on encrypted documents may overlap with this one... :/

I totally agree, and I have an updated draft of that waiting to be posted. I will just post it and if we end up looking at use cases from that tomorrow then I'm fine with that. Originally I was thinking that this might be a stepping stone to IPP Document Encryption, which could likely solve both needs.

>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 06 Feb 2018 15:12:52 -0500

Smith,

> On Feb 6, 2018, at 2:41 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hi Mike,
> 
>> On Feb 6, 2018, at 7:27 AM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Smith,
>> 

Maybe I should put together a slide that explains this...  Anyways, here is a quick breakdown:

    Operation-Attributes Used in       Associated with    Copied to
    Job Creation Requests              Job/Doc Object?    Job/Doc Ticket?
    ---------------------------------  ----------------   -------------
    attributes-charset                 No                 No (note 1)
    attributes-natural-language        Yes (note 2)       Yes (note 2)
    compression                        No                 No
    destination-accesses               Yes                No (note 3)
    document-access                    Yes                No (note 3)
    document-charset                   Yes                Yes
    document-digital-signature         Yes                Yes
    document-format                    Yes                Yes
    document-format-details            Yes                Yes
    document-message                   Yes                Yes
    document-metadata                  Yes                Yes
    document-name                      Yes                Yes
    document-natural-language          Yes                Yes
    document-password                  Yes                No (note 3)
    input-attributes                   Yes                Yes
    ipp-attribute-fidelity             No                 No (note 4)
    job-authorization-uri              Yes                No (note 3)
    job-hold-until                     Yes                Yes
    job-impressions                    Yes                Yes (note 5)
    job-impressions-col                Yes                Yes (note 5)
    job-k-octets                       Yes                Yes (note 5)
    job-media-sheets                   Yes                Yes (note 5)
    job-media-sheets-col               Yes                Yes (note 5)
    job-name                           Yes                Yes
    job-password                       Yes                No (note 3)
    job-password-encryption            Yes                No (note 3)
    job-resource-ids                   Yes                Yes
    last-document                      No                 No
    output-attributes                  Yes                Yes
    printer-uri                        Yes                Yes
    requesting-user-vcard              Yes                Yes (note 5)
    requesting-user-name               Yes                Yes (note 5)
    requesting-user-uri                Yes                Yes (note 5)

    Note 1: Printer might need to transcode from request charset to/from internal charset. 
    Note 2: Text/name strings are tagged with original language in object, so responses may either use the same attributes-natural-language value OR use nameWithLanguage and textWithLanguage for strings that are so tagged.
    Note 3: Security credentials MUST BE protected in transit and at rest and are NOT copied to the Job/Document Ticket.
    Note 4: Attribute fidelity is evaluated once at Job Creation time.
    Note 5: Most-authenticated/validated value is copied to Job/Document Ticket.