Subject: [IPP] IPP WG Agenda 3:00-4:30pm US Eastern (7 June 2018)

From: Ira McDonald <[email-masked]>
Date: Thu, 7 Jun 2018 13:05:55 -0400

Hi,

[Sorry for delay in agenda posting - wrestling w/ computer problems]

Our next IPP WG call will be Thursday 7 June 2018 at
12:00-1:30pm US Pacific / 3:00pm-4:30pm US Eastern

NOTE: Please USE the *new* WebEx and Audio Bridge below

-------------------------------------------------------
Meeting information
-------------------------------------------------------
Topic: IPP WG
Every 2 weeks on Thursday, from Thursday, May 11, 2017, to no end date
3:00 pm  |  Eastern Standard Time (New York, GMT-05:00)  |  1 hr 30 mins

-------------------------------------------------------
WebEx online meeting (join first, before audio bridge)
-------------------------------------------------------
1. Go to https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m0359478143
ca01e059a570ada91f3573
2. If requested, enter your name and email address.
3. If a password is required, enter the meeting password: Printing123
4. Click "Join".

-------------------------------------------------------
Audio Bridge (join second w/ unique access code from WebEx)
-------------------------------------------------------
Call-in toll-free number (US/Canada): +1 866 469-3239 <%28866%29%20469-3239>
Call-in toll number (US/Canada): +1 650 429-3300 <%28650%29%20429-3300>
Call-in toll number (US/Canada): +1 408 856-9570 <%28408%29%20856-9570>

Global toll-free call in numbers and other audio options ("Call Me Back" or
VoIP) are listed once you join the WebEx meeting.

Unique attendee access code:  Displayed in the WebEx meeting

Agenda:
(1) PWG IP Policy, Minute Taker, Roll Call, and Agenda Review
- Mike as minute taker?

(2) Approve IPP minutes from previous meetings
- http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20180426.pdf
-- IPP WG call on 04/26/18
- http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20180515.pdf
-- IPP WG at PWG F2F on 05/15/18 to 05/17/18

(3) Status/Review of various IPP mailing list notes
- http://www.pwg.org/archives/ipp/2018/019610.html
-- New Java implementation of IPP from HP Inc announced on 05/18/18

(4) Status of Open Printing WG GSoC 2018 (Ira)
- https://ftp.pwg.org/pub/pwg/liaison/openprinting/presentations/
TheLinuxFoundationGSoC-2018.pdf
-- good progress on all projects - some questions, but all are getting
resolved
-- DONE - 14 May - GSoC coding begins
-- 11-15 June - GSoc Phase 1 evaluations by Mentors and Students
-- 9-13 July - GSoc Phase 2 evaluations by Mentors and Students
-- 6-14 August - GSoC final week
-- 14-21 August - Mentors submit final Student evaluations
-- 22 August - GSoC announces final results

(5) Status of AMSC and ISO liaisons w/ PWG (Paul)
- https://ftp.pwg.org/pub/pwg/general/Plenary/pwg-plenary-may-2018.pdf
-- see PWG Plenary slides from May PWG F2F

(6) Status/Review of Safe G-Code (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-pwgsafegcode10-20180604-rev.pdf
- http://www.pwg.org/archives/ipp/2018/019614.html
-- Prototype draft - IPP WG review during PWG F2F May 2018
-- Note - link above works! - link in archive message is broken!
-- Schedule - TBD

(7) Status of How to Print Using the IPP (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippguide-20180430.html
- https://github.com/istopwg/pwg-books
-- IPP WG review during PWG F2F May 2018
-- Current HTML draft available in Github repository
-- Schedule - TBD

(8) Status of IPP HTTP Authentication whitepaper (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-ippauth-20180510.pdf
-- Interim draft - IPP WG review during PWG F2F May 2018
-- Schedule - TBD

(9) Discussion of IPP Encrypted Jobs and Documents
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20180328-rev.pdf
- http://www.pwg.org/archives/ipp/2018/019613.html
- https://lists.gnupg.org/pipermail/gnupg-users/2018-May/060315.html
-- Interim draft - IPP WG review during PWG F2F May 2018
-- good news - 06/04/18 - PGP-based path forward!
-- Schedule - TBD

(10) Status of IPP System Service (Ira/Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20180425-rev.pdf
- http://www.pwg.org/archives/ipp/2018/019604.html
- https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-wg-agenda-may-18.pdf
- https://github.com/istopwg/ippsample/projects/1
-- Prototype draft - IPP WG review during PWG F2F May 2018
-- Prototyping tasks being tracked as a Github project
-- Schedule - prototype in "ippserver" - Stable draft in Q2/Q3 2018

(11) Status of IPP Reprint Password (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippreprintpwd-20180424-rev.pdf
- http://www.pwg.org/archives/ipp/2018/019586.html
-- Interim draft - IPP WG review during PWG F2F May 2018
-- Schedule - TBD

(12) Status of IPP Everywhere Printer Self-Certification 1.0 Update 3?
- http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20180515.pdf
-- Goals, ipptool and ippfind updates
-- Schedule - TBD

(13) Status/Review of IPP Everywhere 1.1 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180606-rev.pdf
- http://www.pwg.org/archives/ipp/2018/019617.html
-- Interim draft - IPP WG review during PWG F2F May 2018
-- Schedule - Q2/Q3 2018

(14) Status/Review of IPP Everywhere 1.1 Self-Certification Manual 1.1
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeveselfcert11-20180606-rev.pdf
- http://www.pwg.org/archives/ipp/2018/019617.html
-- Interim draft - IPP WG review during PWG F2F May 2018
-- Schedule - Q2/Q3 2018

(15) Next steps

- IPP WG call on Thu 21 June 2018 at 3:00-4:30pm US Eastern
-- regular topics

- IPP WG call on Thu 5 July 2018 at 3:00-4:30pm US Eastern ???
-- slides for Joint PWG/OP F2F in Sunnyvale, CA

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Thu, 7 Jun 2018 14:43:30 -0400

Hi,

OOPS - added a key topic to top of agenda

On Thu, Jun 7, 2018 at 1:05 PM, Ira McDonald <[email-masked]>
wrote:

> Global toll-free call in numbers and other audio options ("Call Me Back"
> or VoIP) are listed once you join the WebEx meeting.
>

(2.5) Status/Review of IPP 3D Printing Extensions v1.1 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipp3d11-20180605-rev.pdf
-- Initial draft - for IPP WG review
-- Note - Cover page and header not updated (still say April)

> - https://ftp.pwg.org/pub/pwg/liaison/openprinting/presentatio
> ns/TheLinuxFoundationGSoC-2018.pdf