Subject: [IPP] IANA registry issues noted

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 19 Jun 2018 17:47:25 +0000

Hi there,

I was updating my private copy spreadsheets of the IANA IPP Registry and observed the following entries in the registry where "Reference" information has bled back into the "Syntax" column, with problematic text highlighted in RED:

Attributes:

Name				Member Attribute	Sub-member Attribute		Syntax												Reference
platform-temperature											integer(-273:MAX) [PWG5100.NN]							[PWG5100.21]
finishings-col			stitching			stitching-method			type2 keyword]  [PWG5100.1]								[PWG5100.1]
platform-temperature											integer(-273:MAX) [PWG5100.NN]							[PWG5100.21]
folding-offset-supported(extension)								1setOf (integer(0:MAX) | rangeOfInteger(0:MAX))  [PWG5100.1]	[PWG5100.1]

Keywords:

Attribute						Keyword 		Value	Syntax
finishing-template-supported							1setOf (type2 keyword | name(MAX)) [PWG5200.FIN]

I am aware of a few IPP implementations that generate source code based on the IANA registry. These types of issues might cause problems for such implementations, so I'm reporting them.

Cheers,

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 20 Jun 2018 08:32:46 -0400

Smith,

Thanks, I'll add this to my TODO list for the next registry update.  I'll also look into doing a better job of stripping the reference when I import lines from the text-based registration templates in the register utility.

> On Jun 19, 2018, at 1:47 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Wed, 20 Jun 2018 14:15:59 +0000

Thanks Mike! I also found the second line for "job-finishings-supported" in the Enum table has '<enum values are the same as the "finishings">' in the Name column but I think that should be in the Value column. Let me know if there is anything I can do to help with the updates.

Smith

> On Jun 20, 2018, at 5:32 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 20 Jun 2018 13:32:24 -0400

Smith,

Thanks, I'll take a quick look at that to make sure everything lines up.

> On Jun 20, 2018, at 10:15 AM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 20 Jun 2018 17:05:44 -0400

... and after a bit of churn and normalizing a bunch of different forms of '<Any "xxx" value>' this is now all up-to-date on the PWG site.  I'll send an IANA update once we have consensus on the new media sizes.

> On Jun 20, 2018, at 1:32 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
>