Subject: [IPP] IPP Finishings enums

From: "Rizzo, Christopher" <[email-masked]>
Date: Mon, 8 Oct 2018 16:31:30 +0000

Dear Ladies and Gents,

Is it possible to request (is PWG IPP Workgroup accepting) proposals for new enums for IPP Finishing functionality that is not currently supported by the existing enums, so that the new functionality can be supported thru finishings, finishings-supported, etc.?

Or can any new IPP Finishing functionality only be implemented via the newer finishings-col, finishings-col-supported, and finishings-col-database?

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Suite 200
Wilsonville, OR 97070-9251
Phone: (503) 582-7577
Intelnet: 8*872-7577
Cube: 7060-Z22-C
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Mon, 8 Oct 2018 16:43:22 +0000

Hi Chris,

Please do go ahead and propose new enums for "finishings-supported". The group will review them and approve or reject as appropriate.

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Oct 8, 2018, at 10:31 AM, Rizzo, Christopher <[email-masked]> wrote:
> 
> Dear Ladies and Gents,
>  
> Email: [email-masked] <mailto:[email-masked]>
>  
> [email-masked] <mailto:[email-masked]>
> https://protect-us.mimecast.com/s/GQMeClYLnLikBX59CGAFPz?domain=pwg.org <https://protect-us.mimecast.com/s/GQMeClYLnLikBX59CGAFPz?domain=pwg.org>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 08 Oct 2018 20:37:14 -0400

Chris,

I think it would still be appropriate to support both finishings and finishings-col for new *kinds* of finishings, but IMHO we shouldn't add enum values for variations of existing finishings.

> On Oct 8, 2018, at 12:31 PM, Rizzo, Christopher <[email-masked]> wrote:
> 
> Dear Ladies and Gents,
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Rizzo, Christopher" <[email-masked]>
Date: Tue, 9 Oct 2018 03:05:48 +0000

Michael,  Smith

Understood.  Thank you for your feedback.

Chris

Christopher Rizzo
Xerox Corporation

On 10/8/18, 5:37 PM, "[email-masked] on behalf of Michael Sweet" <[email-masked]> wrote:

    Chris,