Subject: Re: [IPP] Extending .strings files / IPP convention to support "tool tips"?

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Tue, 23 Oct 2018 14:24:53 +0000

What you described below is very similar to what I was imagining – a suffix of some type to establish the connection between the tooltip and the label with which it is associated. I hadn’t thought about the help angle, but I like that too!
 
Posting this response to the reflector, so we can discuss in the IPP WG.
 
Smith

From: Michael Sweet <[email-masked]> on behalf of Michael Sweet <[email-masked]>
Date: Wednesday, October 3, 2018 at 9:01 AM
To: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Subject: Re: Extending .strings files / IPP convention to support "tool tips"?
 
Smith, 
 
It's an interesting idea, although I think it we will still need to limit the tooltip to plain Unicode text (vs. some sort of rich text/markup).  A simple solution would be to define a convention like adding a "._tooltip" to the attribute name/attribute.value string, e.g.:
 
    "foo" = "Foo";
    "foo._tooltip" = "This is the tooltip for Foo.";
    "foo.value1" = "Primary Foo";
    "foo.value1._tooltip" = "This is the tooltip for Primary Foo.";
    "foo.value2" = "Secondary Foo";
    "foo.value2._tooltip" = "This is the tooltip for Secondary Foo.";
 
The advantage of using "_tooltip" as the identifier is that attribute and keyword values cannot start with the underscore.  Conceptually we could include multiple such extensions ("_helpurl", etc.) to provide some of the same features we have in PPDs on macOS.
 
Initially we can just propose and document it in a white paper, but ultimately I think we'd want to make this part of a JPS3 errata update.

On Oct 3, 2018, at 12:31 AM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
 
Hi Mike,

We have interest in finding a way to get support for adding localized tool tips to the .strings files, to go along with the localized label strings. Any thoughts on this? I don't think this is covered by 5100.13. The convention for associating a tool tip with a particular label string will need some additional work.

WDYT?

Smith

/**
   Smith Kennedy
   Wireless & Standards Architect - IPG-PPS
   Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
   Chair, IEEE ISTO Printer Working Group
   HP Inc.
*/

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Tue, 23 Oct 2018 16:05:21 -0400

Hi Smith and Mike,

Cool idea.  I like it and think we should pursue standardizing it.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Oct 23, 2018 at 10:25 AM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> What you described below is very similar to what I was imagining – a
> suffix of some type to establish the connection between the tooltip and the
> label with which it is associated. I hadn’t thought about the help angle,
> but I like that too!
>
>
>
> *From: *Michael Sweet <[email-masked]> on behalf of Michael Sweet <
> [email-masked]>
> *Date: *Wednesday, October 3, 2018 at 9:01 AM
> *To: *"Kennedy, Smith (Wireless & Standards Architect)" <
> [email-masked]>
> *Subject: *Re: Extending .strings files / IPP convention to support "tool
> tips"?
>
>
>
> Smith,
>
>
>
> It's an interesting idea, although I think it we will still need to limit
> the tooltip to plain Unicode text (vs. some sort of rich text/markup).  A
> simple solution would be to define a convention like adding a "._tooltip"
> to the attribute name/attribute.value string, e.g.:
>
>
>
>     "foo" = "Foo";
>
> The advantage of using "_tooltip" as the identifier is that attribute and
> keyword values cannot start with the underscore.  Conceptually we could
> include multiple such extensions ("_helpurl", etc.) to provide some of the
> same features we have in PPDs on macOS.
>
>
>
> Initially we can just propose and document it in a white paper, but
> ultimately I think we'd want to make this part of a JPS3 errata update.
>
>
>
>
>
> On Oct 3, 2018, at 12:31 AM, Kennedy, Smith (Wireless & Standards
> Architect) <[email-masked]> wrote:
>
>
>
> Hi Mike,
>
> We have interest in finding a way to get support for adding localized tool
> tips to the .strings files, to go along with the localized label strings.
> Any thoughts on this? I don't think this is covered by 5100.13. The
> convention for associating a tool tip with a particular label string will
> need some additional work.
>
> WDYT?
>
> Smith
>
> /**
>    Smith Kennedy