Subject: [IPP] RFC: Recommended Attributes/Specs for IPP Everywhere?

From: Michael Sweet <[email-masked]>
Date: Mon, 14 Jan 2019 12:04:17 -0500

All,

Continuing the discussion from the minutes of the November F2F:

- Q: Should we list recommended attributes?
  - job-password-repertoire-supported, jpeg-features-supported, some others
  - Would also make sense for IPP Privacy Attributes
  - A: Continue discussion on the mailing list, get closure on final list to add
  - Could also reference/recommend additional specs that could be used in addition to IPP Everywhere for specific functionality:
    - IPP Transaction-Based Printing - enterprise/managed printing
    - IPP Shared Infrastructure Extensions - cloud printing

Looking at the current set of specs and registrations, it seems like there is nothing to add for the Shared Infrastructure Extensions - a Cloud implementation would look the same as a local one to a Client.

Aside from the Transaction-Based Printing extensions attributes, we can include the IPP Privacy Attributes and job-presets-supported from IPP Job Presets.

We could also add the Get-User-Printer-Attributes operation from the IPP GUPA registration but I am not aware of any implementations (yet)...

Proposed Changes
----------------

Section 3.1 (Rationale)

- Add references to 5100.16 (TRANS) and PRESETS and PRIVACY registrations

Section 5.3 (IPP Printer Description Attributes)

- Add a separate table of RECOMMENDED Printer Description attributes:
  - job-privacy-attributes, job-privacy-scope, printer-privacy-policy-uri
  - job-account-type-default/-supported and job-authorization-uri-supported (for printers that support paid printing services)
  - job-password-repertoire-supported (for printers that support the print-to-recipient use case)
  - job-presets-supported
  - jpeg-features-supported, jpeg-k-octets-supported, jpeg-x-dimension-supported, jpeg-y-dimension-supported (for printers that support JPEG printing)
  - pdf-k-octets-supported, pdf-versions-supported (for printers that support PDF printing)
  - print-scaling-default/-supported
  - printer-dns-sd-name (for printers that support DNS-SD)

Section 5.5 (IPP Operation Attributes)

- Add a separate table of RECOMMENDED operation attributes:
  - job-authorization-uri and job-impressions-estimated (for printers that support paid printing services)

Section 5.8 (IPP Job Template Attributes)

- Add a separate table of RECOMMENDED Job Template attributes:
  - job-account-type (for printers that support paid printing services)
  - print-scaling

Section 15.1 (Normative References)

- Add references to 5100.16 (TRANS) and PRESETS and PRIVACY registrations

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Mon, 14 Jan 2019 20:42:35 +0000

Hi Mike,

No objections - I think your outline below looks good!

Smith

> On Jan 14, 2019, at 10:04 AM, Michael Sweet <[email-masked]> wrote:
> 
> All,
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/AbKRCpYK0KiZgXBlUDZo5h?domain=pwg.org>