Subject: [IPP] New draft of IPP Authentication Methods posted

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Wed, 9 Jan 2019 15:52:50 +0000

Greetings,

I've posted another incremental draft of IPP Authentication Methods to the PWG FTP site:

   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.pdf
   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.odt
   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.pdf
   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.odt

This revision adds mention of the "oauth-authorization-server-uri" Printer Description attribute and a reference to PWG 5100.18 (IPP INFRA) since that attribute is listed in the sequence diagram. The -rev is compared against the last reviewed revision (20181109).

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Mon, 14 Jan 2019 20:44:51 +0000

Greetings again,

I'm hoping that we can discuss using this revision to start the Working Group Last Call. I'd like to discuss that at this week's IPP WG teleconference.

Cheers,

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Jan 9, 2019, at 8:52 AM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Greetings,
> 
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.pdf <https://protect-us.mimecast.com/s/uzILCG6xjxh8MNqWf0XCEE?domain=ftp.pwg.org>
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.odt <https://protect-us.mimecast.com/s/4AthCJ6AmAhnYWypSpuctY?domain=ftp.pwg.org>
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.pdf <https://protect-us.mimecast.com/s/H-M4CKrBnBF1ny98un4Vsi?domain=ftp.pwg.org>
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.odt <https://protect-us.mimecast.com/s/9IQ9CL9DoDC31DXNu1lOBQ?domain=ftp.pwg.org>
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/T6qyCM8gpgIJZy9xuRN1ni?domain=pwg.org>

---

From: Ira McDonald <[email-masked]>
Date: Wed, 16 Jan 2019 12:05:33 -0500

Hi Smith,

This *should* have been labeled Prototype (not current Interim) and there
should be an email Prototype report (e.g.,"this spec documents all of the
existing IPP Authentication Methods, all of which have implementations")
so that, by voice approval, we can move it to Stable draft and WG LC.

Bear in mind that, for a Best Practices document, we actually also need
PWG LC *and* PWG Formal Vote (not just PWG Call for Objections),
because this is a new spec and not errata and that's our process for
Best Practices documents.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Jan 14, 2019 at 3:45 PM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> Greetings again,
>
> I'm hoping that we can discuss using this revision to start the Working
> Group Last Call. I'd like to discuss that at this week's IPP WG
> teleconference.
>
> Cheers,
>
> Smith
>
> /**
>     Smith Kennedy
>     HP Inc.
> */
>
> <https://protect-us.mimecast.com/s/uzILCG6xjxh8MNqWf0XCEE?domain=ftp.pwg.org>
> <https://protect-us.mimecast.com/s/4AthCJ6AmAhnYWypSpuctY?domain=ftp.pwg.org>
> <https://protect-us.mimecast.com/s/H-M4CKrBnBF1ny98un4Vsi?domain=ftp.pwg.org>
> <https://protect-us.mimecast.com/s/9IQ9CL9DoDC31DXNu1lOBQ?domain=ftp.pwg.org>
>
> This revision adds mention of the "oauth-authorization-server-uri" Printer
> Description attribute and a reference to PWG 5100.18 (IPP INFRA) since that
> attribute is listed in the sequence diagram. The -rev is compared against
> the last reviewed revision (20181109).
>
> Smith
>
> /**
> Smith Kennedy
> HP Inc.
> */
>
> <https://protect-us.mimecast.com/s/T6qyCM8gpgIJZy9xuRN1ni?domain=pwg.org>
>
>

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Wed, 16 Jan 2019 17:22:30 +0000

Hi Ira,

> On Jan 16, 2019, at 10:05 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> This *should* have been labeled Prototype (not current Interim)

I remembered that when I started editing but forgot to change it. I will that change and post an updated draft to nudge that forward.

> and there

I know HP products have supported 'none', 'requesting-user-name', 'basic', and 'digest'. I suppose I need to solicit feedback from other members on whether the authentication methods not implemented by HP might be implemented by them? Has any other vendor or project implemented support for 'negotiate', 'oauth', or 'certificate'?

> Best Practices documents.

Thanks - I forgot about that. Even better reason to finish it off.

> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/kkl1Cqx5v5uYOlwpiZjrr9?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/6kLeCrk5w5fQAoJ5tz_F-q?domain=sites.google.com>
> mailto: [email-masked] <mailto:[email-masked]>
> On Mon, Jan 14, 2019 at 3:45 PM Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> Greetings again,
> 
>> On Jan 9, 2019, at 8:52 AM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Greetings,
>> 
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.pdf <https://protect-us.mimecast.com/s/31gpCv25A5hwWKVDtzMnAi?domain=ftp.pwg.org>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.odt <https://protect-us.mimecast.com/s/aDqhCwp5B5IlL9rDtKc97H?domain=ftp.pwg.org>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.pdf <https://protect-us.mimecast.com/s/9N7YCxk5D5fEJwN2tRnLQj?domain=ftp.pwg.org>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.odt <https://protect-us.mimecast.com/s/V84ZCyP5E5uONkVltAlOXd?domain=ftp.pwg.org>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/Kp0_Czp5G5IWR9V0CBcuVp?domain=pwg.org>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/Kp0_Czp5G5IWR9V0CBcuVp?domain=pwg.org>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 16 Jan 2019 13:38:14 -0500

Ira,

I don’t think Process/3.0 requires prototyping for non-standards track documents. All I see is a prototyping requirement for candidate standards.

Sent from my iPhone

> On Jan 16, 2019, at 12:22 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Hi Ira,
> 
>>> On Mon, Jan 14, 2019 at 3:45 PM Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
>>> Greetings again,
>>>

---

From: Ira McDonald <[email-masked]>
Date: Wed, 16 Jan 2019 15:18:20 -0500

Hi Mike,

Prototype is not required for a Best Practice, but it's been done.

NOTHING in Process/3.0 or our PWG tradition says that, in fact,
everything has to be prototyped.  A simple email from Smith that
says what HP has implemented would be a plus.  Apple CUPS
has certainly done 'negotiate' and 'certificate' right?  What about
'oauth'?

But specs that get Formal Vote do need to go Interim --> Prototype
--> Stable (and not just LC/Vote on Interim).   I'd be happy to say that
the current draft was *meant* to be Prototype and voice vote it into
Stable for WG LC.

Cheers,
- Ira

On Wed, Jan 16, 2019 at 2:09 PM Michael Sweet <[email-masked]> wrote:

> Ira,
>
> I don’t think Process/3.0 requires prototyping for non-standards track
> documents. All I see is a prototyping requirement for candidate standards.
>
> Sent from my iPhone
>
> I remembered that when I started editing but forgot to change it. I will
> that change and post an updated draft to nudge that forward.
>
> and there
> I know HP products have supported 'none', 'requesting-user-name', 'basic',
> and 'digest'. I suppose I need to solicit feedback from other members on
> whether the authentication methods not implemented by HP might be
> implemented by them? Has any other vendor or project implemented support
> for 'negotiate', 'oauth', or 'certificate'?
>
>
> <https://protect-us.mimecast.com/s/kkl1Cqx5v5uYOlwpiZjrr9?domain=sites.google.com>
> <https://protect-us.mimecast.com/s/6kLeCrk5w5fQAoJ5tz_F-q?domain=sites.google.com>
>> <https://protect-us.mimecast.com/s/31gpCv25A5hwWKVDtzMnAi?domain=ftp.pwg.org>
>> <https://protect-us.mimecast.com/s/aDqhCwp5B5IlL9rDtKc97H?domain=ftp.pwg.org>
>> <https://protect-us.mimecast.com/s/9N7YCxk5D5fEJwN2tRnLQj?domain=ftp.pwg.org>
>> <https://protect-us.mimecast.com/s/V84ZCyP5E5uONkVltAlOXd?domain=ftp.pwg.org>
>>
>> This revision adds mention of the "oauth-authorization-server-uri"
>> Printer Description attribute and a reference to PWG 5100.18 (IPP INFRA)
>> since that attribute is listed in the sequence diagram. The -rev is
>> compared against the last reviewed revision (20181109).
>>
>> Smith
>>
>> /**
>> Smith Kennedy
>> HP Inc.
>> */
>>
>> <https://protect-us.mimecast.com/s/Kp0_Czp5G5IWR9V0CBcuVp?domain=pwg.org>
>>
>>
>> <https://protect-us.mimecast.com/s/Kp0_Czp5G5IWR9V0CBcuVp?domain=pwg.org>
>>
>
>

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Wed, 16 Jan 2019 20:25:08 +0000

I just posted an updated draft with the "prototype" status:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116.pdf> 
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116.odt <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116.odt> 
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116-rev.pdf> 
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116-rev.odt <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190116-rev.odt> 

I'll post a "new draft" notification, and either include prototype statement within and/or separately next.

Smith

> On Jan 16, 2019, at 1:18 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/168dCNkjqjfkZGOAcmDqAK?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/NmIWCOYkrki1Ny7JIvWMjx?domain=sites.google.com>
> On Wed, Jan 16, 2019 at 2:09 PM Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
> Ira,
> 
> On Jan 16, 2019, at 12:22 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi Ira,
>> 
>>> On Jan 16, 2019, at 10:05 AM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi Smith,
>>> 
>>> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/168dCNkjqjfkZGOAcmDqAK?domain=sites.google.com>
>>> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/NmIWCOYkrki1Ny7JIvWMjx?domain=sites.google.com>
>>>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.pdf <https://protect-us.mimecast.com/s/GZp4CPNlvlcz0kjOS1CgkJ?domain=ftp.pwg.org>
>>>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109.odt <https://protect-us.mimecast.com/s/iBeeCQWmwmFvXy28Fk1Gg4?domain=ftp.pwg.org>
>>>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.pdf <https://protect-us.mimecast.com/s/FPA7CR6nxnh4GzMJsq5_Rl?domain=ftp.pwg.org>
>>>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippauth-20190109-rev.odt <https://protect-us.mimecast.com/s/WXATCVOrBrcq2RW7skM5-K?domain=ftp.pwg.org>
>>>> 
>>>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/Wku1CW6vDvhr6WM2i1fD3k?domain=pwg.org>
>>> 
>>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/Wku1CW6vDvhr6WM2i1fD3k?domain=pwg.org>
>>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 16 Jan 2019 16:09:39 -0500

Ira,

> On Jan 16, 2019, at 3:18 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 

We have the code to support 'certificate' but have not shipped a cupsd that supports it. Similarly, code to allow 'oauth' to be used was added in 2.2.7 or so but nothing uses it yet.  'requesting-user-name', 'basic', 'digest', and 'negotiate' have been implemented for a very long time.

Anyways, since this document is just referencing already-defined values for specs that have already been prototyped and documenting how to best implement then, I think we've satisfied any implied prototyping requirement.

> the current draft was *meant* to be Prototype and voice vote it into

Again, Process/3.0 has always been vague about the "prototype" status of non-standards-track documents - initial, interim, and stable are all called out but not prototype... :/

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Wed, 16 Jan 2019 21:57:56 +0000

> On Jan 16, 2019, at 2:09 PM, Michael Sweet <[email-masked]> wrote:
> 
> Ira,
> 
>> On Jan 16, 2019, at 3:18 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Mike,
>> 

I'm re-engaging on Process/4.0 in case you both were wondering to resolve this and other issues... 😊