Subject: [IPP] Fwd: [TLS] TLS 1.3 in iOS

From: Ira McDonald <[email-masked]>
Date: Mon, 28 Jan 2019 20:28:28 -0500

Hi,

Bit of good news about TLS 1.3 deployment from the Apple iOS team.

Cheers,
- Ira

---------- Forwarded message ---------
From: Tommy Pauly <tpauly=[email-masked]>
Date: Mon, Jan 28, 2019 at 8:20 PM
Subject: [TLS] TLS 1.3 in iOS
To: [email-masked] <[email-masked]>

Hi all,

Last week, we shipped the first developer seed of iOS 12.2. Among other
features, TLS 1.3 is now enabled by default for the entire system. All
users of Network.framework and NSURLSession APIs will now negotiate TLS
1.3. The number of TLS 1.3 capable clients on the Internet should take
quite a leap forward, and we are pleased to help move the needle towards
faster and more secure network connections.

We'd like to thank the members of this working group, and Eric Rescorla in
particular, for all the work put into this protocol and its deployment on
the Internet.

Enjoy!

—Tommy
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 28 Jan 2019 22:02:00 -0500

All,

FWIW, for a variety of reasons CUPS does not use Network.framework, which is a relatively new thing on macOS/iOS. So while I am very happy that Safari and other generic HTTPS clients on macOS/iOS are able to use TLS 1.3, this does not mean that CUPS and IPP will use TLS 1.3... :(

> On Jan 28, 2019, at 8:28 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> Last week, we shipped the first developer seed of iOS 12.2. Among other features, TLS 1.3 is now enabled by default for the entire system. All users of Network.framework and NSURLSession APIs will now negotiate TLS 1.3. The number of TLS 1.3 capable clients on the Internet should take quite a leap forward, and we are pleased to help move the needle towards faster and more secure network connections. 
> 
> We'd like to thank the members of this working group, and Eric Rescorla in particular, for all the work put into this protocol and its deployment on the Internet.
> 
> Enjoy!
> 
> —Tommy

_________________________________________________________
Michael Sweet, Senior Printing System Engineer