Subject: [IPP] RFC: Errata Update of PWG 5100.3: IPP Production Printing Attributes

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 29 Apr 2019 16:23:07 -0400

All,

Last year's GSoC projects identified some minor issues with PWG 5100.3: IPP Production Printing Attributes. I propose we do an errata update of PWG 5100.3 and volunteer to serve as editor. Changes would include:

- Remove references to the original page overrides spec (5100.4)
- Remove/reword a lot of “implementation-defined” content
- Remove finishings-col - now defined in PWG 5100.1-2017: IPP Finishings 2.1
- Remove new media values (superseded by PWG 5101.1-2012: PWG Media Standardized Names v2.0)
- Obsolete the "current-page-order" Job attribute which gets updated as the document data is transformed to reflect the new page order
- Obsolete the "user-defined-values-supported" Printer attribute as we now (properly) use the IANA IPP registry and well-defined extension semantics for keyword values
- More clearly define the "imposition-template" Job Templates, and possibly add standard values for watermarking and/or borders
- Update the document template, add missing sections, and update references.

Additionally, there are some Job Template attributes (job-account-id, job-accounting-user-id, job-sheets-col, and media-col) which are not specific to production printing.  Since everything in this specification is optional (...) it might make sense to move them to the IPP Job Extensions v2.0 specification (which is currently in PWG Last Call but could be pulled back) so that we can make them required/conditionally required as appropriate.

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Mon, 29 Apr 2019 20:41:22 +0000

Hi Mike,

I support all of these moves. Thanks for your efforts!

If others have differing opinions, or have problems with obsoleting "current-page-order" or "user-defined-values-supported", please speak up!

Smith

/**
    Smith Kennedy
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Apr 29, 2019, at 2:23 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/Aml3Cqx5v5uqZpOEIXBk2_?domain=pwg.org>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Mon, 29 Apr 2019 17:01:56 -0400

Hi Mike,

I agree with all your proposed changes.

You didn't propose what to do about it.  But for Production Printing Set-1
to be at all useful,
there really *should* be some REQUIRED and RECOMMENDED attributes and a
minimum
of actual OPTIONAL attributes - perhaps w/ some feature grouping?

The rest of IPP Production Printing (e.g., IPP/2.2) builds on this spec -
perhaps building sand
castles?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Apr 29, 2019 at 4:41 PM Kennedy, Smith (Wireless & Standards
Architect) via ipp <[email-masked]> wrote:

> If others have differing opinions, or have problems with
> obsoleting "current-page-order" or "user-defined-values-supported", please
> speak up!
>
> Smith
>
> /**
>     Smith Kennedy
> Last year's GSoC projects identified some minor issues with PWG 5100.3:
> IPP Production Printing Attributes. I propose we do an errata update of PWG
> 5100.3 and volunteer to serve as editor. Changes would include:
>
> - Obsolete the "current-page-order" Job attribute which gets updated as
> the document data is transformed to reflect the new page order
> - Obsolete the "user-defined-values-supported" Printer attribute as we now
> (properly) use the IANA IPP registry and well-defined extension semantics
> for keyword values
> - More clearly define the "imposition-template" Job Templates, and
> possibly add standard values for watermarking and/or borders
> Additionally, there are some Job Template attributes (job-account-id,
> job-accounting-user-id, job-sheets-col, and media-col) which are not
> specific to production printing. Since everything in this specification is
> optional (...) it might make sense to move them to the IPP Job Extensions
> v2.0 specification (which is currently in PWG Last Call but could be pulled
> back) so that we can make them required/conditionally required as
> appropriate.
>
> Thoughts?
>
> <https://protect-us.mimecast.com/s/Aml3Cqx5v5uqZpOEIXBk2_?domain=pwg.org>
>
>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Mon, 29 Apr 2019 21:27:40 +0000

Agree with your points as well, Ira! Feature grouping and conformance requirements would be a welcome improvement.

> On Apr 29, 2019, at 3:01 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> You didn't propose what to do about it.  But for Production Printing Set-1 to be at all useful,
> there really *should* be some REQUIRED and RECOMMENDED attributes and a minimum
> The rest of IPP Production Printing (e.g., IPP/2.2) builds on this spec - perhaps building sand
> castles?
> 
> Cheers,
> - Ira
> 
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/BJ1vCQWmwmF0OP6qIxqHeL?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/Wj-xCR6nxnh2EWrlfNEPAF?domain=sites.google.com>
> mailto: [email-masked] <mailto:[email-masked]>
> On Mon, Apr 29, 2019 at 4:41 PM Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Mike,
> 
>> On Apr 29, 2019, at 2:23 PM, Michael Sweet via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> All,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/9abnCVOrBrcG3ylKfyqrDs?domain=pwg.org>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/9abnCVOrBrcG3ylKfyqrDs?domain=pwg.org>