Subject: [IPP] Mopria Alliance Question: Obsoleting document-format details

From: Kevin Schader via ipp <[email-masked]>
Date: Wed, 10 Apr 2019 19:15:45 -0700

Hello,

Could the PWG please provide details on the rationale for obsoleting the
document-format-details attribute in section 10.2 of the IPP Document Object
v1.1 draft specification?

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippdocobject11-20190318-rev.pdf

Best Regards,

Kevin

Kevin A. Schader

Executive Director

Mopria Alliance

 <http://www.mopria.org/> www.mopria.org 

Global Inventures, Inc., a SmithBucklin Company

Accelerating Results Through CollaborationR

2400 Camino Ramon, Suite 375, San Ramon, CA 94583, USA

T: +1.925.275.6672 | F: +1.925.275.6691 | M: +1.925.389.7377

 <http://www.inventures.com/> www.inventures.com

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 11 Apr 2019 02:27:37 +0000

Hi Kevin,

Bill Wagner wrote a description of the situation with "document-format-details" earlier today. I've included it inline below your query. Please respond with your concerns or questions.

Cheers,
Smith

/**
    Smith Kennedy
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

On Apr 10, 2019, at 8:15 PM, Kevin Schader via ipp <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Could the PWG please provide details on the rationale for obsoleting the document-format-details attribute in section 10.2 of the IPP Document Object v1.1 draft specification?
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippdocobject11-20190318-rev.pdf<https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippdocobject11-20190318-rev.pdf>

Best Regards,

Kevin

Kevin A. Schader
Executive Director
Mopria Alliance
www.mopria.org<http://www.mopria.org/>
Global Inventures, Inc., a SmithBucklin Company
Accelerating Results Through Collaboration®
2400 Camino Ramon, Suite 375, San Ramon, CA 94583, USA
T: +1.925.275.6672 | F: +1.925.275.6691 | M: +1.925.389.7377
www.inventures.com<http://www.inventures.com/>

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

Begin forwarded message:

From: wamwagner--- via ipp <[email-masked]<mailto:[email-masked]>>

Subject: [IPP] Issue of document-format-details Attribute

Date: April 10, 2019 at 4:05:18 PM MDT

To: PWG IPP Workgroup <[email-masked]<mailto:[email-masked]>>

Cc: PWG Steering Committee <[email-masked]<mailto:[email-masked]>>

Reply-To: <[email-masked]<mailto:[email-masked]>>

I have presented here my understanding of an issue which I believe needs more discussion.

At the IPP Workgroup Session of the February face-to-face on February 13, 2019, the following points were made  in the presentation  of  Errata Updates to the  IPP Document Object v1.1 specification

"The "document-format-details", "document-format-details-detected", "document-format-version", and "document-format-version-detected " Document Status attributes are obsolete because these attributes have poor interoperability (no registered values, no standard value formats) and have serious privacy issues."

and in the presentation of updates to  the IPP Job Extensions v1.1 specification.

"The "document-format-details" and "document-format-version" attributes are obsolete because these attributes have poor interoperability (no registered values, no standard value formats) and have serious privacy issues."

Discussion considered the use of  "document-format-details" with respect to job accounting, and the recommendation  was to use document-metadata instead. Contributions relative to job accounting were invited.

There have been some messages about a Job Accounting replacement for  "document-format-details", and a Job Accounting BoF has been scheduled for  the April face-to-face  at 3:45 PM to 5:00 PM on April 17. There was little discussion relative to the contention that these attributes were or should be made obsolete. Although it is understood that to make them officially obsolete would require statements in a formally approved standards track PWG specification, it is reasonable that with no objection, such statements would be included in one or more of the specifications being developed.

However, at least one PWG member has recently objected to  proceeding with making  "document-format-details"  and "document-format-details-supported" attributes obsolete, presumably because these attributes are being used.

First, it might be desirable to consider the attributes. “document-format-details” is  both a document status and an operation attribute,  and is of the collection type, consisting of 8 members.
document-format-details (1setOf collection)
document-source-application-name (name(MAX)) 17
document-source-application-version (text(127)) 17
document-source-os-name (name(40)) 17
document-source-os-version (text(40)) 17
document-format (mimeMediaType) 18
document-format-device-id (text(127)) 18
document-format-version (text(127)) 18
document-natural-language (1setOf naturalLanguage)

“document-format-details-supported”  (1setOf keyword) is a printer description attribute, with the keywords corresponding to the members of “document-format-details”

Although the proposal to obsolete attributes did not include "document-format-details-supported ", since document-format-details-supported  and several other attributes (e.g., "document-format-details-default", "document-format-details-detected", "document-format-details-supplied") refer to 'document-format-details", these would also need to be made obsolete.

It is understood that the request is to not obsolete or depreciate the "document-format-details" operation attribute or its members (except document-format-device-id), and to not obsolete or deprecate the "document-format-details-supported"  printer description attribute or its keywords (except document-format-device-id). It is unclear whether the request extends to the “document-format-details” document attribute.

The argument to obsolete these attributes is that some members of the "document-format-details" collection have "poor interoperability (no registered values, no standard value formats) and have serious privacy issues." The poor interoperability stems from their "text" and "name" data types.
Text and Name syntaxes are used for attributes intended for human communication and may be presented in the selected natural language. It is understood that such attributes may not be interoperable from an automata viewpoint.  The fact that these attributes were so typed reflected a tradeoff  of human readability vs machine interoperability. If machine interoperability is required,  then indeed some more appropriate attributes should be used. But that does not necessarily diminish that value of these attributes.
With regard to privacy issues, I would like to see more discussion since it unclear to me what they might be.

I hope that this outline prompts comment from both sides to encourage better understanding at the April face-to-face meeting.
Thanks, Bill Wagner

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp