Subject: [IPP] Fate of "document-format-details" attribute

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 17 Apr 2019 16:15:47 -0400

All,

The following represents the consensus of those attending the IPP workgroup session at the April 2019 PWG Face-to-Face meeting concerning the "document-format-details" attribute and its related attributes:

- All of the definitions of the attribute will be moved to the IPP Job Extensions v2.0 specification update in development

- The "document-format-details" attribute will be DEPRECATED (still available for use) and will be reduced to the "collection" syntax (just a single value). This is compatible at the wire level and reflects that there are no uses for multiple values in a single document.

- The "document-format", "document-format-version", and "document-natural-language" member attributes will be made OBSOLETE because they are redundant with the corresponding top-level attributes and could be used to bypass security/format checks.

- The "document-format-device-id" member attribute will be made OBSOLETE because it is too short (127 octets vs. 1023 octets for "printer-device-id").

- The "document-format-application-name" and "document-format-application-version" member attributes will be retained for informational use with a cautionary notice about interoperability and authenticity issues and the potential for use as PII.

- The "document-format-os-name" and "document-format-os-version" member attributes will be retained for informational use with a cautionary notice about interoperability and authenticity issues and the potential for use as PII.

- A section will be added to the security considerations concerning the authenticity and PII issues of "document-format-details" in general, with a reference to the EFF work concerning user identification.

- An informational reference will be added to the EFF article on using User-Agent to track users:

  https://www.eff.org/deeplinks/2010/01/tracking-by-user-agent

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Cihan Colakoglu via ipp <[email-masked]>
Date: Thu, 18 Apr 2019 01:31:01 +0000

Hi Michael,

Just a quick note, it was pointed out to me that there appears to be a typo in some of the attribute names:

(replace "format" with "source")

document-format-application-name       --> should be document-source-application-name

document-format-application-version    --> should be document-source-application-version

document-format-os-name                         --> should be document-source-os-name

document-format-os-version                      --> should be document-source-os-version

Best Regards,

Cihan

-----Original Message-----
From: ipp <[email-masked]> On Behalf Of Michael Sweet via ipp
Sent: Wednesday, April 17, 2019 1:16 PM
To: PWG IPP Workgroup <[email-masked]>
Subject: [IPP] Fate of "document-format-details" attribute

All,

ipp mailing list

[email-masked]<mailto:[email-masked]>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 18 Apr 2019 07:28:56 -0400

Cihan,

Whoops, yes of course.  Too much cut and paste... :/

> On Apr 17, 2019, at 9:31 PM, Cihan Colakoglu via ipp <[email-masked]> wrote:
> 
> Hi Michael,
>  
> (replace “format” with “source”)
>  
> document-format-application-name       à should be document-source-application-name
> document-format-application-version    à should be document-source-application-version
> document-format-os-name                         à should be document-source-os-name
> document-format-os-version                      à should be document-source-os-version
>  
> Best Regards,
> Cihan
>  
>   https://www.eff.org/deeplinks/2010/01/tracking-by-user-agent <https://www.eff.org/deeplinks/2010/01/tracking-by-user-agent>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>_______________________________________________
> ipp mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>