Subject: [IPP] Issue of document-format-details Attribute

From: wamwagner--- via ipp <[email-masked]>
Date: Wed, 10 Apr 2019 18:05:18 -0400

I have presented here my understanding of an issue which I believe needs more discussion. 

At the IPP Workgroup Session of the February face-to-face on February 13, 2019, the following points were made  in the presentation  of  Errata Updates to the  IPP Document Object v1.1 specification

"The "document-format-details", "document-format-details-detected", "document-format-version", and "document-format-version-detected " Document Status attributes are obsolete because these attributes have poor interoperability (no registered values, no standard value formats) and have serious privacy issues."

and in the presentation of updates to  the IPP Job Extensions v1.1 specification.

"The "document-format-details" and "document-format-version" attributes are obsolete because these attributes have poor interoperability (no registered values, no standard value formats) and have serious privacy issues."

Discussion considered the use of  "document-format-details" with respect to job accounting, and the recommendation  was to use document-metadata instead. Contributions relative to job accounting were invited. 

There have been some messages about a Job Accounting replacement for  "document-format-details", and a Job Accounting BoF has been scheduled for  the April face-to-face  at 3:45 PM to 5:00 PM on April 17. There was little discussion relative to the contention that these attributes were or should be made obsolete. Although it is understood that to make them officially obsolete would require statements in a formally approved standards track PWG specification, it is reasonable that with no objection, such statements would be included in one or more of the specifications being developed.

However, at least one PWG member has recently objected to  proceeding with making  "document-format-details"  and "document-format-details-supported" attributes obsolete, presumably because these attributes are being used.

First, it might be desirable to consider the attributes. “document-format-details” is  both a document status and an operation attribute,  and is of the collection type, consisting of 8 members.
document-format-details (1setOf collection)
document-source-application-name (name(MAX)) 17
document-source-application-version (text(127)) 17
document-source-os-name (name(40)) 17
document-source-os-version (text(40)) 17
document-format (mimeMediaType) 18
document-format-device-id (text(127)) 18
document-format-version (text(127)) 18
document-natural-language (1setOf naturalLanguage)

“document-format-details-supported”  (1setOf keyword) is a printer description attribute, with the keywords corresponding to the members of “document-format-details”

Although the proposal to obsolete attributes did not include "document-format-details-supported ", since document-format-details-supported  and several other attributes (e.g., "document-format-details-default", "document-format-details-detected", "document-format-details-supplied") refer to 'document-format-details", these would also need to be made obsolete.

It is understood that the request is to not obsolete or depreciate the "document-format-details" operation attribute or its members (except document-format-device-id), and to not obsolete or deprecate the "document-format-details-supported"  printer description attribute or its keywords (except document-format-device-id). It is unclear whether the request extends to the “document-format-details” document attribute.

The argument to obsolete these attributes is that some members of the "document-format-details" collection have "poor interoperability (no registered values, no standard value formats) and have serious privacy issues." The poor interoperability stems from their "text" and "name" data types. 
Text and Name syntaxes are used for attributes intended for human communication and may be presented in the selected natural language. It is understood that such attributes may not be interoperable from an automata viewpoint.  The fact that these attributes were so typed reflected a tradeoff  of human readability vs machine interoperability. If machine interoperability is required,  then indeed some more appropriate attributes should be used. But that does not necessarily diminish that value of these attributes. 
With regard to privacy issues, I would like to see more discussion since it unclear to me what they might be.

I hope that this outline prompts comment from both sides to encourage better understanding at the April face-to-face meeting.
Thanks, Bill Wagner

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 11 Apr 2019 00:21:07 +0000

Hi Bill,

[I dropped the SC from this reply but I understand why you posted to both.]

Thank you very much for posting this. I had prepared a separate description of my understanding of the problem, and was waiting before posting, but yours provides a timeline that I find very helpful. And you posted first.

I'm working on a slide set so that we can have the discussion next week in the Job Accounting BoF. I'm hoping some can provide feedback or contribute additions or modifications so that we can move the discussion about requirements and problems with existing attributes forward so that we can make progress.

Smith

/**
    Smith Kennedy
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Apr 10, 2019, at 4:05 PM, wamwagner--- via ipp <[email-masked]> wrote:
> 
> [email-masked] <mailto:[email-masked]>
> https://protect-us.mimecast.com/s/imYZCKrBnBFGY0MVUMqLHz?domain=pwg.org <https://protect-us.mimecast.com/s/imYZCKrBnBFGY0MVUMqLHz?domain=pwg.org>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 11 Apr 2019 15:01:42 +0000

Hi again,

I will attempt to articulate the reasons for the proposal in the IPP Work Group to obsolete the "document-format-details" attribute (PWG 5100.7 "IPP Job Extensions"). My goal is to provoke those who have concerns with this proposal to respond so that we can come to collectively understand the problems with "document-format-details", and agree on how best to solve those problems.

There are several shortcomings with "document-format-details". One problem is its "non-interoperability". The term "non-interoperability" in this context means that the syntax of many of the member attributes of "document-format-details" are defined to use data types that allow a broad range of user- or vendor-defined values with no well-defined values or structure. The lack of structure and/or registered values makes interoperability challenging at best if the values are supposed to be machine-consumable. (Other IPP attributes suffer from this problem - it isn't just "document-format-details".)

Here are the member attributes of "document-format-details":

 document-format				mimeMediaType
*document-format-device-id			text(127)
*document-format-version			text(127)
 document-natural-language			1setOf naturalLanguage
*document-source-application-name		name(MAX)
*document-source-application-version		text(127)
*document-source-os-name			name(40)
*document-source-os-version			text(40)

All of the ones in red and starred above are basically text strings with no value registry defined. These are the ones that suffer from "non-interoperability".

The other shortcomings with "document-format-details" involve the risk of leaking PII / personal data, and the lack of data trustworthiness. I won't explore these contributing factors here, but I won't cover them here. If others would like to respond with a more detailed examination of these shortcomings, I'd appreciate it. I'm going to get slides made for us to discuss these topics in Lexington.

The original plan was to simply OBSOLETE "document-format-details" so that all of these shortcomings could be handled simply by making it "go away", and then work to find a replacement that doesn't suffer from the same problems. But there are alternatives. If we DEPRECATE "document-format-details", ecosystems using that attribute can continue to use it for some time, and hopefully migrate to whatever new solution is developed. Those ecosystems may be able to manage the PII / personal data leakage issue and the data untrustworthiness issue as effectively a closed system, but it will be on them to manage that.

One other alternative could be to bind registries to those member attributes to resolve the "non-interoperability" issue, but we are still faced with the PII / personal data leakage issue and the data untrustworthiness issue. While this is an option, I don't think this is worth pursuing.

A potential replacement for "document-format-details" might be "document-metadata" [PWG 5100.13], which is structured and might solve the non-interoperability problem. But we still need too address the PII / personal data leakage and data untrustworthiness issues, which may necessitate defining new attributes with associated authentication and visibility semantics so that at least the PII / personal data leakage issues are addressed.

Please do reply to this message with arguments that contribute to resolving this issue. We will likely discuss this in an upcoming IPP Work Group meeting and/or at the April F2F (https://www.pwg.org/chair/meeting-info/april-2019-lexington.html <https://www.pwg.org/chair/meeting-info/april-2019-lexington.html>).

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Apr 10, 2019, at 6:21 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Hi Bill,
> 
>> On Apr 10, 2019, at 4:05 PM, wamwagner--- via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> https://protect-us.mimecast.com/s/imYZCKrBnBFGY0MVUMqLHz?domain=pwg.org <https://protect-us.mimecast.com/s/cJjIC2kr5rf94MKoFnaAKk?domain=pwg.org>
>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Sun, 14 Apr 2019 21:13:12 -0400

Smith,

> On Apr 11, 2019, at 11:01 AM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> ...
> If we DEPRECATE "document-format-details", ecosystems using that attribute can continue to use it for some time, and hopefully migrate to whatever new solution is developed. Those ecosystems may be able to manage the PII / personal data leakage issue and the data untrustworthiness issue as effectively a closed system, but it will be on them to manage that.

Two issues come to mind:

1. Vendors that feel that they need 'document-format-details" will continue to use it regardless of whether we obsolete it now.  We might even see new solutions based on the same broken attribute, just as we recently saw a new implementation of PWG 5100.4 ("Override Attributes for Documents and Pages", which was withdrawn by the PWG 16 years ago!)

2. Deprecating something we are going to replace sends a confusing message and gives us more work when we subsequently obsolete it.

> One other alternative could be to bind registries to those member attributes to resolve the "non-interoperability" issue, but we are still faced with the PII / personal data leakage issue and the d…

The issue is that we don't have registries for name values, and the current definition of document-source-os-name already says to use lowercase versions of the IANA OS names registry (https://www.iana.org/assignments/operating-system-names/operating-system-names.xhtml#operating-system-names-1) which still doesn't have a registration for Solaris (note the "issue" that was left in the original published specification...) nor does it have registrations for current versions of Windows (or even a generic version of Windows), Android, ChromeOS, etc.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer