Subject: [IPP] Visual Studio release and Windows SDK versions to use for "ippsample" and "ippeveselfcert" projects

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Wed, 24 Apr 2019 21:02:58 +0000

Hi there,

Some of my Windows using brethren at HP are confused about which version of Visual Studio and what Windows SDK they need to have installed for our "ippsample" and "ippeveselfcert" GitHub projects. And I'm a bit confused as well. I feel like we need to spend a little time finding out what version most developers might have currently (nothing too new but nothing old either). Any thoughts on this?

I'm thinking we ought to mandate and use Windows 10 (October 2018 Update?), Visual Studio 2017 Community Edition (free, compatible with open source projects, IIRC), and the Windows 10 SDK for October 2019 Update (10.0.17763.0).

Thoughts?

Smith

/**
    Smith Kennedy
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 24 Apr 2019 17:23:31 -0400

Smith,

For Windows development I currently have:

- Windows 10
- Windows 10 SDK 10.0.17134.12 (October 2018 - I assume this is the version you meant since they haven't done an October 2019 release yet...)
- Visual Studio 2019 - Community Edition 
- Advanced Installer 15.4

I can add this info to the BUILD.md files, along with the installer info (once I get Github master updated) to make this clear.

FWIW, Visual Studio 2019 Community Edition is now available and I intend on updating to it soon...

> On Apr 24, 2019, at 5:02 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Wed, 24 Apr 2019 21:46:41 +0000

> On Apr 24, 2019, at 3:23 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 

Yep, October 2018. But I did mean SDK 10.0.17763.0. I was reading the table here as reference since MSDN didn't have a good page: https://en.wikipedia.org/wiki/Microsoft_Windows_SDK <https://en.wikipedia.org/wiki/Microsoft_Windows_SDK>

> - Visual Studio 2019 - Community Edition

I'm guessing you mean VS 2017 - Community Edition since you talk about upgrading to VS 2019 Community Edition below.

> - Advanced Installer 15.4

Did we have to buy Advanced Installer? I was wondering if we wanted to move to WiX or something, which IIRC is totally free.

>> On Apr 24, 2019, at 5:02 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi there,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/SOZaC9rB5BFywoELcoDsrX?domain=pwg.org>
>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 24 Apr 2019 17:50:38 -0400

Smith,

> On Apr 24, 2019, at 5:46 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> 
> 
>> On Apr 24, 2019, at 3:23 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Smith,
>> 

17763 is a later update I haven't yet applied, but in general I try to setup the project to use the "default" (newest) SDK available.

> I'm guessing you mean VS 2017 - Community Edition since you talk about upgrading to VS 2019 Community Edition below.

D'oh! Yes.

> Did we have to buy Advanced Installer? I was wondering if we wanted to move to WiX or something, which IIRC is totally free. 

No, advanced installer is also free for our usage - IIRC there are "pro" features you have to pay for but our installer is pretty basic.

I looked at WiX but it seemed a lot more complicated for our needs.