Subject: [IPP] Initial draft of IPP Production Printing Extensions v1.1 (PPX) posted

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 01 May 2019 13:00:14 -0400

All,

I have posted an initial draft of an errata update of PWG 5100.3, renamed to "IPP Production Printing Extensions v1.1 (PPX)", to:

	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx11-20190501.docx
	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx11-20190501.pdf
	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx11-20190501-rev.pdf

This errata is intended to address:

- Removal of references to the original page overrides spec (5100.4)
- Removal and rewording of a lot of “implementation-defined” behavior
- Removal of finishings-col which is now defined in PWG 5100.1-2017: IPP Finishings 2.1
- Removal of new media values which are superseded by PWG 5101.1-2012: PWG Media Standardized Names v2.0
- Obsoletion of the "current-page-order" Job attribute which got updated as the document data is transformed to reflect the new page order (IPP does not expose those sorts of things)
- Obsoletion of the "user-defined-values-supported" Printer attribute as we now (properly) use the IANA IPP registry and well-defined extension semantics for keyword values
- Updating of the defintion of the "imposition-template" Job Template attribute
- Updating of the document template, adding missing sections, and updating references.

Two major issues require discussion:

1. There are a handful of attributes defined in 5100.3 that are not specific to production printing, most notably "media-col" but also "job-account-id", "job-acocunting-user-id", "job-sheets-col", and "presentation-direction-number-up". IMHO they should get moved to the IPP Job Extensions v2.0 update (which is currently in PWG Last Call) and then we can also make "media-col" required (right now everything is OPTIONAL)

2. This specification tries to redefine how Input Pages are numbered in order to support "reverse order" document processing, and that adds a HUGE amount of complexity and special casing that IMHO is totally unnecessary, and could lead to incorrect processing of Jobs by proxies (for example) in the newer infrastructure printing architectures.  I would like to obsolete the "page-order-received" Job Template attribute and all of the "n-to-1-order" semantics in the original 5100.3 so that we don't have those special cases and focus on well-defined semantics and interoperability.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 9 May 2019 17:40:35 -0400

Hi,

At today's IPP WG call, we agreed unanimously to approve:

Major Issue 1:  Move the proposed attributes (and the related use
cases) to IPP Job Extensions v2.0.

Major Issue 2:  Remove entirely the strange (and poorly specified)
"reverse-order" document processing (which Mike has never seen
in the wild in printers surveyed in Apple labs).

Also to publish new IPP Production Printing Extensions (PPX)
as v2.0 (new major version) and create "ipp-features-supported"
keywords to group new attributes as CONDITIONALLY REQUIRED.
And (perhaps) to make some attributes simply REQUIRED or
RECOMMENDED.  All for the purpose of minimizing OPTIONAL
attributes in PPX.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, May 1, 2019 at 1:00 PM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> I have posted an initial draft of an errata update of PWG 5100.3, renamed
> to "IPP Production Printing Extensions v1.1 (PPX)", to:
>
> - Obsoletion of the "current-page-order" Job attribute which got updated
> as the document data is transformed to reflect the new page order (IPP does
> not expose those sorts of things)
> - Obsoletion of the "user-defined-values-supported" Printer attribute as
> we now (properly) use the IANA IPP registry and well-defined extension
> semantics for keyword values
> 1. There are a handful of attributes defined in 5100.3 that are not
> specific to production printing, most notably "media-col" but also
> "job-account-id", "job-acocunting-user-id", "job-sheets-col", and
> "presentation-direction-number-up". IMHO they should get moved to the IPP
> Job Extensions v2.0 update (which is currently in PWG Last Call) and then
> we can also make "media-col" required (right now everything is OPTIONAL)
>
> 2. This specification tries to redefine how Input Pages are numbered in
> order to support "reverse order" document processing, and that adds a HUGE
> amount of complexity and special casing that IMHO is totally unnecessary,
> and could lead to incorrect processing of Jobs by proxies (for example) in
> the newer infrastructure printing architectures.  I would like to obsolete
> the "page-order-received" Job Template attribute and all of the
> "n-to-1-order" semantics in the original 5100.3 so that we don't have those
> special cases and focus on well-defined semantics and interoperability.
>