Subject: [IPP] Prototype experience: IPP System Service

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 09 May 2019 14:12:01 -0400

All,

I have completed implementation of all required operations and attributes in the current draft of the IPP System Service v1.0 in the ippserver sample code, including support for template-printer and template-job resources, mapping of static-strings resources to printer-strings-uri and printer-strings-languages-supported when allocated to a printer, and the Register-Output-Device operation for proxies.

I've identified a few additional typographical issues in the January 30, 2019 version of the current IPP System Service draft and will post an updated stable draft early next week.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 9 May 2019 17:18:43 -0400

Hi,

At today's IPP WG call, we noted that Mike has completed prototype work for
the IPP System Service and we unanimously agreed that the next draft of IPP
System Service should move to "Stable" status and go into IPP WG Last Call
and thence into PWG Last Call in Q2 2019.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, May 9, 2019 at 2:12 PM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> I have completed implementation of all required operations and attributes
> in the current draft of the IPP System Service v1.0 in the ippserver sample
> code, including support for template-printer and template-job resources,
> mapping of static-strings resources to printer-strings-uri and
> printer-strings-languages-supported when allocated to a printer, and the
> Register-Output-Device operation for proxies.
>
> I've identified a few additional typographical issues in the January 30,
> 2019 version of the current IPP System Service draft and will post an
> updated stable draft early next week.
>