Subject: [IPP] WG Last Call: IPP System Service v1.0 (Ends May 31, 2019)

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 15 May 2019 10:04:49 -0400

All,

This message starts the IPP Workgroup Last Call of the IPP System Service v1.0 specification, available at:

	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20190515.pdf

All required (and many optional/recommended) portions of this specification have been prototyped in the "ippserver" program in the IPP Sample Code project.

Please reply to this message with any feedback, which we can review at the following IPP workgroup conference call.

Thanks!

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: wamwagner--- via ipp <[email-masked]>
Date: Wed, 22 May 2019 18:40:25 -0400

Sorry, should have brought these questions up sooner, but we have looked at pieces of this over such a long time I was waiting for a more or less complete  final version. These are my reactions on reading the spec, although I haven’t gotten that far. Don’t need a formal response, but perhaps we can address them sometime in conference.
Thanks

Format:
a. Three paragraph breaks at top margin seems excessive , Some unfortunate page breaks. (5, 18, 21)
b. assorted double spaces
Line 932  "a Resource by analogy to  to “date-time-at-processing

para 1.1 --1.3 Do These really belong here, and with this level of detail? Uses terminology in section 2.

382 	Rationale for Two ... - " IPP System object and (via a System response to the Get-Printers operation) zero or more IPP Printer objects"  Why two? Perhaps multiple?
440   "System:  Listener for incoming..."
a. Should this be Imaging System?  
b. Do we need  same entity in both Protocol and Printer Terminology? (e.g., Printer)
c. Do  Printer, System entities  under protocol  correspond to Printer and System Objects described later?
483 "Imaging System:  A logical or physical system supports a System object and a System Service for monitoring and management of one or more Imaging Services"
a. That supports?  
b. Before the  statement was " zero or more IPP Printer objects"  Zero or one?  
c.  Is the Imaging System managing Printer Objects, Printers or Imaging Services? Can  we use Imaging Service  rather than Printer after having defined them as synonymous?
470. FaxoutJob, Why not use Job in definition? Also in Scan Job, Transform Job, Print Job.
595	"After Jane initiates service enumeration by using the IPP Client on her laptop to send a query to the Imaging System for the list of available services." No After?
3.2.4 " to extend the functionality of the Imaging System"  Is it the functionality of the Imaging System or of Imaging Services supported by the Imaging System?
Should some mention be made in used cases of user restictions on some System Service operations?
646  "managed Imaging System" 
a. Why  'managed"? 
b. print service is a defined term(initial Caps) 
648. Why "system" in this document  and not Imaging System?
653.  Note is interesting, but does it belong here?
666. 	to reuse existing IPP Printer operations and attributes in the individual Imaging Services, but NOT directly in this specification"  
a. The "but ..." phrase is unclear.
b. Printer vs Imaging  Service. Confusing, since definitions said they were synonymous
c. Note?
674, 681,   " but NOT directly in this specification"  same question

From: Michael Sweet via ipp
Sent: Wednesday, May 15, 2019 10:05 AM
To: PWG IPP Workgroup
Subject: [IPP] WG Last Call: IPP System Service v1.0 (Ends May 31, 2019)

All,

Thanks!

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 23 May 2019 14:09:25 -0400

Bill,

Thanks for the feedback!  I'll do a pass over the current draft to see if there are similar issues further into the document as well...

> On May 22, 2019, at 6:40 PM, [email-masked] <mailto:[email-masked]> wrote:
> 
> From: Michael Sweet via ipp <mailto:[email-masked]>
> To: PWG IPP Workgroup <mailto:[email-masked]>
>                 https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20190515.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20190515.pdf>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>