Subject: [IPP] no List for Scanning?

From: Mark DM via ipp <[email-masked]>
Date: Sun, 19 May 2019 17:06:44 -0500

Is there no list for topics related to PWGs scanning protocol?

If so, can someone kindly redirct me?

Thanks

Mark
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Sun, 19 May 2019 19:00:08 -0400

Hi,

This (IPP WG) is the correct mailing list for IPP Scan Service (PWG
5100.17).
Please ask your questions here.

Cheers,
- Ira (IPP WG co-chair)

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: Ira McDonald via ipp <[email-masked]>
Date: Sun, 19 May 2019 19:36:45 -0400

Hi Mark,

I'm forwarding your reply back to the IPP WG list.  There may be
Mopria members who can help out.  The Mopria support for Scan
does not use the PWG standard IPP Scan Service though.

Cheers,
- Ira

On Sun, May 19, 2019 at 7:30 PM Mark DM <[email-masked]> wrote:

> Thanks for the reply, Ira.
>
> I have been working to replicate the functionality of the eSCL protocol
> for some models of scanners.  Recently I developed new problems with
> WIreshark , not to mention I have no eSCL scanner here to test with
> presently. If I had either or I would be in better shape.
>
> I was hoping  that somewhere someone might have what I need and that is
> basically the exchanges between scanner and client Immediately after the
> scan xml is sent . So far I am getting this far the scan is generated, I
> can see it , but the Mopria Android client I am using then crashes.
>
> As I have it working now There is a POST to /eSCL/ScanJobs then the
> scanner should issue a 200 OK .
>
> Then last I saw on Wireshark it looked like the client was sending GET to
> /eSCL/ScannerStatus so I modded my code to alter the status from "Idle"
> before the scan  to "Processing" during the scan then back to "Idle"???
> after the scan? maybe this is where I need to put something like  "ready"
> with URL?
>
> What I was never able to see is what was happening as the image was being
> scanned and prepared and once it became available.
>
> Maybe some wireshark traces would be best if someone has some they could
> send me.
>
> I would like to be able to finish this project but am stuck, and so near
> the end!
>
> The available info on this on the web is either far beyond my
> comprehension without learning a new language and customs or very thin. I
> know there is a lot of info at PWG.ORG that is where I found the
> "Processing" from "Idle" but that was sheer luck.
>
> As I recall somewhere there may be a 201 reply needed with a link to the
> file. What I read that said that though seemed to have a mix of eSCL and HP
> protocols so that may have come fro the HP protocol. Once the
> scansettings.xml is sent then my Mopria Client is crashing anyway, probabl
> for not finding what it is looking for , or not getting the reply expected.
>
> Thanks,
>
> Mark
>
> On Sun, May 19, 2019 at 6:00 PM Ira McDonald <[email-masked]>
> wrote:
>
>> Hi,
>>