Subject: [IPP] Questions on Specification History

From: wamwagner--- via ipp <[email-masked]>
Date: Fri, 21 Jun 2019 17:53:47 -0400

Looking through the IPP Published Work list on the PWG website, I noticed that 5100.4 and 5100.10 are not listed. 5100.4 (Override Attributes for Documents and  Pages) is well marked as obsolete on the FTP site. 5100.10 (Internet Printing Protocol Version 2.0) is not. 

1. 5100.6 (Page Overrides) apparently obsoletes 5100.4 . It is not immediately clear whether Document Overrides are still supported.
2. The relationship between 5100.10 and 5100.12 (IPP Version 2.0, 2.1, and 2.2) does not appear to be spelled out. One would expect that .12 supersedes .10 . Is this correct? If so, should this not be indicated somewhere?
Thanks
Bill Wagner
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Fri, 21 Jun 2019 18:03:03 -0400

Hi Bill,

Good questions.

Since 5100.4 is Obsolete (and not merely Deprecated) it is no longer listed
in the Published Standards section.  5100.6 blurb (and Abstract) should
clearly state that it supersedes 5100.4 and that 5100.4 is no longer
supported.

5100.10 is indeed superseded by 5100.12.  Again the 5100.12 blurb (and
Abstract) should clearly state that it supersedes 5100.10.  IMO,5100.10 is
Obsolete and should be withdrawn from the Published Standards section.

Note - It's also true that 5100.12 (our only full PWG Standard) will
definitely
need to be revised (and moved back down to Candidate Standard) to reflect
corrections and attribute transitions among IPP PPX, IPP EPX, and IPP Job
Extensions (among others) - that looks like a 2020 calendar year activity
to me.  I suggest that we should NOT fold additional later IPP standards
into that 5100.12 update (because that would break compatibility).

All - WDYT?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Fri, Jun 21, 2019 at 5:54 PM wamwagner--- via ipp <[email-masked]> wrote:

> Looking through the IPP Published Work list on the PWG website, I noticed
> that 5100.4 and 5100.10 are not listed. 5100.4 (Override Attributes for
> Documents and  Pages) is well marked as obsolete on the FTP site. 5100.10
> (Internet Printing Protocol Version 2.0) is not.
>
>
>
>    1. 5100.6 (Page Overrides) apparently obsoletes 5100.4 . It is not
>    immediately clear whether Document Overrides are still supported.
>    2. The relationship between 5100.10 and 5100.12 (IPP Version 2.0, 2.1,
>    and 2.2) does not appear to be spelled out. One would expect that .12
>    supersedes .10 . Is this correct? If so, should this not be indicated
>    somewhere?
>
> Thanks
>
> Bill Wagner

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 21 Jun 2019 18:44:45 -0400

Bill,

> On Jun 21, 2019, at 5:53 PM, wamwagner--- via ipp <[email-masked]> wrote:
> 
> 	• 5100.6 (Page Overrides) apparently obsoletes 5100.4 . It is not immediately clear whether Document Overrides are still supported.

The 5100.4 docx and pdf files all say obsolete.  Perhaps we can add a placeholder that points to the new one (that is already reflected in the internal document database, but we don't show it on the current site).

> 	• The relationship between 5100.10 and 5100.12 (IPP Version 2.0, 2.1, and 2.2) does not appear to be spelled out. One would expect that .12 supersedes .10 . Is this correct? If so, should this not be indicated somewhere?

Yes, when we added IPP/2.2 we bumped the spec number; we probably should have just reused the old number, but oh well.

I can probably post an updated copy of 5100.10 that points to 5100.12, plus add a placeholder on the documents page with the same pointer.

________________________
Michael Sweet

---

From: Ira McDonald via ipp <[email-masked]>
Date: Sat, 22 Jun 2019 17:08:35 -0400

Hi Mike,

5100.10 didn't define v2.2 (only v2.0 and v2.1).  That's why we used
a new number of 5100.12 for clarity, I think.

Cheers,
- Ira

On Fri, Jun 21, 2019 at 6:44 PM Michael Sweet via ipp <[email-masked]> wrote:

> > Looking through the IPP Published Work list on the PWG website, I
> noticed that 5100.4 and 5100.10 are not listed. 5100.4 (Override Attributes
> for Documents and  Pages) is well marked as obsolete on the FTP site.
> 5100.10 (Internet Printing Protocol Version 2.0) is not.
> >
> >       • 5100.6 (Page Overrides) apparently obsoletes 5100.4 . It is not
> The 5100.4 docx and pdf files all say obsolete.  Perhaps we can add a
> placeholder that points to the new one (that is already reflected in the
> internal document database, but we don't show it on the current site).
>
> >       • The relationship between 5100.10 and 5100.12 (IPP Version 2.0,
> 2.1, and 2.2) does not appear to be spelled out. One would expect that .12
> Yes, when we added IPP/2.2 we bumped the spec number; we probably should
> have just reused the old number, but oh well.
>
> I can probably post an updated copy of 5100.10 that points to 5100.12,
> plus add a placeholder on the documents page with the same pointer.
>
> ________________________
> Michael Sweet
>
>
>