Subject: [IPP] FYI: Report on prototyping for original IPP Production Printing Attributes - Set 1

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 24 Jun 2019 15:56:35 -0400

All,

I did some digging into what level of prototyping was done for the original IPP Production Printing Attributes - Set 1 specification (PWG 5100.3-2001).  As near as I can tell from the mailing list archives and meeting minutes, *no* prototyping was reported.  In fact, the process document that was in effect at the time (I think) was:

    https://ftp.pwg.org/pub/pwg/general/process/Historical/pwg-process.pdf

The original published 5100.3 used the "PWG Draft Standard" status (corresponding to the old IETF Draft Standard status), which means that it should have had some level of prototyping, however the process document said nothing about prototyping beyond the following:

It is expected that the PWG Draft Standard takes into account implementation experience gained from prototype activities done during the development of the document.

So unless we can dig up any significant amount of prototyping that was done for 5100.3-2001, I recommend we wait for an actual prototype report for the v2.0 document.

Note: As I mentioned during today's conference call, I believe we can prototype all of the required attributes in the current draft in ippserver without too much difficulty.  The attributes can be reported/supported already, but are currently not implemented by ipptransform, e.g., to use cardstock media for covers and/or add blank insert sheets and separator sheets in the right places...

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Tue, 25 Jun 2019 23:54:12 +0000

Thanks for looking into this Mike! I agree with your assessment below.

Smith

> On Jun 24, 2019, at 1:56 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
>     https://ftp.pwg.org/pub/pwg/general/process/Historical/pwg-process.pdf <https://protect-us.mimecast.com/s/xzXhC31v5vipGD2EDcqKUtZ?domain=ftp.pwg.org>
> 
> https://protect-us.mimecast.com/s/xzILC2kr5rfpR5895cnidC7?domain=pwg.org