Subject: [IPP] RFC: print-quality-percent (integer(0:100))

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 28 Aug 2019 15:33:20 -0400

All,

As an alternative to adding more (out of order) enum values to print-quality, how about a print-quality-percent (integer(0:100)) attribute where:

- print-quality-percent='25' maps to print-quality='3' (draft),
- print-quality-percent='50' maps to print-quality='4' (normal), and
- print-quality-percent='75' maps to print-quality='5' (high5)

Thoughts?

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Wed, 28 Aug 2019 15:59:38 -0400

Hi Mike,

I like this new attribute.  I've been hearing developers bemoan that they
have
much finer-grained support for print-quality for the past 25 years.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Aug 28, 2019 at 3:33 PM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> As an alternative to adding more (out of order) enum values to
> print-quality, how about a print-quality-percent (integer(0:100)) attribute
> where:
>

---

From: Sean Kau via ipp <[email-masked]>
Date: Wed, 28 Aug 2019 13:02:24 -0700

Do printers support this fine grained quality?  Would the printer map to
it's nearest supported value?

-- 
Sean Kau

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Wed, 28 Aug 2019 20:04:07 +0000

Hi Mike,

The only problem I see is that vendor- or site-defined print quality values, printer vendors likely want labels that can at least uniquely identify the additional settings, and that could have corresponding _tooltip and _helpurl content.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Aug 28, 2019, at 1:33 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/IvxiC2kr5rfp2N1mkU1hC1u?domain=pwg.org>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Wed, 28 Aug 2019 16:21:52 -0400

Hi Smith,

I see your point about unique labels, but are you suggesting that we
should define finer-grained standard "print-quality" values?  (I suggest
that there lies madness.)

Cheers,
- Ira

On Wed, Aug 28, 2019 at 4:04 PM Kennedy, Smith (Wireless & Standards
Architect) via ipp <[email-masked]> wrote:

> Hi Mike,
>
> The only problem I see is that vendor- or site-defined print quality
> values, printer vendors likely want labels that can at least uniquely
> identify the additional settings, and that could have corresponding
> _tooltip and _helpurl content.
>
> Smith
>
> /**
>     Smith Kennedy
>     HP Inc.
> */
>
> <https://protect-us.mimecast.com/s/IvxiC2kr5rfp2N1mkU1hC1u?domain=pwg.org>
>
>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 28 Aug 2019 17:09:42 -0400

Sean,

Yeah, we'd probably do the same thing we have for job-priority (where job-priority-supported identifies the number of discrete values that are supported instead of a range...)

> On Aug 28, 2019, at 4:02 PM, Sean Kau <[email-masked]> wrote:
> 
> Do printers support this fine grained quality?  Would the printer map to it's nearest supported value?
> 
> I like this new attribute.  I've been hearing developers bemoan that they have

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 28 Aug 2019 17:19:18 -0400

Smith,

I do understand the appeal that some vendors have for adding more knobs to differentiate their products, however I can tell you from a client perspective that Apple is extremely unlikely to support arbitrary vendor print quality values since it makes for a bad user experience.

> On Aug 28, 2019, at 4:04 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Hi Mike,
> 

________________________
Michael Sweet