Subject: RE: RE:FWD: PROFORMA INVOICE // Overdue Payment Update :

From: ietfa.amsl.com [email-masked]
Date: 18 Aug 2019 15:06:34 -0700

Email Administrator

Messages

Action Required

Good day.

I sent this earlier with my regular email but no reply from you.

Kindly check if the remittance details in the invoice matches with yours as funds will be released tomorrow.

I do not want to be held responsible for wrong remittance.

Thank you

Click-here

Account Payable Specialist.

---

From: ietfa.amsl.com [email-masked]
Date: 19 Aug 2019 16:51:37 -0700

Email Administrator

Messages

Action Required

Good day.

Thank you

Click-here