Subject: [IPP] Handling use case where smaller Input Page media size is printed on larger physical media

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 25 Oct 2019 20:00:33 +0000

Hi there,

I have a question about how best to handle via IPP a scenario where the Printer supports printing a Job whose input pages specify a smaller physical size than the media on which they are actually printed. For instance, the Job specifies A4 input pages but the Printer prints it onto A0 roll feed media.

I can imagine two ways to handle this:

1.      The Printer present "virtual input trays" (via "media-col-ready") for all the smaller media sizes it can produce from the media loaded. If the Client selected A4, the Printer would "produce" A4 output from the roll feed media loaded.
2.      The Printer presents finishing operations, etc. to allow the Client / User to specify finishing operations and possibly specify other "hints" for rotation, etc. to produce the A4 media.

The latter method seems to me to be more "process-based" rather than "intent-based", which I believe runs counter to our core IPP design principles. It also makes it difficult for the Client to provide a "page setup" with the target media dimensions based on what might be loaded or supported by the Printer. The first method is more "intent-based" in that the Printer is advertising A4 being loaded, the Client is submitting Input Pages with A4 dimensions, and the Printer is handling that by printing to A4 bounds and possibly cutting out the pages. The trouble is that, for larger roll feed printers, the "media-col-ready" could bloat out almost exponentially.

Thoughts on this? I'm expecting to add this to the next draft of Driverless Printing Extensions (formerly JPS3v2).

Cheers,

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 25 Oct 2019 17:25:18 -0400

Smith,

The likely scenarios (based on my experience with existing IPP printers):

1. The printer scales the input pages to the output media (ipp-attribute-fidelity, media/media-col, and/or print-scaling can force this);

2. The printer centers the input pages on a series of A0 pages, wasting a lot of paper; or

3. The printer stops and asks the operator to load A4 media.

The imposition-template attribute (from PPX) could be used to implement same-up behavior (A4 pages tiled across the row), with finishings-col used to cut the pages apart with several trimming values.

(in the old days you'd enable queuing and nesting and you'd get "automatic" imposition across the roll...)

> On Oct 25, 2019, at 4:00 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Hi there,
>  
> 	• The Printer present “virtual input trays” (via “media-col-ready”) for all the smaller media sizes it can produce from the media loaded. If the Client selected A4, the Printer would “produce” A4 output from the roll feed media loaded.
> 	• The Printer presents finishing operations, etc. to allow the Client / User to specify finishing operations and possibly specify other “hints” for rotation, etc. to produce the A4 media. 
>  
> The latter method seems to me to be more “process-based” rather than “intent-based”, which I believe runs counter to our core IPP design principles. It also makes it difficult for the Client to provide a “page setup” with the target media dimensions based on what might be loaded or supported by the Printer. The first method is more “intent-based” in that the Printer is advertising A4 being loaded, the Client is submitting Input Pages with A4 dimensions, and the Printer is handling that by printing to A4 bounds and possibly cutting out the pages. The trouble is that, for larger roll feed printers, the “media-col-ready” could bloat out almost exponentially.
> Thoughts on this? I’m expecting to add this to the next draft of Driverless Printing Extensions (formerly JPS3v2).
>  
> Cheers,
>  
> Smith
>  
> /**
>     Smith Kennedy
>     HP Inc.
> */
>  
>  
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Mon, 28 Oct 2019 16:05:05 +0000

Hi Mike,

All 3 of the “likely scenarios” below don’t satisfy the user’s expectations. If we went with imposition-template and ‘finishings-col” to cut out the pages, that starts to turn into specifying a “process”. I suppose a Preset could be used, but that seems awkward. Can you speak more about the “queueing and nesting” from “the old days”? Was that via IPP or using something else?

Smith

From: [email-masked] <[email-masked]>
Sent: Friday, October 25, 2019 3:25 PM
To: Kennedy, Smith (Wireless & IPP Standards) <[email-masked]>
Cc: PWG IPP Workgroup <[email-masked]>
Subject: Re: [IPP] Handling use case where smaller Input Page media size is printed on larger physical media

Smith,

> On Oct 25, 2019, at 4:00 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi there,
>
> [email-masked]<mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 28 Oct 2019 12:17:16 -0400

Smith,

> On Oct 28, 2019, at 12:05 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Hi Mike,
>  
> All 3 of the “likely scenarios” below don’t satisfy the user’s expectations.

Generally #1 is addressed in the Client UI so that the scaling behavior is explicit (and thus matching user expectations...)  But in the absence of explicit intent I would argue that the Printer has no way to know what the user's expectations are and I would expect 3 users to give 4 different expectations of this scenario... :/

> If we went with imposition-template and ‘finishings-col” to cut out the pages, that starts to turn into specifying a “process”.

There is always a bit of process/intent mixing with finishings - the key here is that you aren't telling the printer the order of operations, just the list of operations that are needed to satisfy the user's explicit intent.

> I suppose a Preset could be used, but that seems awkward. Can you speak more about the “queueing and nesting” from “the old days”? Was that via IPP or using something else?

That was a DesignJet setting on the printer's console you enabled, and then the HP-GL/2 jobs you sent from your computer would be ordered, rotated, etc. to best use the roll.  Basically, open AutoCAD and then plot each of the layers/designs separately, then the printer would combine them all on the roll.  Also worked for HP-RTL if you had enough memory/hard drive space on the DesignJet...