Subject: [IPP] RFC: Printer Firmware Updates via IPP System Service

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 15 Oct 2019 15:26:59 -0400

All,

During our last call review of the IPP System Service v1.0, several questions came up concerning how firmware updates will be applied once the resource is created, uploaded (sent), and installed.  The consensus was to add a subsection 17.x (Appendix A - Rationale for Design Choices) documenting how we see this working without defining/requiring a particular file format.  The following is my proposed text for this subsection:

17.4 Executable Resources

This specification defines two types of executable resources: firmware ('executable-firmware') and application software ('executable-software').  While no specific file format has been mandated, an executable resource file:

- Provides a manifest providing descriptive text, version number(s), subunit or other associations, and a cryptographic hash of the executable content,
- Provides a cryptographic signature of the metadata, and
- Contains the executable content.

When subunit firmware is installed (or queued for installation on the next restart of the System), it applies to all compatible subunits.  For example, if a System contains multiple fold finishers and an Administrator installs new fold finisher firmware, all of the fold finishers are updated - there is no way to selectively upgrade a single subunit.

When application software is installed, it typically applies to the System and all of its Printers.  However, this specification does not prohibit applications that need to be subsequently allocated to a Printer, for example a cloud-based PDF interpreter application could be installed and later allocated to a specific Printer.

Please provide your feedback before the next IPP workgroup conference call on October 24, 2019 so that we can start a PWG Formal Vote to span the November face-to-face meeting.

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Tue, 15 Oct 2019 20:29:32 -0400

Hi Mike,

+1

I like your proposed text and think it's at an appropriate level of detail.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Oct 15, 2019 at 3:27 PM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> During our last call review of the IPP System Service v1.0, several
> questions came up concerning how firmware updates will be applied once the
> resource is created, uploaded (sent), and installed.  The consensus was to
> add a subsection 17.x (Appendix A - Rationale for Design Choices)
> documenting how we see this working without defining/requiring a particular
> file format.  The following is my proposed text for this subsection:
>
> This specification defines two types of executable resources: firmware
> ('executable-firmware') and application software ('executable-software').
> While no specific file format has been mandated, an executable resource
> file:
>
> - Provides a manifest providing descriptive text, version number(s),
> subunit or other associations, and a cryptographic hash of the executable
> content,
> When subunit firmware is installed (or queued for installation on the next
> restart of the System), it applies to all compatible subunits.  For
> example, if a System contains multiple fold finishers and an Administrator
> installs new fold finisher firmware, all of the fold finishers are updated
> - there is no way to selectively upgrade a single subunit.
>
> When application software is installed, it typically applies to the System
> and all of its Printers.  However, this specification does not prohibit
> applications that need to be subsequently allocated to a Printer, for
> example a cloud-based PDF interpreter application could be installed and
> later allocated to a specific Printer.
>
>
> Please provide your feedback before the next IPP workgroup conference call
> on October 24, 2019 so that we can start a PWG Formal Vote to span the
> November face-to-face meeting.
>
> ________________________
> Michael Sweet
>
>
>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Fri, 18 Oct 2019 13:06:59 +0000

I agree with Ira - no objections to adding it.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Oct 15, 2019, at 2:29 PM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi Mike,
> 
> +1
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Tue, Oct 15, 2019 at 3:27 PM Michael Sweet via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> All,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>