Subject: [IPP] Canon request for client's job submission date and time

From: Rick Yardumian via ipp <[email-masked]>
Date: Thu, 20 Feb 2020 00:12:43 +0000

Hi,

For accounting purposes, Canon needs the client's job submission date and time. I cannot find an IPP client attribute that defines this. Therefore Canon is requesting a new IPP Client attribute that defines when the client submitted the job. Note that Canon wants the client's date and time, not the Printer's date and time that you could get from RFC 8011 date-time-at-creation job status attribute since that attribute gives the printer's time zone which might be different from the client's time zone. Please let us know what you think about this request.

Thank you,
Rick
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Sean Kau via ipp <[email-masked]>
Date: Wed, 19 Feb 2020 16:19:43 -0800

Do you need the time zone of the client or just a reliable time?  Is it
possible we can record everything in UTC?

On Wed, Feb 19, 2020, 16:12 Rick Yardumian via ipp <[email-masked]> wrote:

> Hi,
>
>
>
> For accounting purposes, Canon needs the client's job submission date and
> time. I cannot find an IPP client attribute that defines this. Therefore
> Canon is requesting a new IPP Client attribute that defines when the client
> submitted the job. Note that Canon wants the client's date and time, not
> the Printer's date and time that you could get from RFC 8011
> date-time-at-creation job status attribute since that attribute gives the
> printer's time zone which might be different from the client's time zone.
> Please let us know what you think about this request.
>
>
>
> Thank you,
>
> Rick

---

From: Rick Yardumian via ipp <[email-masked]>
Date: Thu, 20 Feb 2020 00:38:37 +0000

Hi Sean,

Yes UTC would be fine. The currently defined IPP printer attribute date-time-at-creation format is defined in RFC 2579 DateAndTime which uses UTC so IPP is already using UTC for some attributes.

Bes regards,
Rick

From: Sean Kau <[email-masked]>
Sent: Wednesday, February 19, 2020 4:20 PM
To: Rick Yardumian <[email-masked]>
Cc: PWG IPP Workgroup <[email-masked]>
Subject: Re: [IPP] Canon request for client's job submission date and time

Email was not sent from a Canon Network!
Do you need the time zone of the client or just a reliable time?  Is it possible we can record everything in UTC?

On Wed, Feb 19, 2020, 16:12 Rick Yardumian via ipp <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thank you,
Rick
_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 19 Feb 2020 20:43:21 -0500

Rick,

What is the use case for this request?  With IPPS basically being implemented by all current IPP printers, both the Client and Printer clocks will need to be fairly close in order for the TLS negotiation to work. So that leaves knowing the timezone for some reason, which for all of thew implementations I've worked with should be irrelevant - CUPS, for example, converts dateTime values to UTC seconds which get mapped to whatever the local timezone is.

> On Feb 19, 2020, at 7:12 PM, Rick Yardumian via ipp <[email-masked]> wrote:
> 
> Hi,
>  

________________________
Michael Sweet