Subject: [IPP] Updated draft of IPP Driverless Printing Extensions v2.0 posted for review

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 4 Feb 2020 05:24:08 +0000

Greetings,

I've just posted an updated draft of IPP Driverless Printing Extensions v2.0. It is available here:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203.docx>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203-rev.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203-rev.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203-rev.docx>

Changes in this revision include:

Accepted all changes and made all recommended edits from the November F2F review, which stopped at section 6.2. Made substantial changes from the beginning:
Reviewed and rewrote the Abstract and Introduction to better match the new title
Reviewed and rewrote a number of the use cases and added new use cases that should have already been there
Created table in section 4 mapping coordinating Use Cases and Design Requirements to the corresponding IPP additions defined in the body of the document
Imported the IPP Presets registration document definitions to add them to this specification
Moved "device-service-count", "device-uuid", "printer-organization", and "printer-organizational-unit" attributes and their associated use cases to IPP Enterprise Printing Extensions v2.0 [PWG5100.11-2020] because they are more aligned with enterprise printing than driverless printing
I'm afraid the next review will require starting at the beginning again, but I think the old text from 5100.13 needed rewriting to match the title and to better cover the attributes that 5100.13 had already defined as well as the additions.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 4 Feb 2020 07:26:05 -0500

Smith,

"device-uuid", "printer-organization", and "printer-organizational-unit" are required for IPP Everywhere, which is not an enterprise-focused document.  "device-service-count" is a count of services that use the same output device, which crosses enterprise, production, and cloud/shared infrastructure.

I can appreciate wanting to clean up the scope of this document, but I think we want to be careful about moving common attributes to highly-focused specifications who scope and conformance requirements don't match how they are used in things like IPP Everywhere.

> On Feb 4, 2020, at 12:24 AM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Greetings,
> 
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203.pdf 
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203.docx 
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203-rev.pdf 
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200203-rev.docx
> 
> 	• Accepted all changes and made all recommended edits from the November F2F review, which stopped at section 6.2. Made substantial changes from the beginning:
> 	• Reviewed and rewrote the Abstract and Introduction to better match the new title
> 	• Reviewed and rewrote a number of the use cases and added new use cases that should have already been there
> 	• Created table in section 4 mapping coordinating Use Cases and Design Requirements to the corresponding IPP additions defined in the body of the document
> 	• Imported the IPP Presets registration document definitions to add them to this specification
> 	• Moved "device-service-count", "device-uuid", "printer-organization", and "printer-organizational-unit" attributes and their associated use cases to IPP Enterprise Printing Extensions v2.0 [PWG5100.11-2020] because they are more aligned with enterprise printing than driverless printing

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 4 Feb 2020 12:30:35 +0000

OK, I will restore those and post a new draft.

Smith

> On Feb 4, 2020, at 5:26 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
> > https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> 
> ________________________
> Michael Sweet
> 
>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Tue, 4 Feb 2020 07:33:34 -0500

Hi Smith,

Thanks.  I concur w/ Mike's comments on the scope of these attributes.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
(to 30 April 2020) 203 W Oak St  Elletsville, IN 47429  812-876-9970

On Tue, Feb 4, 2020 at 7:30 AM Kennedy, Smith (Wireless & IPP Standards)
via ipp <[email-masked]> wrote:

> "device-uuid", "printer-organization", and "printer-organizational-unit"
> are required for IPP Everywhere, which is not an enterprise-focused
> document. "device-service-count" is a count of services that use the same
> output device, which crosses enterprise, production, and cloud/shared
> infrastructure.
>
> I can appreciate wanting to clean up the scope of this document, but I
> think we want to be careful about moving common attributes to
> highly-focused specifications who scope and conformance requirements don't
> match how they are used in things like IPP Everywhere.
>
>
> > • Accepted all changes and made all recommended edits from the November
> F2F review, which stopped at section 6.2. Made substantial changes from the
> beginning:
> > • Created table in section 4 mapping coordinating Use Cases and Design
> Requirements to the corresponding IPP additions defined in the body of the
> document
> > • Moved "device-service-count", "device-uuid", "printer-organization",
> and "printer-organizational-unit" attributes and their associated use cases
> to IPP Enterprise Printing Extensions v2.0 [PWG5100.11-2020] because they
> are more aligned with enterprise printing than driverless printing
> > I'm afraid the next review will require starting at the beginning again,
> but I think the old text from 5100.13 needed rewriting to match the title
> and to better cover the attributes that 5100.13 had already defined as well
> as the additions.
> >
> > Smith
> >
> > /**
> > Smith Kennedy
> > HP Inc.
> > */
> >

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 4 Feb 2020 13:18:16 +0000

I found some other issues so I've actually withdrawn that draft.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Feb 4, 2020, at 5:33 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Tue, Feb 4, 2020 at 7:30 AM Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> On Feb 4, 2020, at 5:26 AM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Smith,
>> 
>> > On Feb 4, 2020, at 12:24 AM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> >
>> > Greetings,
>> >
>> > [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>