Subject: [IPP] job-error-action (in NODRIVER) interaction with ipp-attribute-fidelity

From: Sean Kau via ipp <[email-masked]>
Date: Thu, 6 Feb 2020 13:11:23 -0800

We've defined job-error-action in NODRIVER (
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200204-rev.pdf).
 ipp-attribute-fidelity was created in STD92 (
https://tools.ietf.org/html/std92) and states:

   o  If the Client supplies 'true', the Printer MUST reject the request
      if the Client supplies unsupported Job Template attributes.

job-error-action states that it applies when "an error is encountered in a
document during processing of the job" and includes an option to
"suspend-job".

Does job-error-action only pertain to issues with document format?  Should
ipp-attribute-fidelity take precedence for issues with the Job Ticket?

As I read it, one possible (and undesirable) implementation of these two
attributes would be that we could suspend a job in response to a bad job
ticket.

--
Sean Kau
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 6 Feb 2020 17:09:52 -0500

Sean,

job-error-action only applies to processing jobs.  ipp-attribute-fidelity is used at time of job creation - if the check fails, no job is created and so job-error-action would not apply.

> On Feb 6, 2020, at 4:11 PM, Sean Kau via ipp <[email-masked]> wrote:
> 
> We've defined job-error-action in NODRIVER (https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippnodriver20-20200204-rev.pdf).  ipp-attribute-fidelity was created in STD92 (https://tools.ietf.org/html/std92) and states:
> 
> job-error-action states that it applies when "an error is encountered in a document during processing of the job" and includes an option to "suspend-job".
> 
> Does job-error-action only pertain to issues with document format?  Should ipp-attribute-fidelity take precedence for issues with the Job Ticket?
> 
> As I read it, one possible (and undesirable) implementation of these two attributes would be that we could suspend a job in response to a bad job ticket.
> 
> --
> Sean Kau

________________________
Michael Sweet