Subject: Re: [IPP] IPP WG Last Call: IPP Label Printing Extensions v1.0 (Ends February 13, 2020)

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 14 Feb 2020 17:40:14 +0000

Hi Mike,

These comments are late so I apologize for my tardiness:

Line 137-138: Replace with "And given the need to support label and receipt printers with IPP, this IPP Label Printing Extensions v1.0 should extend IPP by:"
Lines 139-141: Change the first word to be "Defining" or "Providing" to align with the first comment
Section 5.2.1: is it possible for there to be more than one label mode configured? If so, then "label-mode-configured" ought to be (1setOf type2 keyword).
Lines 290-291: Move the first bullet to the bottom of the unordered list? It seems like we ought to be conveying a preference for standard document formats over proprietary ones

Again, sorry for being late!

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Jan 30, 2020, at 2:35 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> [This Last Call starts today, January 30, 2020 and ends at 10pm PST on February 13, 2020]
> 
> All,
> 
> This message starts the IPP workgroup Last Call of the IPP Label Printing Extensions v1.0 registration document, available at:
> 
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipplabel10-20200130.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipplabel10-20200130.docx>
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipplabel10-20200130.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipplabel10-20200130.pdf>
> 
> This registration defines IPP attributes and values needed for common desktop, mobile, and industrial label printers.
> 
> All parts of this registration have been prototyped in the "LPrint" project:
> 
> https://github.com/michaelrsweet/lprint <https://github.com/michaelrsweet/lprint>
> 
> Please reply to this message with any feedback, which we can review at the following IPP workgroup conference call.
> 
> Thanks!
> 
> ________________________
> Michael Sweet
> 
> 
> 
> _______________________________________________
> ipp mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 14 Feb 2020 14:25:02 -0500

Smith,

Thanks for the feedback, late or otherwise... :)

> On Feb 14, 2020, at 12:40 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Hi Mike,
> 
> 	• Line 137-138: Replace with "And given the need to support label and receipt printers with IPP, this IPP Label Printing Extensions v1.0 should extend IPP by:"
> 	• Lines 139-141: Change the first word to be "Defining" or "Providing" to align with the first comment

Hmm, I'll reword a bit but I'm not 100% sold on the new wording.

> 	• Section 5.2.1: is it possible for there to be more than one label mode configured? If so, then "label-mode-configured" ought to be (1setOf type2 keyword).

In my experience, there is only a single label mode per printer.  And most label printers have only a single roll anyways... (the only examples I have seen are the DYMO Twin/Duo models, which have a single label mode for both...)

> 	• Lines 290-291: Move the first bullet to the bottom of the unordered list? It seems like we ought to be conveying a preference for standard document formats over proprietary ones

OK

________________________
Michael Sweet