Subject: Re: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 13 Feb 2020 19:02:47 +0000

Just some comments on this.  Hope not too late:

1. Line 230: "Use existing the existing IPP" should be "Use the existing IPP"
2. Should section 6.2 include job-account-id and job-accounting-user-id or not because they're in PWG 5100.7 (this spec only defining previously undefined attributes)?
3. Should section 6.4 include job-account-id-supported, job-accounting-user-id-supported, job-account-id-default and job-accounting-user-id-default or not because they're in PWG 5100.7 (this spec only defining previously undefined attributes)?

Other than these questions, no issues.

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer

From: ipp <[email-masked]> on behalf of PWG Workgroup <[email-masked]>
Reply-To: Michael Sweet <[email-masked]>
Date: Thursday, January 30, 2020 at 1:39 PM
To: PWG Workgroup <[email-masked]>
Subject: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

[This Last Call starts today, January 30, 2020 and ends at 10pm PST on February 13, 2020]

All,

This message starts the IPP workgroup Last Call of the IPP Transaction-Based Printing Extensions v1.1 specification, available at:

                https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrans11-20200130.docx
                https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrans11-20200130.pdf

This document defines extensions to the Internet Printing Protocol that support the business transaction logic needed for paid, PIN, release, and quota-based printing through local and commercial services.

This is an errata update of PWG 5100.16-2013.

Please reply to this message with any feedback, which we can review at the following IPP workgroup conference call.

Thanks!

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 13 Feb 2020 19:06:44 +0000

Apologies - 1 other question:

Should printer-requested-job-attributes be mentioned in regard to adding job-account-id or job-accounting-user-id when one or both of these may be supported but optional?  (ie - job-accounting-user-id present in printer-mandatory-job-attributes because can't print without it, but job-account-id in printer-requested-job-attributes because it is optional, but can print without it).

Thanks,
Chris

Christopher Rizzo
Xerox Corporation

From: Christopher Rizzo <[email-masked]>
Date: Thursday, February 13, 2020 at 11:02 AM
To: Michael Sweet <[email-masked]>, PWG Workgroup <[email-masked]>
Subject: Re: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

Thanks,
Chris

Christopher Rizzo
Xerox Corporation

All,

Thanks!

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 13 Feb 2020 19:17:16 +0000

Sorry for the multiple emails.

Suggest changing Section 4.1 this:

Printers that support multiple payment or billing options for each user account can support

them via the “job-account-id” and “job-accounting-user-id” Job Template attributes

[PWG5100.7]. Printers notify Clients that they require these values in a print job creation

request by including the corresponding attribute names in the “printer-mandatory-job

attributes” Printer Description attribute [PWG5100.7].

To this:

Printers that support multiple payment or billing options for each user account can support

them via the “job-account-id” and “job-accounting-user-id” Job Template attributes

[PWG5100.7]. Printers notify Clients that they require one or both of these values in a print job creation

request by including the corresponding attribute name(s) in the “printer-mandatory-job

attributes” Printer Description attribute [PWG5100.7].  Printers notify Clients that one or both of these values

are optional in a print job creation request by including the corresponding attribute name(s) in the “printer-requested-job

attributes” Printer Description attribute.

Note: job-account-id and job-accounting-user-id cannot appear in both printer-mandatory-job-attributes and printer-requested-job-attributes at the same time.

Chris

Christopher Rizzo
Xerox Corporation

From: Christopher Rizzo <[email-masked]>
Date: Thursday, February 13, 2020 at 11:06 AM
To: Michael Sweet <[email-masked]>, PWG Workgroup <[email-masked]>
Subject: Re: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

Thanks,
Chris

Christopher Rizzo
Xerox Corporation

Thanks,
Chris

Christopher Rizzo
Xerox Corporation

All,

Thanks!

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 13 Feb 2020 14:37:19 -0500

Chris,

Thanks for your feedback!

> On Feb 13, 2020, at 2:02 PM, Rizzo, Christopher <[email-masked]> wrote:
> 

Thanks, will fix!

> 2. Should section 6.2 include job-account-id and job-accounting-user-id or not because they're in PWG 5100.7 (this spec only defining previously undefined attributes)?

These are defined in 5100.7 so we don't define them here.  (had we decided to update TRANS last year, I probably would have moved them to this spec, but we didn't... :)

> 3. Should section 6.4 include job-account-id-supported, job-accounting-user-id-supported, job-account-id-default and job-accounting-user-id-default or not because they're in PWG 5100.7 (this spec o…

Ditto.

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 13 Feb 2020 14:40:19 -0500

Chris,

I think we should leave those discussions to the Job Accounting document, since printer-mandatory-job-attributes is defined in 5100.13 and job-account-id and job-accounting-user-id are defined in 5100.7...

(Smith: I could move printer-mandatory-job-attributes to this specification if you like; at least then we are getting more of the accounting/transaction stuff in one place?)

> On Feb 13, 2020, at 2:06 PM, Rizzo, Christopher <[email-masked]> wrote:
> 

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 13 Feb 2020 14:42:10 -0500

Chris,

printer-mandatory-job-attributes is in 5100.13 (at present), although that document is also being revised so we *could* move printer-mandatory-job-attributes to 5100.16 and then be able to deal with the interactions more clearly...

Thoughts everyone?

> On Feb 13, 2020, at 2:17 PM, Rizzo, Christopher <[email-masked]> wrote:
> 

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 13 Feb 2020 19:44:31 +0000

Ok by me to move to 5100.16.  Apologies for such late inputs I know Transaction Printing is at last call.

Chris

Christopher Rizzo
Xerox Corporation

From: Michael Sweet <[email-masked]>
Date: Thursday, February 13, 2020 at 11:43 AM
To: Christopher Rizzo <[email-masked]>
Cc: PWG Workgroup <[email-masked]>
Subject: Re: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

Chris,

Thoughts everyone?

On Feb 13, 2020, at 2:17 PM, Rizzo, Christopher <[email-masked]<mailto:[email-masked]>> wrote:
Sorry for the multiple emails.

To this:

Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]<mailto:[email-masked]>

From: Christopher Rizzo <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 13, 2020 at 11:06 AM
To: Michael Sweet <[email-masked]<mailto:[email-masked]>>, PWG Workgroup <[email-masked]<mailto:[email-masked]>>
Subject: Re: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]<mailto:[email-masked]>

From: Christopher Rizzo <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 13, 2020 at 11:02 AM
To: Michael Sweet <[email-masked]<mailto:[email-masked]>>, PWG Workgroup <[email-masked]<mailto:[email-masked]>>
Subject: Re: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]<mailto:[email-masked]>

From: ipp <[email-masked]<mailto:[email-masked]>> on behalf of PWG Workgroup <[email-masked]<mailto:[email-masked]>>
Reply-To: Michael Sweet <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 30, 2020 at 1:39 PM
To: PWG Workgroup <[email-masked]<mailto:[email-masked]>>
Subject: [IPP] IPP WG Last Call: IPP Transaction-Based Printing Extensions v1.1 (Ends February 13, 2020)

All,

Thanks!

________________________
Michael Sweet

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 13 Feb 2020 19:50:26 +0000

No objections from me as far as moving it out of IPP Driverless Printing Extensions v2.0 (5100.13).

I just looked at our agenda for today in the IPP WG, and working toward finishing our review of the latest draft of "IPP Driverless Printing Extensions v2.0" (https://ftp.pwg.org/pub/pwg/ipp/wd-ippnodriver20-20200204-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd-ippnodriver20-20200204-rev.pdf>) wasn't listed.

Talk to y'all in a few minutes...

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Feb 13, 2020, at 12:42 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> Chris,
> 
> > https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrans11-20200130.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrans11-20200130.docx>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrans11-20200130.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrans11-20200130.pdf>
> >
> > https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> 
> ________________________
> Michael Sweet
> 
> 
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>