Subject: [IPP] Canon issues about suggested job accounting fields - "Source-document-name(s)" and "Client host network identifier(s)"

From: Rick Yardumian via ipp <[email-masked]>
Date: Sat, 15 Feb 2020 01:09:56 +0000

Hi,

In Smith's Job Accounting Fields important to HP email( thread http://www.pwg.org/archives/ipp/2019/020282.html), he lists "Source document name(s)". Is "Source document name(s)" mapped into RFC 8011 'document-name' or other IPP attributes? If "Source-document-name(s)" is mapped into 'document-name', how is the plural of names handled?

Canon requests that the end user have a choice to opt out of sending "Source-document-name(s)".

Canon thinks the mapping for currently defined IPP Job Description or Job Status attributes for Client host network identifier(s) (hostname, various addresses) is not clear. So the end user does not have clear way to opt out of sending Client host network identifier(s) (hostname, various addresses) which is not good. If Canon's understanding is correct, Canon does not agree to the idea that Client host network identifier(s) are important.

Best regards,

Rick

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Sat, 15 Feb 2020 09:11:01 -0500

Rick,

> On Feb 14, 2020, at 8:09 PM, Rick Yardumian via ipp <[email-masked]> wrote:
> 
> Hi,
>  
> In Smith’s Job Accounting Fields important to HP email( threadhttp://www.pwg.org/archives/ipp/2019/020282.html), he lists “Source document name(s)”. Is “Source document name(s)” mapped into RFC 8011 ‘document-name’ or other IPP attributes? If “Source-document-name(s)” is mapped into ‘document-name’, how is the plural of names handled?

Each Document object has its own "document-name" attribute, so a multi-document Job will have N Document objects and N "document-name" attributes.
 
> Canon requests that the end user have a choice to opt out of sending “Source-document-name(s)”.

Absolutely, that's the point of "printer-requested-job-attributes" - to list the attributes/values that the accounting system wants but doesn't absolutely need.  The End User can then provide explicit consent via the proposed Client UI.  Right now I just show a simple "yes to all", "yes to required", and "no" choice for the user, but nothing says we can't have a UI that provides check boxes in the list to allow the user to have more control over things...

> Canon thinks the mapping for currently defined IPP Job Description or Job Status attributes for Client host network identifier(s) (hostname, various addresses) is not clear. So the end user does not have clear way to opt out of sending Client host network identifier(s) (hostname, various addresses) which is not good. If Canon’s understanding is correct, Canon does not agree to the idea that Client host network identifier(s) are important.

Well, when the Client connects to the Printer it will know the Client's source address - no way around that one with a network protocol and TCP/IP sockets...  The question is really whether the Printer will log or use any of that information, which normally is part of a service's privacy policy and is covered by the "printer-privacy-policy-uri" attribute.  But I should probably add a section that provides additional recommendations about what the privacy policy should address (the privacy attributes registration is a little too general in this context...)

________________________
Michael Sweet

---

From: Rick Yardumian via ipp <[email-masked]>
Date: Wed, 19 Feb 2020 23:27:30 +0000

Hi Mike,

Thanks for the detailed response. Canon supports the ability to opt-out of the "Source-document-name(s)".

We appreciate that you will add a section explaining your "Client host network identifier(s)" recommendations.

Thank you again for your very informative responses.

Best regards,
Rick

-----Original Message-----
From: Michael Sweet <[email-masked]> 
Sent: Saturday, February 15, 2020 6:11 AM
To: Rick Yardumian <[email-masked]>
Cc: PWG IPP Workgroup <[email-masked]>
Subject: Re: [IPP] Canon issues about suggested job accounting fields - "Source-document-name(s)" and "Client host network identifier(s)"

Email was not sent from a Canon Network!

Rick,

________________________
Michael Sweet