Subject: [IPP] Quick followup for the end of our first day at the F2F...

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 5 Feb 2020 17:10:55 -0500

All,

Just to conclude the legacy client support discussion for accounting, there is an existing "job-state-reasons" keyword value 'job-held-for-review' that would work for the "hold job" behavior for legacy Clients.

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 6 Feb 2020 04:05:47 -0500

Hi Mike,

Agreed - this seems like an appropriate Job state reason.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
(to 30 April 2020) 203 W Oak St  Ellettsville, IN 47429  812-876-9970

On Wed, Feb 5, 2020 at 5:11 PM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> Just to conclude the legacy client support discussion for accounting,
> there is an existing "job-state-reasons" keyword value
> 'job-held-for-review' that would work for the "hold job" behavior for
> legacy Clients.
>
> ________________________
> Michael Sweet
>
>
>

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 6 Feb 2020 16:51:21 +0000

Also agree!

BTW, 'job-held-for-review' is defined in 5100.16. In 5100.11, we defined 'job-password-wait'. In IPP Enterprise Printing Extensions v2.0, we are defining two new keywords for "job-held-until" and will have associated "job-state-reasons" With all of these other specs open, should we move it out of 5100.16 and put it into, for instance, IPP Enterprise Printing Extensions v2.0?

Just throwing that out there - I'll add a note about this to my next draft of EPX so we can revisit interactively.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Feb 6, 2020, at 2:05 AM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi Mike,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Wed, Feb 5, 2020 at 5:11 PM Michael Sweet via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> All,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 6 Feb 2020 11:55:09 -0500

Smith,

5100.16 is transaction-based printing which covers a bunch of paid printing scenarios, so WRT accounting I think we are OK leaving it there. :)

> On Feb 6, 2020, at 11:51 AM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Also agree! 
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 7 Feb 2020 17:38:07 +0000

OK!

> On Feb 6, 2020, at 9:55 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
>