Subject: [IPP] Procedure for submitting and errata update for an accepted standard

From: Sean Kau via ipp <[email-masked]>
Date: Wed, 5 Feb 2020 19:43:24 -0800

Per outstanding errata for 5100.1 and the call to incorporate outstanding
errata into our docs, do we have an established procedure I should follow?

-- 
Sean Kau
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 6 Feb 2020 10:26:00 -0500

Sean,

Basically, you can:

1. Let one of the WG officers know you want to work on it.

2. Download the Word version of the published specification from the standards (replace the .pdf extension with .docx or .doc, depending on the age; I'll see about updating the standards page to include the Word link as well...)

3. If necessary (not for 5100.1, which has been updated very recently), download the current PWG template from https://ftp.pwg.org/pub/pwg/general/templates/wd-template.docx and save it in Word as a template.

4. Edit the Word version and upload it to the FTP server in the pub/pwg/ipp/wd directory. 

When you edit the Word document, make sure to turn change tracking on - that allows others to see what you've changed.  For previously-published standards you'll need to revert some of the header content (replace PWG Candidate Standard 5100.NN-YYYY with Working Draft) and likely update the copyright to extend to the current year.  (I usually do that before turning on change tracking)  You'll also need to add a "Changes" section at the back with a subsection for each revision you post - look at some of the existing working drafts for an idea of the content.  And finally make sure to turn line numbers on for the main body (under the layout controls in Word).

Before you post an update, save the document with the date added to the filename, e.g. "wd-ippfinishings22-20200206.docx" would be the filename for an errata update of IPP Finishings (to version 2.2) on February 6, 2020.  Then save a "redlined" PDF version with revisions (wd-ippfinishings22-20200206-rev.pdf) and a clean PDF version without the revisions showing (wd-ippfinishings22-20200206.pdf).  All three get uploaded to the PWG FTP server - you can request the login details directly from any of the PWG or WG officers.

[PS - I'm going to work on a new web page for this with some screenshots to make this a bit clearer...]

> On Feb 5, 2020, at 10:43 PM, Sean Kau via ipp <[email-masked]> wrote:
> 
> Per outstanding errata for 5100.1 and the call to incorporate outstanding errata into our docs, do we have an established procedure I should follow?
> 
> -- 
> Sean Kau

________________________
Michael Sweet