Subject: Re: [IPP] iana registrations section 2: 1setOf missing?

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 16 Apr 2020 16:32:46 -0400

Hi Gerhard,

I'm copying in Mike Sweet, who generates all the IANA IPP Registry updates
for PWG
(and has some tools for helping with this process).  Mike and I are the
IETF Designated
Experts for the IANA IPP Registry.

Looking at RFC 8011 and its predecessor RFC 2911, it indeed looks like
there's a
missing wrapper of '1setOf' - which is unfortunate, because this would be a
change
that was *not* backward compatible in ipptool scripts for IPP Everywhere
Self-Cert.

Mike - can you shed some light on these two issues?

Cheers,
- Ira
Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Apr 16, 2020 at 4:17 PM Gerhard Muth <[email-masked]> wrote:

> Dear IPP experts,
>
> my own ipp implementation (https://github.com/gmuth/ipp-client-kotlin)
> warned me about spec violations in live ipp connections:
>
> WARN: 'number-up-supported' is not registered as '1setOf'
> WARN: 'printer-resolution-supported' is not registered as '1setOf'
>
> So I looked into it:
>
> Page 109 of RFC  8011 (pdf)
>
>
> https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xhtml#ipp-registrations-2
> says:
>
>
> For both attributes „1setOf“ is missing.
>
> If this is a valid issue could you please forward a request for correction
> to the iana organisation?
>
> My ipp validation code is based on the iana csv file
>
> https://github.com/gmuth/ipp-client-kotlin/blob/master/src/main/kotlin/de/gmuth/ipp/iana/IppRegistrationsSection2.kt
>
> Best regards,
> Gerhard
>
>
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 16 Apr 2020 16:58:32 -0400

Ira/Gerhard,

This is definitely a typo in the current registry.  I will submit a fix for this tomorrow, so hopefully everything will be correct by next week.

> On Apr 16, 2020, at 4:32 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Gerhard,
> 
> I'm copying in Mike Sweet, who generates all the IANA IPP Registry updates for PWG
> (and has some tools for helping with this process).  Mike and I are the IETF Designated
> Looking at RFC 8011 and its predecessor RFC 2911, it indeed looks like there's a
> missing wrapper of '1setOf' - which is unfortunate, because this would be a change
> that was *not* backward compatible in ipptool scripts for IPP Everywhere Self-Cert.
> 
> my own ipp implementation (https://github.com/gmuth/ipp-client-kotlin) warned me about spec violations in live ipp connections:
> 
> <Bildschirmfoto 2020-04-16 um 21.49.42.png><Bildschirmfoto 2020-04-16 um 21.57.06.png>
> 
> https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xhtml#ipp-registrations-2 says:
> 
> <Bildschirmfoto 2020-04-16 um 21.53.53.png>
> <Bildschirmfoto 2020-04-16 um 21.57.39.png>
> 
> If this is a valid issue could you please forward a request for correction to the iana organisation?
> 

________________________
Michael Sweet

---

From: Ira McDonald via ipp <[email-masked]>
Date: Fri, 17 Apr 2020 19:40:06 -0400

Hi Gerhard,

Thanks for reporting this error.  Mike prepared an update for the IANA
IPP Registry today and I've just submitted it to IANA.  It should be done
early next week.

Cheers,
- Ira

On Thu, Apr 16, 2020 at 4:58 PM Michael Sweet <[email-masked]> wrote:

> Ira/Gerhard,
>
> This is definitely a typo in the current registry.  I will submit a fix
> for this tomorrow, so hopefully everything will be correct by next week.
>
>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Tue, 21 Apr 2020 16:11:49 -0400

Hi Gerhard,

Now fixed in the IANA IPP Registry - with many thanks to Amanda Baber
for careful and rapid updates.

Cheers,
- Ira