Subject: [IPP] FYI - IPP exposure to open internet

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Wed, 24 Jun 2020 04:09:14 +0000

Maybe you have already seen this.  Forwarding in case it needs discussion

https://www.shadowserver.org/news/open-ipp-report-exposed-printer-devices-on-the-internet/

Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 24 Jun 2020 08:53:23 -0400

Chris,

Thanks for forwarding this!

Looks like the bulk of the open "devices" are CUPS servers, which would have needed to be explicitly configured to allow remote access - the default is localhost-only, then local subnets (for regular printer sharing), then whole-internet (if you want things wide open...)

> On Jun 24, 2020, at 12:09 AM, Rizzo, Christopher via ipp <[email-masked]> wrote:
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 24 Jun 2020 16:05:49 +0000

Do many printers implement the CUPS attributes?

It would be interesting to learn what motivated the owners to put their printers or print servers on public networks.

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Jun 24, 2020, at 6:53 AM, Michael Sweet via ipp <[email-masked]> wrote:

 Chris,

> https://www.shadowserver.org/news/open-ipp-report-exposed-printer-devices-on-the-internet/<https://www.shadowserver.org/news/open-ipp-report-exposed-printer-devices-on-the-internet>
>
>
> Chris
>
> Christopher Rizzo
> Xerox Corporation
> https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 24 Jun 2020 12:11:49 -0400

Smith,

Very few - I am aware of a few office MFPs that use CUPS internally, and there are network print services that implement the CUPS-Get-Printers operation for AirPrint (to lookup a printer by its printer-id value - it is used for Bluetooth beacons), but the numbers of devices and spread of version numbers sounds more like Internet-facing Linux servers to me.

> On Jun 24, 2020, at 12:05 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 

________________________
Michael Sweet