Subject: [IPP] Slides to discuss feature compatibility topics for IPP EPX

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 4 Jun 2020 15:31:39 +0000

Greetings,

I'm currently trying to author the IPP EPX section that describes compatibility between the Job Release, Job Storage and Proof Print features. I've posted some slides for a future discussion of IPP EPX features and their compatibility with one another. I'd like to review and discuss so that I make sure I've thought of all of the corner cases and issues. I know this is last minute - I'm not anticipating that we look at it today, but we can if time permits.

https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibility-investigation-20200604.pdf

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 4 Jun 2020 16:16:29 +0000

Hi Jeremy,

Good question! The way Proof Print had been defined in 5100.11, the "proof-print" Job Template attribute MUST be removed from the copy of the retained job that will conclude the Proof Print, with the intention that the Printer will not retain the Job copy since it lacks its own "proof-print" Job Template attribute. The goal is to not change this in EPX.

Your question led me to wonder if there are "job accounting" attributes (Job Status attributes) that indicate that a Job is a copy of another Job to construct the audit trail?

Smith

From: Jeremy Leber <[email-masked]>
Sent: Thursday, June 4, 2020 9:41 AM
To: PWG IPP Workgroup <[email-masked]>; Kennedy, Smith (Wireless & IPP Standards) <[email-masked]>
Subject: Re: Slides to discuss feature compatibility topics for IPP EPX

Hi Smith,

This has probably already been discussed, but would proof print jobs remain in storage (to allow further attempts) after the second "completed" state, or are they removed from storage at that point?

Thanks,
Jeremy

Jeremy Leber
Area Owner, Network & Mobile Firmware Development

O  +1 859 825-4505
[email-masked]<mailto:[email-masked]>

[http://www.lexmark.com/common/images/email/lexmark-logo-email-signature.png]<http://www.lexmark.com>
www.lexmark.com<http://www.lexmark.com/>
________________________________
From: ipp <[email-masked]<mailto:[email-masked]>> on behalf of Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, June 4, 2020 11:31 AM
To: PWG IPP Workgroup <[email-masked]<mailto:[email-masked]>>
Subject: [IPP] Slides to discuss feature compatibility topics for IPP EPX

Greetings,

https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibility-investigation-20200604.pdf<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fftp.pwg.org%2Fpub%2Fpwg%2Fipp%2Fslides%2Fipp-epx-feature-compatibility-investigation-20200604.pdf&data=02%7C01%7Cjeremy.leber%40lexmark.com%7Ca89230589c184745ebab08d8089c6f16%7C127090656e6c41c99e4dfb0a436969ce%7C1%7C1%7C637268815269344900&sdata=Cgv0QI1wbidzPGaGwv92bsDDRxWGj2j0ndGXujJndWs%3D&reserved=0>

Smith

/**
    Smith Kennedy
    HP Inc.
*/

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 4 Jun 2020 13:40:59 -0400

Smith,

> On Jun 4, 2020, at 12:16 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Hi Jeremy,
>  
> Good question! The way Proof Print had been defined in 5100.11, the “proof-print” Job Template attribute MUST be removed from the copy of the retained job that will conclude the Proof Print, with the intention that the Printer will not retain the Job copy since it lacks its own “proof-print” Job Template attribute. The goal is to not change this in EPX.

I believe the current semantics are if you send a Resubmit-Job operation, the new Job inherits all but the proof-print Job Template attribute, which means that a job-retain-until/-time/-interval attribute in the request (or the corresponding xxx-default value) will apply to the copy.  Thus, the copy of the proof Job *could* also be retained, but only as a side-effect of the job-retain attributes.
 
> Your question led me to wonder if there are “job accounting” attributes (Job Status attributes) that indicate that a Job is a copy of another Job to construct the audit trail?

Not at present, although I do remember having a discussion about adding a "parent-job-id" attribute at some point for this very reason.  It doesn't look like it actually made it into JPS2, so that might be something to consider adding for EPX. (and then parent-job-id and parent-job-uuid for "fun")

> [email-masked]
> www.lexmark.com
> From: ipp <[email-masked]> on behalf of Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]>
> To: PWG IPP Workgroup <[email-masked]>
> I’m currently trying to author the IPP EPX section that describes compatibility between the Job Release, Job Storage and Proof Print features. I’ve posted some slides for a future discussion of IPP EPX features and their compatibility with one another. I’d like to review and discuss so that I make sure I’ve thought of all of the corner cases and issues. I know this is last minute – I’m not anticipating that we look at it today, but we can if time permits.
>  

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 4 Jun 2020 18:04:09 +0000

Hi Mike,

From: Michael Sweet <[email-masked]>
Sent: Thursday, June 4, 2020 11:41 AM
To: Kennedy, Smith (Wireless & IPP Standards) <[email-masked]>
Cc: Jeremy Leber <[email-masked]>; PWG IPP Workgroup <[email-masked]>
Subject: Re: [IPP] Slides to discuss feature compatibility topics for IPP EPX

Smith,

> On Jun 4, 2020, at 12:16 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi Jeremy,
>

I believe the current semantics are if you send a Resubmit-Job operation, the new Job inherits all but the proof-print Job Template attribute, which means that a job-retain-until/-time/-interval attribute in the request (or the corresponding xxx-default value) will apply to the copy. Thus, the copy of the proof Job *could* also be retained, but only as a side-effect of the job-retain attributes.
[S.Kennedy] Yep that is true – if there are other attributes such as “job-retain-until”, then the Job copy will persist longer than a “normal” Job. But it will NOT be listed in a Get-Jobs (“which-jobs” = ‘proof-print’).

Not at present, although I do remember having a discussion about adding a "parent-job-id" attribute at some point for this very reason. It doesn't look like it actually made it into JPS2, so that might be something to consider adding for EPX. (and then parent-job-id and parent-job-uuid for "fun")
[S.Kennedy] I’ll add “parent-job-id” and “parent-job-uuid” to EPX. Should the parent also have a Job Status attribute “copy-job-ids” and “copy-job-uuids”?

>
> Smith
>
>
>
>
> From: Jeremy Leber <[email-masked]<mailto:[email-masked]>>
> To: PWG IPP Workgroup <[email-masked]<mailto:[email-masked]>>; Kennedy, Smith (Wireless & IPP Standards) <[email-masked]<mailto:[email-masked]>>
> www.lexmark.com<http://www.lexmark.com>
> https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibility-investigation-20200604.pdf<https://ftp.pwg.org/pub/pwg/ipp/slides/ipp-epx-feature-compatibility-investigation-20200604.pdf>
>
> Smith
>
> /**
> Smith Kennedy
> HP Inc.
> */
>
>
>
> [email-masked]<mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 4 Jun 2020 14:16:23 -0400

Smith,

> On Jun 4, 2020, at 2:04 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> ...

No, that will make implementation a lot more difficult.  Just have the child jobs track their immediate parent and the Client can build a tree out of it as needed...

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 4 Jun 2020 14:17:30 -0400

... although we could add a 'job-copied' keyword for "job-state-reasons" to record whether a copy has been made.

> On Jun 4, 2020, at 2:16 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 4 Jun 2020 18:52:00 +0000

Hi Mike,

> -----Original Message-----
> Sent: Thursday, June 4, 2020 12:18 PM
> >>> Your question led me to wonder if there are “job accounting”
> attributes (Job Status attributes) that indicate that a Job is a copy of
> another Job to construct the audit trail?
> >>
> >> Not at present, although I do remember having a discussion about adding
> a "parent-job-id" attribute at some point for this very reason. It doesn't
> look like it actually made it into JPS2, so that might be something to
> consider adding for EPX. (and then parent-job-id and parent-job-uuid for
> "fun")
> >>
> >> [S.Kennedy] I’ll add “parent-job-id” and “parent-job-uuid” to EPX.
> Should the parent also have a Job Status attribute “copy-job-ids” and
> “copy-job-uuids”?
> >
> > No, that will make implementation a lot more difficult.  Just have the
> child jobs track their immediate parent and the Client can build a tree
> out of it as needed...
>

It might be more work to implement adding that, but it seems like that effort would be offset by the work of finding all of the child Jobs.

I started to wonder if "Get-Jobs" can accept a "job-state-reasons" attribute to request filtered results in the response. But if the set of terminal Jobs isn't that massive, the auditing and tree construction could all be done locally without repeated IPP operations. It might be worth discussing this in the "Job Accounting with IPP" once these attributes are defined in EPX.

(Perhaps "parent-job-uuid" ought to be defined in NODRIVER where "job-uuid" is defined?)
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp