Subject: RE: Deleting ipSecPolicyTimePeriod related classes from IPsec PIB

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 2 Nov 2004 15:43:35 +0100

Thanks for pinging/reminding me.

It seems that I last reviewed revision 9 ad that I should take
a look at rev 10. Will put it on my todo list.
Not sure I can get to it before the end of IETF61.
Actaully I doubt I will be able to do so before Nov 15 or so.
Pls ping me again around that time if I have not answered.

Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, October 27, 2004 19:33
> To: [email-masked]; [email-masked]
> Subject: Deleting ipSecPolicyTimePeriod related classes from IPsec PIB
> 
> 
> Hi Bert,
> 
> In March, we received your comments on IPsec PIB and made 
> modifications accordingly. The only remaining issue is about 
> the ipSecPolicyTimePeriod classes. You and I discussed two 
> solutions and both seemed to have some drawback:
> 
> Solution #1. Put the ipSecPolicyTImePeriod classes into a 
> separate module within the IPsec PIB document. The drawback 
> is that since the title of the draft is IPsec PIB, it should 
> not contain a separate module that is not IPsec related. 
> People will probably not look into this draft to find time 
> related PIB classes
> 
> Solution #2. Put the ipSecPolicyTime Period classes into a 
> separate module in a separate IETF draft. The drawback is 
> that it seems to me that IETF does not want to entertain 
> another PIB draft. 
> 
> At the end of our April e-mail discussions, you were going to 
> check if the TimePeriod classes are the only ones that should 
> be separate from the IPsec PIB. I am now proposing another 
> simpler solution as follows. 
> 
> If, after checking the document, you also think that the 
> TimePeriod classes are the only ones that are not IPsec 
> specific, what about we delete the ipSecPolicyTimePeriod 
> classes from the IPsec PIB so that we can move on?
> 
> If on the other hand, you think that there are other stuff 
> that are not IPsec specific, please let use know. Thanks.
> 
> Best regards
> Man Li
> 
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 7 Nov 2004 17:17:22 +0100

I started to look at thos document again.
But this is a very looong document, so I see no way to finsih
my review before end of IETF61 week.

W.r.t. the TimePeriod, I see your TC and I also see
pmSchedTimePeriod in the pm-mib (an approved document
now in RFC-Editor queue): draft-ietf-snmpconf-pm-14.txt
They are using a PmUTF8string  (their own TC).
They also have a size limited (0..31) while you use 
unlimited length (even though your DISPLAY-HINT seems to
limit it to 255.

Similar concern for yout TimeOfDayTC.

And then I need to check how much similarities or differences
there are with the other time/schedule related TCs.

I wonder, would you not be able to just use some of the 
tables of the PM-MIB? 
Has anyone every looked at that?

Bert

> From: Wijnen, Bert (Bert) 
> Sent: Tuesday, November 02, 2004 09:44
> To: [email-masked]'; [email-masked]
> Subject: RE: Deleting ipSecPolicyTimePeriod related classes from IPsec
> PIB
> 
>

---

From: <[email-masked]>
Date: Mon, 8 Nov 2004 16:58:08 -0500

Hi Bert,

You have a good point about TimePeriod in PM-MIB. By now, you have convinced me that the time period classes should not be in IPsec PIB. Hence if there is no objection from you and the group, I would suggest to delete them from IPsec PIB. IPsec PIB will be just like Diffserv PIB in the sense that it focuses on config a specific policy and it contains neither time period information nor any reference to time period.

Please let us know if you think otherwise. We also look forward to hearing your further comments on the draft. Thanks

Best regards
Man 

> From: ext Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: Sunday, November 07, 2004 11:17 AM
> To: Li Man.M (Nokia-NRC/Boston); [email-masked]'

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sun, 14 Nov 2004 05:09:50 +0100

Inline

> Sent: Monday, November 08, 2004 16:58
> You have a good point about TimePeriod in PM-MIB. By now, you 
> have convinced me that the time period classes should not be 
> in IPsec PIB. Hence if there is no objection from you and the 
> group, I would suggest to delete them from IPsec PIB. IPsec 
> PIB will be just like Diffserv PIB in the sense that it 
> focuses on config a specific policy and it contains neither 
> time period information nor any reference to time period.
> 
ANd so, I guess people who need such classes then use them
from the MIB, right?

> Please let us know if you think otherwise. We also look 
> forward to hearing your further comments on the draft. Thanks
> 

I know I am (too) slow on this.
But it is a 75 page PIB definition. Not a quick read.
I am on the road this coming week.
Will try to give this doc some attention in week of 22 nov.

By the way, the issue on what is generic and what is technology
specific is something you can find out if you study the Policy WG
documents. I will have to do same if I am to give you my advise
and my opinions.

Bert

---

From: <[email-masked]>
Date: Mon, 15 Nov 2004 14:29:16 -0500

Please see inline.

> ANd so, I guess people who need such classes then use them

Ideally, if there is a separate time period PIB module document or if the time period is inside the framework PIB, a simple reference to them will do. Since neither is possible now, people have to look for other approaches available in their specific environment.   

> documents. I will have to do same if I am to give you my advise

I looked through RFC 3060, 3460 and 3703 and it seems to me that time period is the only thing in the IPsec PIB that is in 3060 and hence is generic. All other stuff in the IPsec PIB is in RFC 3585 (IPsec config information model) and is hence specific to IPsec. It is possible that my interpretation is not totally correct and if that is the case, please let me know.