Subject: Re: [IPTEL] New draft RFC 2806bis

From: "Richard H. Gumpertz" <[email-masked]>
Date: Fri, 28 Dec 2001 08:07:21 -0600

I apologize if I am reopening something that has already been beat to death...

Why is space prohibited as a visual-separator in telephone numbers?  Yes, it has to be escaped, which can be ugly, but the end-user may not see that escaping.  End users may be dealing with User Interfaces rather than raw URIs and so enhanced readability of the URI is NOT the issue; enhanced readability at the UI level is.  Why not allow space as a visual-separator so that such information can be preserved?

A sentence in 6.1.2 discouraging use of space (due to the ugliness of escaping) as a visual separator seems more appropriate than prohibition.

On the other hand, I understand that allowing escaped spaces as visual separators might break existing implementations, which could be more costly than any benefit to be gained at this point in time by allowing them.

                Rick Gumpertz

At 23:01 12/22/2001 -0500, Henning Schulzrinne wrote:
>I will submit the draft below after the holidays, when the I-D editor
>returns:
>
>http://www.cs.columbia.edu/~hgs/sip/drafts/draft-schulzrinne-rfc2806bis-00.txt
>
>Comments are much appreciated. Much of the text has been rewritten, but
>the document is meant to be backwards-compatible except for the omission
>of the private context name.
>
>Henning
>_______________________________________________
>IPTEL mailing list
>[email-masked]
>http://lists.bell-labs.com/mailman/listinfo/iptel 

--
  Richard H. Gumpertz, Ph.D.
  Raviant Networks, Inc.
  office: +1 (913) 266-5137
  mobile: +1 (913) 484-8777

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "Sean Olson (EUS)" <[email-masked]>
Date: Mon, 7 Jan 2002 14:05:29 -0600

>Why is space prohibited as a visual-separator in telephone 
>numbers?  Yes, it has to be escaped, which can be ugly, but 
>the end-user may not see that escaping.  End users may be 
>dealing with User Interfaces rather than raw URIs and so 
>enhanced readability of the URI is NOT the issue; enhanced 
>readability at the UI level is.  Why not allow space as a 
>visual-separator so that such information can be preserved?

You just answered your own question. This is a UI level thing.
Why put this in the signalling? Personally, I don't care one
way or the other whether visual separators are allowed. It is
extremely trivial to write code for either case. I can't believe
this topic has generated so much discussion.

/sean