Subject: RE: [IPTEL] Query regarding application of TRIP

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Tue, 8 Jan 2002 10:31:29 -0500

Please see inline [RRR].

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Monday, January 07, 2002 4:03 PM
To: Roy, Radhika R, ALASO
Cc: vipin gahlaut; [email-masked]
Subject: Re: [IPTEL] Query regarding application of TRIP

Roy, Radhika R, ALASO wrote:

> Hi, Vipin:
> 
> You are right that TRIP does not help for SIP-H.323 IWF interworking the
> way TRIP has been standardized now. TRIP just addresses for routing of
> the E.164/Decimel/PentaDecimel numbers for inter-ITAD (or inter-Domain)
> communications only. That is, communications are made among the location
> servers of different administrative Telephony domains. It does not deal
> with the GWs as well. It even does not address the propagation of
> capacity, QOS, and other attributes. It has a very limited use.

Radhika, little benefit is gained by using this question to field an 
unrelated barrange of attacks against TRIP. It serves only to confuse 
the person who asked the question and distract the group. Your posts are 
very much becoming disruptive and purposefully counter productive.

[RRR] This is what people like to know about TRIP from technical point of view (its weaknesses and strengths - modeled in the light of BGP). It is rather technical clarifications.

TRIP does not address capacity, Qos, and other attribute propagation 
inter-domain for GOOD REASON.

[RRR] This is the point that people like to know. It is rather technical clarifications (because some people think that something that is not used by TRIP is also NOT good for the GW registration protocol or otherwise).

> For intra-Domain communications among the location servers and GWs
> (SIP-ISUP Tel GW, SIP-H.323 Tel GW), a complete proposal has been made
> how all the attributes (e.g., address families
> [E.164/Decimel/PentaDecimel, email IDs, URL IDs, etc], capacity, QOS,
> etc.) can be used. You can see the proposal in the following URL:
> (http://www.ietf.org/internet-drafts/draft-roy-iptel-itrp-00.txt). With
> this, you can also use SIP-H.323 GWs for IP-IP communications.

I have said it several times, and I will say it once more. This draft is 
out of scope. The group is not considering intra-domain communications.

[RRR] The above draft has been referred to answer the questions of Vipin. If something is not a WG charter item now, it may be considered later. (If it takes too much time to make it is a WG charter, it can be considered for the informational RFC if we think to do so).

[RRR] This draft has sent to see what comes out of the technical discussion. We have to see how the technical discussion on GW registration protocol goes on. This draft has many things and the GW registration and discovery are also a part of it in the context of the intra-Domain protocol. We have seen most of the technical discussion that is going on related to the GW registration protocol has been influenced by this draft. For example, all types of GWs will have the common attributes like address families, capacity, QOS, and others that can be registered with the location server.

[RRR] Please also see another email sent in response to Jon Peterson's questions. This will also clarify more how the above draft is contributing to advance the goals of the IPTEL WG.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com
_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: vipin gahlaut <[email-masked]>
Date: Thu, 10 Jan 2002 04:46:36 +0000 (GMT)

Hi Everybody,

    I am very much thankful to you to help me in
understanding the registration mechanism betwen
location server and gateway nad between LS to LS.

I am reading the draft suggested by Radhika. Actually
I am working in a Telecom company and we have a
gateway solution which is a capable of interworking
between SIP,POTS,H.323,SS7,R1 signalling.

We also have implemented RAS protocol in H323 to
register GW, and also have SIP register mechanism.
Now we want to develop a full fledged Location Server,
which can help in inter ITAD communication and also
Intra ID communication, along with a comprehensive
registration mechanism from GW to LS. 
Actually we want to avoid two registration mechanism
for SIP and H323 and want to have a common solution
for any protocol.

Previously I was thinking to implement only TRIP, but
after the suggestion of ITRP, I found ITRP will also
help in long term. 

Do I need to implement both ITRP( for GW to LS) and 
TRIP ( for LS to LS )???

Please suggest me How should I proceed.

Thanks for your suggestion and help.

Best Regards
Vipin

 --- "Roy, Radhika R, ALASO" <[email-masked]> wrote: >
Please see inline [RRR].
> [RRR] This is what people like to know about TRIP
> from technical point of view (its weaknesses and
> strengths - modeled in the light of BGP). It is
> rather technical clarifications.
> 
> [RRR] This is the point that people like to know. It
> is rather technical clarifications (because some
> people think that something that is not used by TRIP
> is also NOT good for the GW registration protocol or
> otherwise).
> 
> 
(http://www.ietf.org/internet-drafts/draft-roy-iptel-itrp-00.txt).
> With
> [RRR] The above draft has been referred to answer
> the questions of Vipin. If something is not a WG
> charter item now, it may be considered later. (If it
> takes too much time to make it is a WG charter, it
> can be considered for the informational RFC if we
> think to do so).
> 
> [RRR] This draft has sent to see what comes out of
> the technical discussion. We have to see how the
> technical discussion on GW registration protocol
> goes on. This draft has many things and the GW
> registration and discovery are also a part of it in
> the context of the intra-Domain protocol. We have
> seen most of the technical discussion that is going
> on related to the GW registration protocol has been
> influenced by this draft. For example, all types of
> GWs will have the common attributes like address
> families, capacity, QOS, and others that can be
> registered with the location server.
> 
> [RRR] Please also see another email sent in response
> to Jon Peterson's questions. This will also clarify
> more how the above draft is contributing to advance
> the goals of the IPTEL WG.
> 
> -Jonathan R.
> 
> 
> -- 

________________________________________________________________________
Looking for a job?  Visit Yahoo! India Careers
      Visit http://in.careers.yahoo.com
_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel