Subject: RE: [IPTEL] Query regarding application of TRIP

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Mon, 7 Jan 2002 15:25:36 -0500

Hi, Vipin:

You are right that TRIP does not help for SIP-H.323 IWF interworking the way TRIP has been standardized now. TRIP just addresses for routing of the E.164/Decimel/PentaDecimel numbers for inter-ITAD (or inter-Domain) communications only. That is, communications are made among the location servers of different administrative Telephony domains. It does not deal with the GWs as well. It even does not address the propagation of capacity, QOS, and other attributes. It has a very limited use.

However, IPTEL is now defining the GW registration protocol within a given ITAD (intra-ITAD or intra-Domain) where a GW can register all its attributes like address families, capacity, QOS, and others to a location server(that is, the problems of propagation of routes, capacity, QOS, and/or other attributes among the location servers are decoupled).

For inter-Domain TRIP, a location server will get its necessary attributes (e.g., E.164/Decimel/PentaDecimel numbers) once the GWs register with it while the other attributes (e.g., capacity, QOS, etc.) will NOT be used for inter-Domain (or inter-ITAD) communications.

For intra-Domain communications among the location servers and GWs (SIP-ISUP Tel GW, SIP-H.323 Tel GW), a complete proposal has been made how all the attributes (e.g., address families [E.164/Decimel/PentaDecimel, email IDs, URL IDs, etc], capacity, QOS, etc.) can be used. You can see the proposal in the following URL: (http://www.ietf.org/internet-drafts/draft-roy-iptel-itrp-00.txt). With this, you can also use SIP-H.323 GWs for IP-IP communications.

More discussions will be held along this line because we are only developing the GW registration protocol as a first step.

Best regards,

Radhika R. Roy
[email-masked]

-----Original Message-----
From: vipin gahlaut [mailto:[email-masked]]
Sent: Friday, January 04, 2002 6:05 AM
To: [email-masked]
Subject: [IPTEL] Query regarding application of TRIP

Hi Everybody

    I am not very much clear about the application of
TRIP,as in case of H323 and and SIP messages are
exchanged from one IP to other IP. The route between
these 2 IP can be selected by router already placed.
why we need to implement TRIP??

    I will be highly obliged if somebody clears my
doubt.

Thanks & Best Regards
Vipin

____________________________________________________________
Do You Yahoo!?
Send a newsletter, share photos & files, conduct polls, organize chat events. Visit http://in.groups.yahoo.com
_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel
_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 07 Jan 2002 16:03:15 -0500

Roy, Radhika R, ALASO wrote:

> Hi, Vipin:
> 
> You are right that TRIP does not help for SIP-H.323 IWF interworking the
> way TRIP has been standardized now. TRIP just addresses for routing of
> the E.164/Decimel/PentaDecimel numbers for inter-ITAD (or inter-Domain)
> communications only. That is, communications are made among the location
> servers of different administrative Telephony domains. It does not deal
> with the GWs as well. It even does not address the propagation of
> capacity, QOS, and other attributes. It has a very limited use.

Radhika, little benefit is gained by using this question to field an 
unrelated barrange of attacks against TRIP. It serves only to confuse 
the person who asked the question and distract the group. Your posts are 
very much becoming disruptive and purposefully counter productive.

TRIP does not address capacity, Qos, and other attribute propagation 
inter-domain for GOOD REASON.

> For intra-Domain communications among the location servers and GWs
> (SIP-ISUP Tel GW, SIP-H.323 Tel GW), a complete proposal has been made
> how all the attributes (e.g., address families
> [E.164/Decimel/PentaDecimel, email IDs, URL IDs, etc], capacity, QOS,
> etc.) can be used. You can see the proposal in the following URL:
> (http://www.ietf.org/internet-drafts/draft-roy-iptel-itrp-00.txt). With
> this, you can also use SIP-H.323 GWs for IP-IP communications.

I have said it several times, and I will say it once more. This draft is 
out of scope. The group is not considering intra-domain communications.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com