Subject: [IPTEL] carrier codes in draft-rs-trip-gw-03.txt

From: "Bob Penfield" <[email-masked]>
Date: Wed, 3 Apr 2002 15:25:48 -0500

The carrier code attribute and address family defined in this draft does not
support carrier codes for anywhere other than North America. It should
include a country code prefix similar to that proposed in
draft-yu-tel-url-04.txt or draft-walker-iptel-trip-tns-01.txt.

cheers,
(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

_______________________________________________
IPTEL mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/iptel

---

From: "David R. Oran" <[email-masked]>
Date: Thu, 11 Apr 2002 09:16:45 -0400

If there are multiple drafts with these things, would it not be better
to create an IANA registry for these values?

For the ADs: are there some special considerations or problems with
having an IANA registry of numbers which map to (possibly by the
identity mapping) numbers whose ownership and assignment actually comes
from elsewhere?

Dave.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bob Penfield
> Sent: Wednesday, April 03, 2002 3:26 PM
> To: list iptel
> Subject: [IPTEL] carrier codes in draft-rs-trip-gw-03.txt
> 
> 
> The carrier code attribute and address family defined in this 
> draft does not support carrier codes for anywhere other than 
> North America. It should include a country code prefix 
> similar to that proposed in draft-yu-tel-url-04.txt or 
> draft-walker-iptel-trip-tns-01.txt.
> 
> cheers,
> (-:bob
> 
> Robert F. Penfield
> Chief Software Architect
> Acme Packet, Inc.
> 130 New Boston Street
> Woburn, MA 01801
> [email-masked]
> 
> 
> http://lists.bell-> labs.com/mailman/listinfo/iptel
>

---

From: Scott Bradner <[email-masked]>
Date: Thu, 11 Apr 2002 11:18:41 -0400 (EDT)

I need more detail (not following close enough I guess)

but in general the IANA maintains registries where it assigns values

Scott

---

---

From: "David R. Oran" <[email-masked]>
Date: Thu, 11 Apr 2002 09:16:45 -0400

Dave.

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 11 Apr 2002 13:32:53 -0400

Within the context of TRIP and PSTN/GSTN gateway location, the idea is to
use the carrier identification codes (CICs) already used in the PSTN/GSTN.
The problem is that each country has its own carrier codes. Thus the need
for a country code. However, since there is already a naming authority for
country codes and within each country a naming authority for carrier codes
(at least those in circuit switched networks), we do not need an IANA
registry for those. The point of the original mail was that if we are using
legacy CICs in the IP world, there should be a consistent way to represent
and handle them.

If these CICs start getting used across the IP Telephony protocols, and new
CICs are needed for IP tel networks and providers, how would you then manage
the CIC namespace? Would the same authorities continue to give out CICs? Or
would IANA manage the IP-specific CICs? I have not thought much about this
and don't really have any strong opinions at this point. Just something to
think about.

cheers,
(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "Scott Bradner" <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Thursday, April 11, 2002 11:18 AM
Subject: RE: [IPTEL] carrier codes in draft-rs-trip-gw-03.txt

> >From [email-masked]  Thu Apr 11 09:23:55 2002
> From: "David R. Oran" <[email-masked]>
> To: "'Bob Penfield'" <[email-masked]>,
>    "'list iptel'" <[email-masked]>
> Cc: "Scott Bradner" <[email-masked]>, "'Allison Mankin'" <[email-masked]>
> Subject: RE: [IPTEL] carrier codes in draft-rs-trip-gw-03.txt
> Date: Thu, 11 Apr 2002 09:16:45 -0400
> Organization: Cisco Systems
> MIME-Version: 1.0
> Content-Type: text/plain;
> charset="us-ascii"
> Content-Transfer-Encoding: 7bit
> X-Priority: 3 (Normal)
> X-MSMail-Priority: Normal
> X-Mailer: Microsoft Outlook, Build 10.0.3416
> In-Reply-To: <[email-masked]>
> Importance: Normal
> X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
>

---

From: Scott Bradner <[email-masked]>
Date: Thu, 11 Apr 2002 14:50:06 -0400 (EDT)

it seems that the IANA should not be recording values that someone
else assigns since they will get out of sync

Scott

---

From: Michael Hammer <[email-masked]>
Date: Fri, 12 Apr 2002 10:53:55 -0400

Bob,

The E.164 number space, the country codes, the CIC codes are all part of 
the PSTN realm.  I don't see a need for any redundant management of those 
values.  Previously it was pointed out that the CIC codes combined with the 
country codes, as described in draft-yu-tel-url-04.txt, would make them 
globally unique.  Hopefully, that convention will answer your needs.  If 
there was another issue here, I missed it.

Mike