Subject: [IPTEL] Fwd: draft-ietf-iptel-trip-gw-00.txt has been posted

From: Dhaval Shah <[email-masked]>
Date: Sun, 09 Jun 2002 11:20:08 -0700

Hi Folx,

Just a follow-up to the draft posting.

The main changes in this version are:
- Removed Carrier-Trunkgroup attribute and address family and
    references to it.
- Added Terminology and Definitions section.
- Updated CallSuccess attribute.
- Added Prefix attribute.
- Added Carrier attribute.
- Added TrunkGroups attribute.
- Added TrunkGroup Address Family.
- Added Carrier Address Family.
- Added Route Consolidation section.
- Added some more references.

A couple of open issues that come to mind are:
- International carrier ids
- Jonathan had a suggestion regarding having an update rate capability that 
the LS would send
to the gateway. The purpose would be to have the gateway not send updates 
at a rate higher than the
specified number.

Thx,
Dhaval

>Date: Fri, 07 Jun 2002 07:51:22 -0700
>To: [email-masked]
>From: Dhaval Shah <[email-masked]>
>Subject: draft-ietf-iptel-trip-gw-00.txt has been posted
>Cc: [email-masked], [email-masked], [email-masked], Rajneesh 
>Kumar <[email-masked]>
>Bcc: [email-masked], [email-masked], [email-masked], [email-masked], 
>[email-masked], [email-masked], [email-masked], [email-masked], 
>[email-masked], [email-masked]
>
>Hi Folx,
>
>The draft is now available on the ftp server:
>ftp://ftp-eng.cisco.com/dhaval/draft-ietf-iptel-trip-gw-00.txt
>
>If someone has problems retrieving it, please email directly and we will
>email a copy to you.
>
>Please let us know if you have any questions.
>
>Thx,
>Dhaval (for the trip-gw team)

---

From: Dhaval Shah <[email-masked]>
Date: Mon, 10 Jun 2002 18:15:24 -0700

Hi Anna,

Please see comments inlined below..

At 02:34 PM 6/10/2002 -0400, Anna Cheung wrote:
>Hi Dhaval,
>
>I have some questions after reading the trip-gw draft, and hope
>you or somebody in the work group could clarify.
>
>Thanks
>/Anna
>
>
>1) Available Capacity (AC) is defined as non-transitive
>in the draft. I'm just wondering if it should be transitive instead.
>The reason being if the LS fronting the GW does not advertises
>the AC of the route to other LS's in the core of the network, then there
>could be cases where a route is selected with higher TotalCapacity but
>lower available Capacity. (From the draft, it seems to be
>the reason it is defined as non-transitive is due to the fact that
>it might change frequently. But if the GW only advertises when
>somethrehold is crossed, then the frequency might not be a big problem
>for the LS ??)

This would add another level of complexity and gets into tuning
to avoid staleness etc. We analyzed this and thought of not including at 
this time.

>
>2) Section 4.4 prefix attribute, is it saying that the prefix attribute is
>a conditional mandatory attribute for the trunk address family and CIC
>address family?  I'm a bit confused by the statement "conditional mandatory
>(if reachable routes is present)"

This means that if the reachableroutes attribute is present, then the prefix
attribute must be present. A length of zero for the prefix attribute 
indicates a prefix
that matches all prefixes for the respective address family type and 
application protocol.
I thought I had included that statement in the draft but loox like it got 
removed while re-arranging
the Prefix attributes section. Will add it in the next rev.

>3) When a GW advertises a route of type trunk address family (or CIC address
>family), if attribute prefix attribute is NOT present, does it mean the 
>advertised
>trunk (or CIC) can be used to reach ANY prefix?

No. Please see note above.

>
>4) Can you please clarify why carrier attribute must not be used with 
>trunk family
>and trunk attribute must not be used with the CIC family ?

Introduces hierarchy and complexity amongst other reasons and was not 
deemed important
enough at this stage. We have noted it as a future issue.

>5) Reading section 4.10.1, I'm under the impression that an LS may receive
>alternative routes from the same gateway for a given destination. Is this 
>true?
>  Doesn't the subsequent advertisment of a given route from the same GW 
> just replaces
>the previous advertisement?

Section 4.10.1 tries to address the case where the LS may receive 
alternative routes
for the same destination from *different* gateways. If the same gateway 
wants to advertise
alternative routes for a given destination, then it can send them in one 
update to the LS.

>6) When a GW advertise an update with the follows:
>- trunk address family,
>- trk value=trk1,
>- prefix attribute=1613,
>- nexthop = NH1
>
>The update is saying that route trk1 and prefix 1613 is
>reachable via NH1.  Could we also interpret that 1613
>is reachable via NH1?

Yes, if you don't care about trk1.

Hope this helps.

Thx,
Dhaval

>
>-----Original Message-----
>From: Dhaval Shah [mailto:[email-masked]]
>Sent: Sunday, June 09, 2002 2:20 PM
>Subject: [IPTEL] Fwd: draft-ietf-iptel-trip-gw-00.txt has been posted
>
>Hi Folx,
>
>- Jonathan had a suggestion regarding having an update rate capability 
>that the LS would send
>>Cc: [email-masked], [email-masked], [email-masked], 
>>Rajneesh Kumar <[email-masked]>
>>Bcc: [email-masked], [email-masked], [email-masked], 
>>[email-masked], [email-masked], [email-masked], [email-masked], 
>>[email-masked], [email-masked], [email-masked]
>>
>>Hi Folx,
>>

---

From: Dhaval Shah <[email-masked]>
Date: Thu, 13 Jun 2002 08:09:28 -0700

At 05:08 PM 6/10/2002 -0400, Anna Cheung wrote:
>One more question..
>
>If  a route that was advertised with address family trunk or CIC become 
>invalid,
>how does the gateway advertise a withdraw for these two address family to 
>the LS?

By using the good old WithdrawnRoutes attribute defined in TRIP RFC :-)

Thx,
Dhaval

>From: Anna Cheung
>Sent: Monday, June 10, 2002 2:35 PM
>To: 'Dhaval Shah'; [email-masked]
>Cc: Li Li
>Subject: RE: [IPTEL] Fwd: draft-ietf-iptel-trip-gw-00.txt has been posted
>
>Hi Dhaval,
>

---

From: Dhaval Shah <[email-masked]>
Date: Thu, 13 Jun 2002 08:24:36 -0700

At 01:44 PM 6/12/2002 -0400, Anna Cheung wrote:
>Hi Dhaval,
>
>Follow up to your reply for question
>2 below. Why do you want to make the prefix attribute a mandatory
>attribute for the prefix address family?  The reachableRoute and withdrawRoute

Towards the end of section 4.7.1 of trip-gw draft, we have,
"The Prefix attributes MUST NOT be used with the Prefix address
families." Also, please note that  it's *conditional* mandatory.

Thx,
Dhaval

>
>as defined in the TRIP rfc 3219 can be a set or sequence of prefixes.
>
>Thanks
>/Anna
>Sent: Monday, June 10, 2002 9:15 PM
>To: Anna Cheung
>Cc: [email-masked]; Li Li
>>>[email-masked], [email-masked], [email-masked], 
>>>[email-masked], [email-masked], [email-masked], [email-masked]
>>>
>>>Hi Folx,
>>>