Subject: AW: [Iptel] tel URI and ENUM

From: "Stastny Richard" <[email-masked]>
Date: Mon, 24 Mar 2003 20:42:22 +0100

Flemming wrote:

	 Agreed - it seems reasonable that things that are related to the call in general
	as opposed to the tel-URI specifically, should rather be present in headers (or
	media descriptions, depending on what type of properties we are looking at). I'm
	not sure we have everything covered though:
	
	1. Which category does the "cic" parameter in yu-tel-url belong to ?
	
	2. What if I wanted to add the equivalent of carrier selection, i.e. an
	indicator to show whether a "cic" parameter was provided because the user
	actively requested it or because it was simply the pre-subscribed carrier for
	this call ?
	
	-- Flemming

The cic in Yu's draft relates only to the Freephone provider:
"The freephone-related information includes the dialed freephone 
   number, the carrier identification code (CIC) that identifies the 
   freephone service provider/carrier and the translated POTS number. "
 
So he related to the first IN-dip in the freephone sequence. It has nothing to
do with call-by-call carrier selection or pre-selection CIC.
 
The whole issue and terminology needs therefore additional work, internationalisation 
and discussion anyway.
 
regards
Richard
_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 24 Mar 2003 15:17:38 -0500

> do with call-by-call carrier selection or pre-selection CIC.

Not quite - from Section 4:

"If a country uses the CIC codes
   to identify the service providers/carriers that are not limited to
   the freephone service providers/carriers, this new parameter can
   also be used to identify those service providers/carriers even when
   freephone service is not involved.   One example is the CIC dialed
   by the caller for selecting a specific inter-exchange carrier in the
   U.S. (e.g., 101XXXX). "

However the draft has admittedly gone back and forth on this issue. Ignoring that, the bigger
question perhaps is whether the draft should address or not. I think it should.

-- Flemming