Subject: AW: AW: [Iptel] tel URI and ENUM

From: "Stastny Richard" <[email-masked]>
Date: Thu, 20 Mar 2003 00:30:12 +0100

>> 1. use e.g on Webpage: TH, NP, CP should not be used or are not applicable, TD may be useful
>> 2. use in signalling (e.g. INVITE): TH, TD, NP, CP may be useful

>But CP can usually be indicated in a different way, e.g., in Caller-Info
>in SIP. I think that's a better place for CP-style information.

Fully agree

> 3. use in ENUM: TH and CP are not applicable, TD may be usefull, NP is essential (see below)

>What are examples of NP in this context?
 
The following was an example:

>> ENUM or ENUM-like systems may be used to store translation information in a tel URI
>> e.g. tel:+43123456;rn=8620123456 according to the Yu-extensions.

In the yu-tel draft it is proposed to use the rn, npdi and cic parameters for signalling, the draft itself
is not explicitely stating how this information is derived, but he is giving some examples as IN-SCP or ENUM
 
We are planning to use ENUM to be accessible from IP and TDM-networks, or at least put the same
information contained in the IN-SCP also in ENUM, because it is derived from the same database,
so for a number not terminating on IP but on TDM the same information in ENUM can be storred 
as in the IN-SCP. This allows the e.g. the rn or cic to be already supplied, thus saving the TDM an additional
IN dip. This is only one examples, more scenarios are in discussion.
 
Richard

>       (TH) translation history hints ("translation X has been performed");
>      
>       (TD) translation directive ("translation X should/should not be performed");
>      
>       (NP) number property: "the number in the tel URI is a 'foo'" (and it
>       will be a 'foo' for a long time).
>      
>       (CP) call property: the call with this tel URI has the following properties
>      

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 20 Mar 2003 23:41:40 -0500

> >in SIP. I think that's a better place for CP-style information.

Note however that these statements are not mutually exclusive; depending on where the tel-URI is used
(Request-URI, To, From, Call-Info, etc.), different parameters may make sense.

-- Flemming