Subject: WG: [Iptel] tel URI and ENUM

From: "Alexeitsev, D" <[email-masked]>
Date: Thu, 20 Mar 2003 10:22:12 +0100

Hello Henning, All

>The subtle difference is that a tel URI can both directly reach a specific resource as well as do this via translation and 
>that multiple translation steps can be involved, but that property is inherent in the phone number (via things like 800# 
>translation, number portability and ENUM) and not specific to a tel URI.

Could you explain how tel: URI can be used to reach directly a specified resource? In my understanding tel: URI being a URN has only one meaningful operation - resolution/translation, i.e. it can not be used for routing of any kind and is not bound to any specific resource access protocol.

Greetings,
Denis Alexeitsev

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 20 Mar 2003 10:55:21 -0500

Alexeitsev, D wrote:
> Hello Henning, All
> 
> 
>> The subtle difference is that a tel URI can both directly reach a 
>> specific resource as well as do this via translation and that 
>> multiple translation steps can be involved, but that property is 
>> inherent in the phone number (via things like 800# translation, 
>> number portability and ENUM) and not specific to a tel URI.
> 
> 
> Could you explain how tel: URI can be used to reach directly a 
> specified resource? In my understanding tel: URI being a URN has only
>  one meaningful operation - resolution/translation, i.e. it can not
> be used for routing of any kind and is not bound to any specific 
> resource access protocol.

By direct, I mean that no further translation is necessary. A gateway or 
dialer, for example, can just apply the local dialing rules ("prefix 9") 
and reach a telephone number, as is.

In a web contect, this is vaguely similar to the mailto: URL, where 
clicking on it does not cause a direct protocol action, but rather pops 
up a mail client that 'dials' the email address when pressing 'Send'.