Subject: [Iptel] Re: [Sip] draft-ietf-iptel-trunk-group-00.txt

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 01 Dec 2003 09:19:14 -0600

Medhavi Bhatia wrote:
> Vijay and Cullen - Thanks for the quick response!
>  
> One comment we had concerned the syntax used in the Contact header, 
> which does not conform to the tel -> sip url conversion specified in RFC 
> 3261. The placement of tgrp= in the examples in section 5 seems to be in 
> the url parameters whereas we think it should be in the user parameters.

Medhavi:

This was already identified as a bug and has been corrected
in the latest rev.

> Also the draft has tried to specify the format of the trunk group 
> identifier and include the notion of namespace in it. I had some 
> discussion with one of our partners who pointed out that even within an 
> administrative domain, chances are that trunk groups may clash due to 
> misconfiguration. His suggestion was to make the user configuration 
> unique by appending a switch identifier which is normally unique, 
> thereby altering the syntax of the identifier. Is that something that is 
> being considered at this point ? We would like to get involved.

That's a good consideration, however, we would have a hard time
making it part of any standardization.  What followed the "tgrp="
was a token, and as such can be constructed in any manner so as
to render it unique within a given organizational boundary (or
cross-organization boundaries).  Using a switch identifier as
a prefix, as you note above, is one means to impart uniqueness
to the token.

We can have more discussions on this aspect after you have
digested the rev'ed I-D later on this week.

Thanks for your comments and interest.

Cheers,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Mon, 1 Dec 2003 00:33:39 -0500

One comment we had concerned the syntax used in the Contact header, which
does not conform to the tel -> sip url conversion specified in RFC 3261. The
placement of tgrp= in the examples in section 5 seems to be in the url
parameters whereas we think it should be in the user parameters.

Also the draft has tried to specify the format of the trunk group identifier
and include the notion of namespace in it. I had some discussion with one of
our partners who pointed out that even within an administrative domain,
chances are that trunk groups may clash due to misconfiguration. His
suggestion was to make the user configuration unique by appending a switch
identifier which is normally unique, thereby altering the syntax of the
identifier. Is that something that is being considered at this point ? We
would like to get involved.

Thanks - Medhavi.
  ----- Original Message ----- 
  From: Vijay K. Gurbani
  To: Medhavi Bhatia
  Cc: [email-masked]
  Sent: Sunday, November 30, 2003 11:00 PM
  Subject: Re: [Sip] draft-ietf-iptel-trunk-group-00.txt

  Medhavi Bhatia wrote:
  > Folks,
  >
  > Is this draft being revived ? We had some questions/comments on the
  > syntax specified in it and were wondering if this was being worked on or
  > dropped.
  >
  > Medhavi.

  Medhavi:

  This work is being done in the IPTEL WG.  The work
  continues; at the 58th IETF in Minneapolis, there
  were some discussions between the authors.
  The result of these is a new revision to the I-D.
  The ball is now in my court; I am working on
  incorporating some previous comments and our
  discussions at the 58th IETF.  I plan to
  have the rev'ed I-D to the co-authors by the middle
  of the first week of December and to the IPTEL WG
  list shortly thereafter.

  So, please stay tuned till next week.