Subject: RE: [Sip] RE: [Iptel] Calling Party's Category

From: "GARCIN Sebastien RD-CORE-ISS" <[email-masked]>
Date: Tue, 30 Nov 2004 17:51:33 +0100

In the Call Return service, a destination exchange memories an incoming call which failed due to non-reply. If the call was orginated by a payphone then the destination exchange does not memories the number since it makes no sense in calling back a payphone. 

BR,
sebastien

-----Message d'origine-----
De : David R Oran [mailto:[email-masked]] 
Envoyé : mardi 30 novembre 2004 17:23
À : GARCIN Sebastien RD-CORE-ISS
Cc : Jesske, R; Tom Taylor; [email-masked]; [email-masked]
Objet : Re: [Sip] RE: [Iptel] Calling Party's Category

On Nov 30, 2004, at 10:42 AM, GARCIN Sebastien RD-CORE-ISS wrote:

> Hi,
>
> As an fixed line operator we also are interested in this feature and 
> would be happy that the IETF finally moves forward with this draft.
> This type of parameter is widely signalled in ISDN/PSTN networks. In 
> SIP (for example) it is required in context of both:
>
> - pure SIP networks (e.g. in case of a SIP payphone), and
> - interworking with legacy networks
>
> I think the uses case for this parameter will depend on the operator 
> service portfolio. For example, in France, the calling party's 
> category parameter is used for the Call Return service.
>
Could you explain a bit about how this is used? I, for one would find it helpful and possibly a motivating use case.

Also note that if this information is used for any security or billing-sensitive operations, we have to deal with the issue of how to secure it against spoofing (SIP UAs are generally not trusted). Would you believe a call made by Robert Mitnick from a prison phone would actually have a prison CPC in it's SIP headers :-) ?

(Mitnick is a widely known phone freak and network hacker who served a number of years in US prisons).

> Best regards,
> sebastien
>
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part 
> de Tom Taylor Envoyé : mardi 30 novembre 2004 16:07 À : Jesske, R Cc : 
> [email-masked]; [email-masked] Objet : Re: [Iptel] Calling Party's 
> Category
>
> The question was what the requirement is for this sort of indication.  
> How is it used?
>
> Jesske, R wrote:
>> Dear all,
>> in the past there was a discussion regarding the specification of a 
>> Calling Party's Category for SIP. (draft-mahy-iptel-cpc-00.txt) What 
>> is the actual status of this activity.
>> We are still interested in such kind of originating indication if the 
>> call/communication is coming from a normal SIP user or a SIP 
>> -Payphone or SIP-Hotelphone.
>> Is there a interest from other parties in this issue?
>>
>> Best Regards
>>
>> Roland
>>
>> Deutsche Telekom AG
>> T-Com Zentrale
>> Roland Jesske, TE332-2
>> Section TE33; Signalling, Gateways and Switching Systems Am 
>> Kavalleriesand 3, 64295 Darmstadt, Germany
>> Phone:  +49 6151 83-5940
>> Fax:      +49 6151 83-4577
>> email:   [email-masked]
>>
>>
>>
>>
>> _______________________________________________
>> Iptel mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/iptel
>>
>>
>
> --
> Tom Taylor
> Carrier VoIP Standards Development
> Nortel Networks
> Phone +1 613 763 1496  (ESN 393-1496)
> E-mail: [email-masked]
>
> _______________________________________________
> Iptel mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/iptel
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip
>
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: David R Oran <[email-masked]>
Date: Tue, 30 Nov 2004 11:57:25 -0500

On Nov 30, 2004, at 11:51 AM, GARCIN Sebastien RD-CORE-ISS wrote:

> In the Call Return service, a destination exchange memories an 
> incoming call which failed due to non-reply. If the call was orginated 
> by a payphone then the destination exchange does not memories the 
> number since it makes no sense in calling back a payphone.
>
In the US it does. Do payphones in France not accept incoming calls?

> Could you explain a bit about how this is used? I, for one would find 
> it helpful and possibly a motivating use case.
>
> Also note that if this information is used for any security or 
> billing-sensitive operations, we have to deal with the issue of how to 
> secure it against spoofing (SIP UAs are generally not trusted). Would 
> you believe a call made by Robert Mitnick from a prison phone would 
> actually have a prison CPC in it's SIP headers :-) ?
>
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]