Subject: RE: [Sip] RE: [Iptel] Calling Party's Category

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 30 Nov 2004 19:39:50 -0500

I view these sorts of security attributes as elements of trait-based
authorization. The calling party's category requires the sort of
pre-arrangement and federation to which something like SAML naturally lends
itself.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]]
> Sent: Tuesday, November 30, 2004 9:27 PM
> To: David R Oran
> Cc: Jesske, R; [email-masked]; Tom Taylor; [email-masked]
> Subject: Re: [Sip] RE: [Iptel] Calling Party's Category
> 
> 
> David R Oran wrote:
> 
> >
> > On Nov 30, 2004, at 10:42 AM, GARCIN Sebastien RD-CORE-ISS wrote:
> >
> >> As an fixed line operator we also are interested in this 
> feature and 
> >> would be happy that the IETF finally moves forward with 
> this draft. 
> >> This type of parameter is widely signalled in ISDN/PSTN 
> networks. In 
> >> SIP (for example) it is required in context of both:
> >>
> >> - pure SIP networks (e.g. in case of a SIP payphone), and
> >> - interworking with legacy networks
> >>
> >> I think the uses case for this parameter will depend on 
> the operator 
> >> service portfolio. For example, in France, the calling party's 
> >> category parameter is used for the Call Return service.
> >>
> > Could you explain a bit about how this is used? I, for one 
> would find 
> > it helpful and possibly a motivating use case.
> 
> 
> I'm equally confused. I'm familiar with the calling party category in 
> ISUP, which works only because of the walled-garden nature of the SS7 
> network. Without that, there are really two major factors around this 
> which need to be characterized:
> 
>    1. Who is authorized to assert a particular calling party category?
>       This is much trickier than the identity problem; with 
> identity, we
>       can trust that a domain is the authority for the use of 
> user names
>       in that domain. For calling party category, there is no such
>       relationship. For example, it would probably not be valid for a
>       domain of "adamroach.com" to assert a calling party category of
>       "priority," "operator," or "police."
>    2. Under which circumstances is the calling party category required
>       to be present? Is there some architectural mechanism that can be
>       used to enforce this? (We don't need to define it, but there
>       should at least be some idea about whether it's 
> possible). If not,
>       then there is no purpose in coming up with a protocol mechanism
>       for conveying such information.
> 
> /a
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: David R Oran <[email-masked]>
Date: Tue, 30 Nov 2004 22:01:14 -0500

> pre-arrangement and federation to which something like SAML naturally 
Yes. I agree this is the right approach to any characteristic of an 
endpoint/subscriber that has to be securely asserted, and particularly, 
which should not be easily repudiatable.
Dave.

>>       for conveying such information.
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]