Subject: Re: [Iptel] Calling Party's Category

From: Tom Taylor <[email-masked]>
Date: Tue, 30 Nov 2004 13:50:52 -0500

Jonathan, I hope I am stating this correctly.

The Chair's proposal at the meeting was that this draft be dropped, because with 
SIP-T defined, there is no need to define other means in SIP to carry signalling 
destined specifically to the PSTN.  However, if use cases can be provided which 
demonstrate a requirement to be met in the pure SIP environment, work can be done 
(probably in SIPPING) to meet those requirements.

Nguyen, An wrote:
> Mr. Taylor;
> 
> I am just curious ... What is the status of the Internet Draft?
> 
> An
> 
> 
[snip]

-- 
Tom Taylor
Carrier VoIP Standards Development
Nortel Networks
Phone +1 613 763 1496  (ESN 393-1496)
E-mail: [email-masked]

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: [email-masked]
Date: Tue, 30 Nov 2004 16:06:13 EST

In a message dated 11/30/2004 11:49:18 AM Eastern Standard Time, 
[email-masked] writes:

> Also note that if this information is used for any security or 
> billing-sensitive operations, we have to deal with the issue of how to 
> secure it against spoofing (SIP UAs are generally not trusted). Would 
> you believe a call made by Robert Mitnick from a prison phone would 
> actually have a prison CPC in it's SIP headers :-) ?
> 

Of course, this shows a basic difference in the way this capability is 
handled in SIP vs today's telephone network. It's an important thing to deal with, 
since many of these things are mandated by law. For example, I believe the 
requirement to identify calls from a prison as such is mandated.

In today's network, in order to provide assurance that the call is properly 
marked, not just for CPC but calling party ID as well, the phone in the prison 
is rnot esponsible for the marking. The switch outside the prison marks any 
call that comes over that pair of wires. Robert Mitnick had no opportunity to 
change that marking.

The issue for SIP is to provide the same level of assurance for such 
functions. I'm sure anxious to hear a resolution to this problem, since it keeps 
coming back. CPC is not unique in this regard, so a general solution is needed.

Mike Pierce
Artel

---

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 30 Nov 2004 19:39:50 -0500

I view these sorts of security attributes as elements of trait-based
authorization. The calling party's category requires the sort of
pre-arrangement and federation to which something like SAML naturally lends
itself.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]]
> Sent: Tuesday, November 30, 2004 9:27 PM
> To: David R Oran
> Cc: Jesske, R; [email-masked]; Tom Taylor; [email-masked]
> Subject: Re: [Sip] RE: [Iptel] Calling Party's Category
> 
> 
> David R Oran wrote:
> 
> >
> > On Nov 30, 2004, at 10:42 AM, GARCIN Sebastien RD-CORE-ISS wrote:
> >
> >> As an fixed line operator we also are interested in this 
> feature and 
> >> would be happy that the IETF finally moves forward with 
> this draft. 
> >> This type of parameter is widely signalled in ISDN/PSTN 
> networks. In 
> >> SIP (for example) it is required in context of both:
> >>
> >> - pure SIP networks (e.g. in case of a SIP payphone), and
> >> - interworking with legacy networks
> >>
> >> I think the uses case for this parameter will depend on 
> the operator 
> >> service portfolio. For example, in France, the calling party's 
> >> category parameter is used for the Call Return service.
> >>
> > Could you explain a bit about how this is used? I, for one 
> would find 
> > it helpful and possibly a motivating use case.
> 
> 
> I'm equally confused. I'm familiar with the calling party category in 
> ISUP, which works only because of the walled-garden nature of the SS7 
> network. Without that, there are really two major factors around this 
> which need to be characterized:
> 
>    1. Who is authorized to assert a particular calling party category?
>       This is much trickier than the identity problem; with 
> identity, we
>       can trust that a domain is the authority for the use of 
> user names
>       in that domain. For calling party category, there is no such
>       relationship. For example, it would probably not be valid for a
>       domain of "adamroach.com" to assert a calling party category of
>       "priority," "operator," or "police."
>    2. Under which circumstances is the calling party category required
>       to be present? Is there some architectural mechanism that can be
>       used to enforce this? (We don't need to define it, but there
>       should at least be some idea about whether it's 
> possible). If not,
>       then there is no purpose in coming up with a protocol mechanism
>       for conveying such information.
> 
> /a
> 
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Tue, 30 Nov 2004 16:06:13 EST

Mike Pierce
Artel