Subject: Re: [Isms] CALL FOR CONSENSUS: ISMS Architecture

From: Keith McCloghrie <[email-masked]>
Date: Fri, 29 Apr 2005 06:17:27 -0700 (PDT)

Out-of-band - Strongly favour
  In-band keying - Oppose
  Encapsulation keying - Oppose

Keith.

> I would like to ensure that ISMS members are making a choice on the
> architecture and not on the proposals, since the proposals themselves
> can work with a different architecture, for e.g. we can have EUSM work
> both with the current out-of-band keying model as well as an in-band
> keying model.
> 
> Here is my position
> 
> Out-of-band keying - Strongly favour. This approach introduces the
> minimal amount of change of SNMPv3 USM and achieves all the
> goals of ISMS.
> 
> In-band keying - Maybe,  again this position is for the architectural
> approach to negotiate keys using SNMP. I still strongly oppose the
> specifics of the SBSM proposal.
> 
> Encapsulation keying - Oppose.
> 
> 
> regards,
>    kaushik!
> 
> 
> At 02:21 PM 4/26/2005, Juergen Quittek wrote:
> >Dear all,
> >
> >We have to come to an agreement on the architecture we will use.
> >Ken asked some days ago, but only one of the replies stated a clear
> >position.
> >
> >Shall I take this as an indicator that the rest is not decided yet?
> >Or does not care?  Or can we go on with the table that Robert posted?
> >
> >>
> >>Keying|      For             | Against | Abstain
> >>------+----------------------+---------+-------------
> >>OOB   |  6 (4 Yes, 2 Maybes) |  3 No   | 4 no comment
> >>IB    |  8 (6 Yes, 2 Maybe)  |  1 No   | 4 no comment
> >>EK    | 10 (5 Yes, 5 Maybe)  |  0 No   | 3 no comment
> >>
> >>
> >>Key:  Y=YES/preference    (y=second pref/implied pref)
> >>       M=MAYBE/second pref (m=implied second pref)
> >>       N=NO
> >>       -=no explicit rejection (no comment)
> >>
> >>OOB | IB  | EK  | Name (alphabetical by first name)
> >>----+-----+-----+----------------------------------
> >>  N  |  N  |  Y  | David Harrington
> >>  -  |  y  |  -  | David Perkins
> >>  N  |  Y  |  M  | Ira McDonald
> >>  M  |  -  |  Y  | Juergen Schoenwaelder
> >>  Y  |  M  |  -  | Kaushik Narayan
> >>  Y  |  -  |  -  | Marcus Leech
> >>  Y  |  -  |  M  | Martin Soukup
> >>  N  |  Y  |  M  | Robert Story
> >>  m  |  y  |  Y  | Sam Hartman
> >>  Y  |  -  |  m  | Sharon Chisolm
> >>  -  |  M  |  Y  | Tom Petch
> >>  -  |  Y  |  Y  | Uri Blumenthal
> >>  -  |  Y  |  M  | Wes Hardaker
> >
> >Has anybody changed her/his mind?
> >Or does anybody want to replace a dash by a letter?
> >
> >Thanks,
> >
> >    Juergen
> >--
> >Juergen Quittek        [email-masked]       Tel: +49 6221 90511-15
> >NEC Europe Ltd.,       Network Laboratories        Fax: +49 6221 90511-55
> >Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   http://www.netlab.nec.de
> >
> >
> >
> >--On 4/21/2005 4:17 PM -0400 Ken Hornstein wrote:
> >
> >>ISMS members,
> >>
> >>There's been a lot of discussion recently on the mailing list about the
> >>pros and cons of different security models.  I think the discussion has
> >>been good, but unfortunately I don't think it's getting any closer to a
> >>consensus (I thank Robert for trying to draw things closer;
> >>unfortunately Juergen and I have been rather busy off-line, and I
> >>apologize for that).  I know that some on the mailing list have
> >>expressed a preference for choosing a security protocol first, but
> >>we've been tasked with choosing the architecture first, and I believe
> >>that is the appropriate approach.
> >>
> >>Anyway, I'd like to call for a consensus on the security architecture.
> >>As we all know, the three choices are:
> >>
> >>- Out of band keying (the architecture used by EUSM)
> >>- In-bakd keying (the architecture used by SBSM)
> >>- Encapsulation keying (the architecture used by TLSM)
> >>
> >>What I would like to see is WG members express which architecture(s)
> >>they prefer (you can choose more than one, but please, don't choose all
> >>three).  Please feel free to state your reasons for your choices, but
> >>in the interests of reaching consensus in a reasonable timeframe, I am
> >>asking that WG members please refrain from commenting on other people's
> >>choices unless they feel that the person has stated a fact which is
> >>obviously wrong.
> >>
> >>Thanks for your time,
> >>
> >>--Ken
> >>
> >>_______________________________________________
> >>Isms mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/isms
> >
> >
> >
> >_______________________________________________
> >Isms mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/isms
> 
> _______________________________________________
> Isms mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isms
> 

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: Wes Hardaker <[email-masked]>
Date: Fri, 29 Apr 2005 15:22:10 -0700

>>>>> On Fri, 29 Apr 2005 06:17:27 -0700 (PDT), Keith McCloghrie <[email-masked]> said:

Keith> Out-of-band - Strongly favour
Keith> In-band keying - Oppose
Keith> Encapsulation keying - Oppose

I'd like to remind the people that have indicated that only one
solution is acceptable that this sort of attitude will likely sink the
WG entirely.  Consensus, as David Perkins reminded me on the phone a
few minutes ago, is the willingness of people to come together to
agree on something that will be satisfactory for most people even if
not ideal.  I encourage people to consider carefully the consequences
of stating that you're unwilling to adopt any approach but your
favorite.

-- 
Wes Hardaker
Sparta, Inc.