Subject: AW: [Isms] USM Protection vs Transport Protection

From: Tschofenig Hannes <[email-masked]>
Date: Sun, 17 Apr 2005 13:23:07 +0200

hi kaushik, 

it is true that the type of protection has an impact on solution (at least
with what most protocols provide today).
however, i think that this issue is the least difficult one. once you have
the session keys and the algorithms in place it is really easy to protect
the messages using standard mechanisms. 

a more difficult part is to decide on the key management part.

ciao
hannes

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] 
> [mailto:[email-masked]] Im Auftrag von Kaushik Narayan
> Gesendet: Freitag, 15. April 2005 23:49
> An: [email-masked]
> Betreff: [Isms] USM Protection vs Transport Protection
> 
> 
> Hi All,
> 
> Having gone through the discussion of architectural
> choices, I think the first decision that we might want
> to make is whether we need continue to use USM for
> message protection vs. using some other protection
> mechanism such as the transport protection suggested
> by TLSM.
> 
> regards,
>    kaushik!
> 
> _______________________________________________
> Isms mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isms
> 

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: Kaushik Narayan <[email-masked]>
Date: Mon, 18 Apr 2005 10:38:44 -0700

Hi Hannes,

It would much easier to decide on the key management part
once we decide on type of protection required, for e.g. if we decide to use
transport protection, i.e. choose a transport layer protocol, such as TLS for
SNMPv3 protection then the key management choice is pretty straight
forward. Alternatively if we choose to use USM (native SNMP security) for
protection of SNMPv3, then our choices between using in-band or out-of-band
keying and most security protocols can be made to work either ways.

regards,
   kaushik!