Subject: RE: [Isms] SSH / Reusability / etc

From: "Blumenthal, Uri" <[email-masked]>
Date: Mon, 18 Apr 2005 13:58:42 -0400

Copying keys is a bad idea. Using a key exchange protocol to derive keys
for other protocols is OK (examples: Kerberos provides keys for
communicants, EAP provides keys for L2 entities, IKE provides keys for
IPsec). Nothing evil about having something to negotiate keys for either
USM or something else. Nothing evil in that something negotiating its
own keys of course.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Fleischman, Eric
Sent: Monday, April 18, 2005 10:53 AM
To: [email-masked]; Wes Hardaker; Sam Hartman
Cc: [email-masked]
Subject: RE: [Isms] SSH / Reusability / etc

From: David B Harrington [mailto:[email-masked]] 
>So there is no ambiguity, 
>
>1) I do not support copying the keys from another 
>protocol to stuff into USM. I think that approach 
>creates the potential for exposure of the keys, which 
>would weaken both protocols.

I trust that you are not objecting re-using an enterprise-wide Kerberos
or PKI authentication system for ISMS?

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

_______________________________________________
Isms mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isms

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 18 Apr 2005 12:38:54 -0700 (PDT)

HI,

I'm not sure that I have heard a proposal that uses "copying
of keys". Is there one?

Regards,
/david t. perkins