Subject: Re: [its] n-hop routing protocols for vehicular communications -MANET

From: Adrian Farrel <[email-masked]>
Date: Thu, 14 Mar 2013 12:11:48 +0000

I think that Alex and Abdussalam are right to distinguish the two use-cases of v2v and routed.

Of course, that distinction only exists if v2v is a direct media link, rather than routed through a 
network of street architecture. Similarly, v2v is only different if it is not simply an extension 
of intra-vehicle networking.

Wrt routed (v2v2v2v2v) networking, it really should be observed that this was one of prime 
motivating factors for MANET, and handling that environment would need to be discussed with MANET 
before it appears on any future ITS charter.

Adrian

On Thu 14/03/13 11:29 AM , "Abdussalam Baryun" [email-masked] sent:
> Hi Alex,
> 
> I don't think MANET WG has considered the use-case of ITS WG as we
> stated in our charter, and I don't think they will recharter either
> because they still not completed the two standards required for them
> (I am an active participant in MANET WG). This MANET WG still not
> defined its subnets, which is important for ITS WG and I tried with
> that WG, but they want to postpone, or they think it is dangerous (as
> they mentioned twice).
> 
> IMHO, the ITS should consider 1-hop and n-hops data-transports, but
> for different purposes from other IETF-WGs. For example in RFC6130
> protocols the 1-hop and 2-hop of nieghbors is considered for route
> discovery. I think in the ITS we may include transport-service
> discovery of nieghbors. In MANET the routing n-hops are all
> infrastructure-less but in ITS may involve both. In MANET-WG routings
> always assumes that all Router Machines (i.e. as we are taliking M2M)
> have the same MANET-routing protocol, in ITS-WG we need to assume that
> all Router Machines have the proposed ITS protocol.
> 
> In addition, to make the steps simple in works we may start with the
> 1-hop for infrastructure and 1-hop for infrastructureless, but then we
> make n-hop. Alex, I would like to know your opinion as well,
> 
> Abdussalam Baryun
> university of Glamorgan, UK
> 
> On 3/13/13, Alexandru Petrescu <
> [email-masked]> wrote:> Hello ITS participants,
> >
> > While working on Charter Proposal we are
> distinguishing between 1-hop> V2V communications (a single subnet between
> several vehicles), and n-hop> communications (vehicle-to-vehicle-to-vehicle,
> each time a different> subnet between vehicles).
> >
> > I would like to ask participants whether there
> is interest in n-hop> routing protocols for vehicular
> communications.>
> > Is work needed on MANET protocols for
> this?>
> > Are there special requirements for this? (i.e. a
> case where a MANET> protocol is not sufficient for n-hop vehicular
> communications).>
> > Yours,
> >
> > Alex
> >
> >
> _______________________________________________> its mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/its>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
> 
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 14 Mar 2013 17:52:56 +0100

I think v2v can be motivated for many WGs, I think MANET WG should
consider to focus its charter or motivations, because MANET covers
also LLNs as it was already discussed and MANET WG participants don't
want to let go of any application specific even though they are
considering general specific.

AB