Subject: Re: [its] What do we need to make ITS WG go forward? - EtherType for ITS

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 23 Oct 2013 17:27:56 +0200

Hi Dan,

Let me bring back this topic.

Since our last discussion the EtherType for ETSI GeoNetworking 0x8947
has been set at IEEE:
http://standards.ieee.org/develop/regauth/ethertype/eth.txt

However, it is absent at the IANA website:
http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xml

Where should we ask at IANA about this type?

Also, this ethertype 0x8947 seems absent from the linux kernel sources.

Where should we ask a patch?

Alex

Le 30/01/2013 11:00, Romascanu, Dan (Dan) a écrit :
> Hi,
>
> If the PDF letter is dated 1/29 (yesterday) than we may see the IEEE
> RA list updated soon.
>
> There is no need for IANA to make an allocation (if we are
> discussing EtherTypes). The responsibility for EtherTypes assignment
> is with the IEEE RA and the file at IANA is only informational. See
> the note at
> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xml.
>
>
>
Regards,
>
> Dan
>
>
>
>
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
>> Sent: Wednesday, January 30, 2013 11:54 AM To: [email-masked]
>> Subject: Re: [its] What do we need to make ITS WG go forward? -
>> EtherType for ITS
>>
>> In private I got hold of a pdf letter from IEEE to ETSI dated
>> January 29th, 2013, which says that the EtherType is #8947.  (not
>> sure hexa or decimal).
>>
>> See that letter attached to this email.
>>
>> One would say that things unfold as we speak.
>>
>> I still think that IANA should also allocate it as well. (maybe
>> I'll get another pdf in private telling me it's already done...)
>>
>> Alex
>>
>> Le 30/01/2013 10:39, Alexandru Petrescu a écrit :
>>> Le 30/01/2013 10:11, Thierry Ernst a écrit :
>>>>
>>>> Alex,
>>>>
>>>> IEEE have assigned Ethernet Type Field number #8947 for ITS
>>>> use (ETSI TC ITS's GeoNetworking). Check the following
>>>> document available on the ETSI server:
>>>>
>>>> ITS(13)000020
>>>> <http://docbox.etsi.org/ITS/ITS/05-CONTRIBUTIONS/2013/ITS%2813%290000
>>>>
>>>>
>>>>
20_Ethernet_Type_Field_number_for_GeoNetworking.pdf>
>>>>
>>>>
>>>> Ethernet Type Field number for GeoNetworking
>>>> http://docbox.etsi.org/ITS/ITS/05-CONTRIBUTIONS/2013/ITS(13)000020_Et
>>>>
>>>>
>>>>
hernet_Type_Field_number_for_GeoNetworking.pdf
>>>>
>>>>
>>>
>>> Thierry,
>>>
>>> I
>>>>
>>> may be wrong, but here are my thoughts.
>>>
>>> I am trying to access these URLs you provide above but they are
>>> password protected.  What is the username and password?
>>>
>>> The URL indicates ETSI, not IEEE.
>>>
>>> The IEEE URL for EtherTypes is the following, I believe:
>>> http://standards.ieee.org/develop/regauth/ethertype/eth.txt
>>>
>>> That eth.txt file does not contain 0707 nor 8947.  But it does
>>> contain, for example 86DD which is 'IPv6'.
>>>
>>> The 0x0707 EtherType is present in an implementation which is
>>> supposed compliant with ETSI ITS (plugtests).  Wireshark dump
>>> available upon request.
>>>
>>> Besides, if this is to be about IPv6, I think it should be
>>> reserved at IANA as well, in addition to reserving it at IEEE.
>>> The IANA URL for IEEE 802 Numbers is at:
>>> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xml
>>>
>>>
>>>
>>>
(the #8947 that you mention above does not seem to figure in this
>>> IANA URL).
>>>
>>> This is why I believe this number should be reserved both as an
>>> EtherType at IEEE and at IANA.
>>>
>>> Yours,
>>>
>>> Alex
>>>
>>>>
>>>> Regards, Thierry.
>>>>
>>>>
>>>> On 28/01/13 14:28, Alexandru Petrescu wrote:
>>>>> Le 28/01/2013 14:16, Joe Klein a écrit :
>>>>>> I really dislike the fact that ISO is charging for the ISO
>>>>>>  21217 - Architecture & ISO 21210 - IPv6 Networking.
>>>>>>
>>>>>> Does this make it any better? Safer?  Should ISO now have
>>>>>> cybersecurity and safety liability if the specification
>>>>>> leads to deaths and damage to property?
>>>>>
>>>>> Does it make any better interoperable as well?
>>>>>
>>>>> EtherType 0x0707 described in ITS documents, implemented,
>>>>> but not specified by IEEE nor reserved at IANA - does not
>>>>> make it interoperable.
>>>>>
>>>>> One wouldn't think that this 0x0707 ethertype be reserved by
>>>>>  somebody who is not IANA nor IEEE?
>>>>>
>>>>> (see a good example of interoperability: IPv6 0x86dd
>>>>> ethertype is reserved at IEEE and at IANA
>>>>> http://www.iana.org/assignments/ieee-802-numbers/ieee-802-numbers.xm
>>>>>
>>>>>
>>>>>
l)
>>>>>
>>>>>
>>>>>
>>>
>>>>>
>> Alex
>>>>>
>>>>> Or should these standards remain in
>>>>>> the public domain, for researches to review and validate?
>>>>>>
>>>>>> Just my 2 cents.
>>>>>>
>>>>>> Joe
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Mon, Jan 28, 2013 at 6:31 AM, Thierry Ernst
>>>>>> <[email-masked]> wrote:
>>>>>>>
>>>>>>> Dear all,
>>>>>>>
>>>>>>> At this stage, I don't think a new working group is
>>>>>>> needed. First, it would need a charter, and support from
>>>>>>> the industry. But more importantly, IETF WGs are not
>>>>>>> usually sector-driven, so it means the different issues
>>>>>>> pertaining to ITS should be brought to VARIOUS existing
>>>>>>> WGs, and a WG should only be created if there is an
>>>>>>> important issue for which there is no existing WG that
>>>>>>> could work on it.
>>>>>>>
>>>>>>> This said, as mentioned earlier, ITS is not only about
>>>>>>> vehicular communications, though the issues listed by
>>>>>>> Alexandru below mostly consider vehicular
>>>>>>> communications.
>>>>>>>
>>>>>>> What ITS really needs is the definition of a common
>>>>>>> communication architecture and the definition of what
>>>>>>> features should be comprised for an IPv6 networking
>>>>>>> stack deployed for ITS use cases. This cannot be done at
>>>>>>> IETF, and actually already exists at ISO: - ISO 21217 -
>>>>>>> Architecture - ISO 21210 - IPv6 Networking
>>>>>>>
>>>>>>> As an input to the discussion, please consider reading
>>>>>>> documents D2.1 and D2.2 available on the ITSSv6 project
>>>>>>> web page: http://www.itssv6.eu/documentation/ D2.2
>>>>>>> provides an analysis of the currently published version
>>>>>>> of ISO 21210, but new work items have been launched
>>>>>>> since then to address remaining issues.
>>>>>>>
>>>>>>> Regards, Thierry.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On 28/01/13 11:08, Alexandru Petrescu wrote:
>>>>>>>>
>>>>>>>> Le 28/01/2013 05:02, Stan Ratliff (sratliff) a écrit :
>>>>>>>>>
>>>>>>>>> All,
>>>>>>>>>
>>>>>>>>> This is just one opinion, but I'd like to understand
>>>>>>>>> why ITS would need its own IETF group. The work here
>>>>>>>>> is the same (IMO) as what is taking place in MANET.
>>>>>>>>> I would vote that this work be taken up in MANET.
>>>>>>>>
>>>>>>>>
>>>>>>>> Stan,
>>>>>>>>
>>>>>>>> Thank you for the offer.  I considered this offer
>>>>>>>> since some time.
>>>>>>>>
>>>>>>>> I try to understand whether some of these items on
>>>>>>>> which I have interest could be brought in in MANET WG:
>>>>>>>> - V2V using prefix exchange - VIN-based IP addressing
>>>>>>>> scheme - ND Prefix Delegation - PMIP-based network
>>>>>>>> mobility - IPv6 single-address connecion 'sharing'
>>>>>>>> with a cellular operator and a vehicular moving network
>>>>>>>>  (type '64share' of v6ops). - Default Route with
>>>>>>>> DHCPv6.
>>>>>>>>
>>>>>>>> Please let me know.
>>>>>>>>
>>>>>>>> Yours,
>>>>>>>>
>>>>>>>> Alex
>>>>>>>>
>>>>>>>>>
>>>>>>>>> Regards, Stan
>>>>>>>>>
>>>>>>>>> On Jan 26, 2013, at 9:34 AM, Abdussalam Baryun
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>> Hi Nabil,
>>>>>>>>>>
>>>>>>>>>> I think we already done some steps but not sure
>>>>>>>>>> how far now. We will need to propose the WG and
>>>>>>>>>> provide the WG charter, as use cases and work to be
>>>>>>>>>> done in this group. This charter needs to be
>>>>>>>>>> approved by the IESG. I have not attended the last
>>>>>>>>>> meeting so not sure about the status now,
>>>>>>>>>>
>>>>>>>>>> AB
>>>>>>>>>>
>>>>>>>>>> On 1/26/13, Nabil Benamar <[email-masked]>
>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>> Hi All,
>>>>>>>>>>>
>>>>>>>>>>> I'm still interested in this list and want to
>>>>>>>>>>> join voices previously heard to make it a
>>>>>>>>>>> working group. So what should we exactly do, to
>>>>>>>>>>> achieve this goal ?
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> 2013/1/26 Abdussalam Baryun
>>>>>>>>>>> <[email-masked]>
>>>>>>>>>>>
>>>>>>>>>>>> Hi All,
>>>>>>>>>>>>
>>>>>>>>>>>> I was interested in this group but not sure
>>>>>>>>>>>> where are we so far. Is there progress, or is
>>>>>>>>>>>> there issues/efforts that need to be completed
>>>>>>>>>>>> and volunteered.
>>>>>>>>>>>>
>>>>>>>>>>>> AB
>>>>>>>>>>>> _______________________________________________
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
its mailing list [email-masked]
>>>>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> -- * * *تحياتي ، **Cordialement, Regards* * * *
>>>>>>>>>>> * *نبيل بنعمرو Nabil Benamar* Professor of
>>>>>>>>>>> computer sciences Simulation and Modelisation
>>>>>>>>>>> Laboratory Human Sciences Faculty of Meknes
>>>>>>>>>>> Moulay Ismail* *University* Meknes, Morocco *GSM:
>>>>>>>>>>> * *+ 212 6 70832236 http://nabilbenamar.com/
>>>>>>>>>>>
>>>>>>>>>>> *
>>>>>>>>>>>
>>>>>>>>>>> --------------------------------------------------------------
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
------------------
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>
>>>>>>>>>>>
>>>>> *
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>> _______________________________________________
>>>>>>>>>> its mailing list [email-masked]
>>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> _______________________________________________ its
>>>>>>>>> mailing list [email-masked]
>>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> _______________________________________________ its
>>>>>>>> mailing list [email-masked]
>>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________ its
>>>>>>> mailing list [email-masked]
>>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>>
>>>>>> _______________________________________________ its mailing
>>>>>> list [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/its
>>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________ its mailing
>>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/its
>>>>
>>>>
>>>>
>>>> _______________________________________________ its mailing
>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/its
>>>>
>>>
>>>
>>> _______________________________________________ its mailing list
>>>  [email-masked] https://www.ietf.org/mailman/listinfo/its
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 23 Oct 2013 15:41:10 +0000

Hi Alexandru,

The authority for allocation is with the IEEE, and the list to be referenced and used in specifications is the one at IEEE. 

The IANA list is informational and includes as specified on the page 'contributed unverified information from various sources'. It would be good I think to have the new ethertype mentioned on the IANA page as well, because some IETF-ers may go first to that list. I suggest that you just send an email to IANA asking for the change (additional row in the table) be made according to the IEEE allocation. We can talk about this with the IANA folks in Vancouver if this is not solved until then. 

I am not sure who needs to be asked about the linux kernel patches, I can guess that a query to the [email-masked] may result on useful information from people involved with that layer. 

I hope this helps. 

Regards,

Dan

> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]]
> Sent: Wednesday, October 23, 2013 6:28 PM
> To: Romascanu, Dan (Dan); [email-masked]
> > There is no need for IANA to make an allocation (if we are discussing
> > EtherTypes). The responsibility for EtherTypes assignment is with the
> > IEEE RA and the file at IANA is only informational. See the note at
> >> In private I got hold of a pdf letter from IEEE to ETSI dated January
> >> 29th, 2013, which says that the EtherType is #8947.  (not sure hexa
> >> or decimal).
> >>
> >> I still think that IANA should also allocate it as well. (maybe I'll
> >> get another pdf in private telling me it's already done...)
> >>
> >> Alex
> >>
> >>>> IEEE have assigned Ethernet Type Field number #8947 for ITS use
> >>>> (ETSI TC ITS's GeoNetworking). Check the following document
> >>>> available on the ETSI server:
> >>>>
> >>>> ITS(13)000020
> >>> Besides, if this is to be about IPv6, I think it should be reserved
> >>> at IANA as well, in addition to reserving it at IEEE.
> >>> l
> >>>>>> cybersecurity and safety liability if the specification leads to
> >>>>>> deaths and damage to property?
> >>>>>
> >>>>> EtherType 0x0707 described in ITS documents, implemented, but not
> >>>>> specified by IEEE nor reserved at IANA - does not make it
> >>>>> interoperable.
> >>>>>
> >>>>> (see a good example of interoperability: IPv6 0x86dd ethertype is
> >>>>> reserved at IEEE and at IANA
> >>>>>>> At this stage, I don't think a new working group is needed.
> >>>>>>> First, it would need a charter, and support from the industry.
> >>>>>>> But more importantly, IETF WGs are not usually sector-driven, so
> >>>>>>> it means the different issues pertaining to ITS should be
> >>>>>>> brought to VARIOUS existing WGs, and a WG should only be created
> >>>>>>> if there is an important issue for which there is no existing WG
> >>>>>>> that could work on it.
> >>>>>>>
> >>>>>>> This said, as mentioned earlier, ITS is not only about vehicular
> >>>>>>> communications, though the issues listed by Alexandru below
> >>>>>>> mostly consider vehicular communications.
> >>>>>>>
> >>>>>>> communication architecture and the definition of what features
> >>>>>>> should be comprised for an IPv6 networking stack deployed for
> >>>>>>> ITS use cases. This cannot be done at IETF, and actually already
> >>>>>>> exists at ISO: - ISO 21217 - Architecture - ISO 21210 - IPv6
> >>>>>>> Networking
> >>>>>>>
> >>>>>>> As an input to the discussion, please consider reading documents
> >>>>>>> D2.1 and D2.2 available on the ITSSv6 project web page:
> >>>>>>> http://www.itssv6.eu/documentation/ D2.2 provides an analysis of
> >>>>>>> the currently published version of ISO 21210, but new work items
> >>>>>>> have been launched since then to address remaining issues.
> >>>>>>>
> >>>>>>> Regards, Thierry.
> >>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>>>> This is just one opinion, but I'd like to understand why ITS
> >>>>>>>>> would need its own IETF group. The work here is the same (IMO)
> >>>>>>>>> as what is taking place in MANET.
> >>>>>>>> Thank you for the offer.  I considered this offer since some
> >>>>>>>> time.
> >>>>>>>>
> >>>>>>>> I try to understand whether some of these items on which I have
> >>>>>>>> interest could be brought in in MANET WG:
> >>>>>>>> - V2V using prefix exchange - VIN-based IP addressing scheme -
> >>>>>>>> ND Prefix Delegation - PMIP-based network mobility - IPv6
> >>>>>>>> single-address connecion 'sharing'
> >>>>>>>> with a cellular operator and a vehicular moving network  (type
> >>>>>>>> '64share' of v6ops). - Default Route with DHCPv6.
> >>>>>>>>
> >>>>>>>> Please let me know.
> >>>>>>>>
> >>>>>>>> Yours,
> >>>>>>>>
> >>>>>>>> Alex
> >>>>>>>>
> >>>>>>>>>
> >>>>>>>>> Regards, Stan
> >>>>>>>>>
> >>>>>>>>>> I think we already done some steps but not sure how far now.
> >>>>>>>>>> We will need to propose the WG and provide the WG charter, as
> >>>>>>>>>> use cases and work to be done in this group. This charter
> >>>>>>>>>> needs to be approved by the IESG. I have not attended the
> >>>>>>>>>> last meeting so not sure about the status now,
> >>>>>>>>>>
> >>>>>>>>>> AB
> >>>>>>>>>>
> >>>>>>>>>>> I'm still interested in this list and want to join voices
> >>>>>>>>>>> previously heard to make it a working group. So what should
> >>>>>>>>>>> we exactly do, to achieve this goal ?
> >>>>>>>>>>>
> >>>>>>>>>>>
> >>>>>>>>>>>> I was interested in this group but not sure where are we so
> >>>>>>>>>>>> far. Is there progress, or is there issues/efforts that
> >>>>>>>>>>>> need to be completed and volunteered.
> >>>>>>>>>>>>
> >>>>>>>>>>>> AB
> >>>>>>>>>>> * *نبيل بنعمرو Nabil Benamar* Professor of computer sciences
> >>>>>>>>>>> Simulation and Modelisation Laboratory Human Sciences
> >>>>>>>>>>> Faculty of Meknes Moulay Ismail* *University* Meknes,
> >>>>>>>>>>> Morocco *GSM: