Subject: [its] What happened at the BoF 'geonet'

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 07 Nov 2013 01:42:27 +0100

Hello ITSers,

The BoF went well, there were at least 100 people attending; many people
were interested to contribute and work on Internet-wide generic issues
(20 attendees).

However, the Internet-wide geonetworking scope as presented in the
problem statement draft is too wide for the moment and we have to narrow
it.  This will need additional work, and an update of the problem
statement draft.

In particular, thanks to our IAB Advisor Eliot Lear - the following
issues should guide our progress:
o What are the scaling points?
o What components need to be involved?
o What are the security and privacy considerations?
o What existing work is applicable and what existing work is not
   applicable?
o What problems we do NOT want to solve?  Most importantly, of course,
   who will implement and who will deploy?

Goergios and Alex

---

From: <[email-masked]>
Date: Thu, 7 Nov 2013 01:21:16 +0000

Hi all,

Please note that we will need to organize a new BOF on Interent-wide Geonetworking.

Before this BOF will take place we will need to have:

(1) a focussed problem scope, with an updated problem statement draft

(2) the answers to the questions listed in the below email:

(3) a charter

Best regards,

Georgios

________________________________
Van: [email-masked] [[email-masked]] namens Alexandru Petrescu [[email-masked]]
Verzonden: donderdag 7 november 2013 1:42
To: [email-masked]
Onderwerp: [its] What happened at the BoF 'geonet'

Hello ITSers,

Goergios and Alex
_______________________________________________
its mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/its

---

From: <[email-masked]>
Date: Thu, 7 Nov 2013 11:56:55 +0000

Hi all,

Below you can find a proposal where I try to narrow signifficantly the scope of the Internet-wide Geonetworking activities:

The Internet-wide Geonetworking WG will focus on:

o) Extend DNS mechanisms and protocols to support mapping, in a bidirectional way, destination geographical areas into IP addresses (or URIs) of Access Routers and/or Gateways, which are able to broadcast or multicast packets to to the nodes located in these destination geographical areas.

o) Design a protocol that carries destination area information from a source node to the Access Routers and/or Gateways, which are able to broadcast or multicast packets from this source to the nodes located in these destination geographical areas.

Note that the way (mecahnisms or protocols) of how the Access Routers and/or the Gateways dsitribute the packets (broadcast or multicast) is out of the scope of this WG. This is because several existing mechanisms can be used for this purpose. E.g., MANET, ETSI ITS IPv6 geonetworking, etc.

Comments are welcome!

Best regards,
Georgios

________________________________
Van: Karagiannis, G. (EWI)
Verzonden: donderdag 7 november 2013 2:21
To: Alexandru Petrescu; [email-masked]
Onderwerp: RE: [its] What happened at the BoF 'geonet'

Hi all,

(3) a charter

Best regards,

Georgios

Hello ITSers,

Goergios and Alex

---

From: Eliot Lear <[email-masked]>
Date: Thu, 07 Nov 2013 05:59:00 -0800

Hi Alex,

Thanks again to you and Melinda for leading the BoF.  Some thoughts:

>   who will implement and who will deploy?

This is a starting point.  You and this group should iterate  on this
list and further develop important design decisions based on some real
world requirements and experience.  A few of us can point you at
existing work, and even some of the people who developed the work.  ILNP
was discussed as a potential scaling point as an overlay network.  Ran
Atkinson was the developer of ILNP, as well as one of the first
implementers of IPv6,.  LISP is similar technology.  Dino Farinacci has
led development for that solution.  Ran and Dino, GEOnet considers the
notion of proximity-based networking.  It raises many interesting
questions, such as what sort of scope we're talking about (meters or
kilometers, for instance).

I make the assumption for the moment, as did others in the room that an
overlay network is the right approach.  You may find otherwise.

Eliot

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 7 Nov 2013 08:50:29 -0800

> Thanks again to you and Melinda for leading the BoF.  Some thoughts:

Unfortunately, I could not make it but I heard good things about it.

Thanks for the forward Eliot.

> kilometers, for instance).

We have put Geo-Coordianates as a Routing Locator (RLOC) type of tuple in the LISP mapping database. We did some trials with Fedex to track packages by assigningn EIDs to the shipping physical packages, which mapped from a Fedex Tracking Number. When the packages roamed and emitted signals from whatever layer-1 RF technology that decided to use, routers will hear the EID and register their own Geo-Coordinate based RLOCs with the LISP mapping system.

We then wrote an iPad application to query the mapping database (with lig, the LISP Internet Groper) and then display a moving blue ball. There were was no data-plane play in this use-case, simply using a network based database of flexibily encoded addresses.

> overlay network is the right approach.  You may find otherwise.

Dino

---

From: <[email-masked]>
Date: Thu, 7 Nov 2013 17:19:38 +0000

Hi Mike,

Thanks for the comment!

The issues that you mentioned regarding security and definition of the geographic area are issues that will of course be in the scope of the working group.

Best regards,

Georgios

________________________________
Van: Mike Kallas [[email-masked]]
Verzonden: donderdag 7 november 2013 17:33
To: Karagiannis, G. (EWI); [email-masked]
Onderwerp: Re: [its] Narrowing the scope of the Internet-wide Geornetworking activities

i agree that "how the Access Routers and/or the Gateways dsitribute the packets" should be out f scope, but i am not sure that the 2 point you mentioned in the proposed scope are enough. for example for example any communication of this type would not be in response to a direct request which makes security and privacy a big issue to be handled. Also a single access router would not necessarily cover the desired geographic are. also how do you define the geographic area? is it a point and a radius, how do you handle overlap? that is why i have been pushing for this iterative approach, because i dont think it is exactly this simple

________________________________
From: "[email-masked]" <[email-masked]>
To: [email-masked]
Sent: Thursday, November 7, 2013 3:56 AM
Subject: [its] Narrowing the scope of the Internet-wide Geornetworking activities

Hi all,

Comments are welcome!

Best regards,
Georgios

Hi all,

Best regards,
Georgios

Hello ITSers,

Goergios and Alex

_______________________________________________
its mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/its

---

From: "Carl Reed" <[email-masked]>
Date: Thu, 7 Nov 2013 10:46:33 -0700

Perhaps check out an OGC standard called GeoXACML. This is a “geo” extension to XACML. The geo extension is based on ISO 19107 Spatial Schema. 19107 defines spatial geometry types. 19107 is also used in OGC Simple Features (implemented in every commercial and open source database), SQL/MM, the OGC Geography Markup Language (GML, and GeoJSON. The geodetic location object referenced in PIDF-LO (and other IETF RFCs) is defined using a GML application schema, which is based on 19107.

So, regardless if the group decides to use an existing encoding for geographic area, I would strongly encourage the use of the geometry model defined in 19107. That way, mapping from one instance to another is greatly facilitated. 

Regards

Carl Reed
CTO
OGC

From: [email-masked] 
Sent: Thursday, November 07, 2013 10:19 AM
To: [email-masked] ; [email-masked] 
Subject: Re: [its] Narrowing the scope of the Internet-wide Geornetworking activities

Hi Mike,

Thanks for the comment!

Best regards,

Georgios

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
From: "[email-masked]" <[email-masked]>
To: [email-masked] 
Sent: Thursday, November 7, 2013 3:56 AM
Subject: [its] Narrowing the scope of the Internet-wide Geornetworking activities

Hi all,

Comments are welcome!

Best regards,
Georgios

--------------------------------------------------------------------------------

Hi all,

(3) a charter

Best regards,
Georgios

--------------------------------------------------------------------------------

Hello ITSers,

Goergios and Alex

--------------------------------------------------------------------------------
_______________________________________________
its mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/its

---

From: Mike Kallas <[email-masked]>
Date: Thu, 7 Nov 2013 10:10:55 -0800 (PST)

Point captured in Doc !

________________________________
 From: Carl Reed <[email-masked]>
To: [email-masked]; [email-masked]; [email-masked] 
Sent: Thursday, November 7, 2013 9:46 AM
Subject: Re: [its] Narrowing the scope of the Internet-wide Geornetworking activities

Perhaps check out an OGC standard called GeoXACML. This is a “geo” 
extension to XACML. The geo extension is based on ISO 19107 Spatial Schema. 
19107 defines spatial geometry types. 19107 is also used in OGC Simple Features 
(implemented in every commercial and open source database), SQL/MM, the OGC 
Geography Markup Language (GML, and GeoJSON. The geodetic location object 
referenced in PIDF-LO (and other IETF RFCs) is defined using a GML application 
schema, which is based on 19107.
 
So, regardless if the group decides to use an existing encoding for 
geographic area, I would strongly encourage the use of the geometry model 
defined in 19107. That way, mapping from one instance to another is greatly 
facilitated. 
 
Regards

Carl Reed
CTO
OGC
  
From: [email-masked] 
Sent: Thursday, November 07, 2013 10:19 AM
To: [email-masked] ; [email-masked] 
Subject: Re: [its] Narrowing the scope of the Internet-wide 
Geornetworking activities
  Hi Mike,
 
Thanks for the comment!
The issues that you mentioned regarding security and definition of the 
geographic area are issues that will of course be in the scope of the working 
group.
 
Best regards,
Georgios

Van: Mike Kallas [[email-masked]]
Verzonden: donderdag 7 november 2013 17:33
To: Karagiannis, G. (EWI); 
[email-masked]
Onderwerp: Re: [its] Narrowing the scope of the 
Internet-wide Geornetworking activities

i agree that "how the Access Routers and/or the 
Gateways dsitribute the packets" should be out f scope, but i am not sure that 
the 2 point you mentioned in the proposed scope are enough. for example for 
example any communication of this type would not be in response to a direct 
request which makes security and privacy a big issue to be handled. Also a 
single access router would not necessarily cover the desired geographic are. 
also how do you define the geographic area? is it a point and a radius, how do 
you handle overlap? that is why i have been pushing for this iterative approach, 
because i dont think it is exactly this simple

________________________________
 From: "[email-masked]" <[email-masked]>
To: [email-masked] 
Sent: Thursday, November 7, 2013 3:56 
AM
Subject: [its] Narrowing the 
scope of the Internet-wide Geornetworking activities

Hi all,
 
Below you can find a proposal where I try to narrow signifficantly the 
scope of the Internet-wide Geonetworking activities:

o) Extend DNS mechanisms and protocols 
to support mapping, in a bidirectional way, destination geographical areas into 
IP addresses (or URIs) of Access Routers and/or Gateways, which are able to 
broadcast or multicast packets to to the nodes located in these destination 
geographical areas.
 
o) Design a protocol that carries 
destination area information from a source node to the Access Routers and/or 
Gateways, which are able to broadcast or multicast packets from this source to 
the nodes located in these destination geographical areas.

Note that the way (mecahnisms or protocols) of how 
the Access Routers and/or the Gateways dsitribute the packets (broadcast or 
multicast) is out of the scope of this WG. This is because several existing 
mechanisms can be used for this purpose. E.g., MANET, ETSI ITS IPv6 
geonetworking, etc.
 
Comments are welcome!
 
Best regards,
Georgios

Van: Karagiannis, G. (EWI)
Verzonden: donderdag 7 november 2013 2:21
To: Alexandru Petrescu; 
[email-masked]
Onderwerp: RE: [its] What happened at the BoF 
'geonet'

Hi all,
 
Please note that we will need to organize a new BOF on Interent-wide 
Geonetworking.

(1) a focussed problem scope, with an updated problem statement 
draft
 
(2) the answers to the questions listed in the below email:
o What are the scaling points?
o What components need to be 
involved?
o What are the security and privacy considerations?
o What 
existing work is applicable and what existing work is not
applicable?
o 
What problems we do NOT want to solve? Most importantly, of course,
who will 
implement and who will deploy?

(3) a charter
 
Best regards,
Georgios

Van: [email-masked] [[email-masked]] namens 
Alexandru Petrescu [[email-masked]]
Verzonden: donderdag 
7 november 2013 1:42
To: [email-masked]
Onderwerp: [its] What 
happened at the BoF 'geonet'

Hello ITSers,

The BoF went well, there 
were at least 100 people attending; many people
were interested to contribute 
and work on Internet-wide generic issues
(20 attendees).

However, the 
Internet-wide geonetworking scope as presented in the
problem statement draft 
is too wide for the moment and we have to narrow
it.  This will need 
additional work, and an update of the problem
statement draft.

In 
particular, thanks to our IAB Advisor Eliot Lear - the following
issues 
should guide our progress:
o What are the scaling points?
o What 
components need to be involved?
o What are the security and privacy 
considerations?
o What existing work is applicable and what existing work is 
not
   applicable?
o What problems we do NOT want to 
solve?  Most importantly, of course,
   who will implement and 
who will deploy?

Goergios and 
Alex
its mailing 
list

its 
mailing list

its mailing 
list

---

From: Melinda Shore <[email-masked]>
Date: Thu, 07 Nov 2013 10:45:20 -0800

On 11/07/2013 03:56 AM, [email-masked] wrote:
> o) Extend DNS mechanisms and protocols to support mapping, in a
> bidirectional way, destination geographical areas into IP addresses
> (or URIs) of Access Routers and/or Gateways, which are able to
> broadcast or multicast packets to to the nodes located in these
> destination geographical areas.

I would *strongly* encourage you to drop this from a proposed
charter, for several reasons:

1) I think that if you assume a particular "solution" before
    the group is chartered you'll lose some agility in terms
    of being able to respond to comments, but more importantly
    you may be closing yourself off to better design options
2) In general, there's a high bar on putting new functionality
    into DNS.  It's not impossible but you really need to show
    that the database characteristics you need are a good match
    for DNS.
3) I don't think your requirements are clear enough right now
    to be able to say whether or not DNS really is a good match.
    Think in terms of things like scalability, security and
    privacy, characteristics of your namespace (hierarchical vs.
    flat, and so on), etc.

If there's a serious intention to pursue working group formation
I'd encourage you to tighten up the problem statement, clearly
identify pieces of work that would need to be done (and
interrelationships), and drop discussion of a particular solution.
It's okay to discuss the gaps and overlap between what you need and
what's out there, but proposing a particular solution is not only
outside the scope of a problem statement but it's also more likely
to hurt your case than to help.

Melinda

---

From: Ted Lemon <[email-masked]>
Date: Thu, 7 Nov 2013 21:06:58 +0000

> o) Extend DNS mechanisms and protocols to support mapping, in a bidirectional way, destination geographical areas into IP addresses (or URIs) of Access Routers and/or Gateways, which are able to br…

This is a solution proposal, and is likely to be very controversial.   You need to clearly describe the problem that this solution addresses, and then discuss possible solutions, including this one, but with an openness to the possibility that some other solution may be preferable.

This will be frustrating, because you already have a solution, but we have found that stepping back and describing the problem, and then approaching it with a blank slate, is often very helpful—the first solution to a problem is often good, but doesn't scale well, or isn't general enough, or simply isn't the best solution to the problem.   By temporarily putting the first solution out of your mind, you may find that you have the freedom to do something much better.

---

From: Mike Kallas <[email-masked]>
Date: Thu, 7 Nov 2013 08:33:21 -0800 (PST)

Hi all,

 

 
Comments are welcome!
 
Best regards,
Georgios

Hi all,

 

(3) a charter
 
Best regards,
Georgios

Hello ITSers,

Goergios and Alex

---

From: <[email-masked]>
Date: Thu, 7 Nov 2013 21:34:57 +0000

Hi Melinda,

Thanks for the comments!

Please note that this was not an attempt to write the charter nor the problem statement, nor to advertise the use of the extended DNS solution, but an attempt to narrow the scope and stimulate discussion on this.

I have used the term DNS, but one can replace the name DNS with a mapping system.

The update on the problem statement will come soon!

Best regards,

Georgios

________________________________
Van: Melinda Shore [[email-masked]]
Verzonden: donderdag 7 november 2013 19:45
To: Karagiannis, G. (EWI); [email-masked]
Onderwerp: Re: [its] Narrowing the scope of the Internet-wide Geornetworking activities

Melinda