Subject: [its] Question and Suggestion

From: Mike Kallas <[email-masked]>
Date: Wed, 6 Nov 2013 12:14:08 -0800 (PST)

First, I enjoyed meeting some of you at the BOF and look forward to working with you all on this topic.

Second, I apologize for not asking my questions and making my comments at the BOF. I was taking notes and did not want to lose track of that.

Question about the proposed charter: do we have to include use cases in the charter? I see a danger in limiting our use cases to the two mentioned in the proposed charter. Use cases usually drive the requirements that drive the protocols. If we don't identify enough related use cases we could miss many things in the protocol that would drive other bodies to create similar protocols to solve issues in the same domain. I see a better approach is to have a use cases document that tries to gather as many related use cases as possible. We can eventually narrow it down to come up with a practical solution.

Suggestion: I like the idea that somebody mentioned in the meeting about iterating between problem definition and solution. I think the suggestion is to do brainstorming. I would volunteer to start a brainstorming document that could be used for discussions. This document would include:
- Problems
- Use cases
- Assumptions
- Potential solutions

It would only be intended to drive discussion. I would not propose that this would be any type of final publishable document.

Please give me feedback on my question and my suggestion

Mike

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 6 Nov 2013 20:44:49 +0000

Mike and all,

I think documenting as many use cases as possible is wise.  However, I do not think they have to be "related".  Probably the more diverse the better.  I suspect my interpretation of Mike's use of "related" is incorrect.

Perhaps a wiki could be used for brainstorming.

Will

PS.  I missed the meeting. I tried to attend  remotely, but got pulled away at work. :-(
I'll have to go view the recoded meeting.

Mike

---

From: Mike Kallas <[email-masked]>
Date: Wed, 6 Nov 2013 12:51:50 -0800 (PST)

sorry for the confusion. by "related" i mean "related to the purpose of the group" not "related to each other" sorry.

________________________________
 From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
To: Mike Kallas <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Wednesday, November 6, 2013 12:44 PM
Subject: Re: [its] Question and Suggestion

Mike and all,

Will

Mike

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 06 Nov 2013 23:20:04 +0100

Hello Mike,

I have been asked whether this 'geonet' has anything to do with the
use-case where an operator analyzes own traffic, needing to identify
which region of that city generates most traffic (given IP address
allocation follows no particular logic with respect to geography).

I'd say yes.

But it would need to be documented.

Alex

Le 06/11/2013 21:14, Mike Kallas a écrit :
> Second, I apologize for not asking my questions and making my
> comments at the BOF. I was taking notes and did not want to lose
> track of that.
>
> Question about the proposed charter: do we have to include use cases
> in the charter? I see a danger in limiting our use cases to the two
> mentioned in the proposed charter. Use cases usually drive the
> requirements that drive the protocols. If we don't identify enough
> related use cases we could miss many things in the protocol that
> would drive other bodies to create similar protocols to solve issues
> in the same domain. I see a better approach is to have a use cases
> document that tries to gather as many related use cases as possible.
> We can eventually narrow it down to come up with a practical
> solution.
>
> Suggestion: I like the idea that somebody mentioned in the meeting
> about iterating between problem definition and solution. I think the
> suggestion is to do brainstorming. I would volunteer to start a
> brainstorming document that could be used for discussions. This
> document would include: - Problems - Use cases - Assumptions -
> Potential solutions
>
> It would only be intended to drive discussion. I would not propose
> that this would be any type of final publishable document.
>
>
> _______________________________________________ its mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/its
>

---

From: Eliot Lear <[email-masked]>
Date: Wed, 06 Nov 2013 14:33:23 -0800

Only briefly.  Charters are not meant to be the full justification for
the work.

Eliot

On 11/6/13 2:20 PM, Alexandru Petrescu wrote:
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>
>

---

From: Mike Kallas <[email-masked]>
Date: Wed, 6 Nov 2013 14:38:01 -0800 (PST)

thanks Alex, i will add it to the brainstorming doc. we can eventually split of the use cases into their own doc

________________________________
 From: Alexandru Petrescu <[email-masked]>
To: [email-masked] 
Cc: [email-masked] 
Sent: Wednesday, November 6, 2013 2:20 PM
Subject: Re: [its] Question and Suggestion

Hello Mike,

I'd say yes.

Alex

> [email-masked] https://www.ietf.org/mailman/listinfo/its

_______________________________________________
its mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/its

---

From: Mike Kallas <[email-masked]>
Date: Wed, 6 Nov 2013 15:07:52 -0800 (PST)

i can start the document by creating a list of content, and then we can ask for volunteers for different sections

________________________________
 From: duanshihui <[email-masked]>
To: 'Mike Kallas' <[email-masked]>; 'Alexandru Petrescu' <[email-masked]>; [email-masked] 
Sent: Wednesday, November 6, 2013 3:00 PM
Subject: 答复: [its] Question and Suggestion

Good. We can plan what we must do first by brainstorming and then
divide the work, so everyone can do his contribution for this bof.
Is there any schedule for this work? Or we can make a plan.
 
发件人:Mike Kallas [mailto:[email-masked]] 
发送时间:2013年11月7日6:38
收件人:Alexandru Petrescu;
[email-masked]
抄送:[email-masked]
主题:Re: [its] Question
and Suggestion
 
thanks
Alex, i will add it to the brainstorming doc. we can eventually split of the
use cases into their own doc

From:Alexandru Petrescu <[email-masked]>
To: [email-masked] 
Cc: [email-masked] 
Sent: Wednesday, November 6, 2013 2:20 PM
Subject: Re: [its] Question and Suggestion

Hello Mike,

I'd say yes.

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 07 Nov 2013 04:03:04 +0100

Richard,

That description of geodissemination makes sense for vehicular 
communications.

But it would need to be documented as a use-case.

Alex

Le 07/11/2013 04:00, Richard Roy a écrit :
> In the ITS community, the concept behind the term GeoNet is that of
> geographical dissemination of information, and is not directly tied to
> analyzing IP traffic based on location.  As noted in my previous posting,
> from the ITS viewpoint, GeoNet would be better named GeoDissemination.
>
> The key point to remember is that we are dealing with information that has
> geographic relevance.  For example, information related to the location and
> extent of a patch of ice on the road is only relevant to those who are
> likely to encounter it.  Those traveling away from the patch, or travelling
> nowhere in the vicinity, have no use for the information.  So the
> information is "delivered to a place" regardless of whether or not there is
> anyone there to receive it.  It's a strange concept to people dealing with
> networks of nodes, however, that's the use case.  Note the similarity to the
> US mail system, where parcels are delivered to locations rather than people
> (end-users), whether the people are home or not! Perhaps this makes the name
> GeoDissemination a bit easier to understand.
>
>
> RR
>
>> -----Original Message-----
>> From: Alexandru Petrescu [mailto:[email-masked]]
>> Sent: Wednesday, November 06, 2013 2:20 PM
>> To: [email-masked]
>> Cc: [email-masked]

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 07 Nov 2013 12:38:18 +0100

Le 07/11/2013 04:52, Richard Roy a écrit :
> It's just an example of geographically relevant information that
> happens to apply to vehicles.

Yes, it happens to apply to vehicles, and then it is good to call
dissemination.

The same geonet concept applies to the localized forest fire hazard
situation.  That wouldn't be dissemination, but rather a periodic upload
of sensed data (sensors deployed in an particular area sense the
temperature and send it back to the center every 1second).  In the
reverse way of a dissemination.

And I agree that there may be more than just the vehicular case, where
the name 'geodissemination' would make sense.  If we find that, we'd ask
to discuss and document that usecase as well.

Alex

> The concept applies to a lot more than just vehicles obviously.  The
> more important point is that in geodissemination we are concerned
> with delivering information to a place where there may or may not be
> nodes without necessarily engaging in a long route discovery
> process.
>
> RR
>
>> -----Original Message----- From: Alexandru Petrescu
>> [mailto:[email-masked]] Sent: Wednesday, November
>> 06, 2013 7:03 PM To: [email-masked]; [email-masked] Cc:
>> [email-masked] Subject: Re: [its] Question and Suggestion
>>
>> Richard,
>>
>>> In the ITS community, the concept behind the term GeoNet is that
>>> of geographical dissemination of information, and is not
>>> directly tied to analyzing IP traffic based on location.  As
>>> noted in my previous
> posting,
>>> The key point to remember is that we are dealing with
>>> information that
>> has
>>> geographic relevance.  For example, information related to the
>>> location
>> and
>>> extent of a patch of ice on the road is only relevant to those
>>> who are likely to encounter it.  Those traveling away from the
>>> patch, or
>> travelling
>>> information is "delivered to a place" regardless of whether or
>>> not there
>> is
>>> anyone there to receive it.  It's a strange concept to people
>>> dealing
>> with
>>> networks of nodes, however, that's the use case.  Note the
>>> similarity to
>> the
>>> US mail system, where parcels are delivered to locations rather
>>> than
>> people
>>> (end-users), whether the people are home or not! Perhaps this
>>> makes the
>> name
>>>> -----Original Message----- From: Alexandru Petrescu
>>>> [mailto:[email-masked]] Sent: Wednesday,
>>>> November 06, 2013 2:20 PM To: [email-masked] Cc:
>>>> [email-masked] Subject: Re: [its] Question and Suggestion
>>>>
>>>> Hello Mike,
>>>>
>>>> I have been asked whether this 'geonet' has anything to do
>>>> with the use-case where an operator analyzes own traffic,
>>>> needing to identify which region of that city generates most
>>>> traffic (given IP address allocation follows no particular
>>>> logic with respect to geography).
>>>>
>>>> I'd say yes.
>>>>
>>>>> First, I enjoyed meeting some of you at the BOF and look
>>>>> forward to working with you all on this topic.
>>>>>
>>>>> comments at the BOF. I was taking notes and did not want to
>>>>> lose track of that.
>>>>>
>>>>> Question about the proposed charter: do we have to include
>>>>> use cases in the charter? I see a danger in limiting our use
>>>>> cases to the two mentioned in the proposed charter. Use
>>>>> cases usually drive the requirements that drive the
>>>>> protocols. If we don't identify enough related use cases we
>>>>> could miss many things in the protocol that would drive other
>>>>> bodies to create similar protocols to solve issues in the
>>>>> same domain. I see a better approach is to have a use cases
>>>>> document that tries to gather as many related use cases as
>>>>> possible. We can eventually narrow it down to come up with a
>>>>> practical solution.
>>>>>
>>>>> Suggestion: I like the idea that somebody mentioned in the
>>>>> meeting about iterating between problem definition and
>>>>> solution. I think the suggestion is to do brainstorming. I
>>>>> would volunteer to start a brainstorming document that could
>>>>> be used for discussions. This document would include: -
>>>>> Problems - Use cases - Assumptions - Potential solutions
>>>>>
>>>>> It would only be intended to drive discussion. I would not
>>>>> propose that this would be any type of final publishable
>>>>> document.
>>>>>
>>>>>
>>>>> _______________________________________________ its mailing
>>>>> list [email-masked] https://www.ietf.org/mailman/listinfo/its
>>>>>
>>>>
>>>>
>>>
>>>
>>>
>>>
>
>
>