Subject: Re: [geonet/its] RSU discussion (was: suggestions about charter scope limitation and the specific language)

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 06 Dec 2013 16:19:05 +0100

Le 17/11/2013 04:13, Rex Buddenberg a écrit :
> Good discussion, Alison ... response on this:
>
> On Sat, 2013-11-16 at 18:28 -0800, Alison Chaiken wrote:
>> Regarding the term RSU:
>> Presumably the only necessary condition for a road-side unit is that
>> it be networked and roadside.   While most RSUs will in fact be
>> permanently installed, is there any reason not to call mobile access
>> routers RSUs if they serve the same function as permanent ones?
>> Perhaps the distinction we need is between "infrastructure" units and
>> mobile ones?
>
> To my knowledge, RSU is not a standard term but rather a vendor-oriented
> packaging one.
>
> The _typical_ roadside unit would have
>   - terrestrial-WAN backside connection.

Some RSUs have terestrial-MAN (like ADSL) instead of WAN.

>   - a router.
>   - one or more radio-WAN base stations.  The term base station has
> accepted meaning within IEEE 802.16 for this component.
>   - power supply.  At least some, if they're deemed mission critical,
> would have both grid power and backup.
>   - SNMP agent that reaches to all these components.
>   - layer 7 gateway if there is non-routable network connects, like to
> P25 voice or non-protocol Land Mobile Radio.

Additionally, some RSUs have GPS receivers by specification.  This may 
sound little plausible because it would be sufficient to hardcode the 
coordinates in a fixed RSU, but others suggest the time from GPS is 
valuable too (not only the coordinates), in alternance to the NTP time 
_if_ the RSU is connected to the Internet.

> Now, there are a variety of atypical configurations depending...
>   - 'quick deploy' models that might use something like 802.16
> connections in place of the terrestrial-WAN.  Think hurricane response.
> Since these might be in places other than along roads (or the road might
> no longer exist;-), still wanna call them RSUs?
>   - mobile models that are installed in, say, a fire truck or a comms
> van.
>   - ... would you still want to call these RSUs?

Good question.

Alex

>
>
>
>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>
>

---

From: John Kenney <[email-masked]>
Date: Fri, 6 Dec 2013 18:15:33 -0800

Hi Folks:
Not sure if this is helpful in this discussion, but in the context of DSRC
the FCC defines RSU in Part 90 (see attached)

Best Regards,
John

On Fri, Dec 6, 2013 at 7:19 AM, Alexandru Petrescu <
[email-masked]> wrote:

> valuable too (not only the coordinates), in alternance to the NTP time _if_
> the RSU is connected to the Internet.
>

-- 
John Kenney
Principal Researcher
Toyota InfoTechnology Center, USA
465 Bernardo Avenue
Mountain View, CA 94043
Tel: 650-694-4160. Mobile: 650-224-6644

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 07 Dec 2013 17:29:54 +0100

On 07/12/2013 03:15, John Kenney wrote:
> Hi Folks:
> Not sure if this is helpful in this discussion, but in the context of
> DSRC the FCC defines RSU in Part 90 (see attached)

Hi John,

Thanks for the reference.

The extracted text is this:
> Roadside unit (RSU). A Roadside Unit
> is a DSRC transceiver that is mounted
> along a road or pedestrian passageway.
> An RSU may also be mounted on a vehicle
> or is hand carried, but it may
> only operate when the vehicle or handcarried
> unit is stationary. Furthermore,
> an RSU operating under this
> part is restricted to the location where
> it is licensed to operate. However, portable
> or hand-held RSUs are permitted
> to operate where they do not interfere
> with a site-licensed operation. A RSU
> broadcasts data to OBUs or exchanges
> data with OBUs in its communications
> zone. An RSU also provides channel assignments
> and operating instructions
> to OBUs in its communications zone,
> when required.

I think this RSU does not have any GNSS feature built in.

Is it usual that these DSRC RSU are not equipped with any form of GPS or 
other satellite-based location interface?

Alex

>
> On Fri, Dec 6, 2013 at 7:19 AM, Alexandru Petrescu
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Additionally, some RSUs have GPS receivers by specification.  This
>     may sound little plausible because it would be sufficient to
>     hardcode the coordinates in a fixed RSU, but others suggest the time
>     from GPS is valuable too (not only the coordinates), in alternance
>     to the NTP time _if_ the RSU is connected to the Internet.
>
>         _________________________________________________
>         its mailing list
>         [email-masked] <mailto:[email-masked]>
>         https://www.ietf.org/mailman/__listinfo/its
>         <https://www.ietf.org/mailman/listinfo/its>
>
>
>
>
>     _________________________________________________
>     its mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/its
>     <https://www.ietf.org/mailman/listinfo/its>
>
>
>
>
> --
> John Kenney
> Principal Researcher

---
Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
http://www.avast.com

---

From: Rex Buddenberg <[email-masked]>
Date: Sat, 07 Dec 2013 08:34:02 -0800

> other satellite-based location interface?

That might be a reasonable requirement, but it's not part of the
definition.

In fact, it would make a lot of sense for the node to piggyback
differential GPS capability.

---

From: Alison Chaiken <[email-masked]>
Date: Sat, 7 Dec 2013 12:58:08 -0800

On Sat, Dec 7, 2013 at 12:40 PM, Richard Roy <[email-masked]> wrote:
> Furthermore, if you read the rules carefully, you'll see there is really no
> operational difference between a stationary or a portable RSU.  Stationary
> RSUs are licensed to operate in a specific location and portable RSUs can
> operate while stationary anywhere where they don't interfere with primary
> users of the band, that's all. From the standpoint of geodissemination of
> information, the distinction is really not overly relevant.

The main point is to avoid stating that RSUs are "installed", as some
of the drafts have.   We should also either change the name
"road-side" to indicate an infrastructural role without using the
terms "road-side" or "infrastructure" (the latter being too freight in
this context.)       Or we could define a class of infrastructural
units whose role is to provide Internet connectivity for ad hoc
communicators but can be an aircraft, a boat, a camera server . . .
The unit provides some of the functionality that a traditional access
point does but is not a traditional access point.    Is it perhaps an
"ad hoc access point"?    I know that this domain has a huge amount of
history with which I am only slightly familiar, so I hesitate to
propose anything myself.    Besides which, I am truly painfully busy
at the moment!

-- Alison

-- 
Alison Chaiken                           [email-masked]
650-279-5600                            http://{she-devel.com,
exerciseforthereader.org}
It's a bug that cars were invented before computers.    -- Eric Schmidt

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 09 Dec 2013 13:59:29 +0100

Le 07/12/2013 21:58, Alison Chaiken a écrit :
>> Furthermore, if you read the rules carefully, you'll see there is
>> really no operational difference between a stationary or a portable
>> RSU.  Stationary RSUs are licensed to operate in a specific
>> location and portable RSUs can operate while stationary anywhere
>> where they don't interfere with primary users of the band, that's
>> all. From the standpoint of geodissemination of information, the
>> distinction is really not overly relevant.
>
> The main point is to avoid stating that RSUs are "installed", as
> some of the drafts have.   We should also either change the name
> terms "road-side" or "infrastructure" (the latter being too freight
> in this context.)       Or we could define a class of
> infrastructural units whose role is to provide Internet connectivity
> for ad hoc communicators but can be an aircraft, a boat, a camera
> server . . . The unit provides some of the functionality that a
> traditional access point does but is not a traditional access point.
> Is it perhaps an "ad hoc access point"?

Maybe a geonet-enabled Access Point?  (a GAP?).

Also, there exist a differentiator between such GAPs.  Some GAPs are
connected to the Internet (with e.g. ADSL, fiber, WMAN), whereas others
are disconnected from the Internet (there only to make umbrella for
vehicles, like in 'canopy').

Alex

> I know that this domain has a huge amount of history with which I am
> only slightly familiar, so I hesitate to propose anything myself.
> Besides which, I am truly painfully busy at the moment!
>
> -- Alison
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 09 Dec 2013 18:44:48 +0100

Le 09/12/2013 18:32, Richard Roy a écrit :
> For the purposes of specifying additions to layer 3 protocols (e.g.
> IPv6), you don't need the concepts of an RSU or an OBU.  You should
> avoid using these terms at all.  The proper terms can be found in ISO
> 21217.
>
> The term "ITS station" (ITS-S) is the general term for a node in ITS
> communication networks.  The special nodes that connect networks (at
> layer 3) are called "ITS-S border routers", and ITS-S border routers
> that also provide access to other ITS-Ss are called "ITS-S access
> routers".  ITS-S border routers that can change their point of
> attachment are called (not suprisingly:^) "ITS-S mobile routers".
> There are also "ITS-S internal routers" for connecting
> station-internal networks, and "ITS-S gateways" for connecting
> networks above layer 3 (e.g. firewalls for security).  Generally, if
> their is a network-related functionality that's useful, you can
> easily guess the name ... simply append "ITS-S" :^)))

Richard,

Thank you for the suggestions on the terms ITS-S.  They sound reasonable.

I wonder whether these terms are related to geonetworking by some aspect?

At ISO is there a difference between an 'ITS station' that is able to to
do geonetworking, and the other 'ITS stations'?

Alex

>
> Hope this helps.
>
> RR
>
>> -----Original Message----- From: Alexandru Petrescu
>> [mailto:[email-masked]] Sent: Monday, December 09,
>> 2013 4:59 AM To: Alison Chaiken; [email-masked] Cc: Rex
>> Buddenberg; John Kenney; [email-masked] Subject: Re: [geonet/its] RSU
>> discussion
>>
>>>> Furthermore, if you read the rules carefully, you'll see there
>>>> is really no operational difference between a stationary or a
>>>> portable RSU.  Stationary RSUs are licensed to operate in a
>>>> specific location and portable RSUs can operate while
>>>> stationary anywhere where they don't interfere with primary
>>>> users of the band, that's all. From the standpoint of
>>>> geodissemination of information, the distinction is really not
>>>> overly relevant.
>>>
>>> "road-side" to indicate an infrastructural role without using
>>> the terms "road-side" or "infrastructure" (the latter being too
>>> freight in this context.)       Or we could define a class of
>>> infrastructural units whose role is to provide Internet
>>> connectivity for ad hoc communicators but can be an aircraft, a
>>> boat, a camera server . . . The unit provides some of the
>>> functionality that a traditional access point does but is not a
>>> traditional access point. Is it perhaps an "ad hoc access
>>> point"?
>>
>> Also, there exist a differentiator between such GAPs.  Some GAPs
>> are connected to the Internet (with e.g. ADSL, fiber, WMAN),
>> whereas others are disconnected from the Internet (there only to
>> make umbrella for vehicles, like in 'canopy').
>>
>> Alex
>>
>>> I know that this domain has a huge amount of history with which I
>>> am only slightly familiar, so I hesitate to propose anything
>>> myself. Besides which, I am truly painfully busy at the moment!
>>>
>>> -- Alison
>>>
>
>
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 09 Dec 2013 19:06:42 +0100

Le 09/12/2013 18:55, Richard Roy a écrit :
> The terms are not related directly to either GeoNetworking (as specified in
> the ETSI standards) or "geonetworking" which, to avoid confusion and
> somewhat expand the scope to include layers other than 3, is generally
> called "geodissemination". In fact, we have a work item in ISO TC204 WG16 on
> geodissemination (which needs some contributors if you are looking for
> something to do:^))))

YEs I am looking for something to do and that is to define a crisper 
problem statement for geonet at IETF.

What is the problem statement described at ISOTC204 WG16 geodissemination?

Alex

>
> Furthermore, ITS-Ss generally support multiple protocols at all layers,
> including layer 1 (it's the CALM concept!) and when they have a given
> functionality such as geodissemination of information, we generally say
> something like "a geodissemination-capable (or -aware) ITS-S".
>
> RR
>
>> -----Original Message-----
>> From: Alexandru Petrescu [mailto:[email-masked]]
>> Sent: Monday, December 09, 2013 9:45 AM
>> To: [email-masked]; 'Alison Chaiken'
>> Cc: 'Rex Buddenberg'; 'John Kenney'; [email-masked]; 'Thierry Ernst'; 'Dr.
>> Hans-Joachim Fischer'; 'Knut Evensen'
>> Subject: Re: [geonet/its] RSU discussion
>>

---

From: Knut Evensen <[email-masked]>
Date: Mon, 9 Dec 2013 18:06:02 +0000

Alexandru,

Just to fill in the answer from Dick:.

The concept of ITS Station is indeed used by both ISO TC204 and ETSI TC ITS. We have made sure that ITS Station means the same in both these SDOs. In fact the basic architecture documents (ISO 21217 and ETSI EN 300 674) are well aligned.

An ITS-S can have any number of interfaces such as WiFi, 3G/LTE, broadcast receivers, and indeed 5.9GHz. On top of these the ITS-S will support various L3 protocols such as "plain" IPv4 (usually tunnelled), IPv6 with various mobility extensions, and specialised ITS protocols such as GeoNetworking and FAST (single hop L3 pass-through).

So the short answer is: The ability to support various protocols is built into the ITS-S concept. Which ones are actually present is an implementation and/or legal decision in each region.

Best regards,
                -knut

-----Original Message-----
From: Alexandru Petrescu [mailto:[email-masked]] 
Sent: 9. desember 2013 18:45
To: [email-masked]; 'Alison Chaiken'
Cc: 'Rex Buddenberg'; 'John Kenney'; [email-masked]; 'Thierry Ernst'; 'Dr. Hans-Joachim Fischer'; Knut Evensen
Subject: Re: [geonet/its] RSU discussion

Le 09/12/2013 18:32, Richard Roy a écrit :
> their is a network-related functionality that's useful, you can easily 
> guess the name ... simply append "ITS-S" :^)))

Richard,

At ISO is there a difference between an 'ITS station' that is able to to do geonetworking, and the other 'ITS stations'?

Alex

>>> terms "road-side" or "infrastructure" (the latter being too
>> connected to the Internet (with e.g. ADSL, fiber, WMAN), whereas 
>> others are disconnected from the Internet (there only to make 
>> umbrella for vehicles, like in 'canopy').
>>
>> Alex
>>

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 10 Dec 2013 06:57:13 +0100

No, an ITS station is defined from a very abstract view point. It is thus very flexible and is able to support any type of networking protocol (and any type of transport protocol, access technology and application). The choice of the network protocol is an implementation and deployment issue. 

Of course, there are some requirements to become an ITS station. In addition, in order to support a particular protocol or technology, one has to define the interface with the other components so that a particular technology can be supported.

For instance, no document currently defines how to support visible light communications; if this technology has some specificities, a short specification may be needed to describe how it could be supported within an ITS station. From an implementation view point, the technology would have to follow some requirements in order to function within an ITS station (i.e. interface with other components). This is much like "IPv6 over foo" RFCs.

Once these requirements are fulfilled, any device can become in ITS station. For instance, a smart phone implementing the right functionalities can become an ITS station.

Regards,
Thierry.