Subject: Re: [geonet/its] [its] minutes of the 'geonet' BoF meeting - please correct where wrong

From: Michael Richardson <[email-masked]>
Date: Sat, 08 Mar 2014 15:03:42 -0500

Alexandru Petrescu <[email-masked]> wrote:
    > Please see below the minutes of the 'geonet' BoF.  Please correct were
    > necessary.

...

    > Question: IEEE 1609 does not make the documents available. We need to
    > make them available. Because its related.

    > Answer: this is an issue and we need help with the liason with IEEE.
    > Liaison: we will address it.

did documents become available?

-- 
Michael Richardson
-on the road-

---

From: Abdussalam Baryun <[email-masked]>
Date: Sun, 9 Mar 2014 03:23:37 +0000

Hi Alex

Thanks for the update. The minutes is not showing names of who asked what.
Is It it one person asking and answering. It seems like the agenda did not
focus discussion on the ITS documents and its active docs. Why not?

Comments below

AB

On Thursday, November 7, 2013, Alexandru Petrescu wrote:

> Hello ITSers,
>
> Thanks to the minute takers.
>
> Following these correcitons I must upload them on the Proceedings of the
> IETF88 soon.
>
> Thanks,
>
> Alex
> -----------------------------------------------------------------------
>
> IETF Geonet BOF minutes
>
> Nov 5 2013
>
> 1:00 to 2:00 PM pacific time
>
> Note taker: Mike Kallas
>
> Agenda shown
> Note Well slide displayed to room.
> Margaret could not make it
> Agenda shown
> Webex is up
>
> Alex: Introductions.
>
> Internet wide geo networking
>
> Explained other related work by other groups
>
> Disseminating IP packets to geographical areas. Or receiving IP
> packets from a geographical area.
>
> Problem statement draft presented by Georgios Karagiannis
>
> Georgios: Challenges presented in the problem statement is not
> addressed by IETF or any other bodies
>
> Lost protocol: Location to service mapping
>
> Two solution presented have actual implementations
>
> Suggestion: List all the related working groups
> Answer: no working group working on the exact same problem
>
> Question: both use cases similar to ETSI scope. I don t see a wider
> coverage than the ad hoc implementation.

Which use case?
What is AD hoc implementation?

> Why not use ETSI Answer:
> short range only. Source has to be close to the area. This is internet
> wide solution: provide that ability to any source on the internet to
> send information to geographic areas.
>
> Question: Bob (Verizon) this is how things work right. What about when
> things go wrong? What about malicious events. Like to see attack
> review, failure nodes scenarios.  Answer: Security and privacy are
> very important. We have to focus on it

Disagree, we focus on solutions for each use case or each problem
statement. We then focus such solution with scenarios if things go wrong of
attacks only in security consideration section.

>
> Next on the Agenda: implementation Interest: presentation.
>
> Last topic: IPv6 over 802.11p. Presentation
>
> End of presentation part.

Who presented and what did the presenter say. This is not minute
writing,  I did not attend but did not benefit from this minute. Minutes
are written for others who did not attend so they understand what was said
exactly.

>
> Interest, clarifications.
>
> Question: problem not well defined. Is it: enumerate IP addresses that
> are currently in a geographical area to send to.
>
> Answer: its is one of the potential solutions.
>
> Answer: need to better define the problem statement. Need to learn
> geographic proximity of certain devices and leave it at a high level
> (not just IP) other options are possible.

Agree

>
> Answer: looking at a relationship between IP addresses and locations
> of Access Routers.

Agree, This is our solutions aim.

>
> Question: requirements around trust model on the geographic database?
> Are the set of networks all part of the same organization or people
> who don't trust each other? Multiple network providers? Could
> affect trust model
>
> Answer: both are relevant. Security is very important. Trust with
> respect to positioning is different from security as defined in
> IETF. Precision is also a factor. Trust of position: precision should
> be part of the discussion. Main concern not who owns IP but where it
> is
>
> Question: uniqueness vs non uniqueness and indirection in
> addressing. For example who is moving and who is not. ILNP tries to do
> indirection. Other issues are privacy: present information without
> identifying person. You may not want symmetric behavior V2x different
> mechanism from x2V.
>
> Answer: thank you. Agree on non symmetry. Need to take ILNP into
> account in addition to others. DNS, LOST
>
> Question: Guarantees. Are you only sending to the area. Is it ok it
> reaches outside the area? Are you expecting error messages if the
> message does not reach?
>
> Answer: Reliability of delivery important
>
> Question: one of the use cases was querying? How do you identify what
> nodes you want to query?
>
> Answer: example fire detectors, temperature, wind
>
> Question: translation between geo and IP very important. What about
> translating from IP address to geo? May be nice to have the solution
> for both.
>
> Answer: yes
>
> Question: skeptical about problem. Geographical routing vs optimal routing.
>
> Answer: an optimal IP routing is different from geographic
> positioning. Optimal route may not be possible
>
>
> Stop discussion: need to figure out what will happen next
>
> How many people read the problem statement: only a few
> How many saw the charter: a few

Why few, I think because the group did not progress in leadership skills.
We need leadership documents or someone who can lead the group to one
vision. Then we are work together toward that vision. Hope that IESG did
not discourage our before agreed vision.

> Is there work appropriate to the ietf: a few, some reluctance
> Not appropriate for IETF: one person only

Not understood, please help, what is the document related?

>
> Scope seems to still be too broad. Is it ready?

What is the scope please point to something?

>
> Who is interested in working on this? Several people (20)

Add me so 21.

>
> There is a mailing list including discussing scope
> http://ietf.org/mailman/listinfo/its
>
> Question: there is interest but are we ready to say go? We should not
> drop it. Is the next step another BOF?

I recommend the next step is to stick to one vision of use cases and
possible solutions that have clear scope (the word scope was the reason why
the group did not make it to IESG mind as far as information announced).

>
> Interesting in a broad sense but the scope is too wide. Need to narrow
> scope. Is there application level stuff needed. Who is capable of
> handling the received data.

Yes, I want to ask Alex to handle the scope issues, please.

>
> Ted: have heard there is interest, haven't heard there is a go, but
> there honestly this is not a drop issue, next step is maybe another
> bof.

Thanks.

>
> Last word: thanks to BOF chairs. Couple of very interesting problems:
> actions to move it forward:

I recommend a vision for solutions direction, so please one direction. Then
each solution to be scoped, then each scope documented in one document.
Please note that IESG should clarify do they want us to scope the
problems or scope the solutions, I think they want all,

IMHO, we should have few main problems, and each problem may have different
issues to address. Each document has a solution.

>
> Crisp problem statement, a little of solutioneering, iteration on
> problems and solutions need to be gone through. More detailed problem
> statement more specifity. Look for any existing work. And help limit
> the scope of things needed to be done.

I don't see any decision made by the group, we need to make decisions to
progress our action or scope every thing ;-)

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 10 Mar 2014 18:12:47 +0100

> did documents become available?

Hi Michael,

Thank you for the question.

No, the P1609 documents have not become more available than before.

In the past month the IETF liaison manager with the IEEE Standards 
Association has identified the right contacts and submitted and further 
clarified a request to make P1609 documents available, towards support 
in developping IPv6-over-802.11p technology in
draft-petrescu-ipv6-over-80211p-01.txt.

Several messages were exchanged in private, including technical 
discussion about technology of IP/p, and process at IETF and at IEEE.

The last message I read is that an agreemend may be found between the 
two organization, although this may need involvement of IPR and legal 
specialists.  A question was made whether a Memorandum of Understanding 
between IEEE and IETF exists such as to facilitate contact.  That's 
where it stands right now.

Is there any agreement, or MoU, between IEEE or IEEE/VTS and IETF?

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 10 Mar 2014 18:16:32 +0100

Hi Abdussalam,

Thanks for the comments.

The comments you provided are related to the Vancouver 'geonet' BoF. 
Should I still address them?  If yes, just let me know.

The London bar BoF meeting minutes have been drafted and circulated 
privately.  I wait a little bit for last edits and I will post on the 
email list soon.

Alex

Le 09/03/2014 04:23, Abdussalam Baryun a écrit :
>
> Hi Alex
>
> Thanks for the update. The minutes is not showing names of who asked
> what. Is It it one person asking and answering. It seems like the agenda
> did not focus discussion on the ITS documents and its active docs. Why not?
>
> Comments below
>
> AB
>
>     Please see below the minutes of the 'geonet' BoF.  Please correct
>     were necessary.
>
>     Following these correcitons I must upload them on the Proceedings of
>     the IETF88 soon.
>
>     Thanks,
>
>     Alex
>     ------------------------------__------------------------------__-----------
>
>     IETF Geonet BOF minutes
>
>     Nov 5 2013
>
> statement. We then focus such solution with scenarios if things go wrong
> of attacks only in security consideration section.
>
>
> are written for others who did not attend so they understand what was
> said exactly.
>
>
> Why few, I think because the group did not progress in leadership
> skills. We need leadership documents or someone who can lead the group
> to one vision. Then we are work together toward that vision. Hope that
> IESG did not discourage our before agreed vision.
>
>
>     http://ietf.org/mailman/__listinfo/its
>     <http://ietf.org/mailman/listinfo/its>
>
> possible solutions that have clear scope (the word scope was the reason
> why the group did not make it to IESG mind as far as information
> announced).
>
>
> I recommend a vision for solutions direction, so please one direction.
> Then each solution to be scoped, then each scope documented in one
> document. Please note that IESG should clarify do they want us to scope
> the problems or scope the solutions, I think they want all,
>
> IMHO, we should have few main problems, and each problem may have
> different issues to address. Each document has a solution.
>
>

---

From: Melinda Shore <[email-masked]>
Date: Mon, 10 Mar 2014 09:45:48 -0800

To be clear, this was not a BOF, and it should not be regarded
as one.  It was an informal get-together to try to get the
proposed charter and problem statement better scoped.  Not only
were we not on the agenda, we were not given meeting space
when we requested it.

Might be better to post a few notes on points of agreement
and on what needs to be done rather than to rathole on
minutes for something that wasn't really even a meeting.

Melinda

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 10 Mar 2014 18:50:33 +0100

Hi Alex

Ok, I thank you and know it is not easy to write minutes. However, the IETF
88 minutes was not clear and has no names, and difficult for me to
understand. As long as it was posted I just commented that I did not
understood but hope that the next 89 minutes is not the same like the
Vancouver minutes (I really look forward to latest 89 meeting minutes, so
for me it is no need to address 88 meeting, thanks).

Regards
AB

On Monday, March 10, 2014, Alexandru Petrescu wrote:

> privately.  I wait a little bit for last edits and I will post on the email
> list soon.
>
> Alex
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 10 Mar 2014 18:56:49 +0100

Hi Melinda,

If the gathering made some results, conclusions or agreements, please tell
us. I agree that it is not important to have minutes ready, but it is
important that we get together and make decisions/agreements, then announce
them.

I hope there was a good result because I am interested in this group, I
look forward to reading discussion results not only discussion points.

Best regards
AB

On Monday, March 10, 2014, Melinda Shore wrote:

> _______________________________________________
> its mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 10 Mar 2014 14:46:00 -0400

On Mar 10, 2014, at 1:50 PM, Abdussalam Baryun <[email-masked]> wrote:
> Ok, I thank you and know it is not easy to write minutes. However, the IETF 88 minutes was not clear and has no names, and difficult for me to understand. As long as it was posted I just commented that I did not understood but hope that the next 89 minutes is not the same like the Vancouver minutes (I really look forward to latest 89 meeting minutes, so for me it is no need to address 88 meeting, thanks). 

To be clear, until a working group is chartered, this is just a discussion among IETF participants, and no minutes are required.   Once a working group is chartered, meeting minutes are _required_, and meetings have to be announced at least two weeks in advance on the mailing list.

So if someone took minutes, it would be great if they could post what they have, but please don't get so formal about it that it becomes an obstacle to forward progress.

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 10 Mar 2014 20:13:43 +0100

Hi Ted,

I agree, and I just replied to posts with my comments. but I think if we
want progress, at least We need to know just results of meetings or
gathering, or what the group chair advise what is missing, Is this ok,
please advise,

AB

On Monday, March 10, 2014, Ted Lemon wrote:

> On Mar 10, 2014, at 1:50 PM, Abdussalam Baryun <[email-masked]<javascript:;>>
> wrote:
> > Ok, I thank you and know it is not easy to write minutes. However, the
> IETF 88 minutes was not clear and has no names, and difficult for me to
> To be clear, until a working group is chartered, this is just a discussion
> among IETF participants, and no minutes are required.   Once a working
> group is chartered, meeting minutes are _required_, and meetings have to be
> announced at least two weeks in advance on the mailing list.
>
> So if someone took minutes, it would be great if they could post what they
> have, but please don't get so formal about it that it becomes an obstacle
> to forward progress.
>
>