Subject: [geonet/its] About WSMP (Wave Short Message Protocol)

From: vamsi <[email-masked]>
Date: Thu, 17 Jul 2014 16:50:06 +0530

Hi ,

 I am planing to develop WSMP (Wave Short Message Protocol) protocol in
transport layer.Any suggestions will be appreciated,
 
My idea is given below

WSMP(Wave Short Message Protocol ie. 1609.3
published by the IEEE Vehicular Society) is a part of the DSRC(Dedicated
Short Range Communications) standards suite which include 802.11p,
1609.x series. Which are used for "intervehicular communication" and
also for "vehicle to infrastructure communication".

The DSRC/WAVE stack:
        
         Application Layer (SAE J2735 Message set dictionary)

                ^
                |
         Transport Layer -| 
                ^         |
                |         |--(WSMP IEEE 1609.3) Both combined
         Network Layer    |
                ^         |
                |         |
         LLC(existing)   -|
                ^        
                |        
         Datalink Layer  -|
                ^         |
                |         |--(1609.4 and IEEE802.11p)
         Physical Layer  -|

Currently as IEEE 802.11-2012 has released,it is having 802.11p also
merged in it.
We may have WSMP acting as both transport layer and network layer.We
have some proprietry 
implementations of all these standards but no open source implementation
has been done.

We propose to develop this in a way so that it has a socket interface to
the user.
Please give your suggestions. 
For more info regarding the stack one may refer to the Document
IEEE1609.0 or John Kenney's 
paper on this subject "Dedicated Short-Range
Communications (DSRC) Standards in the United States"
link  "http://secs.oakland.edu/~gpcorser/vanet-kenny-DSRC.pdf"

---

From: <[email-masked]>
Date: Fri, 18 Jul 2014 05:24:02 +0000

Hi Vamsi,

Thanks for your email!
When you talk about the network layer in the below email are you refering to the IP protocol?

Best regards,
Georgios

________________________________________
Van: its [[email-masked]] namens vamsi [[email-masked]]
Verzonden: donderdag 17 juli 2014 13:20
Aan: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; "its "@ietf.org; [email-masked]
Onderwerp: [geonet/its] About WSMP (Wave Short Message Protocol)

Hi ,

My idea is given below

The DSRC/WAVE stack:

                ^
                |
         Transport Layer -|
                ^         |

_______________________________________________
its mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/its

---

From: vamsi <[email-masked]>
Date: Fri, 18 Jul 2014 11:25:17 +0530

Dear karagian,
 
Thank for reply!

WSMP referring Transport layer + Network layer protocol. WSMP protocol
don't have IP address concept, it used MAC address and sending packet
broadcast.

---

From: vamsi <[email-masked]>
Date: Fri, 18 Jul 2014 11:25:17 +0530

Dear karagian,
 
Thank for reply!

---

From: <[email-masked]>
Date: Fri, 18 Jul 2014 06:11:57 +0000

Dear Vamsi,

Thanks for your answer!
Please note that the IETF is only focusing on protocols and/or mechanisms that are (or will become) part of the IP protocol stack!

Best regards,
Georgios Karagiannis

________________________________________
Van: vamsi [[email-masked]]
Verzonden: vrijdag 18 juli 2014 7:55
Aan: Karagiannis, G. (EWI)
CC: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Onderwerp: Re: [geonet/its] About WSMP (Wave Short Message Protocol)

Dear karagian,

Thank for reply!

---

From: <[email-masked]>
Date: Fri, 18 Jul 2014 06:11:57 +0000

Dear Vamsi,

Thanks for your answer!

Best regards,
Georgios Karagiannis

Dear karagian,

Thank for reply!

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 21 Jul 2014 11:47:32 +0200

Hello vamsi,

Implementing WSMP messages may be useful for vehicular network trials 
where an RSU sends such message to a vehicle, or where one vehicle sends 
similar message to another vehicle.

Which one of the several standardized WSMP messages would be simplest to 
implement and demonstrate first?  Have you decided?

Once that decided, one may wonder how to do it: it may be that one easy 
and very cheap way to implement is to encode that WSMP message as an UDP 
payload of an IP message, on a linux machine, using the classic BSD 
socket interface.

It is true that there is no open-source implementation available of 
WSMP, but it would be really easy to write one as described above.

To achieve that, one would like to use an 802.11p freely available open 
source implementation in kernel.  There are ongoing efforts towards that 
direction, check the kernel.org source.  You could also ask about it on 
this email list.

Alex

---

From: Rex Buddenberg <[email-masked]>
Date: Mon, 21 Jul 2014 09:42:02 -0700

Alex,

Your note inadvertently highlights some of the problems I see here.

As vamsi earlier noted, the WSMP protocol stack is not IP.  Therefore
UDP is not relevant. ... if you truly believe in WSMP.  I don't.

First we have an internet problem here with at least two segments: an
in-vehicle LAN and an external radio-WAN.  This may not be obvious but
it's hard to envision a single end system in the vehicle at any scale.
MAC addresses are appropriate for single-segment addressing, but IP is
designed for multi-segment internetworking.  So I have a conceptual
problem with WSMP short-shrifting this.  I have doubts about being able
to do internetworking with MAC addresses; and I have more serious doubts
about it being worth it.

Second question that isn't obvious here is: what is the reliability
model?  There are three possible answers:
  - no reliability (what we sarcastically called spray & pray).  If you
buy the IP argument above, then UDP is an appropriate transport layer
answer to the question.  (Does WSMP support an analog to UDP?)
  The remaining two answers have TCP-like reliability aspects but differ
in how they handle late joiners in a multicast environment (this _is_
multicast, is it not?):
  - when a new node joins the multicast group, that node needs all of
the data in the connection so the sender scrolls back to Square One.
  - when a new node joins the multicast group it gets reliable service
but that starts at the join-time, not at session initiation.  
  (TCP conflates these two models -- the difference is moot in a unicast
environment).

---

From: vamsi krishna tp <[email-masked]>
Date: Tue, 22 Jul 2014 18:13:33 +0530

Dear Karagian,

Thanks for your reply. Just to clarify a bit, and pardon me if I'm wrong,
as you may be knowing that DSRC standards are mostly single hop and
broadcast type communication, IP layer is not necessary there(although the
architecture shows WSMP in parallel with IPv6 + UDP/TCP). Does that mean
that IETF will not be taking any interest in the WSMP part?

Regards,
Vamsi

On Fri, Jul 18, 2014 at 11:41 AM, <[email-masked]> wrote:

> Dear Vamsi,
>
> Thanks for your answer!
> Please note that the IETF is only focusing on protocols and/or mechanisms
> that are (or will become) part of the IP protocol stack!
>
> Best regards,
> Georgios Karagiannis
>
> CC: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> > Aan: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; "its "@ietf.org; [email-masked]

---

From: vamsi krishna tp <[email-masked]>
Date: Tue, 22 Jul 2014 18:13:33 +0530

Dear Karagian,

Regards,
Vamsi

---

From: vamsi krishna tp <[email-masked]>
Date: Tue, 22 Jul 2014 17:55:25 +0530

HI RR,

         Thanks for that valuable info/suggestion. Can you please send me
the link where
 I can get updated about this harmonisation procedure.

Regards,
Vamsi

On Sat, Jul 19, 2014 at 5:29 AM, Richard Roy <[email-masked]> wrote:

> All,
>
> I'm not quite sure why this thread is on the geonet/its mailing list,
> however I can provide a few comments for consideration.
>
> 1)IEEE 1609's WSMP is currently undergoing "harmonization" with TC204
> WG16's
> FNTP and is likely to be changing in the very near future so you may want
> to
> wait a bit before you go to the trouble of coding up a protocol that will
> be
> out of date by the time you get it implemented. You will also appreciate
> the
> changes/improvements! (see 3))
>
> 2) The whole point of the fast protocol is to minimize overhead and
> processing for point-to-point communications.  As such, there is no need
> for
> a network layer, and consequently, the protocol is designed without one.
> There are NO network layer addresses (or functionalities) in the fast
> protocol at all; hence it is a NULL-networking layer protocol.
>  Furthermore,
> in the current WSMP, there is NO transport layer protocol either! Hence it
> is also a NULL-transport layer protocol.  Essentially the fast protocol
> does
> nothing except take an LSDU and deliver it to the higher layer entity which
> is supposed to get it! In the current WSMP, that is indicated by the PSID
> field (see point 3)).
>
> 3) Point 2) notwithstanding, one of the proposals to harmonize FNTP with
> WSMP includes network and transport layer headers that add flexibility to
> optionally add some limited functionality at the network and/or transport
> layers. As with all network layer protocols, the transport protocol is
> specified in a transport protocol ID in the network header.  Most
> importantly, the new fast protocol uses PORT NUMBERS (not PSIDs/ITS-AIDs)to
> identify the higher layer entity (above the transport layer) that is to
> receive the TSDU.  This will make the creation of sockets quite simple.
>
> Hope this is useful ...
>
> Cheers,
>
> RR
>
> > -----Original Message-----
> > From: vamsi [mailto:[email-masked]]
> > Sent: Thursday, July 17, 2014 10:55 PM
> > To: [email-masked]
> > Cc: [email-masked]; [email-masked]; [email-masked];
> > [email-masked]; [email-masked]; [email-masked];
> > [email-masked]
> > Subject: Re: [geonet/its] About WSMP (Wave Short Message Protocol)
> >
> > Dear karagian,
> >
> > Thank for reply!
> >

---

From: vamsi krishna tp <[email-masked]>
Date: Tue, 22 Jul 2014 17:55:25 +0530

HI RR,

Regards,
Vamsi

---

From: "John Moring" <[email-masked]>
Date: Fri, 25 Jul 2014 12:59:10 -0700

As Vice Chair of the IEEE 1609 Working Group, and editor of the IEEE Std
1609.3 that specifies WSMP, allow me to provide a little background.
 
As was previously noted, WSMP does not run over IP. It was developed
specifically as an alternative to IPv6 (1609's other stack) for low-latency,
low-overhead, point to point traffic.
 
There is ongoing discussion of potentially enhancing or providing an
alternate to WSMP in future versions of 1609, some of which is described by
Dick Roy below. What a future revision of IEEE Std 1609.3 might include or
when it would be published is yet to be determined.  
 
Interested parties may join our email reflector by addressing
[email-masked] with message body "subscribe stds-p1609".
 
Regards,
John Moring

  _____  

From: its [mailto:[email-masked]] On Behalf Of vamsi krishna tp
Sent: Tuesday, July 22, 2014 5:25 AM
To: Richard Roy
Cc: Alexandru Petrescu; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]; Saurabh Pal
Subject: Re: [geonet/its] About WSMP (Wave Short Message Protocol)

HI RR,

Regards,

Vamsi

All,

1)IEEE 1609's WSMP is currently undergoing "harmonization" with TC204 WG16's
FNTP and is likely to be changing in the very near future so you may want to
wait a bit before you go to the trouble of coding up a protocol that will be
out of date by the time you get it implemented. You will also appreciate the
changes/improvements! (see 3))

2) The whole point of the fast protocol is to minimize overhead and
processing for point-to-point communications.  As such, there is no need for
a network layer, and consequently, the protocol is designed without one.
There are NO network layer addresses (or functionalities) in the fast
protocol at all; hence it is a NULL-networking layer protocol.  Furthermore,
in the current WSMP, there is NO transport layer protocol either! Hence it
is also a NULL-transport layer protocol.  Essentially the fast protocol does
nothing except take an LSDU and deliver it to the higher layer entity which
is supposed to get it! In the current WSMP, that is indicated by the PSID
field (see point 3)).

Hope this is useful ...

Cheers,

RR

---

From: Alison Chaiken <[email-masked]>
Date: Thu, 31 Jul 2014 08:29:12 -0700

> implementations of all these standards but no open source implementation

Componentality, a Finno-Russian startup, has open-source FlexRoad and
Drivity tools that are part of Automotive Grade Linux:

      http://www.componentality.com/drivity/
      http://www.componentality.com/flexroad/

I suggest that you join the Automotive Grade Linux mailing list

   [email-masked]

by visiting

       https://lists.linuxfoundation.org/mailman/listinfo/automotive-discussions

The AGL project is active and well-funded even if the mailing list is
dead.   I am sure that they would welcome further contributions.

I know that Adrian Chadd is also working on a BSD-licensed stack, but
haven't seen him recently and don't know the state of his work.

Best wishes,
Alison

-- Alison

-- 
Alison Chaiken                           [email-masked]
650-279-5600                            http://{she-devel.com,
exerciseforthereader.org}
It's a bug that cars were invented before computers.    -- Eric Schmidt

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 31 Jul 2014 21:35:10 +0200

[on behalf of Alison Chaiken [email-masked]; she says this below]

by visiting

Best wishes,
Alison

-- Alison

---

From: "Konstantin A. Khait" <[email-masked]>
Date: Thu, 31 Jul 2014 23:45:05 +0400

Hello Alexandru, Alison and All,

Sorry for the long silence. We will go through the mail thread and respond soon. Unfortunately, we are limited in resources during summer vacations time, therefore latency is long enough.

Thanks for remembering of us,

Kostia

-----

Konstantin A. Khait

Chief of Engineering

Componentality Oy

Tel: +358(0)469081696

+7(921)9005780

Skype: kostia.khait

E-Mail: [email-masked]

53100 Finland

Ratakatu 47

Lappeenranta

> В  В  В  В http://www.componentality.com/drivity/

> В  В  В  В http://www.componentality.com/flexroad/

> В  В  [email-masked]

> В

> dead. В  I am sure that they would welcome further contributions.