Subject: [geonet/its] FYI - ETSI ITS - work on cooperative cruise control, platooning

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 24 Oct 2014 17:16:31 +0200

Hello geonet/itsers,

ETSI ITS group is an SDO in Europe.  They produced many standards in the 
past for vehicular communications, e.g. ETSI ITS geo-networking among 
others.

ETSI ITS recently agreed to start working on pre-standardization items 
called "Cooperative Cruise Control" and "Platooning".  These two 
applications make automobiles (and trucks) talk to each other 
continuously to keep speed constant.  It helps relieve automobile driver 
stress in jam situation or reduce gas consumption by 'platooning'.

Currently the focus is on requirements including communication requirements.

In my oppinion, and this is why I forward it to this group, establishing 
direct IP connections between vehicles may open paths for exchanging IP 
data containing speed/location and trigger a control process of adapting 
the speed.  One already controls vehicles by sending IP data to them, 
from the infrastructure.  It would be a simple matter for IP experts to 
send that same data from other vehicle, without going to the infrastructure.

Thoughts?

Yours,

Alex

---

From: John Kenney <[email-masked]>
Date: Fri, 24 Oct 2014 16:45:00 -0700

Hi Alex,
Thanks for sharing this.

I think many of us in the DSRC/Cooperative ITS community consider these two
applications to be a very natural fit for the technology.  Furthermore, my
expectation is that the applications can work well with one-hop V2V
communication of the type that does not typically use IP.  So, I don't see
a benefit of including IP.  That doesn't mean it wouldn't work, but as you
know the DSRC community generally plans to use a lighter weight protocol,
WSMP, for applications that do not need IP.  I expect ETSI will think along
similar lines.

Best Regards,
John

-- 
John Kenney
Principal Researcher
Toyota InfoTechnology Center, USA
465 Bernardo Avenue
Mountain View, CA 94043
Tel: 650-694-4160. Mobile: 650-224-6644

On Fri, Oct 24, 2014 at 8:16 AM, Alexandru Petrescu <
[email-masked]> wrote:

> applications make automobiles (and trucks) talk to each other continuously
> to keep speed constant.  It helps relieve automobile driver stress in jam
> situation or reduce gas consumption by 'platooning'.
>
> the speed.  One already controls vehicles by sending IP data to them, from
> the infrastructure.  It would be a simple matter for IP experts to send
> that same data from other vehicle, without going to the infrastructure.
>
> Thoughts?
>
> Yours,
>
> Alex
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Sat, 25 Oct 2014 08:49:31 +0900

--
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random
Protocol Engineering Lab., Sangmyung University

#email: [email-masked]
#webpage: https://sites.google.com/site/hurryon

> On Oct 25, 2014, at 8:45 AM, John Kenney <[email-masked]> wrote:
> 
> Hi Alex,
> Thanks for sharing this.
> 
> I think many of us in the DSRC/Cooperative ITS community consider these two applications to be a very natural fit for the technology.  Furthermore, my expectation is that the applications can work well with one-hop V2V communication of the type that does not typically use IP.  So, I don't see a benefit of including IP.  That doesn't mean it wouldn't work, but as you know the DSRC community generally plans to use a lighter weight protocol, WSMP, for applications that do not need IP.  I expect ETSI will think along similar lines.

+1

> On Fri, Oct 24, 2014 at 8:16 AM, Alexandru Petrescu <[email-masked] <mailto:[email-masked]>> wrote:
> Hello geonet/itsers,
> 
> ETSI ITS group is an SDO in Europe.  They produced many standards in the past for vehicular communications, e.g. ETSI ITS geo-networking among others.
> 
> ETSI ITS recently agreed to start working on pre-standardization items called "Cooperative Cruise Control" and "Platooning".  These two applications make automobiles (and trucks) talk to each other continuously to keep speed constant.  It helps relieve automobile driver stress in jam situation or reduce gas consumption by 'platooning'.
> 
> In my oppinion, and this is why I forward it to this group, establishing direct IP connections between vehicles may open paths for exchanging IP data containing speed/location and trigger a control process of adapting the speed.  One already controls vehicles by sending IP data to them, from the infrastructure.  It would be a simple matter for IP experts to send that same data from other vehicle, without going to the infrastructure.
> 
> Thoughts?
> 
> Yours,
> 
> Alex
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/its <https://www.ietf.org/mailman/listinfo/its>
> 
> 
> 
>

---

From: Jean-Marie BONNIN <[email-masked]>
Date: Sun, 26 Oct 2014 00:53:15 +0200

> Le 25 oct. 2014 à 01:49, Jong-Hyouk Lee <[email-masked]> a écrit :
> 
> 
> --
> #email: [email-masked] <mailto:[email-masked]>
> #webpage: https://sites.google.com/site/hurryon <https://sites.google.com/site/hurryon>
>> On Oct 25, 2014, at 8:45 AM, John Kenney <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Alex,
>> Thanks for sharing this.
>> 

Yes you’re probably right. 
ETSI has planed to standardize these applications over G5 (IEEE 802.11p), but it could be very interesting to see if we can meet the requirement using IP instead of CAM messages directly over G5. 

My understanding is that using only one-hop v2v could be not sufficient in certain circonstances, when two lines of platooning vehicles have to merge for example, or more obviously when you have to be forwarded by the infrastructure to reach the next vehicle. In this last situation, you could use multi hop geo-routing or have a part of the application that run in the infrastructure. 

My 2 ¢

JMB

>> John

 <http://www.telecom-bretagne.eu/>	Jean-Marie BONNIN
Professor, Head of RSM dpt
IRISA, D2 (Network, Telecommunications & Services) dpt    
IRISA  <http://www.irisa.fr/>/ UeB  <http://www.ueb.eu/>
Tel. : +33 2 99 12 70 07 - +33 6 60 76 79 76	2, rue de la Châtaigneraie
CS 17607
35576 Cesson Sévigné, France 
 <http://perso.telecom-bretagne.eu/jmbonnin> LinkedIn  <http://fr.linkedin.com/pub/jean-marie-bonnin/0/991/285>RG <http://www.researchgate.net/profile/Jean-Marie_Bonnin>

---

From: "Varadi , Andras (lesswire AG Ungarn)" <[email-masked]>
Date: Mon, 27 Oct 2014 11:22:00 +0000

Dear Alex, John

I agree with John, but would like to point out that I think its likely that we will need to extend EU Geonetworking (EN 302 636) to work over IP (e.g. LTE) links also.
I think we will have such requirements for EU Day2 or 3 (2nd, Third generation C-ITS) (example: update our Local Dynamic Map with a new Warning message received over cellular connection (not G5/11p))

Üdvözlettel / Best regards,
   András Váradi

     Project Manager – C2X/ITS Systems

     Automotive & WLAN Group
     lesswire   Hungary | Office: +36 23521 667 | Email: [email-masked]<mailto:[email-masked]>

From: its [mailto:[email-masked]] On Behalf Of John Kenney
Sent: Saturday, October 25, 2014 1:45 AM
To: Alexandru Petrescu
Cc: [email-masked]
Subject: Re: [geonet/its] FYI - ETSI ITS - work on cooperative cruise control, platooning

Hi Alex,
Thanks for sharing this.

Best Regards,
John

On Fri, Oct 24, 2014 at 8:16 AM, Alexandru Petrescu <[email-masked]<mailto:[email-masked]>> wrote:
Hello geonet/itsers,

Thoughts?

Yours,

Alex

_______________________________________________
its mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/its

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 27 Oct 2014 13:56:45 +0100

Richard,

Le 24/10/2014 22:32, Richard Roy a écrit :
> Alex et. al.,
>
> I'm not sure I understand what is meant by "IP data".

You are saying it below, but let me expand the abbreviation: IP stands 
for Internet Protocol and is the networking layer used to bring us this 
email messsage, for example.  IP data is an IP packet carrying data as 
payload of a transport message, like TCP or UDP.

> These two applications, platooning and CACC (Cooperative Adaptive
> Cruise Control), are ITS services instantiated by ITS applications
> which are in turn instantiated by ITS application processes in ITS
> stations.

On one hand I doubt that in today's pervasive communication systems 
connected to the Internet one can still delimit applications exclusively 
dedicated to one particular domain, for example ITS.

On another hand, it is desirable for an application organization to
talk exclusively that application, provided we have an unspoken
agreement about which term corresponds to real world terms.

> They exchange ADUs in performing the service (platooning messages for
> the platooning service, and CACC messages for the CACC service).

ADU - application data unit?  If yes, then an ADU is an IP datagram, right?

> How the lower layers accomplish is of little to no consequence to the
> service generally,

Yes, of little consequence, but their presence is mandatory.  In 
advanced communication systems (flexible, scalable) it is hardly 
possible to have an application layer running straight on top of a
physical layer, for example.  A networking layer should be there to help
direct the traffic through complex mazes of nodes.

> and for these two services, this is surely the case.  That is, it is
>  irrelevant to the service which transport, network, data link, and
> physical layer protocols are used. It could be UDP/IP and the T/N
> layers, but it could also be UDP/NNTP.

I tend to agree with you.  The application layer requirements, and the
services it should offer, are independent of the underlying layers.

However, there is an overarching requirement to first establish IP 
paths, before allowing applications and services to execute.

One possibility to establish these paths are the IP paths.  Others may
be T/N(?) layers.  UDP and NNTP both need IP paths to be established.

This is the nice feature of IP paths: once established one can think of
many different ways to implement vatious applications: over UDP, over
HTTP, or even encapsulated in yet another IP header to give a renewed 
perspective.

> What is interesting about these two services is that they are
> generally executed among a "set of vehicles", all
> communicating/sharing information among the nodes in the set.  Here
> the idea of setting up a "group" and adding the concepts of joining
> and leaving would seem to make sense.

I agree.

The sets of vehicles could be described in further detail.  What are the
indivisble parts of these groups - what are these groups made of?  And
how to establish IP paths between these?

> Perhaps the IP data being referred to is part of this process, i.e.,
> setting up and managing an IP groupcast address. Either way, it's
> important to remember that what ETSI TC ITS (in conjunction with SAE
> by the way) is doing deals with ITS application processes, not with
> the layers of the comm stack used to exchange the ADUs. If the IETF
> perceives that there are elements missing in the IP specs that would
> be required to implement these services, it would seem appropriate to
> address them in the IETF.

Well that is good to hear.

If the ETSI ITS Technical Committee, or the SAE of ISO, think that IETF 
could help in designing requirements for the establishment of IP paths 
between vehicles for applications such as cooperative and adaptive cruis 
control, or platooning, then that should be said.

Alex

>
> My two cents ...
>
>
> RR
>> -----Original Message----- From: Alexandru Petrescu
>> [mailto:[email-masked]] Sent: Friday, October 24,
>> 2014 8:17 AM To: [email-masked] Subject: [geonet/its] FYI - ETSI ITS
>> - work on cooperative cruise control,platooning
>>
>> Hello geonet/itsers,
>>
>> ETSI ITS group is an SDO in Europe.  They produced many standards
>> in the past for vehicular communications, e.g. ETSI ITS
>> geo-networking among others.
>>
>> ETSI ITS recently agreed to start working on pre-standardization
>> items called "Cooperative Cruise Control" and "Platooning".  These
>> two applications make automobiles (and trucks) talk to each other
>> continuously to keep speed constant.  It helps relieve automobile
>> driver stress in jam situation or reduce gas consumption by
>> 'platooning'.
>>
>> In my oppinion, and this is why I forward it to this group,
>> establishing direct IP connections between vehicles may open paths
>> for exchanging IP data containing speed/location and trigger a
>> control process of adapting the speed.  One already controls
>> vehicles by sending IP data to them, from the infrastructure.  It
>> would be a simple matter for IP experts to send that same data
>> from other vehicle, without going to the infrastructure.
>>
>> Thoughts?
>>
>> Yours,
>>
>> Alex
>>
>
>
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 27 Oct 2014 14:06:07 +0100

Le 25/10/2014 01:45, John Kenney a écrit :
> Hi Alex,
> Thanks for sharing this.
>
> I think many of us in the DSRC/Cooperative ITS community consider these
> two applications to be a very natural fit for the technology.

Yes, these two applications (c-a speed control, platooning) are natural 
fits for the vehicle-to-vehicle kinds of communications.  Very little if 
at all fixed infrastructure is needed, it must be fast, and despite 
apparent high dynamicity (movements) the networking structure may be 
relatively stable.

> Furthermore, my expectation is that the applications can work well with
> one-hop V2V communication of the type that does not typically use IP.
> So, I don't see a benefit of including IP.  That doesn't mean it
> wouldn't work, but as you know the DSRC community generally plans to use
> a lighter weight protocol, WSMP, for applications that do not need IP.
> I expect ETSI will think along similar lines.

I know ETSI geonetworking and IEEE WSMP are protocols which may be used 
in vehicle-to-vehicle communications.  On another hand, I wonder whether 
an universally accepted protocol such as IP may not be preferrable at 
crossroads where incompatibilities seem to develop.

If IP paths are used, then the IP data can very well be WSMP data, or 
ETSI ITS ADU data, carried as UDP or other transport protocol of choice.

It would open doors not only to IEEE WSMP/ETSI ITS data, but also to the 
highly skilled application developper developping the next big thing in 
a garage.

Alex

> On Fri, Oct 24, 2014 at 8:16 AM, Alexandru Petrescu
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hello geonet/itsers,
>
>     ETSI ITS group is an SDO in Europe.  They produced many standards in
>     the past for vehicular communications, e.g. ETSI ITS geo-networking
>     among others.
>
>     would be a simple matter for IP experts to send that same data from
>     other vehicle, without going to the infrastructure.
>
>     Thoughts?
>
>     Yours,
>
>     Alex
>
>     _________________________________________________
>     its mailing list
>     https://www.ietf.org/mailman/__listinfo/its
>     <https://www.ietf.org/mailman/listinfo/its>
>
>
>
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 27 Oct 2014 15:50:04 +0100

Le 26/10/2014 00:53, Jean-Marie BONNIN a écrit :
>
>> Le 25 oct. 2014 à 01:49, Jong-Hyouk Lee <[email-masked]
>> <mailto:[email-masked]>> a écrit :
>>
>>
>> --
>>> On Oct 25, 2014, at 8:45 AM, John Kenney <[email-masked]
>>> <mailto:[email-masked]>> wrote:
>>>
>>> Hi Alex,
>>> Thanks for sharing this.
>>>
>>> I think many of us in the DSRC/Cooperative ITS community consider
>>> these two applications to be a very natural fit for the technology.
>>> Furthermore, my expectation is that the applications can work well
>>> with one-hop V2V communication of the type that does not typically
>>> use IP.  So, I don't see a benefit of including IP.  That doesn't
>>> mean it wouldn't work, but as you know the DSRC community generally
>>> plans to use a lighter weight protocol, WSMP, for applications that
>>> do not need IP.  I expect ETSI will think along similar lines.
>>
>> +1
>
> ETSI has planed to standardize these applications over G5 (IEEE
> 802.11p), but it could be very interesting to see if we can meet the
> requirement using IP instead of CAM messages directly over G5.

I agree, it would be interesting to see if we can meet these 
requirements by using IP: interesting from a purely technologial 
viewpoint, but also business and deployment points of view.

> My understanding is that using only one-hop v2v could be not sufficient
> in certain circonstances, when two lines of platooning vehicles have to
> merge for example, or more obviously when you have to be forwarded by
> the infrastructure to reach the next vehicle. In this last situation,
> you could use multi hop geo-routing or have a part of the application
> that run in the infrastructure.

I agree.

The initial step would be how to link only two vehicles together, by 
using a scalable IP-based technology.  More complex vehicle topologies 
(two lines joing, splitting) are certainly excellent challenges for IP 
network designers using tools such as loop avoidance, discovery, hop limits.

Alex

>>>     items called "Cooperative Cruise Control" and "Platooning".
>>>     These two applications make automobiles (and trucks) talk to each
>>>     other continuously to keep speed constant.  It helps relieve
>>>     automobile driver stress in jam situation or reduce gas
>>>     consumption by 'platooning'.
>>>
>>>     establishing direct IP connections between vehicles may open
>>>     paths for exchanging IP data containing speed/location and
>>>     trigger a control process of adapting the speed.  One already
>>>     controls vehicles by sending IP data to them, from the
>>>     infrastructure.  It would be a simple matter for IP experts to
> T四残om Bretagne <http://www.telecom-bretagne.eu> 	*Jean-Marie BONNIN*
> IRISA <http://www.irisa.fr> / UeB <http://www.ueb.eu>
> Site web <http://perso.telecom-bretagne.eu/jmbonnin> LinkedIn
> <http://fr.linkedin.com/pub/jean-marie-bonnin/0/991/285> RG
> <http://www.researchgate.net/profile/Jean-Marie_Bonnin>
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 27 Oct 2014 16:08:20 +0100

Dear Lei Chen,

Thank you for the reply.

Le 27/10/2014 14:03, Lei Chen a écrit :
> Dear all,
>
> Just a bit self introduction, we are working on the second edition of
> cooperative driving challenge (www.gcdc.net <http://www.gcdc.net>)
> and somehow we came across the same topics here.

GCDC is the same organization that issued the first freely available
802.11p driver?

> Thanks to Alex to bring this topic up, it is very relevant for the
> platoon applications.
>
> Basically, like Andras and John said, V2V through DSRC will be the
> first implementation for initial application of platooning.  IP will
>  most probably be used for Day2 applications that require more data
> communications, for example, video streaming between platoon vehicles
> or LDM.

[LDM?  (light-based communications, LiFi?)]

I am happy to see IP communications are considered, even that is in the
second day.  I personally do not worry very much of being maybe later,
because I think IP will support more applications, currently unspoken of.

> It seems ETSI does this with an adaption layer (EN302 636-6-1, TS102
>  636-6-1) for IPv6 to work with GeoNet.

Yes, there is an adaptation layer for IPv6 and geonet.  It may be highly
necessary in the initial steps of bringing IPv6 as close as possible to
the deployment.

IPv6-straight-over-80211p also uses an Adaptation Layer (the Ethernet 
Adaptation Layer used by 802.11b).

> Anyway, GeoNet seems to be in the protocol stack for C-ITS no matter
> what.

Thanks for the remark.  It is true that GeoNet of ETSI ITS is present
there but one should distinguish the cases where it is absolutely
necessary - something else can not do its role.  These cases are the
communications depending extensively on location: geo-dissemination, etc.

> If IPv6 is considered, then the transport layer will be TCP/UDP over
> IPv6 over GeoNet, though I am not sure about the protocol overhead.
> It is an interesting issue to investigate.

Yes, it is an issue to investigate.

At IETF there is a document called IPv6-over-80211p that I author.  The
ideas expressed in this document could be used in this investigation.
The document itself lacks certain aspects that anyone interested could
contribute.

> For platooning in Day1 applications, GeoNet (BTP and GeoNet for
> transport) over G5 maybe the most appropriate choice at the current
> stage because of the advantages of time delay.

Not sure what you mean by 'time delay'?

If you mean latency between vehicles, then I think 802.11p gives better
latency, in the order of tens of millseconds.

Or you mean that products implementing ETSI ITS GeoNet have a time
advantage being already there?  If so then I agree with you.

> We are looking at different implementations of GeoNet for potential
> deployment in GCDC. As we work towards Day2 applications, IPv6 is
> potentially considered. INRIA has been working on the implementation
> through CarGeo6. If you guys have more information about the
> implementation now, it is very appreciated that you share with us.

Sure, certainly.  I downloaded CarGeo6 and looked at the code.  I have 
the feeling that with it a car sends its position to another car.

At my place we have another implementation of exchanging IPv6 routing 
information over 802.11p.  We also have an update version of the 
original 802.11p GCDC driver for most recent linux kernels as well as 
other reliability improvements.

> Also, if you know teams that want to show their implementations of
> cooperative driving to the world, GCDC 2016 is the place to go. They
>  are free to contact us for registration or check www.gcdc.net
> <http://www.gcdc.net> for details.

YEs, this is a good announcement.  Please state here what are the 
participating conditions - is it free to join, what are the fees 
involved, in which country is it happening.

Alex

>
> Best regards, Lei
>
>
> *Lei Chen, PhD* Senior Researcher Cooperative Systems
>
>
>
> *Viktoria Swedish ICT AB* Lindholmspiren 3A SE-417 56 Göteborg,
> Sweden Tel: +46 76 777 1449 E-mail: [email-masked] <mailto:>
> www.viktoria.se <http://www.viktoria.se>
>
> Part of RISE
>
>> On 27 Oct 2014, at 12:22, Varadi , Andras (lesswire AG Ungarn)
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Dear Alex, John I agree with John, but would like to point out that
>> I think its likely that we will need to extend EU Geonetworking (EN
>> 302 636) to work over IP (e.g. LTE) links also. I think we will
>> have such requirements for EU Day2 or 3 (2^nd , Third generation
>> C-ITS) (example: update our Local Dynamic Map with a new Warning
>> message received over cellular connection (not G5/11p)) Üdvözlettel
>> / Best regards, András Váradi Project Manager – C2X/ITS Systems
>>
>> Automotive & WLAN Group lesswire Hungary***|***Office: +36 23521
>> 667***|***Email:[email-masked] <mailto:[email-masked]>
>> *From:*its [mailto:[email-masked]]*On Behalf Of*John Kenney
>> *Sent:*Saturday, October 25, 2014 1:45 AM *To:*Alexandru Petrescu
>> *Cc:[email-masked] <mailto:[email-masked]> *Subject:*Re: [geonet/its]
>>  FYI - ETSI ITS - work on cooperative cruise control, platooning Hi
>>  Alex, Thanks for sharing this. I think many of us in the
>> DSRC/Cooperative ITS community consider these two applications to
>> be a very natural fit for the technology. Furthermore, my
>> communication of the type that does not typically use IP.  So, I
>> don't see a benefit of including IP.  That doesn't mean it wouldn't
>> work, but as you know the DSRC community generally plans to use a
>> lighter weight protocol, WSMP, for applications that do not need
>> IP.  I expect ETSI will think along similar lines. Best Regards,
>> John -- John Kenney Principal Researcher Toyota InfoTechnology
>> Center, USA 465 Bernardo Avenue Mountain View, CA 94043 Tel:
>> 650-694-4160. Mobile: 650-224-6644 On Fri, Oct 24, 2014 at 8:16 AM,
>> Alexandru Petrescu <[email-masked]
>> <mailto:[email-masked]>> wrote: Hello geonet/itsers,
>>
>> _______________________________________________ its mailing list
>> _______________________________________________ its mailing list

---

From: Lei Chen <[email-masked]>
Date: Mon, 27 Oct 2014 18:30:57 +0100

Just want to mention that for GCDC 2016, any vendors that are willing to sponsor teams with OBUs or want to involve with the challenge are more than welcome. Please spread if possible. 

Thanks in advance.

Regards,
Lei

> On 27 Oct 2014, at 18:24, Lei Chen <[email-masked]> wrote:
> 
> Dear Alex,
> 
> Thanks very much for the detailed explanation and also the opportunity to share with our community about GCDC 2016. 
> 
> Please see the following for details.
> 
> Best regards,
> Lei
> 
>> On 27 Oct 2014, at 16:08, Alexandru Petrescu <[email-masked]> wrote:
>> 
>> Dear Lei Chen,
>> 
>> Thank you for the reply.
>> 
>   Last time, GCDC implemented 802.11p thanks to the work with Eric Koenders. 
> It is open-source, I hope that is the same one you are talking about. 
>> 
>   Sorry for that,  LDM = local dynamic map. Using DSRC and based on CAM messages, 
> LDM is able to be constructed, but if we consider more accurate and complex LDM for 
> environmental perception, I would say IP will be needed. 
> 
>> 
>> IPv6-straight-over-80211p also uses an Adaptation Layer (the Ethernet Adaptation Layer used by 802.11b).
>> 
> Absolutely agree! In general, for infotainment application or less time critical applications, IP network (LTE for example) 
> will be the best choice. However, for time critical applications or as you said, geo-dependent applications, 
> GeoNet over 802.11p may be necessary, at least for the near future applications. If we consider further with 5G, where the latency is 
> expected to be significantly reduced, I guess everything can be done through IP. But it is hard to draw conclusions about it 
> at the current stage. Anyway,I guess the cross-layer Decentralized Congestion Control (DCC) in C-ITS should be able
> to take care of this based on the QoS requirement at the application layer and direct the traffic to appropriate transport and access 
> methods, at least it is supposed to do this. 
> 
>   Thanks, I am checking with the document, I would say IPv6 over 802.11p is absolutely an option 
> and we are investigating the possibilities. I hope we can also contribute to this topic. 
> 
>> 
>   Yes, it is latency. 802.11p based access generally have better latency, and a light weight BTP&GeoNet 
> also contributes to the latency issue. I guess IP over 802.11p may achieve similar latency performance, though I need to check
> a bit more over that. As for IPv6 over GeoNet over 802.11p, as we already mentioned, the overhead is worth investigating 
> further. It is also one topic we will look at. 
> 
>> 
>> Sure, certainly.  I downloaded CarGeo6 and looked at the code.  I have the feeling that with it a car sends its position to another car.
>> 
>> At my place we have another implementation of exchanging IPv6 routing information over 802.11p.  We also have an update version of the original 802.11p GCDC driver for most recent linux kernels as well as other reliability improvements.
>> 
>   We are investigating CarGeo6 now. But it is very interesting you have an update version of the 802.11p protocol. I am not sure if you already make it open source or not. If so, it will be absolutely a great help for us to check the possibilities of applying IPv6 over 802.11p. Could you indicate me how and where I can check and then I can talk with my colleagues both at Viktoria and TNO for further discussions? If we prove the performance with IP over 802.11p during the challenge, I would say that will be a great contribution to C-ITS, at least for some part. Thanks very much beforehand:-)   
> 
>>> are free to contact us for registration or check www.gcdc.net <http://www.gcdc.net/>
>>> <http://www.gcdc.net <http://www.gcdc.net/>> for details.
>> 
>> YEs, this is a good announcement.  Please state here what are the participating conditions - is it free to join, what are the fees involved, in which country is it happening.
> 
> Thanks Alex, it is my pleasure to share with our community the announcement.    
> 
> GCDC2016, or i-GAME (www.gcdc.net <http://www.gcdc.net/>) is the second edition of GCDC based on its success in 2011 and with the purpose to accelerate cooperative driving through public challenge. GCDC2016 will mainly focus on the interoperability of communications, e.g. communications are vendor independent and teams are very welcome to implement based on different equipments from different vendors . However, the communications protocol will align to the latest C-ITS standards (Release 1) and potentially will contribute to Release 2. 
> 
> It is totally free to join the challenge and in addition to that, teams will get support from organizers (TNO and TU/e from holland, Viktoria Swedish ICT from Sweden and IDIADA from Spain). The final challenge will be Q2 2016 at the test site in Helmond in Holland, exactly the same test site as GCDC 2011. GCDC2016 have two challenge scenarios and one demo scenario. Challenge scenarios include both urban (intersection passing) and highway (platoon merge due to roadwork). Demo scenario is about emergency vehicle passing. All scenarios are defined to be close to reality and the implementations are also expected to be as close-to market as possible. We want to show the benefits of cooperative driving and also raise the awareness from both government and public.
> 
> The call on registrations is on-going. Notice that the registration is not binding at this stage. Teams can show interest and ask for further information and if possible, the organizers may help to assist to find partners. Teams are also very welcome to contribute to the implementation of communication protocols together with us. Just drop us emails :-)
> 
> For those who are interested, some general requirements are as follows,
> 	•A vehicle that will be fitted with the requirements
> 		•Minimum longitudinal automation
> 		•Interoperable V2X communication and interaction – will be tested both remotely online and physically at the challenge site
> 		•Drivers are in the vehicles, safety is critical
> 	•Drivers and support crew
> 	•Budget for travel, transport and subsistence
> 	•Taking part in preparative workshops and the rigorous functional testing before the challenge
> 	•Be ready by Spring 2016!
> 
> In return, the teams will get
> 	•Once in a lifetime opportunity to work with universities, OEMs and authorities to forward the state of cooperative autonomous driving
> 	•Get in contact with world class companies and people in this field
> 	•Collaborate at the forefront of standardization efforts
> 	•Help your institution learn and build its reputation
> 	•Win the challenge and eternal fame!
> 
> Just a video introduction of last time’s challenge (https://www.youtube.com/watch?v=lmRifLzw8iA <https://www.youtube.com/watch?v=lmRifLzw8iA>) for those who are interested. Teams now can register at www.gcdc.net <http://www.gcdc.net/> or contact the following people. 
> 
> 	For registration and team information:  [email-masked] <mailto:[email-masked]> (Laurens Schrijnemakers)
> 
> 	For project information and collaboration: [email-masked] <mailto:[email-masked]> (Sander Maas)    
> 
> We sincerely look forward for teams from all over the world to participate :)
> 
>> 
>> Alex
>> 
>>> 
>>> Best regards, Lei
>>> 
>>>

---

From: Lei Chen <[email-masked]>
Date: Mon, 27 Oct 2014 18:24:14 +0100

Dear Alex,

Best regards,
Lei

 

GCDC2016, or i-GAME (www.gcdc.net) is the second edition of GCDC based on its success in 2011 and with the purpose to accelerate cooperative driving through public challenge. GCDC2016 will mainly focus on the interoperability of communications, e.g. communications are vendor independent and teams are very welcome to implement based on different equipments from different vendors . However, the communications protocol will align to the latest C-ITS standards (Release 1) and potentially will contribute to Release 2. 

Just a video introduction of last time’s challenge (https://www.youtube.com/watch?v=lmRifLzw8iA) for those who are interested. Teams now can register at www.gcdc.net or contact the following people. 

	For registration and team information:  [email-masked] (Laurens Schrijnemakers)

	For project information and collaboration: [email-masked] (Sander Maas)

---

From: Lei Chen <[email-masked]>
Date: Mon, 27 Oct 2014 14:03:19 +0100

Dear all,

         Just a bit self introduction, we are working on the second edition of cooperative driving challenge (www.gcdc.net) and somehow we came across the same topics here. 

         Thanks to Alex to bring this topic up, it is very relevant for the platoon applications. 

         Basically, like Andras and John said, V2V through DSRC will be the first implementation for initial application of platooning.  IP will most probably be used for Day2 applications that require more data communications, for example, video streaming between platoon vehicles or LDM. It seems ETSI does this with an adaption layer (EN302 636-6-1, TS102 636-6-1) for IPv6 to work with GeoNet. Anyway, GeoNet seems to be in the protocol stack for C-ITS no matter what. If IPv6 is considered, then the transport layer will be TCP/UDP over IPv6 over GeoNet, though I am not sure about the protocol overhead. It is an interesting issue to investigate.

        For platooning in Day1 applications, GeoNet (BTP and GeoNet for transport) over G5 maybe the most appropriate choice at the current stage because of the advantages of time delay. We are looking at different implementations of GeoNet for potential deployment in GCDC. As we work towards Day2 applications, IPv6 is potentially considered. INRIA has been working on the implementation through CarGeo6. If you guys have more information about the implementation now, it is very appreciated that you share with us. 

        Also, if you know teams that want to show their implementations of cooperative driving to the world, GCDC 2016 is the place to go. They are free to contact us for registration or check www.gcdc.net for details. 

       Best regards,
Lei

Lei Chen, PhD
Senior Researcher Cooperative Systems

Viktoria Swedish ICT AB
Lindholmspiren 3A
SE-417 56 Göteborg, Sweden
Tel: +46 76 777 1449
E-mail: [email-masked] <mailto:>
www.viktoria.se <http://www.viktoria.se/>

Part of RISE

> On 27 Oct 2014, at 12:22, Varadi , Andras (lesswire AG Ungarn) <[email-masked]> wrote:
> 
> Dear Alex, John
>  
>      lesswire   Hungary | Office: +36 23521 667 | Email: [email-masked] <mailto:[email-masked]>
>