Subject: [geonet/its] Usage of LS packet

From: Devendra Naga C <[email-masked]>
Date: Wed, 24 Jun 2015 11:33:25 +0000

Hello,

This question is to understand the usage of the LS packet (Req and Reply) in the geo-networking protocol. As per my understanding these packets are useful in locating a geo-adhoc router that is not reachable by the geo-networking beacon.

1. How a geo-adhoc router finds the destination MID in the first place before sending an LS-Req ?

2. What makes a geo-adhoc router to find about the destination ?

3. What is the real world example of the LS-Req and LS-Rep packets? (Might be this relates to the second question)

Thank you.

Dev

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 24 Jun 2015 16:38:45 +0200

Le 24/06/2015 13:33, Devendra Naga C a écrit :
> Hello,
>
>
> This question is to understand the usage of the LS packet (Req and
> Reply) in the geo-networking protocol. As per my understanding these
> packets are useful in locating a geo-adhoc router that is not reachable
> by the geo-networking beacon.
>
>

I dont know, but here is my suggestion on how to do it.

Fit a webcam on the car, read the nearby car's license plate.  Find the 
correlation plate-VIN number on some database on the Internet.  Convert 
the VIN into a MID.

That is if you absolutely need a MID, and geo-networking protocol.

You can achieve the same effect differently: have everyone declare her 
presence with an IPv6 MLD Report message.  At that point every car knows 
each other's address.

> 2. What makes a geo-adhoc router to find about the destination ?

Sorry, repeat the question?

> 3. What is the real world example of the LS-Req and LS-Rep packets?
> (Might be this relates to the second question)

I think LS-Req/Rep stand for Link-State Request and Response?  If so, I 
suppose they are relics of OSPF inspiration of geo-aware manet protocols?

What does LS stand for?

What is the application you think about?  The use-case?

Alex

>
>
> Thank you.
>
> Dev
>
>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Devendra Naga C <[email-masked]>
Date: Wed, 24 Jun 2015 14:56:59 +0000

[Sorry about my email client-  it doesn't support inline replies, i had to add the '>' s]

Hello,

> presence with an IPv6 MLD Report message.  At that point every car knows

I am referring to the Location Service packet (aka the LS packet) of the Geo networking protocol defined in
ETSI EN 302-636-4-1 (v1.2.0). Sorry about not stating it clearly.

>From the document, The LS-Request packet is sent out from a host that does not have the destination information (such as its LPV) in the location service table (LocT). But if the vehicle is only equipped with a DSRC based device, how does it figures about what MID it has to send an LS-Request to ? or in an easier way to ask the question, does LS-Request is used to expand the coverage range of a DSRC device when in case of an alert or an advisory ?

> Sorry, repeat the question?

My apologies here again. The question is related to the similar concept of why a packet in the geo-networking needs to be
forwarded to a destination that is unknown to the geo-networking layer itself (because the destination is out of the range of the host vehicle).

> suppose they are relics of OSPF inspiration of geo-aware manet protocols?

I was referring about the Geo-networking standard ETSI EN 302-636-4-1.

> What does LS stand for?

Location Service

> What is the application you think about?  The use-case?

Its a stack that i am currently developing on the geo-networking using the above mentioned standard. That is the Geo-networking using the DSRC as a medium of communication in the Layer 2.

Thank you.
Dev

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 24 Jun 2015 17:46:46 +0200

Dont worry emailers - cite as you can.

Le 24/06/2015 16:56, Devendra Naga C a écrit :
>>> This question is to understand the usage of the LS packet (Req
>>> and Reply) in the geo-networking protocol. As per my
>>> understanding these packets are useful in locating a geo-adhoc
>>> router that is not reachable by the geo-networking beacon.
>>>
>>>
>> Fit a webcam on the car, read the nearby car's license plate.  Find
>> the correlation plate-VIN number on some database on the Internet.
>> Convert the VIN into a MID.
>
>> You can achieve the same effect differently: have everyone declare
>> her presence with an IPv6 MLD Report message.  At that point every
>> car knows each other's address.
>
> I am referring to the Location Service packet (aka the LS packet) of
> the Geo networking protocol defined in ETSI EN 302-636-4-1 (v1.2.0).
> Sorry about not stating it clearly.

Ok, for that to progress here you  will need to make that document into 
an Internet Draft.  Because we can't debug ETSI ITS documents here.

Can you write an Internet Draft
which describes ETSI EN 302-636-4-1 (v1.2.0)?

In that draft you can formulate that MID question more clearly.

>> From the document, The LS-Request packet is sent out from a host
>> that does not have the destination information (such as its LPV) in
>> the location service table (LocT). But if the vehicle is only
>> equipped with a DSRC based device, how does it figures about what
>> MID it has to send an LS-Request to ? or in an easier way to ask
>> the question, does LS-Request is used to expand the coverage range
>> of a DSRC device when in case of an alert or an advisory ?
>
> My apologies here again. The question is related to the similar
> concept of why a packet in the geo-networking needs to be forwarded
> to a destination that is unknown to the geo-networking layer itself
> (because the destination is out of the range of the host vehicle).

Ok, so I understand you know how to implement that forwarding but you 
dont have the MID.

I dont know how others find the MID?  I suppose it is often pre-encoded, 
known in advance.  This is acceptable in a laboratory or demo setting, 
but it is of course unacceptable in more mature deployments.

For that you will need to come up with a scheme to 'resolve' that 
initial MID.  Feel free to propose.

>
>> 3. What is the real world example of the LS-Req and LS-Rep
>> packets? (Might be this relates to the second question)
>
>> I think LS-Req/Rep stand for Link-State Request and Response?  If
>> so, I suppose they are relics of OSPF inspiration of geo-aware
>> manet protocols?
>

Ok, we need to be careful with this term.  Because Service Location 
Protocol (SLP) has a very well defined meaning at IETF, it's an RFC.

> Its a stack that i am currently developing on the geo-networking
> using the above mentioned standard. That is the Geo-networking using
> the DSRC as a medium of communication in the Layer 2.

What headers are used between the Geo-Networking headers and the DSRC 
headers?  (just use wireshark to find out, it's easy).

Alex

>
>
>> Alex
>
> Thank you. Dev
>
>>
>>
>> Thank you.
>>
>> Dev
>>
>>
>>
>> _______________________________________________ its mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/its
>>
>
> _______________________________________________ its mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/its
>
>