Subject: [geonet/its] Why not using IPv6 link local address for one hop V2V

From: Dapeng Liu <[email-masked]>
Date: Wed, 22 Jul 2015 13:30:04 +0200

Hello all,

During the noon discussion, we were discussing whether we can use IPv6 link
local address for one hop V-V IP communication.

One reason is that the vehicle that discover a neighbor with link local
IPv6 address can not distinguish whether that is another vehicle or it is a
smart phone in the car or it is a smart phone from road side passengers.

If we want to use IPv6 link local address, a dedicate prefix for V2V may
needed.

Any thoughts?

------
Best Regards,
Dapeng Liu

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 22 Jul 2015 14:37:13 +0200

Hi Dapeng,

YEs, during the bar bof discussion a couple of people agreed LL 
addresses may be sufficient.  A question was raised on whether or not 
the use of link-local addresses is enough to make vehicles in close 
range talk to each other in a 1-hop manner.

To clarify, the topology would be the following:

     ----       ----  LL   LL  ----       ----
    | H1 |-----| R1 |--o   o--| R2 |-----| H2 |
     ----       ----           ----       ----

R1 and R2 may be able to communicate to each other by using their LL 
addresses, but could H1 talk to H2?

H1, R1 are in car1, and H2, R2 are in car2.  H1 is the GPS data source 
and H2 is the GPS data receiver.  H1 needs to send the location data to 
H2, in order to inform the nearby vehicle about whether they can try to 
platoon themselves.

The GPS data could be any other app-level data, for example the output 
of the odometer (speed measurement), or a camera streaming an IP video.

To me, yes, LL addresses between R1 and R2 are sufficient, but they are 
not sufficient for communication between H1 and H2.

Dedicate prefix for V2V management?  Yes, why not, could be a good help 
in making addresses.  What do the other think?

Duplicate Address Detection taking too much time between R1 and R2? 
Maybe yes.  Maybe avoid it?

LL addresses using random MAC addresses?  Good idea for privacy, but 
maybe depends on the privacy concerns?  MAC address randomization impact 
on fast auto-configuration?  Are MAC addresses required by the law to be 
visible just like the license plates are?  Or are the MAC addresses more 
like the photo of the driver - private data accepted so by the government.

Alex

Le 22/07/2015 13:30, Dapeng Liu a écrit :
> Hello all,
>
> During the noon discussion, we were discussing whether we can use IPv6
> link local address for one hop V-V IP communication.
>
> IPv6 address can not distinguish whether that is another vehicle or it
> is a smart phone in the car or it is a smart phone from road side
> passengers.
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: "Huangjing (A)" <[email-masked]>
Date: Wed, 22 Jul 2015 13:11:13 +0000

Hi, Alexandru,

Not sure why H1 cannot communicate with H2, is it because they are out of range and need another node to forward/relay the message for them?
If this is the case, then I think this is multi-hop communication, rather 1-hop.

Random address generation may not be a good idea due to possible duplicated address.

James

> -----Original Message-----
> From: its [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
> Sent: Wednesday, July 22, 2015 8:37 PM
> To: [email-masked]
> Subject: Re: [geonet/its] Why not using IPv6 link local address for one hop V2V
> 
> Hi Dapeng,
> 
> YEs, during the bar bof discussion a couple of people agreed LL addresses may
> be sufficient.  A question was raised on whether or not the use of link-local
> addresses is enough to make vehicles in close range talk to each other in a
> 1-hop manner.
> 
> H1, R1 are in car1, and H2, R2 are in car2.  H1 is the GPS data source and H2
> is the GPS data receiver.  H1 needs to send the location data to H2, in order to
> inform the nearby vehicle about whether they can try to platoon themselves.
> 
> The GPS data could be any other app-level data, for example the output of the
> odometer (speed measurement), or a camera streaming an IP video.
> 
> To me, yes, LL addresses between R1 and R2 are sufficient, but they are not
> sufficient for communication between H1 and H2.
> 
> Dedicate prefix for V2V management?  Yes, why not, could be a good help in
> making addresses.  What do the other think?
> 
> visible just like the license plates are?  Or are the MAC addresses more like
> the photo of the driver - private data accepted so by the government.
> 
> Alex
> 
> > If we want to use IPv6 link local address, a dedicate prefix for V2V
> > may needed.
> >
> > Any thoughts?
> >
> >
> > ------
> > Best Regards,
> > Dapeng Liu
> >
> >

---

From: "Huangjing (A)" <[email-masked]>
Date: Wed, 22 Jul 2015 13:16:45 +0000

Hi, Dapeng,

Maybe we can distinguish a vehicle from a mobile by other means, rather than IP prefix / address.
For message broadcast (e.g. safety related message), we may require a dedicated multicast address; for Unicast communication, I think we should make use of higher level information, such as TCP/UDP(or similar one) port or application level information

Any thoughts?

James

From: its [mailto:[email-masked]] On Behalf Of Dapeng Liu
Sent: Wednesday, July 22, 2015 7:30 PM
To: [email-masked]
Subject: [geonet/its] Why not using IPv6 link local address for one hop V2V

Hello all,

During the noon discussion, we were discussing whether we can use IPv6 link local address for one hop V-V IP communication.

One reason is that the vehicle that discover a neighbor with link local IPv6 address can not distinguish whether that is another vehicle or it is a smart phone in the car or it is a smart phone from road side passengers.

If we want to use IPv6 link local address, a dedicate prefix for V2V may needed.

Any thoughts?

------
Best Regards,
Dapeng Liu

---

From: Dapeng Liu <[email-masked]>
Date: Wed, 22 Jul 2015 16:14:22 +0200

Sure. My point is we can not just use IPv6 link local address to fulfill
the requirement.  agree?

Thanks,
Dapeng Liu

2015-07-22 15:16 GMT+02:00 Huangjing (A) <[email-masked]>:

> For message broadcast (e.g. safety related message), we may require a
> dedicated multicast address; for Unicast communication, I think we should
> make use of higher level information, such as TCP/UDP(or similar one) port
> or application level information
>
>
>
> Any thoughts?
>
>
>
> James
>
>
>
> *From:* its [mailto:[email-masked]] *On Behalf Of *Dapeng Liu
> *Sent:* Wednesday, July 22, 2015 7:30 PM
> *To:* [email-masked]
> *Subject:* [geonet/its] Why not using IPv6 link local address for one hop
> V2V
>
>
>
> Hello all,
>
>
>

-- 

------
Best Regards,
Dapeng Liu

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 22 Jul 2015 16:47:10 +0200

I tend to agree.  Just that I dont think we need another kind of addresses.

In other words: yes, just using LL addresses to realize V2V 
communication is not enough.  no, in that messages between routers can 
be sourced just by their link-local addresses.

Or maybe a prefix between vehicles would be needed.

The creation of IP addresses _inside_ vehicles is currently a problem as 
well.

Alex

Le 22/07/2015 16:14, Dapeng Liu a écrit :
> 2015-07-22 15:16 GMT+02:00 Huangjing (A) <[email-masked]
> <mailto:[email-masked]>>:
>
>     Hi, Dapeng,____
>
>     __ __
>
>     Maybe we can distinguish a vehicle from a mobile by other means,
>     rather than IP prefix / address.____
>
>     For message broadcast (e.g. safety related message), we may require
>     a dedicated multicast address; for Unicast communication, I think we
>     should make use of higher level information, such as TCP/UDP(or
>     similar one) port or application level information____
>
>     __ __
>
>     Any thoughts?____
>
>     __ __
>
>     James____
>
>     __ __
>
>     *From:*its [mailto:[email-masked]
>     <mailto:[email-masked]>] *On Behalf Of *Dapeng Liu
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Subject:* [geonet/its] Why not using IPv6 link local address for
>     one hop V2V____
>
>     __ __
>
>     Hello all,____
>
>     __ __
>
>     During the noon discussion, we were discussing whether we can use
>     IPv6 link local address for one hop V-V IP communication.____
>
>     __ __
>
>     One reason is that the vehicle that discover a neighbor with link
>     local IPv6 address can not distinguish whether that is another
>     vehicle or it is a smart phone in the car or it is a smart phone
>     from road side passengers.
>     ____
>
>     __ __
>
>     may needed.____
>     __ __
>     Any thoughts?____
>     __ __
>     Dapeng Liu____

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 22 Jul 2015 16:57:58 +0200

One has to think these vehicles approach and their Routers (R1, R2) are 
reachable to each other, on their egress 802.11p interfaces.

But the Hosts inside each vehicle (H1 and H2) can not see each other, 
simple because they have Ethernet cable interfaces (not 802.11p).

        Ethernet        11p        Ethernet

Between H1 and H2 there are indeed 2 IP hops (R1 and R2).

But the range of action of protocols we would like to concentrate on is 
the hop between vehicles.  And use existing protocols on the hop 
_inside_ the vehicle.

R1 and R2 should do something simple between them, on that single 1-hop, 
such that H1 and H2 can talk to each other, even though H1 and H2 may be 
separated by 2 or more IP hops.

The structure inside each vehicle is relatively stable, there is no 
mobility.

The structure between vehicles is highly dynamic, but they are all 
neighbors in IP terms.

Alex

Le 22/07/2015 15:11, Huangjing (A) a écrit :
>>> local

---

From: Rex Buddenberg <[email-masked]>
Date: Wed, 22 Jul 2015 09:25:10 -0700

The problem with physical (as opposed to logical) 'v-v' connection is
that you have good probability of not reaching the vehicles you need to
reach most.  Like crossing traffic where the RF path is blocked by a
building.  
     Organizing unicast groups seems to me to be the logical way out.
The group membership is likely to be very dynamic.

On Wed, 2015-07-22 at 13:30 +0200, Dapeng Liu wrote:
> local IPv6 address can not distinguish whether that is another vehicle
> or it is a smart phone in the car or it is a smart phone from road
> side passengers.  
> 
>

---

From: Dapeng Liu <[email-masked]>
Date: Thu, 23 Jul 2015 01:05:01 +0200

OK. That comes to the question: should we use IP for one hop V2V. I guess
Alex have posted a picture to explain the scenario why IP is needed..

Thanks,
Dapeng Liu

2015-07-23 0:33 GMT+02:00 Richard Roy <[email-masked]>:

> The real question is not "can we use IPv6 for single-hop communications?",
> the real question is "should we use a network protocol for single-hop
> communications when it is really a link-layer issue?"  I think most people
> would say "IPv6 is not necessary; MAC bridging at the data link layer is
> more than enough for this situation".
>
> IPv6 carries an overhead (>39 bytes) that V2V comms, especially on the
> crowded safety channel, do not need.
>
> Cheers,
>
> RR
>
> > From: Rex Buddenberg [mailto:[email-masked]]
> > Sent: Wednesday, July 22, 2015 9:25 AM
> > To: Dapeng Liu
> > Cc: [email-masked]
> > Subject: Re: [geonet/its] Why not using IPv6 link local address for one
> > hopV2V
> >

-- 

------
Best Regards,
Dapeng Liu

---

From: Dapeng Liu <[email-masked]>
Date: Thu, 23 Jul 2015 14:25:16 +0200

This one:
https://mailarchive.ietf.org/arch/msg/its/APoKCskywm6sEVSo2g7RjuRH15E

2015-07-23 1:29 GMT+02:00 Richard Roy <[email-masked]>:

>
>
>
>   ------------------------------
>
> *From:* Dapeng Liu [mailto:[email-masked]]
> *Sent:* Wednesday, July 22, 2015 4:05 PM
> *To:* [email-masked]
> *Cc:* Rex Buddenberg; [email-masked]
> *Subject:* Re: [geonet/its] Why not using IPv6 link local address for one
> hopV2V
>
>
>
> *[RR>] Not sure I've seen that posting.  Perhaps Alex could re-post it??*
>
>
>
> Thanks,
>
> Dapeng Liu
>
>
>

-- 

------
Best Regards,
Dapeng Liu

---

From: "Huangjing (A)" <[email-masked]>
Date: Fri, 24 Jul 2015 10:41:51 +0000

Agree, link local address is not sufficient for V2V communication.
But, if we consider only 1-hop communication, it is probably sufficient.

James

> Sent: Wednesday, July 22, 2015 10:47 PM
> To: [email-masked]
> In other words: yes, just using LL addresses to realize V2V communication is
> not enough.  no, in that messages between routers can be sourced just by
> their link-local addresses.
> 
> The creation of IP addresses _inside_ vehicles is currently a problem as well.
> 
> Alex
> 
> > Sure. My point is we can not just use IPv6 link local address to
> > fulfill the requirement.  agree?
> >
> > Thanks,
> > Dapeng Liu
> >

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 24 Jul 2015 21:09:24 +0200

Maybe the terminology should change from 1-hop to 1-variable-hop and n 
stable hops (the Ethernets in the cars).

Not sure what name to give to this: n-stable-hops plus 1 variable hop.

That's the structure in V2V.

Alex

---

From: Jean-Marie BONNIN <[email-masked]>
Date: Fri, 24 Jul 2015 22:50:05 +0200

Hi Dick

If an application always need only one hop and it is alway deployed in the same manner in the car, probably we can use only link layer technologies to address and transport application data. But the same application could some time use one-hop and another time use multi-hop communications … of course we could manage this in an intermediate layer such as the ETSI facilities but it becomes more complex. It could be simpler for the applications to always use IP. 

If the concern is just about the overhead due to the IP header, is could be reduce a lot using header compression technics. 

JM

> Le 24 juil. 2015 à 21:09, Alexandru Petrescu <[email-masked]> a écrit :
> 
> Maybe the terminology should change from 1-hop to 1-variable-hop and n stable hops (the Ethernets in the cars).
> 

----------------------------
Prof. Jean-Marie BONNIN
Institut Mines Télécom / Télécom Bretagne
IRISA / D2 / OCIF
Head of Telecom Bretagne / RSM department (Network, Security and Multimedia)
Head of IRISA / D2 (Network, Telecommunication and Services)
Mob: +33 660 767 976

---

From: Rex Buddenberg <[email-masked]>
Date: Fri, 24 Jul 2015 16:39:21 -0700

In line, then comments:

On Fri, 2015-07-24 at 22:50 +0200, Jean-Marie BONNIN wrote:
> Hi Dick
> 
> 
> If an application always need only one hop and it is alway deployed in
> the same manner in the car, probably we can use only link layer
> technologies to address and transport application data. 

That's what the non-IP stack in IEEE 1609 is trying to do.  

> But the same application could some time use one-hop and another time
> use multi-hop communications … of course we could manage this in an
> intermediate layer such as the ETSI facilities but it becomes more
> complex. It could be simpler for the applications to always use IP. 

It is simpler, but there's a much more compelling reason: security.

First, understand that the notion of single-hop is fiction.  
  - the other automobile that you want to communicate with is one you
can't see (cross-traffic, blocked by a building ... he's about to t-bone
you).  
  - we always have three hops in the simplest topology -- local comms
within each automobile plus a radio hop.  There's a bunch of denial
going on ... the two sides of the argument can be stereotyped into the
"IoT' faction and the 'gateway faction'.  The gateway group tries to
deny the multiple hop characteristic, but it doesn't work.

The highjacked Jeep conversation shows the fallacy of the gateway
problem: you need end-to-end authenticity and gateways can't deliver it.

> 
> 
> If the concern is just about the overhead due to the IP header, is
> could be reduce a lot using header compression technics. 

Agreed.  But this is a minor point.  Get the end-end delivery of
authenticity in the center of the target.
> > Maybe the terminology should change from 1-hop to 1-variable-hop and
> > n stable hops (the Ethernets in the cars).
> > 
> > > > communication is