Subject: Re: [geonet/its] Why not using IPv6 link local address for one hopV2V

From: Jérôme Härri <[email-masked]>
Date: Thu, 23 Jul 2015 10:35:11 +0200

Hi Dapeng,

To the risk of mentioning it again (Dick and I had a same discussion in this ITS group around the same time last  year, please see the logs) and again still agree with his statement below, the true question is indeed not if we should use IP for one-hop V2V, but also which application would need to have a 1-hop V2V in IPv6. 

Both ETSI and IEEE do not rely on IP for 1-hop V2V for safety-related communications, as simply stated: it is not required, period. 

IP is necessary for interoperability and global connectivity. So, this group should describe which applications would require either interoperability between different technologies and/or global connectivity (to the cloud, between vehicles over the cloud), and which would require direct V2V communication (which would not be done better via the cloud/backend). 

Once we have such description, then we can discuss if we need IPv6 for V2V and how to make it happen.

There could be some of these applications, e.g. proximity/social networking (unsupervised LTE D2D, maybe WiFi direct, etc..), cellular traffic offloading, to name a few…but we should really take the debate from the right end.

My two cents…

Cheers,

Jérôme

--------------------------------------------------------------

Dr. habil Jérôme Härri

Tenured Assistant Professor

Wireless Vehicular Networks

Description: Description : EURECOM_20ANS_FR_50

EURECOM

2229 Route des Crêtes - BP193

06904 SOPHIA ANTIPOLIS CEDEX

----------------------------------------------------------------------------

From: its [mailto:[email-masked]] On Behalf Of Dapeng Liu
Sent: Thursday 23 July 2015 01:05
To: [email-masked]
Cc: Rex Buddenberg; [email-masked]
Subject: Re: [geonet/its] Why not using IPv6 link local address for one hopV2V

OK. That comes to the question: should we use IP for one hop V2V. I guess Alex have posted a picture to explain the scenario why IP is needed..

Thanks,

Dapeng Liu

2015-07-23 0:33 GMT+02:00 Richard Roy <[email-masked]>:

The real question is not "can we use IPv6 for single-hop communications?",
the real question is "should we use a network protocol for single-hop
communications when it is really a link-layer issue?"  I think most people
would say "IPv6 is not necessary; MAC bridging at the data link layer is
more than enough for this situation".

IPv6 carries an overhead (>39 bytes) that V2V comms, especially on the
crowded safety channel, do not need.

Cheers,

RR

> -----Original Message-----
> From: Rex Buddenberg [mailto:[email-masked]]
> Sent: Wednesday, July 22, 2015 9:25 AM
> To: Dapeng Liu
> Cc: [email-masked]
> Subject: Re: [geonet/its] Why not using IPv6 link local address for one
> hopV2V
>
> The problem with physical (as opposed to logical) 'v-v' connection is
> that you have good probability of not reaching the vehicles you need to
> reach most.  Like crossing traffic where the RF path is blocked by a
> building.
>      Organizing unicast groups seems to me to be the logical way out.
> The group membership is likely to be very dynamic.
>
> On Wed, 2015-07-22 at 13:30 +0200, Dapeng Liu wrote:
> > Hello all,
> >
> >
> > During the noon discussion, we were discussing whether we can use IPv6
> > link local address for one hop V-V IP communication.
> >
> >
> > One reason is that the vehicle that discover a neighbor with link
> > local IPv6 address can not distinguish whether that is another vehicle
> > or it is a smart phone in the car or it is a smart phone from road
> > side passengers.
> >
> >
> > If we want to use IPv6 link local address, a dedicate prefix for V2V
> > may needed.
> >
> >
> > Any thoughts?
> >
> >
> > ------
> > Best Regards,
> > Dapeng Liu
> > _______________________________________________
> > its mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/its
>
>

-- 

------
Best Regards,
Dapeng Liu

---

From: [email-masked]
Date: Thu, 23 Jul 2015 04:20:26 -0700 (PDT)

Thanks for the comment， I agree with this approach.

Regards，
Dapeng Liu

—
通过 Mailbox 发送

On Thu, Jul 23, 2015 at 10:43 AM, Richard Roy <[email-masked]>
wrote:

> Thanks Jerome.  I could not have stated it better!
>  
> RR
>  
>   _____  
> From: Jérôme Härri [mailto:[email-masked]] 
> Sent: Thursday, July 23, 2015 1:35 AM
> To: 'Dapeng Liu'; [email-masked]
> Cc: 'Rex Buddenberg'; [email-masked]
> Subject: RE: [geonet/its] Why not using IPv6 link local address for one
> hopV2V
>  
> Hi Dapeng,
>  
> To the risk of mentioning it again (Dick and I had a same discussion in this
> ITS group around the same time last  year, please see the logs) and again
> still agree with his statement below, the true question is indeed not if we
> should use IP for one-hop V2V, but also which application would need to have
> a 1-hop V2V in IPv6. 
>  
> Both ETSI and IEEE do not rely on IP for 1-hop V2V for safety-related
> communications, as simply stated: it is not required, period. 
>  
> IP is necessary for interoperability and global connectivity. So, this group
> should describe which applications would require either interoperability
> between different technologies and/or global connectivity (to the cloud,
> between vehicles over the cloud), and which would require direct V2V
> communication (which would not be done better via the cloud/backend). 
>  
> There could be some of these applications, e.g. proximity/social networking
> (unsupervised LTE D2D, maybe WiFi direct, etc..), cellular traffic
> offloading, to name a fewbut we should really take the debate from the
> right end.
>  
> My two cents
>  
> Cheers,
>  
> Jérôme
>  
>  
> OK. That comes to the question: should we use IP for one hop V2V. I guess
> Alex have posted a picture to explain the scenario why IP is needed..
>  
> Thanks,
> Dapeng Liu
>