Subject: [its] Comments about Mobile IP

From: Charlie Perkins <[email-masked]>
Date: Thu, 21 Jul 2016 08:30:19 -0700

Hello Dino and all,

I wanted to mention that Fast Mobile IP does a pretty good job of not 
losing packets.  Plus there has been a lot of work in SDOs that I am 
familiar with (3GPP, IEEE, IETF) for fast handovers. The technique of 
geocasting duplicates to neighboring road-side stations is related to 
quite many published approaches using bicasting and multicasting.  This 
amounts to a tradeoff between contol signaling versus data duplication.  
Data duplication is probably more likely to increase interference during 
traffic jams or (worse) emergency situations.

Treating roadway mobility management by "one-dimensional" routing 
protocols is also a cool idea that has received attention at various 
vehicular networking conferences.  Multi-lane roadways and intersections 
have interesting implications on such related approaches.  Also, I 
reckon we ought to consider multi-radio vehicles.

Predictive approaches have been thoroughly explored and can be 
surprisingly effective.  Surprisingly good, but not good enough to avoid 
frequent annoyance.  I reckon they have a very good place as part of a 
hybrid approach -- but then we have more complicated signaling.  But 
more signaling is good if it produces smoother handovers.

I think it would be very interesting to explore a mutually constructive 
approach with Mobile IP and LISP, especially adapting the ideas of Fast 
Mobile IP as mentioned above.  Some of the current approaches for 
distributed anchoring as discussed in [dmm] may also find beneficial 
application.

Regards,
Charlie P.

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Thu, 21 Jul 2016 15:38:28 +0000

ICN techniques may eventually be a good fit due to sort of built-in
multicast or local broadcast as well as multi-homed radio systems.
Depending on the radio system, local broadcast is a natural.  LTE, not so
much.

Will

On 7/21/16, 11:30 AM, "its on behalf of Charlie Perkins"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>its mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/its

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 21 Jul 2016 15:51:48 -0700

> I wanted to mention that Fast Mobile IP does a pretty good job of not losing packets.  Plus there has been a lot of work in SDOs that I am familiar with (3GPP, IEEE, IETF) for fast handovers. The technique of geocasting duplicates to neighboring road-side stations is related to quite many published approaches using bicasting and multicasting.  This amounts to a tradeoff between contol signaling versus data duplication.  Data duplication is probably more likely to increase interference during traffic jams or (worse) emergency situations.

Thanks for the reference Charlie. Glad to know our approach is not new.

Has these approaches optimized the routing system at the same as providing multi-homing (not just multi-homing to the hand-sets but to the RSUs)?

> Treating roadway mobility management by "one-dimensional" routing protocols is also a cool idea that has received attention at various vehicular networking conferences.  Multi-lane roadways and intersections have interesting implications on such related approaches.  Also, I reckon we ought to consider multi-radio vehicles.

Maybe, but that makes the problem more complicated. That is, if you don’t want duplicates to go to the end-system.

> Predictive approaches have been thoroughly explored and can be surprisingly effective.  Surprisingly good, but not good enough to avoid frequent annoyance.  I reckon they have a very good place as part of 

What is the frequent annoyance? Can you explain in detail?

> a hybrid approach -- but then we have more complicated signaling.  But more signaling is good if it produces smoother handovers.

I think background signaling is fine, if needed, but as long as it is in the background and doesn’t have a fast handoff time budget.

> I think it would be very interesting to explore a mutually constructive approach with Mobile IP and LISP, especially adapting the ideas of Fast Mobile IP as mentioned above.  Some of the current approaches for distributed anchoring as discussed in [dmm] may also find beneficial application.

Sure, I think LISP can bring a scalable mapping database control plane to the table and a core route reduction benefit with an overlay. How would you complement this with Mobile-IP?

> Charlie P.

Thanks for the email.

Dino