Subject: [its] V2P - potentially large use case for IPv6 within the DSRC infrastructure

From: Robert Moskowitz <[email-masked]>
Date: Thu, 21 Jul 2016 13:26:21 +0200

I have seen a number of DSRC/WAVE demonstrations with cell phones being 
part of the network for pedestrians and bicycles.  Honda also showed it 
for motorcycles, but future motorcycles can have an embedded DSRC device 
connected to the bike's CANbus for better information.

The concern here is that DSRC is already quite congested in many areas 
where there are pedestrians and in places near mass-transit access, and 
pdestrians walking all over the place, how could a car listen to all the 
phones chirping away?

Add to this the regulatory challenge of yet another radio on the 
phones.  Qualcomm has demonstrated a duo radio with standard WiFi and 
DSRC, but many just change the radio, switch from the WiFi bands to the 
11p bands and switch back and that has serious performance concerns.

So let's keep the phones on IP and route the WAVE messages over IP 
to/from the phones.  This would use Infrastructure components like 
traffic lights as the relays.

There is the security question in that is the 1609.2 certificate that of 
the phone's or the infrastructure piece?  In the former case, the PKI 
proposal from CAMP would have major challenges scaling that large.  Of 
course the counter proposal Verizon submitted ;) could scale up to certs 
for all the phones.   If the signing is done by the infrastructure cert 
which is not a anonymous cert (like in the vehicles), does this present 
any privacy issues for the phone holder?  Probably not.

But a real potential use case.

Bob Moskowitz

---

From: William Whyte <[email-masked]>
Date: Thu, 21 Jul 2016 07:42:58 -0400

Hi Bob,

Who did Verizon submit that "counter proposal" to and is it available
publicly? I don't remember seeing a specific proposal in the 1609 working
group, or, to be honest, anywhere.

Cheers,

William

On Thu, Jul 21, 2016 at 7:26 AM, Robert Moskowitz <[email-masked]>
wrote:

> part of the network for pedestrians and bicycles.  Honda also showed it for
> motorcycles, but future motorcycles can have an embedded DSRC device
> Add to this the regulatory challenge of yet another radio on the phones.
> Qualcomm has demonstrated a duo radio with standard WiFi and DSRC, but many
> just change the radio, switch from the WiFi bands to the 11p bands and
> switch back and that has serious performance concerns.
>
>
> So let's keep the phones on IP and route the WAVE messages over IP to/from
> the phones.  This would use Infrastructure components like traffic lights
> as the relays.
>
>
> which is not a anonymous cert (like in the vehicles), does this present any
> privacy issues for the phone holder?  Probably not.
>
>
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 21 Jul 2016 13:47:21 +0200

It was submitted to the CAMP pilot RFI.  I wrote it with Robert Hopley 
over at Verizon, remember him?

It was a very similar PKI, but turned a lot of pieces around to work 
with phones as clients.  The RFI said it was open to other proposals, 
they responded to Verizon that they really did not want any other 
approaches.

I do not have it.  Contact Hopley at Verizon and perhaps he can get it 
to you.

On 07/21/2016 01:42 PM, William Whyte wrote:
> publicly? I don't remember seeing a specific proposal in the 1609 
> working group, or, to be honest, anywhere.
>
> Cheers,
>
> William
>
>
> On Thu, Jul 21, 2016 at 7:26 AM, Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I have seen a number of DSRC/WAVE demonstrations with cell phones
>     being part of the network for pedestrians and bicycles. Honda also
>     showed it for motorcycles, but future motorcycles can have an
>     embedded DSRC device connected to the bike's CANbus for better
>     information.
>
>
>     The concern here is that DSRC is already quite congested in many
>     areas where there are pedestrians and in places near mass-transit
>     access, and pdestrians walking all over the place, how could a car
>     listen to all the phones chirping away?
>
>
>     phones.  Qualcomm has demonstrated a duo radio with standard WiFi
>     and DSRC, but many just change the radio, switch from the WiFi
>     bands to the 11p bands and switch back and that has serious
>     performance concerns.
>
>
>     There is the security question in that is the 1609.2 certificate
>     that of the phone's or the infrastructure piece?  In the former
>     case, the PKI proposal from CAMP would have major challenges
>     scaling that large.  Of course the counter proposal Verizon
>     submitted ;) could scale up to certs for all the phones.   If the
>     signing is done by the infrastructure cert which is not a
>     anonymous cert (like in the vehicles), does this present any
>     [email-masked] <mailto:[email-masked]>

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Thu, 21 Jul 2016 20:50:59 +0900

Thx for arising a V2P scenario. If possible, can you give the pointer? 
--
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random
Protocol Engineering Lab., Sangmyung University

#email: [email-masked]
#webpage: https://sites.google.com/site/hurryon

> On Jul 21, 2016, at 8:47 PM, Robert Moskowitz <[email-masked]> wrote:
> 
> It was submitted to the CAMP pilot RFI.  I wrote it with Robert Hopley over at Verizon, remember him?
> 
> 
> It was a very similar PKI, but turned a lot of pieces around to work with phones as clients.  The RFI said it was open to other proposals, they responded to Verizon that they really did not want any other approaches.
> 
> I do not have it.  Contact Hopley at Verizon and perhaps he can get it to you.
> 
>> Who did Verizon submit that "counter proposal" to and is it available publicly? I don't remember seeing a specific proposal in the 1609 working group, or, to be honest, anywhere.
>> 
>> Cheers,
>> 
>> William
>> 
>> 
>> On Thu, Jul 21, 2016 at 7:26 AM, Robert Moskowitz <[email-masked] <mailto:[email-masked]>> wrote:
>> I have seen a number of DSRC/WAVE demonstrations with cell phones being part of the network for pedestrians and bicycles.  Honda also showed it for motorcycles, but future motorcycles can have an embedded DSRC device connected to the bike's CANbus for better information.
>> 
>> 
>> The concern here is that DSRC is already quite congested in many areas where there are pedestrians and in places near mass-transit access, and pdestrians walking all over the place, how could a car listen to all the phones chirping away?
>> 
>> 
>> Add to this the regulatory challenge of yet another radio on the phones.  Qualcomm has demonstrated a duo radio with standard WiFi and DSRC, but many just change the radio, switch from the WiFi bands to the 11p bands and switch back and that has serious performance concerns.
>> 
>> 
>> So let's keep the phones on IP and route the WAVE messages over IP to/from the phones.  This would use Infrastructure components like traffic lights as the relays.
>> 
>> 
>> There is the security question in that is the 1609.2 certificate that of the phone's or the infrastructure piece?  In the former case, the PKI proposal from CAMP would have major challenges scaling that large.  Of course the counter proposal Verizon submitted ;) could scale up to certs for all the phones.   If the signing is done by the infrastructure cert which is not a anonymous cert (like in the vehicles), does this present any privacy issues for the phone holder?  Probably not.
>> 
>> 
>> https://www.ietf.org/mailman/listinfo/its <https://www.ietf.org/mailman/listinfo/its>
>> 
>

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 21 Jul 2016 13:56:03 +0200

Much of it was at ITS World Congress back in 2014 in Detroit.  I had a 
number of meetings with Honda on their prototypes.   They were using a 
Nexus phone that Qualcomm had hacked the 11a radio to work for 11p.

CAMP may have some internal documents.  I can probably reach out to the 
Honda people after the 802 meeting if no one else here can point to any 
published work.

On 07/21/2016 01:50 PM, Jong-Hyouk Lee wrote:
> #email: [email-masked] <mailto:[email-masked]>
>> On Jul 21, 2016, at 8:47 PM, Robert Moskowitz 
>>> Who did Verizon submit that "counter proposal" to and is it 
>>> available publicly? I don't remember seeing a specific proposal in 
>>> the 1609 working group, or, to be honest, anywhere.
>>>
>>> Cheers,
>>>
>>> William
>>>
>>>
>>>     I have seen a number of DSRC/WAVE demonstrations with cell
>>>     phones being part of the network for pedestrians and bicycles. 
>>>     Honda also showed it for motorcycles, but future motorcycles can
>>>     have an embedded DSRC device connected to the bike's CANbus for
>>>     better information.
>>>
>>>
>>>     areas where there are pedestrians and in places near
>>>     mass-transit access, and pdestrians walking all over the place,
>>>     how could a car listen to all the phones chirping away?
>>>
>>>
>>>     phones.  Qualcomm has demonstrated a duo radio with standard
>>>     WiFi and DSRC, but many just change the radio, switch from the
>>>     WiFi bands to the 11p bands and switch back and that has serious
>>>     performance concerns.
>>>
>>>
>>>     So let's keep the phones on IP and route the WAVE messages over
>>>     IP to/from the phones.  This would use Infrastructure components
>>>     like traffic lights as the relays.
>>>
>>>
>>>     submitted ;) could scale up to certs for all the phones.   If
>>>     the signing is done by the infrastructure cert which is not a

---

From: Thierry Ernst - Bis <[email-masked]>
Date: Tue, 26 Jul 2016 14:56:22 +0200

Dear all,

There is a number of standards well advanced at ISO TC204 within WG17 (nomadic devices) addressing the situation where a nomadic device (presumably a smart phone) could access to the vehicle information via a in-vehicle router (gateway between the outside world and the in-vehicle network). 

For safety related messages, IP and non-IP can be used alternatively depending on the type of messages, the transmission range (direct communication vs via the cloud, broadcast vs pt-to-pt, 1 hop vs multi-hop, …), the available radio access technologies and capabilities of the ITS station. There are indeed much more situations where IPv6 will be used rather than vehicular WIFI *, although what is being tested in safety pilots in Europe and US is mostly (exclusively?) non-IP. For the time being (and this is why a standard defining the use of IPv6 for vehicular WIFI is needed). 

The connectivity provided by the nomadic device would probably not be used for V2X safety messages unless:
- the vehicle is not equipped with an in-vehicle router
- the in-vehicle router is unable or is not equipped with access technologies other than 11p (safety channel)

In any case, the ITS station architecture (ISO 21217) allows both possibilities. However, transmission of safety related messages by the nomadic device would require the nomadic device to be trusted (the nomadic device must be part of the trusted vehicle domain).

* vehicular WIFI = IEEE 802.11p variants =>  ITS-G5 in Europe or WAVE/DSRC for US - but be aware that for European DSRC has another meaning => CEN DSRC is 5.8 GHz and used mainly for road tolling). 

Regards,
Thierry Ernst.

> Le 21 juil. 2016 à 13:56, Robert Moskowitz <[email-masked]> a écrit :
> 
> Much of it was at ITS World Congress back in 2014 in Detroit.  I had a number of meetings with Honda on their prototypes.   They were using a Nexus phone that Qualcomm had hacked the 11a radio to work for 11p.
> 
> 
> CAMP may have some internal documents.  I can probably reach out to the Honda people after the 802 meeting if no one else here can       point to any published work.
> 
>> #webpage: https://sites.google.com/site/hurryon <https://sites.google.com/site/hurryon>
>>> On Jul 21, 2016, at 8:47 PM, Robert Moskowitz <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> On Thu, Jul 21, 2016 at 7:26 AM, Robert Moskowitz < <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>> wrote:

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 26 Jul 2016 16:57:41 +0200

Hi Thierry,

Thank you for the message.

Le 26/07/2016 à 14:56, Thierry Ernst - Bis a écrit :
>
> Dear all,
>
> There is a number of standards well advanced at ISO TC204 within
> WG17 (nomadic devices) addressing the situation where a nomadic
> device (presumably a smart phone) could access to the vehicle
> information via a in-vehicle router (gateway between the outside
> world and the in-vehicle network).
>
> For safety related messages, IP and non-IP can be used alternatively
> depending on the type of messages, the transmission range (direct
> communication vs via the cloud, broadcast vs pt-to-pt, 1 hop vs
> multi-hop, …), the available radio access technologies and
> capabilities of the ITS station. There are indeed much more
> situations where IPv6 will be used rather than vehicular WIFI *,
> although what is being tested in safety pilots in Europe and US is
> mostly (exclusively?) non-IP.

I would like to answer this question mark.

"Pilots" - the current EU "pilot" project opportunities in H2020 IoT are
Large Scale Pilots like LSP1, 2 ...5.  There are also these "corridors".
  I am not sure about "safety pilots" though.  I will search.

These "pilots", as well as earlier EU projects, do indeed represent a
majority of what is being publicly demonstrated in vehicular
communications, with very much visibility.

But there may be a few other EU projects which do exhibit the use of
IPv6 on vehicles and with IPv6 RSUs on LTE along roads, directly on
802.11-OCB which may be constructed as we speak, or which may have been
demonstrated in less publicized settings.

> For the time being (and this is why a standard defining the use of
> IPv6 for vehicular WIFI is needed).

I agree.

> The connectivity provided by the nomadic device would probably not
> be used for V2X safety messages unless: - the vehicle is not equipped
>  with an in-vehicle router - the in-vehicle router is unable or is
> not equipped with access technologies other than 11p (safety
> channel)

And there are also these devices which are installed in the car as
after-market.  In France it's 'coyote' and in S. Korea it's 'black box'.
  These devices too can get equipped with other-than-LTE wireless 
interfaces.

Coyote already sends safety warnings as IP messages over GPRS.  From
there, it's just a small step from sending these warnings over
802.11-OCB or over LTE-V.

> In any case, the ITS station architecture (ISO 21217) allows both
> possibilities. However, transmission of safety related messages by
> the nomadic device would require the nomadic device to be trusted
> (the nomadic device must be part of the trusted vehicle domain).

I agree.

> * vehicular WIFI = IEEE 802.11p variants =>  ITS-G5 in Europe or
> WAVE/DSRC for US - but be aware that for European DSRC has another
> meaning => CEN DSRC is 5.8 GHz and used mainly for road tolling).

Right, the DSRC term is highly overloaded:

'DSRC' means PHY and MAC layer when defined by ASTM E2213 - 03(2010).
'DSRC' means application layer when defined by SAE J2735_201603.
'DSRC' means other particular PHY/MAC/app-layer by CEN/TC278.
'DSRC' is _not_ defined by IEEE.

The 5.8GHz you mention is near the 5.875-5.925GHz of ITS?
The "road tolling" is what CEN document?

"Road tolling" in France can be assimilated with "portiques" to count
truck passage in some areas, which has seen social debate and waits now
for a renewed goal.

"Road tolling" can also be assimilated with these "péage" - a place to
pay when entering or exit a highway; in France it's 30km/h max speed,
but in Japan it's 50km/h or more.

I am not sure which of these two "road tolling" you mean.

Finally, in some countries the same "road tolling" devices used to enter
the highway have been deployed to enter parking spaces; this has had
some success, but nowadays the fashion comes from smartphones doing this
"road tolling" in parkings, with new apps everyone can write on TCP/IP.
  This is a replacement of dedicated tolling devices with more generic
devices like smartphones equipped with NFC.

Alex

>
> Regards, Thierry Ernst.
>
>
>> Le 21 juil. 2016 à 13:56, Robert Moskowitz
>> <[email-masked] <mailto:[email-masked]>> a
>> écrit :
>>
>> Much of it was at ITS World Congress back in 2014 in Detroit.  I
>> had a number of meetings with Honda on their prototypes.   They
>> were using a Nexus phone that Qualcomm had hacked the 11a radio to
>>  work for 11p.
>>
>>
>> CAMP may have some internal documents.  I can probably reach out
>> to the Honda people after the 802 meeting if no one else here can
>> point to any published work.
>>
>>
>>> Thx for arising a V2P scenario. If possible, can you give the
>>> pointer? -- Jong-Hyouk Lee, living somewhere between /dev/null
>>> and /dev/random Protocol Engineering Lab., Sangmyung University
>>>
>>>> It was submitted to the CAMP pilot RFI.  I wrote it with
>>>> Robert Hopley over at Verizon, remember him?
>>>>
>>>>
>>>> It was a very similar PKI, but turned a lot of pieces around to
>>>> work with phones as clients.  The RFI said it was open to other
>>>> proposals, they responded to Verizon that they really did not
>>>> want any other approaches.
>>>>
>>>>
>>>>> available publicly? I don't remember seeing a specific
>>>>> proposal in the 1609 working group, or, to be honest,
>>>>> anywhere.
>>>>>
>>>>> Cheers,
>>>>>
>>>>> William
>>>>>
>>>>>
>>>>> <<mailto:[email-masked]>[email-masked]>
>>>>> wrote:
>>>>>
>>>>> phones being part of the network for pedestrians and
>>>>> bicycles. Honda also showed it for motorcycles, but future
>>>>> motorcycles can have an embedded DSRC device connected to the
>>>>> bike's CANbus for better information.
>>>>>
>>>>>
>>>>> The concern here is that DSRC is already quite congested in
>>>>> many areas where there are pedestrians and in places near
>>>>> mass-transit access, and pdestrians walking all over the
>>>>> place, how could a car listen to all the phones chirping
>>>>> away?
>>>>>
>>>>>
>>>>> Add to this the regulatory challenge of yet another radio on
>>>>> the phones.  Qualcomm has demonstrated a duo radio with
>>>>> standard WiFi and DSRC, but many just change the radio,
>>>>> switch from the WiFi bands to the 11p bands and switch back
>>>>> and that has serious performance concerns.
>>>>>
>>>>>
>>>>> So let's keep the phones on IP and route the WAVE messages
>>>>> over IP to/from the phones.  This would use Infrastructure
>>>>> components like traffic lights as the relays.
>>>>>
>>>>>
>>>>> There is the security question in that is the 1609.2
>>>>> certificate that of the phone's or the infrastructure piece?
>>>>>  In the former case, the PKI proposal from CAMP would have
>>>>> major challenges scaling that large.  Of course the counter
>>>>> proposal Verizon submitted ;) could scale up to certs for all
>>>>> the phones.   If the signing is done by the infrastructure
>>>>> cert which is not a anonymous cert (like in the vehicles),
>>>>> does this present any privacy issues for the phone holder?
>>>>> Probably not.
>>>>>
>>>>>
>>>>> _______________________________________________ its mailing
>>>>> list [email-masked] <mailto:[email-masked]>
>>>> _______________________________________________ its mailing
>>>> list [email-masked] <mailto:[email-masked]>
>>> _______________________________________________ its mailing list
>>> [email-masked] https://www.ietf.org/mailman/listinfo/its
>>
>> _______________________________________________ its mailing list
> _______________________________________________ its mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/its
>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 26 Jul 2016 08:16:00 -0700

Whereas I am talking about true pedestrian situations.  Well cyclists as 
well.

When I was at Verizon, there was a smallish group looking into how 
pedestrians would participate.  One approach was a WAVE app with a 
1609.2 identity/certificate to trust the phone app.  This was the simple 
part, the harder part was the communication path. You could work out how 
a phone would communicate to infrastructure that would forward 
messages.  The open item was the other direction:  how does the phone 
get vehicle generated messages.

On 07/26/2016 05:56 AM, Thierry Ernst - Bis wrote:
>
> Dear all,
>
> There is a number of standards well advanced at ISO TC204 within WG17 
> (nomadic devices) addressing the situation where a nomadic device 
> (presumably a smart phone) could access to the vehicle information via 
> a in-vehicle router (gateway between the outside world and the 
> in-vehicle network).
>
> capabilities of the ITS station. There are indeed much more situations 
> where IPv6 will be used rather than vehicular WIFI *, although what is 
> being tested in safety pilots in Europe and US is mostly 
> (exclusively?) non-IP. For the time being (and this is why a standard 
> defining the use of IPv6 for vehicular WIFI is needed).
>
> - the in-vehicle router is unable or is not equipped with access 
> technologies other than 11p (safety channel)
>
> possibilities. However, transmission of safety related messages by the 
> nomadic device would require the nomadic device to be trusted (the 
> nomadic device must be part of the trusted vehicle domain).
>
>> Le 21 juil. 2016 à 13:56, Robert Moskowitz <[email-masked] 
>> <mailto:[email-masked]>> a écrit :
>>
>> Much of it was at ITS World Congress back in 2014 in Detroit.  I had 
>> a number of meetings with Honda on their prototypes.   They were 
>> using a Nexus phone that Qualcomm had hacked the 11a radio to work 
>> for 11p.
>>
>>
>> CAMP may have some internal documents.  I can probably reach out to 
>> the Honda people after the 802 meeting if no one else here can point 
>> to any published work.
>>
>>
>>>> proposals, they responded to Verizon that they really did not want 
>>>> any other approaches.
>>>>
>>>>
>>>>> <[email-masked]> wrote:
>>>>>
>>>>>     Honda also showed it for motorcycles, but future motorcycles
>>>>>     can have an embedded DSRC device connected to the bike's
>>>>>     CANbus for better information.
>>>>>
>>>>>
>>>>>     place, how could a car listen to all the phones chirping away?
>>>>>
>>>>>
>>>>>     standard WiFi and DSRC, but many just change the radio, switch
>>>>>     from the WiFi bands to the 11p bands and switch back and that
>>>>>     has serious performance concerns.
>>>>>
>>>>>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 26 Jul 2016 09:00:30 -0700

> but in Japan it's 50km/h or more.

1609.11-2010 is:

IEEE Standard for Wireless Access in Vehicular Environments (WAVE)— 
Over-the-Air Electronic Payment Data  Exchange Protocol for Intelligent 
Transportation Systems (ITS)

In otherwords:  Road tolling.