Subject: [its] A New I-D on "IPv6 Neighbor Discovery for Prefix and Service Discovery in Vehicular Networks"

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 20 Jul 2016 08:13:04 +0900

Hi all,
I have posted a new its I-D:
- Title
   IPv6 Neighbor Discovery for Prefix and Service Discovery in Vehicular
Networks

- File

https://tools.ietf.org/html/draft-jeong-its-vehicular-neighbor-discovery-00

- Abstract
   This document specifies an extension of IPv6 Neighbor Discovery (ND)
   for rapid network prefix and service discovery in vehicular networks.
   It is assumed that a vehicle or a Road-Side Unit (RSU) have an
   external network interface and their internal network.  This document
   defines new ND options to allows a vehicle to announce the network
   prefixes and services inside its internal network to another vehicle
   or RSU.

In this draft, we show a possible approach for the prefix and service
discovery
for vehicular services, such as adaptive cruise control, blackbox camera
sharing,
emergency notification, and navigation.

We can use it for "ITS General Problem Area" that is one of work items in
our its group: https://trac.tools.ietf.org/wg/its/trac/

It will be great for you to take a look at this I-D and give us comments or
suggestions.

Thanks.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 21 Jul 2016 01:08:29 +0200

Hi Dick,
As you know, the option length is the multiple of 8 bytes.
If we provide a list of prefixes and services, it seems to require padding
for this length rule.
It is not impossible, but it seems not a neat solution.
I will figure it out to pack them into a list.

Thanks for your suggestion.

Best Regards,
Paul

On Wed, Jul 20, 2016 at 2:58 AM, Dick Roy <[email-masked]> wrote:

> I’ve skimmed the draft and it looks interesting.  My initial thought is
> that both the VPI and VSI should/could contain a list of prefixes/services
> rather than just a single entry in each.  Is there a problem doing this?
>
>
>
> RR
>
>
> ------------------------------
>
> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
> *Sent:* Tuesday, July 19, 2016 4:13 PM
> *To:* [email-masked]
> *Cc:* Mr. Jaehoon Paul Jeong; 정준식; Chris Shen; Jong-Hyouk Lee; 조영화
> *Subject:* [its] A New I-D on "IPv6 Neighbor Discovery for Prefix and
> Service Discovery in Vehicular Networks"
>
>
>
> Hi all,
>
> It will be great for you to take a look at this I-D and give us comments
> or suggestions.
>
>
>
> Thanks.
>
>
>
> Best Regards,
>
> Paul
>
> --
>