Subject: [ipwave] Request for Checking Revision on IPWAVE PS Draft

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 1 Apr 2019 22:44:17 +0900

Hi Charlie and Sri,

In the last IETF-104 IPWAVE WG session,
if the comments of both of you (as designated reviewers) are addressed well
in the latest version of IPWAVE PS Draft, Carlos said that the authors
will be able to request WGLC on this draft:
https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08

Could you check whether your comments are addressed well or not?

If there are places to improve, please let me know.

Thanks.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Mon, 1 Apr 2019 19:45:09 +0200

Dear Paul,

Just a clarification. Once you get the feedback from Charlie and Sri on
whether their comments have been addressed properly, we will proceed to the
next step (I'll review the document myself). WGLC would go after that
review.

Thanks,

Carlos

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 2 Apr 2019 15:26:31 +0900

HI Carlos,
Sure, no problem.
Thanks for your further review in advance.

Best Regards,
Paul

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 2 Apr 2019 11:33:37 +0000

Paul – Ack! Will review.

Sri

From: "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 1, 2019 at 6:44 AM
To: Charlie Perkins <[email-masked]<mailto:[email-masked]>>, Sri Gundavelli <[email-masked]<mailto:[email-masked]>>
Cc: Russ Housley <[email-masked]<mailto:[email-masked]>>, CARLOS JESUS BERNARDOS CANO <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Subject: Request for Checking Revision on IPWAVE PS Draft

Hi Charlie and Sri,

Thanks.

Best Regards,
Paul
--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Associate Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 4 Apr 2019 23:04:26 +0900

Hi Sri,
Thanks for your help.

Charlie,
Are you able to review my revision?

Thanks.

Best Regards,
Paul

On Tue, Apr 2, 2019 at 8:33 PM Sri Gundavelli (sgundave) <[email-masked]>
wrote:

> Paul – Ack! Will review.
>
> Sri
>
> From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
> To: Charlie Perkins <[email-masked]>, Sri Gundavelli <
> [email-masked]>
> Cc: Russ Housley <[email-masked]>, CARLOS JESUS BERNARDOS CANO <
> [email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <
> [email-masked]>, "Mr. Jaehoon Paul Jeong" <
> [email-masked]>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Fri, 5 Apr 2019 03:27:09 +0000

Hi Paul,

Before I spend too much of time on my reviews, I want to understand the approach here, or may be the style of writing.

Lets look at the text in https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#section-4.1.1

In my previous review, I have provided the following comment,

"[Sri] The focus of the document should be on the problem statement. We have departed from that and now we are talking solutions. I see this problem through out this spec."

Now, if I look at the same section in –08 version, I still see the same issue. I tried reading the below section few times, but I could not understand the actual problem just by reading the below text. With all the references to various papers, its a maze out there, and the reader is completely lost on the goal or the assumptions around the scenario where the problem is seen.  There is no clear explanation of the actual problem in simple terms.It talks about prefix per lane, it talks about clusters, Geographic regions, cross layer identity management etc, and with unclear assumptions on the actual problem. May be its a style of writing, but I tend to think we can eliminate lot of this unnecessary text with no loss of information.

You may want to clarify your approach here, so I don’t provide the same feedback again.

   "4.1.1 IP Address Autoconfiguration

   For IP address autoconfiguration, Fazio et al. proposed a vehicular
   address configuration (VAC) scheme using DHCP where elected leader-
   vehicles provide unique identifiers for IP address configurations in
   vehicles [Address-Autoconf<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Autoconf>].  Kato et al. proposed an IPv6 address
   assignment scheme using lane and position information
   [Address-Assignment<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Assignment>].  Baldessari et al. proposed an IPv6 scalable
   address autoconfiguration scheme called GeoSAC for vehicular networks
   [GeoSAC<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-GeoSAC>].  Wetterwald et al. conducted for heterogeneous vehicular
   networks (i.e., employing multiple access technologies) a
   comprehensive study of the cross-layer identity management, which
   constitutes a fundamental element of the ITS architecture
   [Identity-Management<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Identity-Management>].

   A server-based address autoconfiguration such as VAC
   [Address-Autoconf<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Autoconf>] takes some delay for a vehicle to join a new
   cluster (i.e., a connected VANET) and communicate with neighboring
   vehicles.  This delay may prevent vehicles from exchaning safety

   messages with each other in a prompty way.  It will be good for a
   vehicle to maintain its IP address even when it joins another
   cluster.  A geographical-position-based address autoconfiguration,
   such as a prefix allocation per lane [Address-Assignment<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Assignment>] and a
   prefix allocation per geographic region [GeoSAC<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-GeoSAC>], causes the frequent
   change of a vehicle's IP address and requires the DAD for the
   uniqueness test of a new IP address.  This is significant overhead
   for high-speed moving vehicles.  It will be efficient for a vehicle
   to be able to use its IP address while moving across the clusters and
   geographical regions.  For the cross-layer identity management with
   multiple wireless interfaces [Identity-Management<https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Identity-Management>], it will be
   necessary to maintain an upper-layer session (e.g., TCP session) of a
   vehicle with multiple IP addresses corresponing to the multiple
   wireless interfaces."

Thanks
Sri

From: "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, April 4, 2019 at 7:04 AM
To: Sri Gundavelli <[email-masked]<mailto:[email-masked]>>, Charlie Perkins <[email-masked]<mailto:[email-masked]>>
Cc: Russ Housley <[email-masked]<mailto:[email-masked]>>, CARLOS JESUS BERNARDOS CANO <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Charles E. Perkins" <[email-masked]<mailto:[email-masked]>>, "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Request for Checking Revision on IPWAVE PS Draft

Hi Sri,
Thanks for your help.

Charlie,

Thanks.

Best Regards,
Paul

On Tue, Apr 2, 2019 at 8:33 PM Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>> wrote:
Paul – Ack! Will review.

Sri

Hi Charlie and Sri,

Thanks.

Best Regards,
Paul

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 5 Apr 2019 17:30:35 +0900

Hi Sri,
In the existing protocols section, I tried to summarize and analyze the
existing protocols and schemes
with their pros and cons.
According to your comments, I will focus on the problems of those protocols
more.

Charlie,
You can review -09 version after I will revise -08 version and submit it
later.

Thanks.

Best Regards,
Paul

On Fri, Apr 5, 2019 at 12:27 PM Sri Gundavelli (sgundave) <
[email-masked]> wrote:

> Hi Paul,
>
> Before I spend too much of time on my reviews, I want to understand the
> approach here, or may be the style of writing.
>
> Lets look at the text in
> https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#section-4.1.1
>
> "[Sri] The focus of the document should be on the problem statement. We
> have departed from that and now we are talking solutions. I see this
> problem through out this spec."
>
> Now, if I look at the same section in –08 version, I still see the same
> issue. I tried reading the below section few times, but I could not
> understand the actual problem just by reading the below text. With all the
> references to various papers, its a maze out there, and the reader is
> completely lost on the goal or the assumptions around the scenario where
> the problem is seen.  There is no clear explanation of the actual problem
> in simple terms.It talks about prefix per lane, it talks about clusters,
> Geographic regions, cross layer identity management etc, and with unclear
> assumptions on the actual problem. May be its a style of writing, but I
> tend to think we can eliminate lot of this unnecessary text with no loss of
> information.
>
>    vehicles [Address-Autoconf <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Autoconf>].  Kato et al. proposed an IPv6 address
>    [Address-Assignment <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Assignment>].  Baldessari et al. proposed an IPv6 scalable
>    [GeoSAC <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-GeoSAC>].  Wetterwald et al. conducted for heterogeneous vehicular
>    [Identity-Management <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Identity-Management>].
>
>    [Address-Autoconf <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Autoconf>] takes some delay for a vehicle to join a new
>    such as a prefix allocation per lane [Address-Assignment <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Address-Assignment>] and a
>    prefix allocation per geographic region [GeoSAC <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-GeoSAC>], causes the frequent
>    multiple wireless interfaces [Identity-Management <https://tools.ietf.org/html/draft-ietf-ipwave-vehicular-networking-08#ref-Identity-Management>], it will be
> To: Sri Gundavelli <[email-masked]>, Charlie Perkins <
> [email-masked]>
> [email-masked]>, "Charles E. Perkins" <
> [email-masked]>, "Mr. Jaehoon Paul Jeong" <
> [email-masked]>
> On Tue, Apr 2, 2019 at 8:33 PM Sri Gundavelli (sgundave) <
> [email-masked]> wrote:
>
>> Paul – Ack! Will review.
>>
>> Sri
>>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Fri, 5 Apr 2019 14:05:07 +0000

Hi Paul,

Thanks!

My strong recommendation would be to significantly cut down the text. For each of the problems, I would just add a small paragraph stating the technical requirement and the stated assumption. You can possibly cutdown the document to 4 to 5  pages, with no loss of information, and greatly improving the readability.  But, if you cannot, please at least add few lines which clearly explains the technical requirement.

Sri

From: "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 5, 2019 at 1:30 AM
To: Sri Gundavelli <[email-masked]<mailto:[email-masked]>>
Cc: Charlie Perkins <[email-masked]<mailto:[email-masked]>>, Russ Housley <[email-masked]<mailto:[email-masked]>>, CARLOS JESUS BERNARDOS CANO <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Charles E. Perkins" <[email-masked]<mailto:[email-masked]>>, "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Request for Checking Revision on IPWAVE PS Draft

Hi Sri,
In the existing protocols section, I tried to summarize and analyze the existing protocols and schemes
with their pros and cons.
According to your comments, I will focus on the problems of those protocols more.

Charlie,
You can review -09 version after I will revise -08 version and submit it later.

Thanks.

Best Regards,
Paul

On Fri, Apr 5, 2019 at 12:27 PM Sri Gundavelli (sgundave) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Paul,

Thanks
Sri

Hi Sri,
Thanks for your help.

Charlie,

Thanks.

Best Regards,
Paul

Sri

Hi Charlie and Sri,

Thanks.

Best Regards,
Paul

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 5 Apr 2019 17:51:25 +0000

Hello Sri and Paul,

I agree that the solutions which are described should include a clear statement about which problem(s) they are solving.  The problem they solve should be a problem that is previously mentioned in the text.  If appropriate, it would also be nice to point out what the gaps are in each solution that is described.  In other words, which problems in the previously mentioned text of the problem statement are NOT resolved by that solution.

However, I don't think it is needed to delete all of the text.  The text represents a good amount of work, and the information contained will be useful to future readers of the document.  If the text about the existing solutions is augmented as I described in the previous paragraph, it will have significant value in the future.

Regards,
Charlie P.

From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: Friday, April 05, 2019 7:05 AM
To: Mr. Jaehoon Paul Jeong <[email-masked]>
Cc: Charlie Perkins <[email-masked]>; Russ Housley <[email-masked]>; CARLOS JESUS BERNARDOS CANO <[email-masked]>; [email-masked]; [email-masked]; Charles E. Perkins <[email-masked]>
Subject: Re: Request for Checking Revision on IPWAVE PS Draft

Hi Paul,

Thanks!

Sri

Hi Sri,

Charlie,

Thanks.

Best Regards,
Paul

Now, if I look at the same section in -08 version, I still see the same issue. I tried reading the below section few times, but I could not understand the actual problem just by reading the below text. With all the references to various papers, its a maze out there, and the reader is completely lost on the goal or the assumptions around the scenario where the problem is seen.  There is no clear explanation of the actual problem in simple terms.It talks about prefix per lane, it talks about clusters, Geographic regions, cross layer identity management etc, and with unclear assumptions on the actual problem. May be its a style of writing, but I tend to think we can eliminate lot of this unnecessary text with no loss of information.

You may want to clarify your approach here, so I don't provide the same feedback again.

   wireless interfaces."

Thanks
Sri

Hi Sri,
Thanks for your help.

Charlie,

Thanks.

Best Regards,
Paul

Paul - Ack! Will review.

Sri

Hi Charlie and Sri,

Thanks.

Best Regards,
Paul

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Mon, 8 Apr 2019 18:03:02 +0900

Hi Charlie,
Thanks for your opinion.

I agree with you that we keep the useful contents and make the gap analysis
and problems more clear.

I will work on the revision with the comments from Charlies and Sri
together with the co-authors of IPWAVE PS document.

Thanks.

Best Regards,
Paul

2019년 4월 6일 (토) 오전 2:51, Charlie Perkins <[email-masked]>님이 작성:

> Hello Sri and Paul,
>
>
>
> I agree that the solutions which are described should include a clear
> statement about which problem(s) they are solving.  The problem they solve
> should be a problem that is previously mentioned in the text.  If
> appropriate, it would also be nice to point out what the gaps are in each
> solution that is described.  In other words, which problems in the
> previously mentioned text of the problem statement are NOT resolved by that
> solution.
>
>
>
> However, I don’t think it is needed to delete all of the text.  The text
> represents a good amount of work, and the information contained will be
> useful to future readers of the document.  If the text about the existing
> solutions is augmented as I described in the previous paragraph, it will
> have significant value in the future.
>
>
>
> Regards,
> Charlie P.
>
>
>
> *From:* Sri Gundavelli (sgundave) [mailto:[email-masked]]
> *Sent:* Friday, April 05, 2019 7:05 AM
> *To:* Mr. Jaehoon Paul Jeong <[email-masked]>
> *Cc:* Charlie Perkins <[email-masked]>; Russ Housley <
> [email-masked]>; CARLOS JESUS BERNARDOS CANO <[email-masked]>;
> [email-masked]; [email-masked]; Charles E. Perkins <
> [email-masked]>
> *Subject:* Re: Request for Checking Revision on IPWAVE PS Draft
>
>
>
> Hi Paul,
>
>
>
> Thanks!
>
>
>
> My strong recommendation would be to significantly cut down the text. For
> each of the problems, I would just add a small paragraph stating the
> technical requirement and the stated assumption. You can possibly cutdown
> the document to 4 to 5  pages, with no loss of information, and greatly
> improving the readability.  But, if you cannot, please at least add few
> lines which clearly explains the technical requirement.
>
>
>
>
>
> Sri
>
>
>
>
>
>
>
> *From: *"Mr. Jaehoon Paul Jeong" <[email-masked]>
> *Date: *Friday, April 5, 2019 at 1:30 AM
> *To: *Sri Gundavelli <[email-masked]>
> *Cc: *Charlie Perkins <[email-masked]>, Russ Housley <
> [email-masked]>, CARLOS JESUS BERNARDOS CANO <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> *Subject: *Re: Request for Checking Revision on IPWAVE PS Draft
>
>
>
> Hi Sri,
>
> *From: *"Mr. Jaehoon Paul Jeong" <[email-masked]>
> *Date: *Thursday, April 4, 2019 at 7:04 AM
> *To: *Sri Gundavelli <[email-masked]>, Charlie Perkins <
> *Cc: *Russ Housley <[email-masked]>, CARLOS JESUS BERNARDOS CANO <
> *Subject: *Re: Request for Checking Revision on IPWAVE PS Draft
>
>
>
> Hi Sri,
>
> Thanks for your help.
>
>
>
> Charlie,
>
> *From: *"Mr. Jaehoon Paul Jeong" <[email-masked]>
> *Date: *Monday, April 1, 2019 at 6:44 AM
> *To: *Charlie Perkins <[email-masked]>, Sri Gundavelli <
> [email-masked]>
> *Cc: *Russ Housley <[email-masked]>, CARLOS JESUS BERNARDOS CANO <
> *Subject: *Request for Checking Revision on IPWAVE PS Draft
>
>
>
> Hi Charlie and Sri,
>
>
>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 9 Apr 2019 15:07:21 +0000

Hi Charlie,

I am OK keeping all those external references, but as long as we make the requirement very clear. In the current form, many of the requirements are not clear and the additional context is not helping but only adding to the confusion. I suggest we add text to make the requirement clear and use external references to prove the point.

Regards
Sri

From: Charlie Perkins <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 5, 2019 at 10:51 AM
To: Sri Gundavelli <[email-masked]<mailto:[email-masked]>>, "Mr. Jaehoon Paul Jeong" <[email-masked]<mailto:[email-masked]>>
Cc: Russ Housley <[email-masked]<mailto:[email-masked]>>, CARLOS JESUS BERNARDOS CANO <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Charles E. Perkins" <[email-masked]<mailto:[email-masked]>>
Subject: RE: Request for Checking Revision on IPWAVE PS Draft

Hello Sri and Paul,

However, I don’t think it is needed to delete all of the text.  The text represents a good amount of work, and the information contained will be useful to future readers of the document.  If the text about the existing solutions is augmented as I described in the previous paragraph, it will have significant value in the future.

Regards,
Charlie P.

From: Sri Gundavelli (sgundave) [mailto:[email-masked]]
Sent: Friday, April 05, 2019 7:05 AM
To: Mr. Jaehoon Paul Jeong <[email-masked]<mailto:[email-masked]>>
Cc: Charlie Perkins <[email-masked]<mailto:[email-masked]>>; Russ Housley <[email-masked]<mailto:[email-masked]>>; CARLOS JESUS BERNARDOS CANO <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Charles E. Perkins <[email-masked]<mailto:[email-masked]>>
Subject: Re: Request for Checking Revision on IPWAVE PS Draft

Hi Paul,

Thanks!

Sri

Hi Sri,

Charlie,

Thanks.

Best Regards,
Paul

   wireless interfaces."

Thanks
Sri

Hi Sri,
Thanks for your help.

Charlie,

Thanks.

Best Regards,
Paul

Sri

Hi Charlie and Sri,

Thanks.

Best Regards,
Paul