Subject: [ipwave] Fwd: New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-45.txt

From: NABIL BENAMAR <[email-masked]>
Date: Mon, 29 Apr 2019 22:03:22 +0100

Dear IPWAVErs,

This is the version -45.

We have changed the text in the abstract to narrow the scope of this draft.

Your comments are welcome!

---------- Forwarded message ---------
From: <[email-masked]>
Date: Mon, Apr 29, 2019 at 9:58 PM
Subject: New Version Notification for
draft-ietf-ipwave-ipv6-over-80211ocb-45.txt
To: Jerome Haerri <[email-masked]>, <[email-masked]>,
Jerome Haerri <[email-masked]>, Nabil Benamar <
[email-masked]>, Thierry Ernst <[email-masked]>,
Jong-Hyouk Lee <[email-masked]>

A new version of I-D, draft-ietf-ipwave-ipv6-over-80211ocb-45.txt
has been successfully submitted by Nabil Benamar and posted to the
IETF repository.

Name:           draft-ietf-ipwave-ipv6-over-80211ocb
Revision:       45
Title:          Transmission of IPv6 Packets over IEEE 802.11 Networks
operating in mode Outside the Context of a Basic Service Set
(IPv6-over-80211-OCB)
Document date:  2019-04-29
Group:          ipwave
Pages:          43
URL:
https://www.ietf.org/internet-drafts/draft-ietf-ipwave-ipv6-over-80211ocb-45.txt
Status:
https://datatracker.ietf.org/doc/draft-ietf-ipwave-ipv6-over-80211ocb/
Htmlized:
https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-45
Htmlized:
https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-ipv6-over-80211ocb
Diff:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-45

Abstract:
   In order to transmit IPv6 packets on IEEE 802.11 networks running
   outside the context of a basic service set (OCB, earlier "802.11p")
   there is a need to define a few parameters such as the supported
   Maximum Transmission Unit size on the 802.11-OCB link, the header
   format preceding the IPv6 header, the Type value within it, and
   others.  This document describes how IPv6 (including addressing and
   basic ND) can be used to communicate among nodes in range of one
   another over IEEE 802.11-OCB.  Optimizations and usage of IPv6 over
   more complex scenarios is not covered and is subject of future work.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 

Best Regards

Nabil Benamar
Associate Professor
Department of Computer Sciences
School of Technology
University Moulay Ismail
Meknes. Morocco

---

From: NABIL BENAMAR <[email-masked]>
Date: Tue, 30 Apr 2019 11:30:30 +0100

Dear IPwavers

Yesterday, we have submitted a new version (45) of the draft-ietf-ipwave-ip
v6-over-80211ocb.
Based on the messages exchanged in the ML, we have tightened the scope of
this document by precising in the abstract the following:

Old:

"This document describes these parameters for IPv6 and IEEE 802.11-OCB
networks; it portrays the layering of IPv6 on 802.11-OCB similarly to other
known 802.11 and Ethernet layers - by using an Ethernet Adaptation Layer."

New:

"This document describes how IPv6 (including addressing and basic ND) can
be used to communicate among nodes in range of one another over IEEE
802.11-OCB. Optimizations and usage of IPv6 over more complex scenarios is
not covered and is subject of future work."

Your comments are Welcome as always.

-- 

Best Regards

Nabil Benamar
Associate Professor

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 30 Apr 2019 14:07:22 +0200

Le 30/04/2019 à 12:30, NABIL BENAMAR a écrit :
> Dear IPwavers
> 
> Yesterday, we have submitted a new version (45) of the 
> draft-ietf-ipwave-ipv6-over-80211ocb.
> Based on the messages exchanged in the ML, we have tightened the scope 
> of this document by precising in the abstract the following:
> 
> Old:
> 
> networks; it portrays the layering of IPv6 on 802.11-OCB similarly to 
> other known 802.11 and Ethernet layers - by using an Ethernet Adaptation 
> Layer."
> 
> New:
> 
> "This document describes how IPv6 (including addressing and basic ND) 
> can be used to communicate among nodes in range of one another over IEEE 
> 802.11-OCB. Optimizations and usage of IPv6 over more complex scenarios 
> is not covered and is subject of future work."
> 
> 

Makes sense to me.

Alex

> 
> 
> 
> On Mon, Apr 29, 2019 at 10:03 PM NABIL BENAMAR <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Dear IPWAVErs,
> 
>     This is the version -45.
> 
>     From: <[email-masked] <mailto:[email-masked]>>
>     To: Jerome Haerri <[email-masked]
>     <mailto:[email-masked]>>, <[email-masked]
>     <mailto:ipwave-chairs@ietf..org>>, Jerome Haerri
>     <[email-masked] <mailto:[email-masked]>>, Nabil
>     Benamar <[email-masked] <mailto:[email-masked]>>,
>     Thierry Ernst <[email-masked]
>     <mailto:[email-masked]>>, Jong-Hyouk Lee
>     <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
>     Title:          Transmission of IPv6 Packets over IEEE 802.11
>     Networks operating in mode Outside the Context of a Basic Service
>     Set (IPv6-over-80211-OCB)
>     until the htmlized version and diff are available at tools.ietf.org
>     <http://tools.ietf.org>.
> 
>     The IETF Secretariat
> 
> 
> 
>     -- 
> 
>     Best Regards
> 
>     Nabil Benamar
>     Associate Professor
> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 30 Apr 2019 16:08:26 +0000

Hi Nabil:

I think IESG will ask for more details than this. You may want to qualify in very specific terms on where the default ND is expected to work as expected and where it will fail.

You may want to construct some text based on the Brian’s review.

Sri

From: its <[email-masked]<mailto:[email-masked]>> on behalf of NABIL BENAMAR <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 30, 2019 at 3:30 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ipwave] New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-45.txt

Dear IPwavers

Yesterday, we have submitted a new version (45) of the draft-ietf-ipwave-ipv6-over-80211ocb.
Based on the messages exchanged in the ML, we have tightened the scope of this document by precising in the abstract the following:

Old:

"This document describes these parameters for IPv6 and IEEE 802.11-OCB networks; it portrays the layering of IPv6 on 802.11-OCB similarly to other known 802.11 and Ethernet layers - by using an Ethernet Adaptation Layer."

New:

"This document describes how IPv6 (including addressing and basic ND) can be used to communicate among nodes in range of one another over IEEE 802.11-OCB. Optimizations and usage of IPv6 over more complex scenarios is not covered and is subject of future work."

On Mon, Apr 29, 2019 at 10:03 PM NABIL BENAMAR <[email-masked]<mailto:[email-masked]>> wrote:
Dear IPWAVErs,

This is the version -45.

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Mon, Apr 29, 2019 at 9:58 PM
Subject: New Version Notification for draft-ietf-ipwave-ipv6-over-80211ocb-45.txt
To: Jerome Haerri <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:ipwave-chairs@ietf..org>>, Jerome Haerri <[email-masked]<mailto:[email-masked]>>, Nabil Benamar <[email-masked]<mailto:[email-masked]>>, Thierry Ernst <[email-masked]<mailto:[email-masked]>>, Jong-Hyouk Lee <[email-masked]<mailto:[email-masked]>>

Name:           draft-ietf-ipwave-ipv6-over-80211ocb
Revision:       45
Title:          Transmission of IPv6 Packets over IEEE 802.11 Networks operating in mode Outside the Context of a Basic Service Set (IPv6-over-80211-OCB)
Document date:  2019-04-29
Group:          ipwave
Pages:          43
URL:            https://www.ietf.org/internet-drafts/draft-ietf-ipwave-ipv6-over-80211ocb-45.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-ipwave-ipv6-over-80211ocb/
Htmlized:       https://tools.ietf.org/html/draft-ietf-ipwave-ipv6-over-80211ocb-45
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-ipwave-ipv6-over-80211ocb
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-ipwave-ipv6-over-80211ocb-45

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

--

Best Regards

Nabil Benamar
Associate Professor

--

Best Regards

Nabil Benamar
Associate Professor