Subject: [ipwave] BSM and other J2735 2016 messages free web decoders at ASN1 Playground and Marben

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 3 Apr 2019 13:00:09 +0200

Hi,

The good news: since a few days the freely available BSM and other J2735 
decoders at ASN1 Playground do the year 2016 version, as opposed to the 
earlier 2009 version.  The similar Marben tool does it since some time 
now.  Having two of them is very useful to check interoperability of 
BSMs.  One can capture a BSM with wireshark and then try to decode it on 
ASN1 Playground and on Marben tool: both should give same result.

https://asn1.io/asn1playground/

https://www.marben-products.com/decoder-asn1-automotive/

The continuity of the negative aspect: neither ASN1 Playground nor 
Marben offer the year 2016 BSM grammar ('ASN1 specificatinon'), which 
stays a confidential info.  Only the 2009 version of the BSM grammar is 
freely available.

Lack of open availability of the J2735 grammar has a negative side.  The 
side effect is in Europe.

In Europe one is used to develop open source V2X messaging.  The ETSI 
spec of CAM, DENM and a few others is open, which includes their 
grammars.  The asn1c open source software is fed by these grammars.  For 
these reasons, there are many software packages doing V2X messaging 
available on github.  All come from Europe.

However, for traffic lights communication (not CAM, nor DENM) the 
situation is a bit different.  ETSI defines 'SPAT-EM' which is a sort of 
ASN1 container of the SPAT message (like in C #include).  Thus, whereas 
the 'SPAT-EM' has open grammar, it contains the SPAT grammar which is 
closed.  So one cant implement it with open source.

The conditions of getting that SPAT grammar are difficult for many 
people: fork about 100 eur for the pdf, but also some check to sign some 
complex law agreements about where you could talk about it, or not (SAE 
wants all to come to them).  These conditions translate in very hard to 
make decisions when an implementer wants to put software in some car 
(should put the source code in car, or not).

There is another negative side effect about this, but this concerns SAE 
being potentially hurt.  SAE does not want this grammar to be open. But 
I can buy it, enter it manually on that web page (asn1 playground), and 
that server will read it.  It will probably store it in a temporary 
file, or cache.  I am not sure SAE understands this side effect, but it 
can happen.  This is what SAE should care about with respect to J2735 
openness.  One can learn from the youtube and content availability 
example (initially youtube did not want their content to be 
downloadable, but then videodownloadhelper appeared, and so youtube 
added a QR code: you still get the content but it's tagged).

Note it is possible to implement the 2009 version freely, maybe extend 
it in an SDO that uses open specifications, even though it wont be 
compatible with the SAE 2016 version.

Alex

---

From: Tijink Jasja <[email-masked]>
Date: Wed, 3 Apr 2019 11:30:57 +0000

Hi Alexandre,

please do consult this page:

https://www.tc278.eu/cits

It provides links to the ASN.1 modules for the CEN ISO standards on IVI (ISO TS 19321) and SPAT/MAP/SSM SRM (ISO TS 19091).

For example the addGrpC modules of ISO 19091 for use with ETSI TS 103 301 are available here:

https://standards.iso.org/iso/ts/19091/addgrp_c

They notably include an excerpt of the J2735_2016 module you need.

Regards Jasja

Von: its <[email-masked]> Im Auftrag von Alexandre Petrescu
Gesendet: Mittwoch, 3. April 2019 13:00
An: [email-masked]
Betreff: [ipwave] BSM and other J2735 2016 messages free web decoders at ASN1 Playground and Marben

Hi,

The good news: since a few days the freely available BSM and other J2735 decoders at ASN1 Playground do the year 2016 version, as opposed to the earlier 2009 version.  The similar Marben tool does it since some time now.  Having two of them is very useful to check interoperability of BSMs.  One can capture a BSM with wireshark and then try to decode it on ASN1 Playground and on Marben tool: both should give same result.

The continuity of the negative aspect: neither ASN1 Playground nor Marben offer the year 2016 BSM grammar ('ASN1 specificatinon'), which stays a confidential info.  Only the 2009 version of the BSM grammar is freely available.

Lack of open availability of the J2735 grammar has a negative side.  The side effect is in Europe.

In Europe one is used to develop open source V2X messaging.  The ETSI spec of CAM, DENM and a few others is open, which includes their grammars.  The asn1c open source software is fed by these grammars.  For these reasons, there are many software packages doing V2X messaging available on github.  All come from Europe.

However, for traffic lights communication (not CAM, nor DENM) the situation is a bit different.  ETSI defines 'SPAT-EM' which is a sort of ASN1 container of the SPAT message (like in C #include).  Thus, whereas the 'SPAT-EM' has open grammar, it contains the SPAT grammar which is closed.  So one cant implement it with open source.

The conditions of getting that SPAT grammar are difficult for many people: fork about 100 eur for the pdf, but also some check to sign some complex law agreements about where you could talk about it, or not (SAE wants all to come to them).  These conditions translate in very hard to make decisions when an implementer wants to put software in some car (should put the source code in car, or not).

There is another negative side effect about this, but this concerns SAE being potentially hurt.  SAE does not want this grammar to be open.  But I can buy it, enter it manually on that web page (asn1 playground), and that server will read it.  It will probably store it in a temporary file, or cache.  I am not sure SAE understands this side effect, but it can happen.  This is what SAE should care about with respect to J2735 openness.  One can learn from the youtube and content availability example (initially youtube did not want their content to be downloadable, but then videodownloadhelper appeared, and so youtube added a QR code: you still get the content but it's tagged).

Note it is possible to implement the 2009 version freely, maybe extend it in an SDO that uses open specifications, even though it wont be compatible with the SAE 2016 version.

Alex

The information contained in this e-mail message is privileged and confidential and is for the exclusive use of the addressee. The person who receives this message and who is not the addressee, one of his employees or an agent entitled to hand it over to the addressee, is informed that he may not use, disclose or reproduce the contents thereof, and is kindly asked to notify the sender and delete the e-mail immediately.

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 4 Apr 2019 21:24:43 +0200

Jasja,

I want to thank you for this message.  And to IETF to make this possible.

I must say I am very much surprised by these files.  I am supposed to 
know what's happening at ISO... :-) but not.  So I learn.  And I 
discover CEN.

I looked relatively quickly over it.  There are indeed ASN1 statements, 
in what appears to be similar to the ASN1 of J2735 BSM.

We will look closer with programmers, with the goal to feed it to asn1c 
and check results with ASN1 Playground and Marben tools.

That will take some time.

Until then, my logic would like to ask, if ever you know:

- are these ISO and CEN documents produced by ISO TC204, or by other 
group of ISO?
- if these documents give the ASN1 grammar of BSM for free then who 
would be, err, dumb, but no offence, to pay for BSM ASN1 to SAE?
- if these documents give the ASN1 of BSM, will the packets generated by 
it be verified by ASN1 Playground and Marben, as they verify the BSMs 
generated by the private ASN1 of BSM o fJ2735?  (I suppose the answer is 
yes, we will try it in practice, and I just ask out of curiosity).

I will also present this situation of availability of grammar to a 
particular RSU manufacturer who uses that J2735 SPAT and with whom we 
are supposed to interoperate.

Thanks again for the pointers at ISO and CEN.

Alex

Le 03/04/2019 à 13:30, Tijink Jasja a écrit :
> It provides links to the ASN.1 modules for the CEN ISO standards on IVI 
> (ISO TS 19321) and SPAT/MAP/SSM SRM (ISO TS 19091).
> 
> *Von:*its <[email-masked]> *Im Auftrag von *Alexandre Petrescu
> *Gesendet:* Mittwoch, 3. April 2019 13:00
> *An:* [email-masked]
> *Betreff:* [ipwave] BSM and other J2735 2016 messages free web decoders 
> at ASN1 Playground and Marben
> 
> Hi,
> 
> The information contained in this e-mail message is privileged and 
> confidential and is for the exclusive use of the addressee. The person 
> who receives this message and who is not the addressee, one of his 
> employees or an agent entitled to hand it over to the addressee, is 
> informed that he may not use, disclose or reproduce the contents 
> thereof, and is kindly asked to notify the sender and delete the e-mail 
> immediately.
>