Subject: [Ledger] AGENDA - Interledger Call - 5 September - 3pm UTC

From: Evan Schwartz <[email-masked]>
Date: Tue, 4 Sep 2018 13:33:56 -0400

Agenda:
Launch of Coil.com subscription WebMonetization service in closed beta

Update from Strata Labs (https://www.stratalabs.io/) and Kava (kava.io) on Ethereum and Lightning plugins

Discussion about retail payment solution built on ILP

Open Q&A / discussion

Talk to you tomorrow!

Join from PC, Mac, Linux, iOS or Android: https://zoom.us/s/377506344 (http://email.zoom.us/track/click/30854053/zoom.us?p=eyJzIjoiM0w2aVdDeVIxQS1QMWFUY2dOWDNqRF9FXzg4IiwidiI6MSwicCI6IntcInVcIjozMDg1NDA1MyxcInZcIjoxLFwidXJsXCI6XCJodHRwczpcXFwvXFxcL3pvb20udXNcXFwvc1xcXC8zNzc1MDYzNDRcIixcImlkXCI6XCI1NzY5ZmNlY2IyMTA0YjJlOGY5NTdjZDNkMzU3MDQxMlwiLFwidXJsX2lkc1wiOltcImY3NTEyMWVkZGI2NDQ2YjA4YzI1ODAxNjdiMWQ5ODlhM2MyY2FmMTZcIl19In0)
Or iPhone one-tap:
US: +14086380968,,377506344# or +16468769923,,377506344#

Or Telephone:
Dial(for higher quality, dial a number based on your current location):
US: +1 408 638 0968 (tel:+1%20408%20638%200968) or +1 646 876 9923 (tel:+1%20646%20876%209923) or +1 669 900 6833 (tel:+1%20669%20900%206833)
Meeting ID: 377 506 344

International numbers available: https://zoom.us/u/cbrUAzE3W (http://email.zoom.us/track/click/30854053/zoom.us?p=eyJzIjoiTkhxZ1pWcWZEbDlWZy1VaTBYTnFqX2RwcUs0IiwidiI6MSwicCI6IntcInVcIjozMDg1NDA1MyxcInZcIjoxLFwidXJsXCI6XCJodHRwczpcXFwvXFxcL3pvb20udXNcXFwvdVxcXC9jYnJVQXpFM1dcIixcImlkXCI6XCI1NzY5ZmNlY2IyMTA0YjJlOGY5NTdjZDNkMzU3MDQxMlwiLFwidXJsX2lkc1wiOltcImY3NTEyMWVkZGI2NDQ2YjA4YzI1ODAxNjdiMWQ5ODlhM2MyY2FmMTZcIl19In0)

---

From: Evan Schwartz <[email-masked]>
Date: Wed, 5 Sep 2018 01:04:09 -0400

Here's the repo I've been using to work on the ideas for pull payments over ILP: https://github.com/emschwartz/ilp-spsp-pull-token.

Looking forward to hearing your thoughts on the community call!

---

From: Evan Schwartz <[email-masked]>
Date: Wed, 5 Sep 2018 08:54:35 -0400

Yup! The format for expressing the limitations I'm working with now let's
you set an amount, a start time, a duration, and a number of repetitions.
That lets you pay a certain amount per time, like for a subscription.

However, if you want to make sure you only pay in exchange for the service,
we would need to implement a way to update the token mid-stream (or make
new connections each time) so that the customer could give tokens for
successively larger amounts.

Also -- this just made me realize the way I was thinking of implementing
this wouldn't support updating the token with a higher amount. I was
thinking that additional caveats would only let you reduce the amount (so
3rd parties can't increase it). We either need a way to cancel caveats or
we'll just need to use new tokens.

On Wed, Sep 5, 2018, 8:27 AM 中山太雅 <[email-masked]> wrote:

> Just an idea, there may be a use case that "unit pull payments" could
> be utilized.
> "unit payments" mean that two agree upon paying a certain amount a unit
> time.
>
> e.g.
> A requests 1$ / min to B
> B agrees on it
> B pays 1$ for 1min... A serves for 1 min
> B pays 1$ for 1min... A serves for 1 min
> B pays 1$ for 1min... A serves for 1 min
> B pays 1$ for 1min... A serves for 1 min
> B closes the connection
> A stops the service
>
> 2018年9月5日(水) 14:05 Evan Schwartz <[email-masked]>:
> >
> > Here's the repo I've been using to work on the ideas for pull payments
> over ILP: https://github.com/emschwartz/ilp-spsp-pull-token.
> >
> > Update from Strata Labs and Kava on Ethereum and Lightning plugins
> > Join from PC, Mac, Linux, iOS or Android: https://zoom.us/s/377506344
> >
> > Or iPhone one-tap:
> >     US: +1 408 638 0968 or +1 646 876 9923 or +1 669 900 6833
> >     Meeting ID: 377 506 344
> >     International numbers available: https://zoom.us/u/cbrUAzE3W
>
-- 

Evan Schwartz
Software Engineer