Subject: Re: [Ledger] [Hyperledger Quilt] Proposal: Switching from Gitter to something else

From: Evan Schwartz <[email-masked]>
Date: Mon, 4 Feb 2019 17:02:57 -0800

I like the idea of categorizing the options into synchronous and asynchronous communication methods, as proposed in that Rust thread.

Sync
Current: Gitter

Use case: support and, to a lesser extent, design discussion

Main problems: low response rate because a) there aren't enough contributors who are dedicating time to field issues (myself included) and b) few people have Gitter open all the time so checking for new messages is an extra step

My take: Slack isn't great for open source projects but it is the one that most Interledger contributors have sitting open while they're working, so if we're optimizing for making sure people get help that might be the best one

Async
Current: Github Issues, Mailing List

Use case: design discussion, brainstorming

Main problems: Github issue threads get very long and unwieldy, sending emails to the mailing list seems too weighty because it spams everyone's inbox

My take: Discourse might be worth trying out, based on the experience of the Rust and Ethereum Research communities, but I'm not sure how different the participation would be on that type of forum versus on Github issues and PRs.

PS Thanks Akash for taking the initiative to kick off this discussion!

On Feb 4 2019, at 11:49 am, Brian Kerr <[email-masked]> wrote:
> If we want to expand the community, I definitely would recommend switching to something that isn't forcing people to learn a new app. Adding the hurdle of that will hurt on-boarding and engagement.
>
>
> I'd recommend slack or discord because most people already have the apps and are familiar with how to use them.
> Brian Kerr
> Co-founder
> Kava.io
>
>
>
> On Mon, Feb 04, 2019 at 9:30 AM, David Fuelling <[email-masked] (mailto:[email-masked])> wrote:
> > +1 for Slack. As a 2nd choice I would support
> > https://www.discourse.org (0x forum and chat use that and it seems nice).
> >
> > Agree we need to move off of Gitter.
> >
> > On Mon, Feb 4, 2019 at 3:49 AM Akash Khosla <[email-masked] (mailto:[email-masked])> wrote:
> > > Gotcha, in that case I'll move the Hyperledger side to bcc to avoid confusion - this is focused on the Interledger working group which regularly uses Gitter.
> > >
> > > On Mon, Feb 4, 2019 at 2:30 AM Silona Bonewald <[email-masked] (mailto:[email-masked])> wrote:
> > > > Hello,
> > > >
> > > > Silona the VP of community architecture for Hyperledger here
> > > >
> > > > I'm afraid this is something we cannot change easily. All of the projects at Hyperledger need to be on the same chat system.
> > > >
> > > > Http://Chat.hyperledger.org which is rocket chat.
> > > >
> > > > Please follow Ry"s directions earlier about creating an LF ID. A Linux foundation ID. Hyperledger also is a project under the Linux foundation and we also adhere to some of those standards as well.
> > > >
> > > > As a community and especially quilt bring an interopability tool has to work within the larger community of Hyperledger. We have a unified standard. You can read up on the Hyperledger project process more on the wiki.hyperledger.org (http://wiki.hyperledger.org)
> > > >
> > > > Thank you,
> > > > Silona
> > > >
> > > >
> > > > On Sun, Feb 3, 2019, 23:25 Daniel Carroll <[email-masked] (mailto:[email-masked]) wrote:
> > > > > It would likely be good to have a couple of different platforms.
> > > > >
> > > > > I like Discord and Telegram for community chat and general sharing of information. But both are limited in how you can breakdown information into categories and maintain a logical history.
> > > > >
> > > > > I like Slack and Trello for grouping chunks of data within a team attempting productivity.
> > > > >
> > > > > Dan
> > > > >
> > > > > On Feb 3, 2019, at 9:47 PM, Bhaves Shah <[email-masked] (mailto:[email-masked])> wrote:
> > > > > > I assume when looking at the community at large we want a solution that is seccure in nature and also has the feature set to grow as the community grows, although cost could be an issue later..
> > > > > >
> > > > > > You may want to check - https://flock.com/
> > > > > > Cheers!
> > > > > > Bhaves
> > > > > >
> > > > > >
> > > > > > On 4 Feb 2019, at 10:36 AM, Yuriy Dybskiy <[email-masked] (mailto:[email-masked])> wrote:
> > > > > > > Akash, really great proposal!
> > > > > > > I've been using Discord more and more lately so I'm definitely +1 on that one.
> > > > > > > Rocket.chat (http://rocket.chat/) is built with Meteor and I used to be a huge fan of it so I'm +1 on that option as well :)
> > > > > > >
> > > > > > > Discord might be the easiest to setup and more polished so slight preference there, but long term maybe Rocket.chat (http://rocket.chat/) is a better option.
> > > > > > > Curious what others think.
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > On Sat, Feb 2, 2019 at 7:02 PM AKASH KHOSLA <[email-masked] (mailto:[email-masked])> wrote:
> > > > > > > >
> > > > > > > > Hi all,
> > > > > > > >
> > > > > > > > I was wondering if there would be any interest in moving from Gitter to another platform. The main reason I bring this up is because Gitter could be out of the way for a lot of us and the application doesn't encourage dedicated usage. Email lists are a bit old school and signing up for the Interledger one is out of the way. I think the reason for such a cryptic interface for the w3c style/linux foundation emails list is sybil resistance and anti-spam since there are liberal write permissions to the lists. I think scaling the community requires something better than email and Gitter. Would be great to hear thoughts on this.
> > > > > > > >
> > > > > > > > Couple problems with Gitter:
> > > > > > > > Clunky interface
> > > > > > > >
> > > > > > > > Poor separation of conversations/rooms
> > > > > > > >
> > > > > > > > Bad search function
> > > > > > > >
> > > > > > > > Bad mobile app
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > Some alternatives I think users enjoy using, and are well known in dev communities:
> > > > > > > >
> > > > > > > > Rocket.chat (https://rocket.chat/)
> > > > > > > > Pros:
> > > > > > > > Open source chat (basically a friendly IRC replacement)
> > > > > > > >
> > > > > > > > Self hosting is free, cloud options available, easy to deploy with scripts
> > > > > > > >
> > > > > > > > Slack-like interface
> > > > > > > >
> > > > > > > > Good search functionality
> > > > > > > >
> > > > > > > > Threads (https://github.com/RocketChat/Rocket.Chat/pull/11803#issuecomment-455963816) are being implemented
> > > > > > > >
> > > > > > > > Usable mobile applications
> > > > > > > >
> > > > > > > > Actively maintained + marketplace integrations
> > > > > > > >
> > > > > > > > Can deploy at chat.interledger.org (http://chat.interledger.org) (would be happy to help).
> > > > > > > >
> > > > > > > > Easy sign in with GitHub, just like gitter.
> > > > > > > >
> > > > > > > >
> > > > > > > > Cons:
> > > > > > > >
> > > > > > > > Not as well known as discord, slack or gitter from what I can tell, but I expect it to continue to grow in usage down the line and gain even more support than it already has.
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > Discord
> > > > > > > > Pros:
> > > > > > > > Commonly used
> > > > > > > >
> > > > > > > > Free to use unlike sack
> > > > > > > >
> > > > > > > > Fast and friendly
> > > > > > > >
> > > > > > > > Solid mobile apps
> > > > > > > >
> > > > > > > > Actively maintained
> > > > > > > >
> > > > > > > > No self hosting or maintenance
> > > > > > > >
> > > > > > > > Supports integrations
> > > > > > > >
> > > > > > > >
> > > > > > > > Cons:
> > > > > > > >
> > > > > > > > May not be free forever
> > > > > > > >
> > > > > > > > Chat logs are owned by Discord
> > > > > > > >
> > > > > > > > More complex interface than Slack/Rocket (some colleagues and I describe it as heavier
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > This list may not be complete in terms of pros and cons so please chime in if you have a personal preference or have something to say about these platforms or others. I've spent some time with both alternatives, you can generally find demos on their corresponding websites to see what you like best.
> > > > > > > >
> > > > > > > > Akash Khosla
> > > > > > > > Fourth Year EECS
> > > > > > > > [email-masked] (mailto:[email-masked])
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Best regards,
> > > > > > >
> > > > > > > Yuriy @html5cat (http://twitter.com/html5cat) Dybskiy
> > > > > > >
> > > > > > > e-mail: [email-masked] (mailto:[email-masked])
> > > > > > > phone: +1 (650) 434-2004
> > > > > > >
> > > > > > >
> > > > > > > Dybskiy.com (http://dybskiy.com) / Twitter (http://twitter.com/html5cat) / GitHub (http://github.com/html5cat) / Linkedin (http://ca.linkedin..com/in/dybskiy)
> > > > > _._,_._,_
> > > > > Links:
> > > > > You receive all messages sent to this group.
> > > > >
> > > > > View/Reply Online (#85) (https://lists.hyperledger.org/g/quilt/message/85) | Reply To Sender (mailto:?subject=Private:%20Re:%20Re%3A%20%5BHyperledger%20Quilt%5D%20Proposal%3A%20Switching%20from%20Gitter%20to%20something%20else) | Reply To Group (mailto:[email-masked]?subject=Re:%20Re%3A%20%5BHyperledger%20Quilt%5D%20Proposal%3A%20Switching%20from%20Gitter%20to%20something%20else) | Mute This Topic (https://lists.hyperledger.org/mt/29637867/1540173) | New Topic (https://lists.hyperledger.org/g/quilt/post)
> > > > > Your Subscription (https://lists.hyperledger.org/g/quilt/editsub/1540173) | Contact Group Owner (mailto:[email-masked]) | Unsubscribe (https://lists.hyperledger.org/g/quilt/unsub) [[email-masked] (mailto:[email-masked])]
> > > > > _._,_._,_

---

From: "AKASH KHOSLA" <[email-masked]>
Date: Tue, 05 Feb 2019 01:40:03 -0800

Based on the comments received and talking to people offline I think what's best going forward is to create a self-hosted Discourse as an asynchronous forum to replace email , and have the synchronous chat that replaces Gitter be Discord/Slack. No rocket.chat or niche platforms to avoid developer overhead.

The only questions are now:
-What subdomain should the Discourse be at? forum.interledger.org? or disc.interledger.org or research.interledger.org? 
-Does it make sense for Discourse to have very clearly defined rules for discussions for enforcing high signal to noise ratio (like on https://ethresear.ch/ )? I'm leaning more towards this, and I think that's the most effective way to use the platform while ensuring the Interledger community steers toward productive discussions. Early on, we can be lenient about this and enforce as needed. 
-Should we use bridging software?  ( https://github.com/42wim/matterbridge ) Note that this is not ideal, because moderation is fragmented, and the interoperability aspect basically relies on a bot receiving messages from another client and pushing it to a chat log. You can see the demos on matterbridge to see what I mean. 
-Assuming money not an issue, it looks like Slack is the preferred way to do things vs. Discord. Only downside is that Slack's interface for joining chats is not great (requires an auto-invite tool to be hosted), but I think that's ok, I've generally had better community experiences through Slack despite that.

As long as we have a Discourse that stays with us forever with most of the valuable information, we can always move our synchronous chat if it ever becomes a problem.

*Akash Khosla*
Fourth Year EECS
[email-masked]

On Mon, Feb 4th, 2019 at 5:2 PM, Evan Schwartz <[email-masked]> wrote:

> 
> I like the idea of categorizing the options into synchronous and
> asynchronous communication methods, as proposed in that Rust thread.
> 
> Sync
> 
> 
> * 
> Current : Gitter
> 
> * 
> Use case : support and, to a lesser extent, design discussion
> 
> * 
> Main problems : low response rate because a) there aren't enough
> contributors who are dedicating time to field issues (myself included) and
> b) few people have Gitter open all the time so checking for new messages
> is an extra step
> 
> * 
> My take : Slack isn't great for open source projects but it is the one that
> most Interledger contributors have sitting open while they're working, so
> if we're optimizing for making sure people get help that might be the best
> one
> 
> 
> 
> Async
> 
> 
> * 
> Current : Github Issues, Mailing List
> 
> * 
> Use case : design discussion, brainstorming
> 
> * 
> Main problems : Github issue threads get very long and unwieldy, sending
> emails to the mailing list seems too weighty because it spams everyone's
> inbox
> 
> * 
> My take : Discourse might be worth trying out, based on the experience of
> the Rust and Ethereum Research communities, but I'm not sure how different
> the participation would be on that type of forum versus on Github issues
> and PRs.
> 
> 
> 
> On Feb 4 2019, at 11:49 am, Brian Kerr < [email-masked] > wrote:
> 
>> If we want to expand the community, I definitely would recommend switching
>> to something that isn't forcing people to learn a new app.  Adding the
>> hurdle of that will hurt on-boarding and engagement. 
>> 
>> 
>> On Mon, Feb 04, 2019 at 9:30 AM, David Fuelling < [email-masked] >
>> wrote:
>> 
>>> On Mon, Feb 4, 2019 at 3:49 AM Akash Khosla < [email-masked] > wrote:
>>> 
>>> 
>>>> Gotcha, in that case I'll move the Hyperledger side to bcc to avoid
>>>> confusion - this is focused on the Interledger working group which
>>>> regularly uses Gitter.
>>>> 
>>>> On Mon, Feb 4, 2019 at 2:30 AM Silona Bonewald < [email-masked]
>>>> > wrote:
>>>> 
>>>>> Hello,
>>>>> 
>>>>> 
>>>>> I'm afraid this is something we cannot change easily. All of the projects
>>>>> at Hyperledger need to be on the same chat system. 
>>>>> 
>>>>> 
>>>>> Http://Chat.hyperledger.org ( http://Http://Chat.hyperledger.org ) which is
>>>>> rocket chat. 
>>>>> 
>>>>> 
>>>>> Please follow Ry"s directions earlier about creating an LF ID. A Linux
>>>>> foundation ID.  Hyperledger also is a project under the Linux foundation
>>>>> and we also adhere to some of those standards as well.
>>>>> 
>>>>> 
>>>>> As a community and especially quilt bring an interopability tool has to
>>>>> work within the larger community of Hyperledger.  We have a unified
>>>>> standard. You can read up on the Hyperledger project process more on the wiki.hyperledger.org
>>>>> ( http://wiki.hyperledger.org ) 
>>>>> 
>>>>> 
>>>>> Thank you,
>>>>> Silona
>>>>> 
>>>>> On Sun, Feb 3, 2019, 23:25 Daniel Carroll < [email-masked]
>>>>> wrote:
>>>>> 
>>>>>> I like Discord and Telegram for community chat and general sharing of
>>>>>> information. But both are limited in how you can breakdown information
>>>>>> into categories and maintain a logical history. 
>>>>>> 
>>>>>> 
>>>>>> On Feb 3, 2019, at 9:47 PM, Bhaves Shah < [email-masked] >
>>>>>> wrote:
>>>>>> 
>>>>>> 
>>>>>> 
>>>>> 
>>>>> 
>>>> 
>>>> 
>>>>> 
>>>>>> 
>>>>>>> I assume when looking at the community at large we want a solution that is
>>>>>>> seccure in nature and also has the feature set to grow as the community
>>>>>>> grows, although cost could be an issue later..
>>>>>>> 
>>>>>>> 
>>>>>>> On 4 Feb 2019, at 10:36 AM, Yuriy Dybskiy < [email-masked] > wrote:
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>>> Rocket.chat ( http://rocket.chat/ ) is built with Meteor and I used to be a
>>>>>>>> huge fan of it so I'm +1 on that option as well :)
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Discord might be the easiest to setup and more polished so slight
>>>>>>>> preference there, but long term maybe Rocket.chat ( http://rocket.chat/ ) is
>>>>>>>> a better option.
>>>>>>>> On Sat, Feb 2, 2019 at 7:02 PM AKASH KHOSLA < [email-masked] > wrote:
>>>>>>>> 
>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> Hi all,
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> I was wondering if there would be any interest in moving from Gitter to
>>>>>>>>> another platform. The main reason I bring this up is because Gitter could
>>>>>>>>> be out of the way for a lot of us and the application doesn't encourage
>>>>>>>>> dedicated usage. Email lists are a bit old school and signing up for the
>>>>>>>>> Interledger one is out of the way. I think the reason for such a cryptic
>>>>>>>>> interface for the w3c style/linux foundation emails list is sybil
>>>>>>>>> resistance and anti-spam since there are liberal write permissions to the
>>>>>>>>> lists. I think scaling the community requires something better than email
>>>>>>>>> and Gitter. Would be great to hear thoughts on this.
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> *Rocket.chat ( https://rocket.chat/ )*
>>>>>>>>> Pros:
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> Threads (
>>>>>>>>> https://github.com/RocketChat/Rocket.Chat/pull/11803#issuecomment-455963816
>>>>>>>>> ) are being implemented
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> Can deploy at chat.interledger.org ( http://chat.interledger.org ) (would
>>>>>>>>> be happy to help).
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> Not as well known as discord, slack or gitter from what I can tell, but I
>>>>>>>>> expect it to continue to grow in usage down the line and gain even more
>>>>>>>>> support than it already has.
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> *Discord*
>>>>>>>>> Pros:
>>>>>>>>> * 
>>>>>>>>> Commonly used
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> Free to use unlike sack
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> Fast and friendly
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> Solid mobile apps
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> Actively maintained
>>>>>>>>> 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> * 
>>>>>>>>> This list may not be complete in terms of pros and cons so please chime in
>>>>>>>>> if you have a personal preference or have something to say about these
>>>>>>>>> platforms or others. I've spent some time with both alternatives, you can
>>>>>>>>> generally find demos on their corresponding websites to see what you like
>>>>>>>>> best.
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> *Akash Khosla*
>>>>>>>>> Fourth Year EECS
>>>>>>>>> [email-masked]
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> --
>>>>>>>> Best regards,
>>>>>>>> Yuriy @html5cat ( http://twitter.com/html5cat ) Dybskiy
>>>>>>>> 
>>>>>>>> 
>>>>>>>> e-mail: [email-masked]
>>>>>>>> phone: +1 (650) 434-2004
>>>>>>>> 
>>>>>>>> Dybskiy.com ( http://dybskiy.com ) / Twitter ( http://twitter.com/html5cat
>>>>>>>> ) / GitHub ( http://github.com/html5cat ) / Linkedin (
>>>>>>>> http://ca.linkedin..com/in/dybskiy )
>>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>> 
>>>>>> 
>>>>> 
>>>>> 
>>>> 
>>>> 
>>>>> 
>>>>>> _._,_._,_
>>>>>> Links:
>>>>>> View/Reply Online (#85) ( https://lists.hyperledger.org/g/quilt/message/85
>>>>>> ) | Reply To Sender (
>>>>>> ?subject=Private:%20Re:%20Re%3A%20%5BHyperledger%20Quilt%5D%20Proposal%3A%20Switching%20from%20Gitter%20to%20something%20else
>>>>>> ) | Reply To Group (
>>>>>> [email-masked]?subject=Re:%20Re%3A%20%5BHyperledger%20Quilt%5D%20Proposal%3A%20Switching%20from%20Gitter%20to%20something%20else
>>>>>> ) | Mute This Topic ( https://lists.hyperledger.org/mt/29637867/1540173 ) |
>>>>>> New Topic ( https://lists.hyperledger.org/g/quilt/post )
>>>>>> 
>>>>>> Your Subscription ( https://lists.hyperledger.org/g/quilt/editsub/1540173 )
>>>>>> | Contact Group Owner ( [email-masked] ) | Unsubscribe (
>>>>>> https://lists.hyperledger.org/g/quilt/unsub ) [ [email-masked]
>>>>>> ]
>>>>>> 
>>>>>> _._,_._,_
>>>>>> 
>>>>> 
>>>>> 
>>>> 
>>>> 
>>> 
>>> 
>> 
>> 
> 
>

---

From: "AKASH KHOSLA" <[email-masked]>
Date: Tue, 05 Feb 2019 01:40:03 -0800

*Akash Khosla*
Fourth Year EECS
[email-masked]

---

From: Evan Schwartz <[email-masked]>
Date: Tue, 5 Feb 2019 09:13:47 -0800

I signed up for a trial Discourse account and submitted the request to have them host it for free because it's for an open source project. I'm waiting to hear back on that and working on getting the DNS set up to point forum.interledger.org to it (let me know if anyone feels strongly that the domain should be something else). If they don't approve the free hosting request, we can switch it over to a self-hosted version (and migrate the data).

> Should we use bridging software?
If anyone wants to use it, they would be more than welcome to set it up
> Does it make sense for Discourse to have very clearly defined rules for discussions for enforcing high signal to noise ratio (like on https://ethresear.ch/)?
Possibly; what kind of rules would you envision? (Right now, though, I'm not too worried about having too much discussion. If that becomes a problem, I think we can cross that bridge when we get there)
On Feb 5 2019, at 4:40 am, AKASH KHOSLA <[email-masked]> wrote:
>
> Based on the comments received and talking to people offline I think what's best going forward is to create a self-hosted Discourse as an asynchronous forum to replace email, and have the synchronous chat that replaces Gitter be Discord/Slack. No rocket.chat or niche platforms to avoid developer overhead.
>
> -Does it make sense for Discourse to have very clearly defined rules for discussions for enforcing high signal to noise ratio (like on https://ethresear.ch/)? I'm leaning more towards this, and I think that's the most effective way to use the platform while ensuring the Interledger community steers toward productive discussions. Early on, we can be lenient about this and enforce as needed.
> -Should we use bridging software? (https://github.com/42wim/matterbridge) Note that this is not ideal, because moderation is fragmented, and the interoperability aspect basically relies on a bot receiving messages from another client and pushing it to a chat log. You can see the demos on matterbridge to see what I mean.
>
> > On Feb 4 2019, at 11:49 am, Brian Kerr <[email-masked] (mailto:[email-masked])> wrote:
> > > > > > Http://Chat.hyperledger.org (http://Http://Chat.hyperledger.org) which is rocket chat.
> > > > > >

---

From: "AKASH KHOSLA" <[email-masked]>
Date: Tue, 05 Feb 2019 14:02:16 -0800

This a public forum for participating in Interledger's research efforts, including but not limited to:
* Scaling
* Load balancing
* Connector topology
* Routing
* Decentralized Exchange
* Market Making
* Fee Markets
* Economics
* Privacy techniques
* Custody
* ILP improvements (pre-RFC)

This is *not* the place for:

* Generic crypto and Interledger discussion (use Slack)
* Discussing specific PRs and in progress RFCs (use GitHub)

Technical questions are ok as long as they are relevant and are non-repeats.

Just don't want to have randos asking about when the next ILP plug-in is going to be released on here or "when wallet".

*Akash Khosla*
Fourth Year EECS
[email-masked]

On Tue, Feb 5th, 2019 at 9:13 AM, Evan Schwartz <[email-masked]> wrote:

> 
> I signed up for a trial Discourse account and submitted the request to
> have them host it for free because it's for an open source project. I'm
> waiting to hear back on that and working on getting the DNS set up to
> point forum.interledger.org ( http://forum.interledger.org ) to it (let me
> know if anyone feels strongly that the domain should be something else).
> If they don't approve the free hosting request, we can switch it over to a
> self-hosted version (and migrate the data).
> 
> > Does it make sense for Discourse to have very clearly defined rules for
> discussions for enforcing high signal to noise ratio (like on https://ethresear.ch/
> )?
> 
> Possibly; what kind of rules would you envision? (Right now, though, I'm
> not too worried about having too much discussion. If that becomes a
> problem, I think we can cross that bridge when we get there)
> 
> 
> On Feb 5 2019, at 4:40 am, AKASH KHOSLA < [email-masked] > wrote:
> 
>> 
>> Based on the comments received and talking to people offline I think
>> what's best going forward is to create a self-hosted Discourse as an
>> asynchronous forum to replace email, and have the synchronous chat that
>> replaces Gitter be Discord/Slack. No rocket.chat or niche platforms to
>> avoid developer overhead.
>> 
>> 
>> -What subdomain should the Discourse be at? forum.interledger.org? or
>> disc.interledger.org or research.interledger.org? 
>> -Does it make sense for Discourse to have very clearly defined rules for
>> discussions for enforcing high signal to noise ratio (like on https://ethresear.ch/
>> )? I'm leaning more towards this, and I think that's the most effective
>> way to use the platform while ensuring the Interledger community steers
>> toward productive discussions. Early on, we can be lenient about this and
>> enforce as needed. 
>> -Should we use bridging software?  ( https://github.com/42wim/matterbridge
>> ) Note that this is not ideal, because moderation is fragmented, and the
>> interoperability aspect basically relies on a bot receiving messages from
>> another client and pushing it to a chat log. You can see the demos on
>> matterbridge to see what I mean. 
>> -Assuming money not an issue, it looks like Slack is the preferred way to
>> do things vs. Discord. Only downside is that Slack's interface for joining
>> chats is not great (requires an auto-invite tool to be hosted), but I
>> think that's ok, I've generally had better community experiences through
>> Slack despite that.
>> 
>> 
>> As long as we have a Discourse that stays with us forever with most of the
>> valuable information, we can always move our synchronous chat if it ever
>> becomes a problem.
>> 
>> 
>> *Akash Khosla*
>> Fourth Year EECS
>> [email-masked]
>> 
>> 
>> 
>> On Mon, Feb 4th, 2019 at 5:2 PM, Evan Schwartz < [email-masked] > wrote:
>> 
>>> Main problems: low response rate because a) there aren't enough
>>> My take: Slack isn't great for open source projects but it is the one that
>>> Main problems: Github issue threads get very long and unwieldy, sending
>>> My take: Discourse might be worth trying out, based on the experience of

---

From: "AKASH KHOSLA" <[email-masked]>
Date: Tue, 05 Feb 2019 21:16:28 -0800

Thanks to Evan for getting this up! https://forum.interledger.org

*Akash Khosla*
Fourth Year EECS
[email-masked]

On Tue, Feb 5th, 2019 at 2:2 PM, AKASH KHOSLA <[email-masked]> wrote:

> Just don't want to have randos asking about when the next ILP plug-in is
> going to be released on here or "when wallet".
> 
> 
> 
> 
> 
> 
> *Akash Khosla*
> Fourth Year EECS
> [email-masked]
> 
> 
> 
> 
> On Tue, Feb 5th, 2019 at 9:13 AM, Evan Schwartz < [email-masked] > wrote:
> 
> 
>