Subject: Re: [Ledger] [Hyperledger Quilt] Proposal: Switching from Gitter to something else

From: David Fuelling <[email-masked]>
Date: Mon, 4 Feb 2019 10:30:15 -0700

+1 for Slack. As a 2nd choice I would support
https://www.discourse.org (0x forum and chat use that and it seems nice).

Agree we need to move off of Gitter.

On Mon, Feb 4, 2019 at 3:49 AM Akash Khosla <[email-masked]> wrote:

> Gotcha, in that case I'll move the Hyperledger side to bcc to avoid
> confusion - this is focused on the Interledger working group which
> regularly uses Gitter.
>
> On Mon, Feb 4, 2019 at 2:30 AM Silona Bonewald <
> [email-masked]> wrote:
>
>> Hello,
>>
>> Silona the VP of community architecture for Hyperledger here
>>
>> I'm afraid this is something we cannot change easily. All of the projects
>> at Hyperledger need to be on the same chat system.
>>
>> Http://Chat.hyperledger.org which is rocket chat.
>>
>> Please follow Ry"s directions earlier about creating an LF ID. A Linux
>> foundation ID.  Hyperledger also is a project under the Linux foundation
>> and we also adhere to some of those standards as well.
>>
>> As a community and especially quilt bring an interopability tool has to
>> work within the larger community of Hyperledger.  We have a unified
>> standard. You can read up on the Hyperledger project process more on the
>> wiki.hyperledger.org
>>
>> Thank you,
>> Silona
>>
>> On Sun, Feb 3, 2019, 23:25 Daniel Carroll <
>> [email-masked] wrote:
>>
>>> It would likely be good to have a couple of different platforms.
>>>
>>> I like Discord and Telegram for community chat and general sharing of
>>> information. But both are limited in how you can breakdown information into
>>> categories and maintain a logical history.
>>>
>>> I like Slack and Trello for grouping chunks of data within a team
>>> attempting productivity.
>>>
>>> Dan
>>>
>>> On Feb 3, 2019, at 9:47 PM, Bhaves Shah <[email-masked]>
>>> wrote:
>>>
>>> I assume when looking at the community at large we want a solution that
>>> is seccure in nature and also has the feature set to grow as the community
>>> grows, although cost could be an issue later..
>>>
>>> You may want to check -  https://flock.com/
>>>
>>> Cheers!
>>> Bhaves
>>>
>>> On 4 Feb 2019, at 10:36 AM, Yuriy Dybskiy <[email-masked]> wrote:
>>>
>>> Akash, really great proposal!
>>> I've been using Discord more and more lately so I'm definitely +1 on
>>> that one.
>>> Rocket.chat is built with Meteor and I used to be a huge fan of it so
>>> I'm +1 on that option as well :)
>>>
>>> Discord might be the easiest to setup and more polished so slight
>>> preference there, but long term maybe Rocket.chat is a better option.
>>> Curious what others think.
>>>
>>> On Sat, Feb 2, 2019 at 7:02 PM AKASH KHOSLA <[email-masked]>
>>> wrote:
>>>
>>>> Hi all,
>>>>
>>>> I was wondering if there would be any interest in moving from Gitter to
>>>> another platform. The main reason I bring this up is because Gitter could
>>>> be out of the way for a lot of us and the application doesn't encourage
>>>> dedicated usage. Email lists are a bit old school and signing up for the
>>>> Interledger one is out of the way. I think the reason for such a cryptic
>>>> interface for the w3c style/linux foundation emails list is sybil
>>>> resistance and anti-spam since there are liberal write permissions to the
>>>> lists. I think scaling the community requires something better than email
>>>> and Gitter. Would be great to hear thoughts on this.
>>>>
>>>> Couple problems with Gitter:
>>>>
>>>>    1. Clunky interface
>>>>    2. Poor separation of conversations/rooms
>>>>    3. Bad search function
>>>>    4. Bad mobile app
>>>>
>>>>
>>>> Some alternatives I think users enjoy using, and are well known in dev
>>>> communities:
>>>>
>>>> *Rocket.chat <https://rocket.chat/>*
>>>> Pros:
>>>>
>>>>    1. Open source chat (basically a friendly IRC replacement)
>>>>    2. Self hosting is free, cloud options available, easy to deploy
>>>>    with scripts
>>>>    3. Slack-like interface
>>>>    4. Good search functionality
>>>>    5. Threads
>>>>    <https://github.com/RocketChat/Rocket.Chat/pull/11803#issuecomment-455963816>
>>>>    are being implemented
>>>>    6. Usable mobile applications
>>>>    7. Actively maintained + marketplace integrations
>>>>    8. Can deploy at chat.interledger.org (would be happy to help).
>>>>    9. Easy sign in with GitHub, just like gitter.
>>>>
>>>> Cons:
>>>>
>>>>    1. Not as well known as discord, slack or gitter from what I can
>>>>    tell, but I expect it to continue to grow in usage down the line and gain
>>>>    even more support than it already has.
>>>>
>>>>
>>>> *Discord*
>>>> Pros:
>>>>
>>>>    1. Commonly used
>>>>    2. Free to use unlike sack
>>>>    3. Fast and friendly
>>>>    4. Solid mobile apps
>>>>    5. Actively maintained
>>>>    6. No self hosting or maintenance
>>>>    7. Supports integrations
>>>>
>>>> Cons:
>>>>
>>>>    1. May not be free forever
>>>>    2. Chat logs are owned by Discord
>>>>    3. More complex interface than Slack/Rocket (some colleagues and I
>>>>    describe it as heavier
>>>>
>>>>
>>>> This list may not be complete in terms of pros and cons so please chime
>>>> in if you have a personal preference or have something to say about these
>>>> platforms or others. I've spent some time with both alternatives, you can
>>>> generally find demos on their corresponding websites to see what you like
>>>> best.
>>>>
>>>> *Akash Khosla*
>>>> Fourth Year EECS
>>>> [email-masked]
>>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Yuriy @html5cat <http://twitter.com/html5cat> Dybskiy
>>>
>>> e-mail: [email-masked]
>>> phone: +1 (650) 434-2004
>>>
>>> Dybskiy.com <http://dybskiy.com> / Twitter <http://twitter.com/html5cat>
>>>  / GitHub <http://github.com/html5cat> / Linkedin
>>> <http://ca.linkedin.com/in/dybskiy>
>>>
>>> _._,_._,_
>>> ------------------------------
>>> Links:
>>>
>>> You receive all messages sent to this group.
>>>
>>> View/Reply Online (#85)
>>> <https://lists.hyperledger.org/g/quilt/message/85> | Reply To Sender
>>> <?subject=Private:%20Re:%20Re%3A%20%5BHyperledger%20Quilt%5D%20Proposal%3A%20Switching%20from%20Gitter%20to%20something%20else>
>>> | Reply To Group
>>> <[email-masked]?subject=Re:%20Re%3A%20%5BHyperledger%20Quilt%5D%20Proposal%3A%20Switching%20from%20Gitter%20to%20something%20else>
>>> | Mute This Topic <https://lists.hyperledger.org/mt/29637867/1540173> | New
>>> Topic <https://lists.hyperledger.org/g/quilt/post>
>>>
>>> Your Subscription
>>> <https://lists.hyperledger.org/g/quilt/editsub/1540173> | Contact Group
>>> Owner <[email-masked]> | Unsubscribe
>>> <https://lists.hyperledger.org/g/quilt/unsub> [
>>> [email-masked]]
>>> _._,_._,_
>>>
>>>

---

From: Daniel Carroll <[email-masked]>
Date: Mon, 4 Feb 2019 00:23:33 -0500

I like Discord and Telegram for community chat and general sharing of information. But both are limited in how you can breakdown information into categories and maintain a logical history. 

I like Slack and Trello for grouping chunks of data within a team attempting productivity. 

Dan

> On Feb 3, 2019, at 9:47 PM, Bhaves Shah <[email-masked]> wrote:
> 
> I assume when looking at the community at large we want a solution that is seccure in nature and also has the feature set to grow as the community grows, although cost could be an issue later..
> 
>> I've been using Discord more and more lately so I'm definitely +1 on that one. 
>> Rocket.chat is built with Meteor and I used to be a huge fan of it so I'm +1 on that option as well :)
>> 
>> Discord might be the easiest to setup and more polished so slight preference there, but long term maybe Rocket.chat is a better option.
>>> On Sat, Feb 2, 2019 at 7:02 PM AKASH KHOSLA <[email-masked]> wrote:
>>> 
>>> Hi all,
>>> 
>>> I was wondering if there would be any interest in moving from Gitter to another platform. The main reason I bring this up is because Gitter could be out of the way for a lot of us and the application doesn't encourage dedicated usage. Email lists are a bit old school and signing up for the Interledger one is out of the way. I think the reason for such a cryptic interface for the w3c style/linux foundation emails list is sybil resistance and anti-spam since there are liberal write permissions to the lists. I think scaling the community requires something better than email and Gitter. Would be great to hear thoughts on this.
>>> 
>>> Clunky interface
>>> Poor separation of conversations/rooms
>>> Bad search function
>>> Bad mobile app
>>> 
>>> Some alternatives I think users enjoy using, and are well known in dev communities:
>>> 
>>> Rocket.chat
>>> Pros:
>>> Open source chat (basically a friendly IRC replacement)
>>> Self hosting is free, cloud options available, easy to deploy with scripts
>>> Slack-like interface
>>> Good search functionality
>>> Threads are being implemented
>>> Usable mobile applications
>>> Actively maintained + marketplace integrations
>>> Can deploy at chat.interledger.org (would be happy to help).
>>> Easy sign in with GitHub, just like gitter.
>>> Cons:
>>> Not as well known as discord, slack or gitter from what I can tell, but I expect it to continue to grow in usage down the line and gain even more support than it already has.
>>> 
>>> Discord
>>> Pros:
>>> Commonly used
>>> Free to use unlike sack
>>> Fast and friendly
>>> Solid mobile apps
>>> Actively maintained
>>> No self hosting or maintenance
>>> Supports integrations
>>> Cons:
>>> May not be free forever
>>> Chat logs are owned by Discord
>>> More complex interface than Slack/Rocket (some colleagues and I describe it as heavier
>>> 
>>> This list may not be complete in terms of pros and cons so please chime in if you have a personal preference or have something to say about these platforms or others. I've spent some time with both alternatives, you can generally find demos on their corresponding websites to see what you like best.
>>> 
>>> 		
>>> Akash Khosla
>>> Fourth Year EECS
>>> [email-masked]
>> 
>> 
>> -- 
>> Best regards,
>> Yuriy @html5cat Dybskiy
>> 
>> Dybskiy.com / Twitter / GitHub / Linkedin

---

From: Akash Khosla <[email-masked]>
Date: Mon, 4 Feb 2019 02:48:04 -0800

On Mon, Feb 4, 2019 at 2:30 AM Silona Bonewald <
[email-masked]> wrote:

>> Your Subscription <https://lists.hyperledger.org/g/quilt/editsub/1540173>
>> | Contact Group Owner <[email-masked]> | Unsubscribe