Subject: [Lime] Stephen Farrell's No Objection on charter-ietf-lime-00-10: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Thu, 02 Oct 2014 08:11:59 -0700

Stephen Farrell has entered the following ballot position for
charter-ietf-lime-00-10: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/charter-ietf-lime/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I would suggest that this WG also consider the potential impact
of ciphertext becoming much more common in networks to
be managed. It would be a pity if this work assumed that all
or most data is cleartext. I'd say just adding a sentence that 
this is in scope for consideration would be enough.

---

From: Benoit Claise <[email-masked]>
Date: Thu, 02 Oct 2014 17:42:19 +0200

Hi Stephen,

Would you have a proposed sentence?

Regards, Benoit

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 02 Oct 2014 17:23:29 +0100

> Would you have a proposed sentence?

Not sure, but how about "The WG will consider the impact(s) of
much more common use of encryption on OAM" or something like
that?

S

---

From: Rene Struik <[email-masked]>
Date: Thu, 02 Oct 2014 12:28:57 -0400

Hi Stephen:

I am somewhat concerned that every nail is considered with the 
"pervasive monitoring" hammer.

Personally, I think this a very myopic world view and viewing everything 
in this way is not necessarily in the best interest of bettering the 
overall security posture of the internet at large.

(Of course, like everyone else one is entitled to one's own opinion, but 
being Security AD bears also the responsibility to view a 
multidimensional problem in multiple dimensions, without singling out 
too much a single topic item.)

Best regards, Rene

On 10/2/2014 11:42 AM, Benoit Claise wrote:
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

-- 
email: [email-masked] | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 02 Oct 2014 18:04:02 +0100

> "pervasive monitoring" hammer.

Heh. The metaphor seems a bit backwards though. But actually there
are loads of reasons why more ciphertext will be seen, not just PM
so I think considering the issue is just sensible.

S.

---

From: Qin Wu <[email-masked]>
Date: Fri, 3 Oct 2014 01:03:30 +0000

Yes, There was some discussion on list regarding security aspect.  
http://www.ietf.org/mail-archive/web/lime/current/msg00055.html
Unfortunately we haven't arrived at any agreement on adding it into the LIME Charter.

Also since NETCONF needs YANG DML, the 5th paragraph, security section of RFC6020 should apply.

Regards!
-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Stephen Farrell
发送时间: 2014年10月2日 23:12
收件人: The IESG
抄送: [email-masked]
主题: [Lime] Stephen Farrell's No Objection on charter-ietf-lime-00-10: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I would suggest that this WG also consider the potential impact of ciphertext becoming much more common in networks to be managed. It would be a pity if this work assumed that all or most data is cleartext. I'd say just adding a sentence that this is in scope for consideration would be enough.

---

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Oct 2014 10:36:35 +0200

> much more common use of encryption on OAM" or something like
What I'm missing is: what kind of practical outcomes do you hope for 
with such a sentence in the charter?

Regards, Benoit
> .

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 03 Oct 2014 11:22:47 +0100

On 03/10/14 09:36, Benoit Claise wrote:
>> Not sure, but how about "The WG will consider the impact(s) of much
>> more common use of encryption on OAM" or something like that?

Mostly that the WG take on board that looking inside all or
most packets might no longer be possible, and try do their
good work regardless.

As I said before, this may not be the right place to try
handle all aspects of that issue, but then again maybe starting
here would be good.

S.

>>>> When responding, please keep the subject line intact and reply
>>>> to all email addresses included in the To and CC lines. (Feel
>>>> free to cut this introductory paragraph, however.)
>>>> 
>>>> 
>>>> 
>>>> The document, along with other ballot positions, can be found
>>>> here: http://datatracker.ietf.org/doc/charter-ietf-lime/
>>>> 
>>>> 
>>>> 
>>>> of ciphertext becoming much more common in networks to be
>>>> managed. It would be a pity if this work assumed that all or
>>>> most data is cleartext. I'd say just adding a sentence that

---

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Oct 2014 13:09:55 +0200

> handle all aspects of that issue, but then again maybe starting
Stephen and I just discussed this matter.
While security is important (and will be important part of the guidance 
aspects of the architecture), we don't define a new OAM in this WG. So 
we agreed that this sentence is not necessary.

Regards, Benoit

---

From: Qin Wu <[email-masked]>
Date: Fri, 3 Oct 2014 11:37:31 +0000

Make sense, support.

Regards!
-Qin
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Benoit Claise
发送时间: 2014年10月3日 19:10
收件人: Stephen Farrell; The IESG
抄送: [email-masked]
主题: Re: [Lime] Stephen Farrell's No Objection on charter-ietf-lime-00-10: (with COMMENT)

> Mostly that the WG take on board that looking inside all or most 
> packets might no longer be possible, and try do their good work 
> regardless.
>
> As I said before, this may not be the right place to try handle all 
> aspects of that issue, but then again maybe starting here would be 
> good.
Stephen and I just discussed this matter.
While security is important (and will be important part of the guidance aspects of the architecture), we don't define a new OAM in this WG. So we agreed that this sentence is not necessary.

Regards, Benoit
>>>>> When responding, please keep the subject line intact and reply to 
>>>>> all email addresses included in the To and CC lines. (Feel free to 
>>>>> cut this introductory paragraph, however.)
>>>>>
>>>>>
>>>>>
>>>>> of ciphertext becoming much more common in networks to be managed. 
>>>>> It would be a pity if this work assumed that all or most data is 
>>>>> cleartext. I'd say just adding a sentence that this is in scope 
>>>>> for consideration would be enough.
>>>>>
>>>>>
>>>>>
>>> .
>>>
> .
>