Subject: [Lime] Generic YANG Model for OAM

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Thu, 23 Oct 2014 04:03:09 +0000

Dear all

We have published draft-tissa-yang-oam-model, this ID present a YANG model that provide generic management framework for OAM.

Please take a moment to review and provide comments. Below is the URL to the draft.

:       http://tools.ietf.org/html/draft-tissa-lime-yang-oam-model-01

Thanks
Tissa

---

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Fri, 24 Oct 2014 10:51:55 +0000

Hello Authors,
Please consider the following comments on the draft:
1/ Section 4: Reference to "Section X" to be updated with the correct value.
2/ The same alphabet (x) being used to denote the "deprecated" in status and "rpc" in flags is a bit confusing. Is it possible to change either one of them for better clarity?
3/ Sec 6:   CCM-Interval : missing enum for a few commonly used BFD intervals like 50 ms. I think Nobo has already commented regarding this earlier referring to draft-ietf-bfd-intervals. See earlier discussion here<http://www.ietf.org/mail-archive/web/time/current/msg00092.html>.
4/ Sec1: s/The YANG data mode presented/ The YANG data model presented
5/ Figure 1: s/sub tec/sub tech
6/ Separate timers for Tx and Rx: BFD has the notion of keep-alive messages (CCM) being sent from both ends of the MEP at potentially different rates. Can this be generalized in the common YANG model? In particular, the local MEP can declare a connectivity fault if the keepalives are not received by it from the remoteMEP for a threshold timer based on the negotiated intervals. Please note that the threshold timer varies per remoteMEP.
7/ Sec 6: s/Rve 5/Rev 5
8/ Sec 6: s/Assigm/ Assign (multiple instances)
Thanks
Prasad

From: Lime [mailto:[email-masked]] On Behalf Of Tissa Senevirathne (tsenevir)
Sent: Thursday, October 23, 2014 9:33 AM
To: [email-masked]
Subject: [Lime] Generic YANG Model for OAM

Dear all

Thanks
Tissa

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Fri, 24 Oct 2014 17:24:56 +0000

Hi Prasad

Thanks for the comments. Please see in-line

From: Vengada Prasad Govindan (venggovi)
Sent: Friday, October 24, 2014 3:52 AM
To: Tissa Senevirathne (tsenevir); [email-masked]
Cc: Nobo Akiya (nobo)
Subject: RE: Generic YANG Model for OAM

Hello Authors,
Please consider the following comments on the draft:
1/ Section 4: Reference to "Section X" to be updated with the correct value.
[Answer] Thanks will be updated.

2/ The same alphabet (x) being used to denote the "deprecated" in status and "rpc" in flags is a bit confusing. Is it possible to change either one of them for better clarity?
[Answer] x in the tree is how it is generated from pyang tool. If you read section 5, x is explained as denotion of rpc.
3/ Sec 6:   CCM-Interval : missing enum for a few commonly used BFD intervals like 50 ms. I think Nobo has already commented regarding this earlier referring to draft-ietf-bfd-intervals. See earlier discussion here<http://www.ietf.org/mail-archive/web/time/current/msg00092.html>.
[Answer] CCM will be removed from the gen-YANG. As that is technology specific. It will be moved to technology specific.
4/ Sec1: s/The YANG data mode presented/ The YANG data model presented
[Answer] ack
5/ Figure 1: s/sub tec/sub tech
[Answer] Ack
6/ Separate timers for Tx and Rx: BFD has the notion of keep-alive messages (CCM) being sent from both ends of the MEP at potentially different rates. Can this be generalized in the common YANG model? In particular, the local MEP can declare a connectivity fault if the keepalives are not received by it from the remoteMEP for a threshold timer based on the negotiated intervals. Please note that the threshold timer varies per remoteMEP.
[Answer] Firstly CCM will be removed. Secondly, architecturally we will have generic counters and choice /case statement to extend the counters to include/augment technology specific extensions. Believe these will address what has been requested above.

7/ Sec 6: s/Rve 5/Rev 5
[Answer] Ack
[Answer] Ack
Thanks
Prasad

From: Lime [mailto:[email-masked]] On Behalf Of Tissa Senevirathne (tsenevir)
Sent: Thursday, October 23, 2014 9:33 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Lime] Generic YANG Model for OAM

Dear all

Thanks
Tissa

---

From: Qin Wu <[email-masked]>
Date: Sat, 25 Oct 2014 02:20:24 +0000

Agree to remove CCM since CCM is very ETH CFM specific.
Also Notification needs to be removed as well since it is also ETH CFM specific.

Regards!
-Qin
发件人: Lime [mailto:[email-masked]] 代表 Tissa Senevirathne (tsenevir)
发送时间: 2014年10月25日 1:25
收件人: Vengada Prasad Govindan (venggovi); [email-masked]
抄送: Nobo Akiya (nobo)
主题: Re: [Lime] Generic YANG Model for OAM

Hi Prasad

From: Vengada Prasad Govindan (venggovi)
Sent: Friday, October 24, 2014 3:52 AM
To: Tissa Senevirathne (tsenevir); [email-masked]<mailto:[email-masked]>
Cc: Nobo Akiya (nobo)
Subject: RE: Generic YANG Model for OAM

Hello Authors,
Please consider the following comments on the draft:
1/ Section 4: Reference to “Section X” to be updated with the correct value.
[Answer] Thanks will be updated.

2/ The same alphabet (x) being used to denote the “deprecated” in status and “rpc” in flags is a bit confusing. Is it possible to change either one of them for better clarity?

7/ Sec 6: s/Rve 5/Rev 5
[Answer] Ack

Dear all

Thanks
Tissa