Subject: [Lime] referencing interface defined in ietf-interfaces module

From: Qin Wu <[email-masked]>
Date: Mon, 1 Jun 2015 13:01:31 +0000

In draft-tissa-lime-yang-oam-model-05, there are two ways to represent referencing interface in the ietf-interfaces module:
Representation A:
                leaf interface {
                   type if:interface-ref;
                  description
                  "Interface name as defined by ietf-interfaces";
                }
Representation B:
                leaf interface {
                  type leafref {
                    path "/if:interfaces/if:interface/if:name";
                  }
                  description
                    "Outgoing Interface";

For consistency, we should choose one of them. I believe we should use representation A since interface being referenced is defined in other document.
Comments?

-Qin

---

From: "GUBALLA, JENS (JENS)" <[email-masked]>
Date: Mon, 1 Jun 2015 13:58:58 +0000

Hi Qin,

> In draft-tissa-lime-yang-oam-model-05, there are two ways to represent
> referencing interface in the ietf-interfaces module:
> 
> Representation A:
> 
>                 leaf interface {
> 
>                    type if:interface-ref;
> 
>                   description
> 
> For consistency, we should choose one of them. I believe we should use
> representation A since interface being referenced is defined in other
> document.
[JG] As far as I understand there is no functional difference between A 
and B. Personally I would prefer option A, as this does not require any
knowledge about the paths used in ietf-interfaces.

Did you consider consulting the Yang-doctors for such issues/questions?

https://www.ietf.org/iesg/directorate/yang-doctors.html

Best regards,
Jens

---

From: Qin Wu <[email-masked]>
Date: Mon, 1 Jun 2015 15:37:54 +0000

Thanks Jens for sharing your view and good suggestion.
Yes, we will see how to further consult with YANG doctors for this issue.

-Qin
-----邮件原件-----
发件人: GUBALLA, JENS (JENS) [mailto:[email-masked]] 
发送时间: 2015年6月1日 21:59
收件人: Qin Wu; [email-masked]
主题: RE: referencing interface defined in ietf-interfaces module

Hi Qin,

Best regards,
Jens

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 1 Jun 2015 09:17:07 -0700

Qin,

As Jens mentioned, the ietf-interfaces YANG model has a typedef for referencing the interface, so you might as well use it, rather than (re)defining it.

> On Jun 1, 2015, at 8:37 AM, Qin Wu <[email-masked]> wrote:
> 
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

Mahesh Jethanandani
[email-masked]

---

From: Qin Wu <[email-masked]>
Date: Wed, 3 Jun 2015 00:52:02 +0000

Good point, I agree with you.

-Qin
-----邮件原件-----
发件人: Mahesh Jethanandani [mailto:[email-masked]] 
发送时间: 2015年6月2日 0:17
收件人: Qin Wu
抄送: GUBALLA, JENS (JENS); [email-masked]
主题: Re: [Lime] referencing interface defined in ietf-interfaces module

Qin,

>> In draft-tissa-lime-yang-oam-model-05, there are two ways to 
>> represent referencing interface in the ietf-interfaces module:
>> 
>> Representation A:
>> 
>>                leaf interface {
>> 
>>                   type if:interface-ref;
>> 
>>                  description
>> 
>> For consistency, we should choose one of them. I believe we should 
>> use representation A since interface being referenced is defined in 
>> other document.
> [JG] As far as I understand there is no functional difference between 
> A and B. Personally I would prefer option A, as this does not require 
> any knowledge about the paths used in ietf-interfaces.
> 

Mahesh Jethanandani
[email-masked]