Subject: Re: [Lime] I-D Action: draft-wang-lime-yang-pm-00.txt

From: Qin Wu <[email-masked]>
Date: Fri, 19 Jun 2015 12:20:25 +0000

Hi:
As stated in draft-tissa-lime-yang-oam-model-05, a separate draft with Augmentation of Generic LIME model will be produced
If common Performance Monitoring Statistics are identified.

Here is a initial version of generic performance measurement draft which extends the Generic LIME model by
adding loss and delay measurement to support OAM Performance Management.
https://tools.ietf.org/html/draft-wang-lime-yang-pm-00

Let authors know if you have any comments and suggestions on this draft.

Cheers!
-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2015年6月19日 20:02
收件人: [email-masked]
主题: I-D Action: draft-wang-lime-yang-pm-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Generic YANG Data Model for Operations, Administration, and Maintenance (OAM) Performance Management
        Authors         : Zitao Wang
                          Qin Wu
                          Deepak Kumar
                          Tom Taylor
	Filename        : draft-wang-lime-yang-pm-00.txt
	Pages           : 37
	Date            : 2015-06-19

Abstract:
   This document presents a YANG Data model for OAM Performance
   Management support.  The YANG Model presented in this document
   extends the Generic YANG Data Model for OAM by adding loss and delay
   measurements to support OAM Performance Management.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-wang-lime-yang-pm/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-wang-lime-yang-pm-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Tue, 23 Jun 2015 10:34:40 +0000

Dear authors,

I support this draft. But I have two comments when reading it.
In draft-wang-lime-yang-pm-00, loss measurement is supported. Hence, I am wondering if the loss-repsonder parameter can be enabled to support synthetic loss measurement.
In addition, single ended responder is supported, can I assume dual-ended responder can also be supported as well?

Many thanks.

Regards,

Yan

---

From: wangzitao <[email-masked]>
Date: Wed, 24 Jun 2015 04:33:46 +0000

Yes, for synthetic loss measurement, the loss-responder parameter support synthetic loss measurement. 
And there is a container: measurement-type including a SLM leaf, it can be used to indicate what type of loss measurement will perform.
 
For dual-ended, I think you are right, it can support the dual-ended as well.
The dual-ended allow each local device to calculate the loss on the remote device. 
And in gen-oam-pm model, the measurement-type is a container, which allows easy extension. You can augment it with dual-ended node such as:

augment ”/goam:domains/goam:domain"
+"/goam:MAs/goam:MA/goam:MEP/goampm:loss-measurement"
+"/goampm:measurement-type"{
 leaf dual-ended{
 type boolean;
 }
}

Best Regards!
-Michael

-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Zhuangyan (Yan)
发送时间: 2015年6月23日 18:35
收件人: Qin Wu; [email-masked]
抄送: Tom Taylor
主题: Re: [Lime] I-D Action: draft-wang-lime-yang-pm-00.txt

Dear authors,

Many thanks.

Regards,

Yan

_______________________________________________
Lime mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lime