Subject: [Lime] MEF CFM YANG model

From: Robert Wilton <[email-masked]>
Date: Wed, 22 Jul 2015 07:49:16 +0000

This was a question that I raised briefly with the LIME WG chairs at the
end of the WG meeting, and was asked to repeat here:

My understanding is that MEF have already published a standard CFM YANG
model (MEF 38 - https://www.*mef*.net/Assets/Technical_Specifications/PDF/
*MEF*_*38*.pdf).

Hence I was wondering whether there had been any consideration as to
whether it will be necessary to update the MEF model to be compatible with
the LIME model, and whether there has been or needs to be any engagement
with MEF concerning this?

Quick disclaimer: I've not read either the LIME draft nor the MEF CFM Yang
model!

Thanks,
Rob

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 23 Jul 2015 12:13:58 +0000

The MEF YANG models in MEF 38  date two-three years back. They are outdated and not aligned with the YANG evolution since. MEF has a new YANG project – talk with Mahesh.

Regards,

Dan

From: Lime [mailto:[email-masked]] On Behalf Of Robert Wilton
Sent: Wednesday, July 22, 2015 10:49 AM
To: [email-masked]
Subject: [Lime] MEF CFM YANG model

This was a question that I raised briefly with the LIME WG chairs at the end of the WG meeting, and was asked to repeat here:

My understanding is that MEF have already published a standard CFM YANG model (MEF 38 - https://www<https://urldefense.proofpoint.com/v2/url?u=https-3A__www&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=1U6Z6mTAfMUs8VxcdFiC1evReHrAH1FwTxbPojlaMQQ&s=I-U64Plcoxsiz0fhj80tAt16iiEtty7vWVWCBe-ybSk&e=>.mef.net/Assets/Technical_Specifications/PDF/MEF_38.pdf).

Hence I was wondering whether there had been any consideration as to whether it will be necessary to update the MEF model to be compatible with the LIME model, and whether there has been or needs to be any engagement with MEF concerning this?

Quick disclaimer: I've not read either the LIME draft nor the MEF CFM Yang model!

Thanks,
Rob

---

From: Benoit Claise <[email-masked]>
Date: Thu, 23 Jul 2015 14:44:26 +0200

That's useful info Dan. Thanks

Regard, Benoit
>
> The MEF YANG models in MEF 38  date two-three years back. They are 
> outdated and not aligned with the YANG evolution since. MEF has a new 
> YANG project – talk with Mahesh.
>
> Regards,
>
> Dan
>
> *From:*Lime [mailto:[email-masked]] *On Behalf Of *Robert Wilton
> *Sent:* Wednesday, July 22, 2015 10:49 AM
> *To:* [email-masked]
> *Subject:* [Lime] MEF CFM YANG model
>
> This was a question that I raised briefly with the LIME WG chairs at 
> the end of the WG meeting, and was asked to repeat here:
>
> My understanding is that MEF have already published a standard CFM 
> YANG model (MEF 38 - https://www 
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=1U6Z6mTAfMUs8VxcdFiC1evReHrAH1FwTxbPojlaMQQ&s=I-U64Plcoxsiz0fhj80tAt16iiEtty7vWVWCBe-ybSk&e=>.*mef*.net/Assets/Technical_Specifications/PDF/*MEF*_*38*.pdf). 
>
>
> whether it will be necessary to update the MEF model to be compatible 
> with the LIME model, and whether there has been or needs to be any 
> engagement with MEF concerning this?
>
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 23 Jul 2015 12:53:39 +0000

Hi Dan, et. al,
strictly speaking, MEF Fault Management is not CFM but combination of CFM, formerly IEEE-802.1ag, and Y.1731 that form Ethernet Service OAM.
And if MEF-38 is outdated from YANG POV, then, I assume, MEF-39 that describes Service OAM Performance Monitoring YANG Module may be viewed as lapsed in part of YANG evolution?

                Regards,
                                Greg

From: Lime [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, July 23, 2015 2:14 PM
To: Robert Wilton; [email-masked]
Cc: ext Mahesh Jethanandani
Subject: Re: [Lime] MEF CFM YANG model

Regards,

Dan

From: Lime [mailto:[email-masked]] On Behalf Of Robert Wilton
Sent: Wednesday, July 22, 2015 10:49 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Lime] MEF CFM YANG model

Thanks,
Rob

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 23 Jul 2015 12:54:53 +0000

Yes, this is true for both. Wait however for authoritative responses from Manesh, who is now chairing NETCONF.

Regards,

Dan

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Thursday, July 23, 2015 3:54 PM
To: Romascanu, Dan (Dan); Robert Wilton; [email-masked]
Cc: ext Mahesh Jethanandani
Subject: RE: [Lime] MEF CFM YANG model

Hi Dan, et. al,

                Regards,
                                Greg

To: Robert Wilton; [email-masked]<mailto:[email-masked]>

Regards,

Dan

Thanks,
Rob

---

From: David Ball <[email-masked]>
Date: Thu, 23 Jul 2015 18:52:06 +0100

Hi Dan,

You are correct that MEF has a new YANG project that Mahesh is leading, 
however revising MEF38 and MEF39 is explicitly out of scope for that 
project in MEF.

     David

-- 
David Ball
<[email-masked]>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 24 Jul 2015 12:48:30 +0200

It is out of scope also because of lack of contribution. Do I hear a volunteer to rewrite the model to bring it up to date?

Mahesh Jethanandani
[email-masked]
Editor, MEF YANG project. 

> On Jul 23, 2015, at 7:52 PM, David Ball <[email-masked]> wrote:
> 
> Hi Dan,
> 
> You are correct that MEF has a new YANG project that Mahesh is leading, however revising MEF38 and MEF39 is explicitly out of scope for that project in MEF.
> 
> 
>     David
> 
> 
>> My understanding is that MEF have already published a standard CFM YANG model (MEF 38 - https://www.mef.net/Assets/Technical_Specifications/PDF/MEF_38.pdf). 
>>