Subject: [Lime] draft-tissa-lime-yang-oam-model and draft-ietf-trill-yang-oam feedback

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Jul 2015 14:52:56 +0200

Dear authors,

 From https://www.ietf.org/id/draft-tissa-lime-yang-oam-model-05.txt

    <CODE BEGINS> file "ietf-gen-oam.yang"

    module ietf-gen-oam {
   namespace "urn:ietf:params:xml:ns:yang:ietf-gen-oam";
   prefix goam;

 From https://www.ietf.org/id/draft-ietf-trill-yang-oam-01.txt

    <CODE BEGINS> file "ietf-gen-oam.yang"
    module ietf-trill-oam {
         namespace "urn:cisco:params:xml:ns:yang:ietf-tril-oam";
         prefix trilloam;

The same file argument "ietf-gen-oam.yang" in two different document confuses the extraction tool.

 From https://www.ietf.org/id/draft-ietf-netmod-rfc6087bis-04.txt

        The "<CODE BEGINS>" tag SHOULD be followed by a string identifying
        the file name specified in Section 5.2 of
        [I-D.ietf-netmod-rfc6020bis].  The following example is for the
        '2010-01-18' revision of the 'ietf-foo' module:

          <CODE BEGINS> file "[email-masked]"
            module ietf-foo {
              // ...
              revision 2010-01-18 {
                description "Latest revision";
                reference "RFC XXXX";
              }
              // ...
            }
          <CODE ENDS>

Please correct draft-ietf-trill-yang-oam

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Jul 2015 15:18:02 +0200

Dear authors,

Regarding your draft: draft-tissa-lime-yang-oam-model

pyang --ietf ietf-gen-oam.yang
ietf-gen-oam.yang:596: warning: IETF rule (RFC formatting): line length 
73 exceeds 70 characters

Limit a line to a column width of 70 to avoid errors such as these, 
"warning: IETF rule (RFC formatting): line length 72 exceeds 70 
characters". An example of how to address a line that exceeds 70 columns 
is as follows.

    path "/ipfix-app-info:class-id-dictionary/"

                               + "ipfix-app-info:class-id/ipfix-app-info:id"

Regards, Benoit

-------- Forwarded Message --------
Subject: 	draft-tissa-lime-yang-oam-model and draft-ietf-trill-yang-oam 
feedback
Date: 	Tue, 14 Jul 2015 14:52:56 +0200
From: 	Benoit Claise <[email-masked]>
To: 	[email-masked] <[email-masked]>, 
[email-masked]

Dear authors,

    module ietf-gen-oam {

>Fromhttps://www.ietf.org/id/draft-ietf-trill-yang-oam-01.txt

>Fromhttps://www.ietf.org/id/draft-ietf-netmod-rfc6087bis-04.txt

          <CODE BEGINS> file"[email-masked]"
            module ietf-foo {
              // ...
              revision 2010-01-18 {
                description "Latest revision";
                reference "RFC XXXX";
              }
              // ...
            }
          <CODE ENDS>

Regards, Benoit

---

From: Qin Wu <[email-masked]>
Date: Wed, 15 Jul 2015 00:56:23 +0000

Thanks to get this sort out, we will fix this in the next version.

-Qin
发件人: Lime [mailto:[email-masked]] 代表 Benoit Claise
发送时间: 2015年7月14日 21:18
收件人: [email-masked]
抄送: [email-masked]
主题: [Lime] Fwd: draft-tissa-lime-yang-oam-model and draft-ietf-trill-yang-oam feedback

Dear authors,

pyang --ietf ietf-gen-oam.yang
ietf-gen-oam.yang:596: warning: IETF rule (RFC formatting): line length 73 exceeds 70 characters

Limit a line to a column width of 70 to avoid errors such as these, "warning: IETF rule (RFC formatting): line length 72 exceeds 70 characters". An example of how to address a line that exceeds 70 columns is as follows.

Regards, Benoit

-------- Forwarded Message --------
Subject:

draft-tissa-lime-yang-oam-model and draft-ietf-trill-yang-oam feedback

Date:

Tue, 14 Jul 2015 14:52:56 +0200

From:

Benoit Claise <[email-masked]><mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Dear authors,

   module ietf-gen-oam {

  prefix goam;

   module ietf-trill-oam {

        prefix trilloam;

     <CODE BEGINS> file "[email-masked]"<mailto:[email-masked]>

       module ietf-foo {

         // ...

         revision 2010-01-18 {

           reference "RFC XXXX";

         }

         // ...

       }

     <CODE ENDS>

Regards, Benoit

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Wed, 15 Jul 2015 03:05:43 +0000

Hi,

I will update trill-yang-oam once draft submission is re-opened.

Thanks,
Deepak

From: Lime <[email-masked]<mailto:[email-masked]>> on behalf of Qin Wu <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 14, 2015 at 5:56 PM
To: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lime] Fwd: draft-tissa-lime-yang-oam-model and draft-ietf-trill-yang-oam feedback

-Qin
发件人: Lime [mailto:[email-masked]] 代表 Benoit Claise
发送时间: 2015年7月14日 21:18
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: [Lime] Fwd: draft-tissa-lime-yang-oam-model and draft-ietf-trill-yang-oam feedback

Dear authors,

Regards, Benoit

-------- Forwarded Message --------
Subject:

Date:

From:

To:

[email-masked]<mailto:[email-masked]><[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

Dear authors,

   module ietf-gen-oam {

  prefix goam;

   module ietf-trill-oam {

        prefix trilloam;

       module ietf-foo {

         // ...

         revision 2010-01-18 {

           reference "RFC XXXX";

         }

         // ...

       }

     <CODE ENDS>

Regards, Benoit