Subject: Re: [Lime] I-D Action: draft-wang-lime-yang-pm-00.txt

From: Qin Wu <[email-masked]>
Date: Mon, 13 Jul 2015 03:29:07 +0000

-----邮件原件-----
发件人: wangzitao 
发送时间: 2015年6月24日 12:34
收件人: Zhuangyan (Yan); Qin Wu; [email-masked]
抄送: Tom Taylor
主题: RE: I-D Action: draft-wang-lime-yang-pm-00.txt

Yes, for synthetic loss measurement, the loss-responder parameter support synthetic loss measurement. 
And there is a container: measurement-type including a SLM leaf, it can be used to indicate what type of loss measurement will perform.
 
For dual-ended, I think you are right, it can support the dual-ended as well.
The dual-ended allow each local device to calculate the loss on the remote device. 

[Qin]: Agree.

And in gen-oam-pm model, the measurement-type is a container, which allows easy extension. You can augment it with dual-ended node such as:

augment ”/goam:domains/goam:domain"
+"/goam:MAs/goam:MA/goam:MEP/goampm:loss-measurement"
+"/goampm:measurement-type"{
 leaf dual-ended{
 type boolean;
 }
}
[Qin]:I think the best way to support dual-ended is to define dual-ended-responder parameter and put it under MEP as follows:
    augment "/goam:domains/goam:domain"
      +"/goam:MAs/goam:MA/goam:MEP" {
        leaf dual-ended-delay-responder {
         type boolean;
         }

Best Regards!
-Michael

-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Zhuangyan (Yan)
发送时间: 2015年6月23日 18:35
收件人: Qin Wu; [email-masked]
抄送: Tom Taylor
主题: Re: [Lime] I-D Action: draft-wang-lime-yang-pm-00.txt

Dear authors,

I support this draft. But I have two comments when reading it.
In draft-wang-lime-yang-pm-00, loss measurement is supported. Hence, I am wondering if the loss-repsonder parameter can be enabled to support synthetic loss measurement.
In addition, single ended responder is supported, can I assume dual-ended responder can also be supported as well?

Many thanks.

Regards,

Yan

_______________________________________________
Lime mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lime

---

From: wangzitao <[email-masked]>
Date: Mon, 13 Jul 2015 07:01:24 +0000

-----邮件原件-----
发件人: Qin Wu 
发送时间: 2015年7月13日 11:29
收件人: wangzitao; Zhuangyan (Yan); [email-masked]
抄送: Tom Taylor
主题: RE: I-D Action: draft-wang-lime-yang-pm-00.txt

-----邮件原件-----
发件人: wangzitao 
发送时间: 2015年6月24日 12:34
收件人: Zhuangyan (Yan); Qin Wu; [email-masked]
抄送: Tom Taylor
主题: RE: I-D Action: draft-wang-lime-yang-pm-00.txt

[Qin]: Agree.

[Michael]: yes. It is an another solution and it can simplify the augment target path.

Best Regards!
-Michael

-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Zhuangyan (Yan)
发送时间: 2015年6月23日 18:35
收件人: Qin Wu; [email-masked]
抄送: Tom Taylor
主题: Re: [Lime] I-D Action: draft-wang-lime-yang-pm-00.txt

Dear authors,

Many thanks.

Regards,

Yan