Subject: [Lime] draft-wang-lime-yang-pm YANG feedback

From: Benoit Claise <[email-masked]>
Date: Tue, 14 Jul 2015 15:20:54 +0200

Hi,

At http://www.claise.be/IETFYANGPageCompilation.html, you can see the 
pyang errors associated with your draft.
Basically:

ietf-gen-oam-pm.yang:5: error: module "gen-oam" not found in search path
ietf-gen-oam-pm.yang:712: warning: IETF rule (RFC formatting): line 
length 73 exceeds 70 characters
ietf-gen-oam-pm.yang:732: warning: IETF rule (RFC formatting): line 
length 73 exceeds 70 characters
ietf-gen-oam-pm.yang:740: warning: IETF rule (RFC formatting): line 
length 72 exceeds 70 characters
ietf-gen-oam-pm.yang:913: error: IETF rule (RFC 6087: 4.12): statement 
"container" must have a "description" substatement
ietf-gen-oam-pm.yang:939: error: IETF rule (RFC 6087: 4.12): statement 
"container" must have a "description" substatement
ietf-gen-oam-pm.yang:967: error: IETF rule (RFC 6087: 4.12): statement 
"container" must have a "description" substatement
ietf-gen-oam-pm.yang:995: error: IETF rule (RFC 6087: 4.12): statement 
"container" must have a "description" substatement

Regards, Benoit

---

From: wangzitao <[email-masked]>
Date: Wed, 15 Jul 2015 03:34:53 +0000

Hi,

Thanks to point out these errors. I will fix these in next version.

Best Regards!
-Michael

-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Benoit Claise
发送时间: 2015年7月14日 21:21
收件人: [email-masked]
主题: [Lime] draft-wang-lime-yang-pm YANG feedback

Hi,

At http://www.claise.be/IETFYANGPageCompilation.html, you can see the pyang errors associated with your draft.
Basically:

ietf-gen-oam-pm.yang:5: error: module "gen-oam" not found in search path
ietf-gen-oam-pm.yang:712: warning: IETF rule (RFC formatting): line length 73 exceeds 70 characters
ietf-gen-oam-pm.yang:732: warning: IETF rule (RFC formatting): line length 73 exceeds 70 characters
ietf-gen-oam-pm.yang:740: warning: IETF rule (RFC formatting): line length 72 exceeds 70 characters
ietf-gen-oam-pm.yang:913: error: IETF rule (RFC 6087: 4.12): statement "container" must have a "description" substatement
ietf-gen-oam-pm.yang:939: error: IETF rule (RFC 6087: 4.12): statement "container" must have a "description" substatement
ietf-gen-oam-pm.yang:967: error: IETF rule (RFC 6087: 4.12): statement "container" must have a "description" substatement
ietf-gen-oam-pm.yang:995: error: IETF rule (RFC 6087: 4.12): statement "container" must have a "description" substatement

Regards, Benoit

_______________________________________________
Lime mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lime