Subject: [Lime] split draft-kumar-lime-yang-connectionless-oam into two - one on data and one on methods/rpc?

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Thu, 21 Jul 2016 09:16:08 +0000

Hello,

per the ask from Carlos as WG chair in the meeting: Would it make sense to break the draft-kumar-lime-yang-connectionless-oam into two separate documents?

·       One on the data model itself

·       One on methods for data retrieval (the rpc definitions)

Pros:

·       Yang models in the current document are already structured this way, i.e. one on data and one on methods/rpc

·       Enable clean reference in case additional retrieval methods get defined which are not netconf rpc based. E.g. one could think of retrieving data via IPFIX, Kafka, gRPC, etc. - but one would obviously still want to use the same data formats. Those additional retrieval methods would likely be defined in separate drafts, which would mean that longer term, we would have a clean document reference structure:

o   Data model doc

§  Current set of rpcs doc

§  Additional retrieval method 1 doc

§  Additional retrieval method 2 doc ..

Cons:

·       Splitting the draft requires shepherding two drafts in lockstep - which requires additional work/supervision.

·       Updates to the documents would also need to make sure that data model and method documents (which might be multiple moving forward) are kept in synch.

Thoughts?

Thanks, Frank

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 21 Jul 2016 14:47:12 +0200

Frank,

The models (including RPC definitions) are supposed to be protocol and encoding format independent. Retrieval methods are therefore model independent and should always be defined separate from the model. 

P.s BTW, a gRPC draft was presented in the rtgwg(?) in this ietf. 

Mahesh Jethanandani 
[email-masked]

> On Jul 21, 2016, at 11:16 AM, Frank Brockners (fbrockne) <[email-masked]> wrote:
> 
> Hello,
>  
> ·       Enable clean reference in case additional retrieval methods get defined which are not netconf rpc based. E.g. one could think of retrieving data via IPFIX, Kafka, gRPC, etc. – but one would obviously still want to use the same data formats. Those additional retrieval methods would likely be defined in separate drafts, which would mean that longer term, we would have a clean document reference structure:
> o   Data model doc
> ·       Splitting the draft requires shepherding two drafts in lockstep – which requires additional work/supervision.
> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

---

From: "Srihari Raghavan (srihari)" <[email-masked]>
Date: Thu, 21 Jul 2016 14:13:49 +0000

My 2c.  +1 for splitting the document into two, considering the pros of doing that.

Thanks
Srihari

From: Lime <[email-masked]<mailto:[email-masked]>> on behalf of Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 21 July 2016 at 6:17 PM
To: "Frank Brockners (fbrockne)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Lime] split draft-kumar-lime-yang-connectionless-oam into two - one on data and one on methods/rpc?

Frank,

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

On Jul 21, 2016, at 11:16 AM, Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Pros:

o   Data model doc

Cons:

Thoughts?

Thanks, Frank

_______________________________________________
Lime mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lime

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 29 Jul 2016 10:57:16 +0200

Hello Frank,

The definition of the model and the retreival method(s) should be in
separate documents.

Best regards, Huub.

--------------------
On 21-07-16 11:16, Frank Brockners (fbrockne) wrote:
> Hello,
>
> per the ask from Carlos as WG chair in the meeting: Would it make sense
> to break the draft-kumar-lime-yang-connectionless-oam into two separate
> documents?
>
> ·       Yang models in the current document are already structured this
> way, i.e. one on data and one on methods/rpc
>
> ·       Enable clean reference in case additional retrieval methods get
> defined which are not netconf rpc based. E.g. one could think of
> retrieving data via IPFIX, Kafka, gRPC, etc. – but one would obviously
> still want to use the same data formats. Those additional retrieval
> methods would likely be defined in separate drafts, which would mean
> that longer term, we would have a clean document reference structure:
>
> o   Data model doc
>
> ·       Splitting the draft requires shepherding two drafts in lockstep
> – which requires additional work/supervision.
>
> ·       Updates to the documents would also need to make sure that data
> model and method documents (which might be multiple moving forward) are
> kept in synch.
>
> Thoughts?
>
> Thanks, Frank
-- 
================================================================
Always remember that you are unique...just like everyone else...