Subject: [Lime] I-D Action: draft-ietf-lime-yang-connectionless-oam-03.txt

From: [email-masked]
Date: Fri, 23 Dec 2016 17:28:46 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Layer Independent OAM Management in the Multi-Layer Environment of the IETF.

        Title           : Generic YANG Data Model for Connectionless Operations, Administration, and Maintenance(OAM) protocols
        Authors         : Deepak Kumar
                          Michael Wang
                          Qin Wu
                          Reshad Rahman
                          Srihari Raghavan
	Filename        : draft-ietf-lime-yang-connectionless-oam-03.txt
	Pages           : 55
	Date            : 2016-12-23

Abstract:
   This document presents a base YANG Data model for connectionless OAM
   protocols.  It provides a technology-independent abstraction of key
   OAM constructs for connectionless protocols.  The Based model
   presented here can be extended to include technology specific
   details.  This is leading to uniformity between OAM protocols and
   support nested OAM workflows (i.e., performing OAM functions at
   different or same levels through a unified interface).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-lime-yang-connectionless-oam-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lime-yang-connectionless-oam-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: wangzitao <[email-masked]>
Date: Sat, 24 Dec 2016 01:31:24 +0000

Hi chairs and all,

We have updated the lime Connectionless OAM YANG draft. The main changes are:

-	Modify the “tools” attributes to more abstract leaves such as connectivity-verification, continuity-check, path-discovery, etc.

-	Add tp-address choice/case attributes in “oam-layers” list(i.e., add CO and CL related parameters under OAM-layer to address Greg’s comment),
    it helps to build the relationship with different test points at different layer. However we are not sure it is a good idea to make CL model adding dependency to CO model within OAM-layer. 

-	Add “schema-mount” support and explain how to use schema mount to mount other OAM YANG model in the base model without special extension.

-	In additional, we also point out the limitation of schema mount and recommend using augmentation to extend base model with technology specifics.

In addition, we also update CO models and will send update in the separate email.
Please review CL model draft, comments and suggestions are welcome!

Merry Christmas!

-Michael

-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2016年12月24日 9:29
收件人: [email-masked]
抄送: [email-masked]
主题: [Lime] I-D Action: draft-ietf-lime-yang-connectionless-oam-03.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Lime mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lime