Subject: [Lime] AD review of draft-ietf-lime-yang-connection-oriented-oam-model

From: Benoit Claise <[email-masked]>
Date: Mon, 22 Jan 2018 17:27:24 +0100

Dear all,

Here is the AD review of 
draft-ietf-lime-yang-connection-oriented-oam-model. Sorry for the delay.

- Please use the latest Security Considerations template.
It was until recently at this location: 
https://www.ietf.org/iesg/directorate/yang-doctors.html
But not available any longer. I'm in discussion about it.

- you want to refer to RFC8174 instead of RFC2119

        The keywords "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
        "SHOULD", "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY", and
        "OPTIONAL" in this document are to be interpreted as described inBCP <https://tools.ietf.org/html/bcp14>
        14 <https://tools.ietf.org/html/bcp14>, [RFC2119 <https://tools.ietf.org/html/rfc2119>] [RFC8174 <https://tools.ietf.org/html/rfc8174>] when, and only when, they appear in all
        capitals, as shown here.

- I like the section 4.x that explains part of the tree, with logical 
sections.

- you want to use the YANG tree diagrams in 
draft-ietf-netmod-yang-tree-diagrams-04 
<https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-tree-diagrams/>
I advice a section similar to 
https://tools.ietf.org/html/draft-ietf-netmod-rfc7223bis-03#section-1.3

- you are NMDA compliant. I guess you want a sentence such as:

    The YANG model in this document conforms to the Network Management
    Datastore Architecture defined in I-D.ietf-netmod-revised-datastores.

Again, take https://tools.ietf.org/html/draft-ietf-netmod-rfc7223bis-03 
as an example

- For the YANG specifics, I'm waiting for Carl Moberg YANG doctor review.
This should not prevent starting the IETF LC if Carl's feedback doesn't 
come soon.

Editorial:

- there are a few idnits. See 
https://www.ietf.org/tools/idnits?url=https://www.ietf.org/archive/id/draft-ietf-lime-yang-connection-oriented-oam-model-03.txt
For ex, "3 instances of too long lines in the document"

-

    As an example, consider a scenario where Loopback from device A to
    Device B fails.

Do you mean?

    As an example, consider a scenario where connectivity from device A loopback to
    device B fails.

Along the same lines, what does the following mean?

    Upon detecting the Loopback failures

- indpendent => independent
Note: multiple instances

-   identity rdi {
     base defect-types;
     description
       "Indicates the aggregate health of the remote
        Maintenance End Points (MEPs). ";
   }

It would be best if the identity name would either be meaningful or be 
explained in the description

- similar remark for
   typedef interval{
     type decimal64{
     fraction-digits 2;
    }
    units "milliseconds";
     description
     "Interval between packets in milliseconds.
     0 means no packets are sent.";
   }

Do you want to say to at least say time-interval?

- similar remark (or I guess this is a generic comment):
   grouping cos {
     description
     "Priority used in transmitted packets; for example, in the
      EXP field in MPLS-TP.";
     leaf cos-id {
      type uint8;
      description
      "Class of service.";
     }
   }

In the grouping description, you at least want to mention Class of Service.

- no need to list the WG chairs in the YANG module, as mentioned in 
https://tools.ietf.org/html/draft-ietf-netmod-rfc6087bis-16#appendix-C

-

   identity name-format {
     description
     "This defines the name format, IEEE 8021ag CFM defines varying
     styles of names. It is expected name format as an identity ref
     to be extended with new types.";
   }

Name format of? I guess generic.
Please review the YANG module description.
For example:
     leaf md-name-format {
       type identityref {
         base name-format;
       }
       description
         "Name format.";
     }

At least mention the Management Domain Name Format.

-
	The RPC model facilitates issuing commands to a NETCONF server

It could be RESTCONF as well. It's best to mention "server"

              +--rw mas
                 +--rw ma* [ma-name-string]
                    +--rw ma-name-string          ma-name-string
                    +--rw ma-name-format?         identityref
                    +--rw (ma-name)?
                    |  +--:(ma-name-null)
                    |     +--rw ma-name-null?     empty

https://www.yangcatalog.org/yang-search/yang_tree.php?module=ietf-connection-oriented-oam#

Regards, Benoit

---

From: wangzitao <[email-masked]>
Date: Tue, 23 Jan 2018 05:46:27 +0000

Hi Benoit,
Thank you for this comments.
And we will base on your and Carl’s comments to prepare another version as soon as possible.

Best Regards!
-Michael

发件人: Lime [mailto:[email-masked]] 代表 Benoit Claise
发送时间: 2018年1月23日 0:27
抄送: Carl Moberg (camoberg) <[email-masked]>; [email-masked]
主题: [Lime] AD review of draft-ietf-lime-yang-connection-oriented-oam-model

Dear all,

Here is the AD review of draft-ietf-lime-yang-connection-oriented-oam-model. Sorry for the delay.

- Please use the latest Security Considerations template.
It was until recently at this location: https://www.ietf.org/iesg/directorate/yang-doctors.html
But not available any longer. I'm in discussion about it.

   "OPTIONAL" in this document are to be interpreted as described in BCP<https://tools.ietf.org/html/bcp14>

   14<https://tools.ietf.org/html/bcp14>, [RFC2119<https://tools.ietf.org/html/rfc2119>] [RFC8174<https://tools.ietf.org/html/rfc8174>] when, and only when, they appear in all

   capitals, as shown here.
- I like the section 4.x that explains part of the tree, with logical sections.

- you want to use the YANG tree diagrams in draft-ietf-netmod-yang-tree-diagrams-04<https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-tree-diagrams/>
I advice a section similar to https://tools.ietf.org/html/draft-ietf-netmod-rfc7223bis-03#section-1.3

   Datastore Architecture defined in I-D.ietf-netmod-revised-datastores.
Again, take https://tools.ietf.org/html/draft-ietf-netmod-rfc7223bis-03 as an example

- For the YANG specifics, I'm waiting for Carl Moberg YANG doctor review.
This should not prevent starting the IETF LC if Carl's feedback doesn't come soon.

Editorial:

- there are a few idnits. See https://www.ietf.org/tools/idnits?url=https://www.ietf.org/archive/id/draft-ietf-lime-yang-connection-oriented-oam-model-03.txt
For ex, "3 instances of too long lines in the document"

-

   Device B fails.

Do you mean?

   device B fails.

-   identity rdi {
    base defect-types;
    description

It would be best if the identity name would either be meaningful or be explained in the description

- similar remark for
  typedef interval{
    type decimal64{
    fraction-digits 2;
   }
   units "milliseconds";
    description

- no need to list the WG chairs in the YANG module, as mentioned in https://tools.ietf.org/html/draft-ietf-netmod-rfc6087bis-16#appendix-C

-

  identity name-format {

    description

  }

For example:

    leaf md-name-format {

      type identityref {

        base name-format;

      }

      description

        "Name format.";

    }

-

             +--rw mas

                   +--rw (ma-name)?

                   |  +--:(ma-name-null)

https://www.yangcatalog.org/yang-search/yang_tree.php?module=ietf-connection-oriented-oam#<https://www.yangcatalog.org/yang-search/yang_tree.php?module=ietf-connection-oriented-oam>

Regards, Benoit