Subject: Re: [link-relations] NEW RELATION - canonical

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 02 Jun 2011 00:18:56 +0200

* Julian Reschke wrote:
>On 01.05.2011 19:34, Frank Ellermann wrote:
>> On 2011-04-15 I posted "NEW RELATION - canonical", and one day later I
>> amended it by
>> s/similar similar/similar/.  After two weeks that's now an "ETMO"
>> (error time out), and
>> RFC 5988 offers no default accept or reject rule.
>> ...
>
>I did answer in 
><http://www.ietf.org/mail-archive/web/link-relations/current/msg00186.html>, 
>right?
>
>That being said, I totally agree this is moving too slowly.

You said that a month ago, where the request was already two weeks old.
In your answer you only asked a question; as far as I can tell none of
the designated experts have so far approved or denied the request. So,
"Within at most 14 days of the request, the Designated Expert(s) will
either approve or deny the registration request" does not seem true. I,
well, I am mostly wondering why anyone would have thought it a good idea
to make this promise in the specification. Any thoughts on that? Keeping
in mind that this promise has been broken several times, as far as I can
tell.

(I think it is an unreasonable requirement and am looking for what to
tell the next person who proposes such a requirement so they abandon the
idea early on, I don't really care about how many days it takes to
register a link relation; in this instance, people could just have said
they want Approve or Deny _now_ and I do think they would have gotten
that timely, but dealing in such absolutes often leads to unhappiness.)
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Julian Reschke <[email-masked]>
Date: Thu, 02 Jun 2011 00:27:33 +0200

> that timely, but dealing in such absolutes often leads to unhappiness.)

I agree with you that it's an unreasonable requirement.

I'm also forwarding this message to the people who've been working on 
the spec, but haven't submitted anything yet...

Best regards, Julian

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 3 Jun 2011 22:01:55 +0200

>>> <http://www.ietf.org/mail-archive/web/link-relations/current/msg00186.html>,

Sorry, I sent a reply only as PM back in April, just in
case repeated here:

|> we do have people at Google looking into writing a
|> "proper" spec
|
| Just in case I posted a pointer in the "webmaster help" | forum (*).
|
|> maybe you are willing to assist them, given your IETF |>know-how?
|
| But you don't want the rel="canonical" registration
| in 2016... ;-)  If somebody writes an RFC its IANA
| considerations could update a registration.  You're
| not forced to wait for that; above all don't hold
| your breath.

IOW, I think the relation should be registered now, and
I'm waiting for a "reject" or "accept" decision (seven
weeks now).  The appeal sent to the APPS-AD address
apparently didn't make it, that could be a problem with
the forwarding on the tools server.

[Björn wrote:]
>> I am mostly wondering why anyone would have thought
>> it a good idea to make this promise in the
>> specification. Any thoughts on that?

A review timeout is a good idea, the language tags list
has a similar rule.  Years ago on the charsets list
without clear timeout it took months until folks were
sure that the expert did not more read the list.

-Frank