Subject: Re: registration request for dns-prefetch, preconnect, prefetch, and prerender link relation types

From: Erik Wilde <[email-masked]>
Date: Mon, 1 Feb 2016 11:47:45 -0800

hello mark.

thanks for the feedback.

On 2016-01-30 18:10, Mark Nottingham wrote:
> So something like this would be clearer:
> """
> Indicates a resource that might be required by the next navigation, and that user agents ought to fetch and execute to improve performance.
> """

https://github.com/w3c/resource-hints/pull/54 contains a slightly 
different change, but one that does incorporate the changes you suggested.

the spec has been republished, and 
https://www.w3.org/TR/2016/WD-resource-hints-20160201/#iana-considerations 
lists the updated registration requests:

------------------------------

Relation Name: dns-prefetch
Description: The dns-prefetch link relation type is used to indicate an 
origin that will be used to fetch required resources, and that the user 
agent SHOULD resolve as early as possible.

Relation Name: preconnect
Description: The preconnect link relation type is used to indicate an 
origin that will be used to fetch required resources. Initiating an 
early connection, which includes the DNS lookup, TCP handshake, and 
optional TLS negotiation, allows the user agent to mask the high latency 
costs of establishing a connection.

Relation Name: prefetch
Description: The prefetch link relation type is used to identify a 
resource that might be required by the next navigation, and that the 
user agent SHOULD fetch, such that the user agent can deliver a faster 
response once the resource is requested in the future.

Relation Name: prerender
Description: The prerender link relation type is used to identify a 
resource that might be required by the next navigation, and that the 
user agent should fetch and execute, such that the user agent can 
deliver a faster response once the resource is requested in the future.

------------------------------

any comments/feedback are very much appreciated. thanks,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 5 Feb 2016 13:56:14 +1100

Just a couple of nits.

> On 2 Feb 2016, at 6:47 am, Erik Wilde <[email-masked]> wrote:
> 
> hello mark.
> 
> thanks for the feedback.
> 
> https://github.com/w3c/resource-hints/pull/54 contains a slightly different change, but one that does incorporate the changes you suggested.
> 
> the spec has been republished, and https://www.w3.org/TR/2016/WD-resource-hints-20160201/#iana-considerations lists the updated registration requests:
> 
> Description: The dns-prefetch link relation type is used to indicate an origin that will be used to fetch required resources, and that the user agent SHOULD resolve as early as possible.

* The first words are repetitive (we already know its name). Suggest:

Description: Used to indicate...

* It's nice to talk explicitly about the link context, e.g.:

... indicate an origin that will be used to fetch required resources for the link's context...

* Putting RFC1918 requirements in a registry entry is weird. Suggest:

... that the user agent ought to resolve as early as possible.

That gives us:

Description: Used to indicate an origin that will be used to fetch required resources for the link context, and that the user agent ought to resolve as early as possible.

Does that make sense?

Same comments for the relations below.

Cheers,

> Description: The preconnect link relation type is used to indicate an origin that will be used to fetch required resources. Initiating an early connection, which includes the DNS lookup, TCP handshake, and optional TLS negotiation, allows the user agent to mask the high latency costs of establishing a connection.
> 
> Relation Name: prefetch
> Description: The prefetch link relation type is used to identify a resource that might be required by the next navigation, and that the user agent SHOULD fetch, such that the user agent can deliver a faster response once the resource is requested in the future.
> 
> Relation Name: prerender
> Description: The prerender link relation type is used to identify a resource that might be required by the next navigation, and that the user agent should fetch and execute, such that the user agent can deliver a faster response once the resource is requested in the future.
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Erik Wilde <[email-masked]>
Date: Tue, 23 Feb 2016 19:20:53 +0100

hello mark.

thanks for your feedback!

> Same comments for the relations below.

sure, all looks good to me. 
https://github.com/w3c/resource-hints/pull/56 should reflect your 
suggestions and will become part of the next published draft.

thanks and cheers,

dret.