Subject: 'about' and 'describes' appear to have significant overlap

From: <[email-masked]>
Date: Sun, 28 Oct 2018 23:59:23 +0000

The relations 'about' and 'describes' appear to have significant overlap.
I've looked at both RFCs but neither mentions the other.
Is there a succinct explanation of the difference?

Simon J D Cox
Research Scientist - Environmental Informatics<https://research.csiro.au/ei>
Team Leader - Environmental Information Infrastructure
CSIRO Land and Water<http://www.csiro.au/Research/LWF>

E [email-masked]<mailto:[email-masked]> T +61 3 9545 2365 M +61 403 302 672
   Mail: Private Bag 10, Clayton South, Vic 3169
   Visit: Central Reception, Research Way, Clayton, Vic 3168  ///honey.zebra.chip<https://w3w.co/honey.zebra.chip>
   Deliver: Gate 3, Normanby Road, Clayton, Vic 3168
people.csiro.au/Simon-Cox<http://people.csiro.au/Simon-Cox>
orcid.org/0000-0002-3884-3420<http://orcid.org/0000-0002-3884-3420>
researchgate.net/profile/Simon_Cox3<https://www.researchgate.net/profile/Simon_Cox3>
github.com/dr-shorthair<https://github.com/dr-shorthair>
lov.okfn.org/dataset/lov/agents/Simon%20Cox<http://lov.okfn.org/dataset/lov/agents/Simon%20Cox>
Twitter @dr_shorthair<https://twitter.com/dr_shorthair>
Skype dr_shorthair<skype:dr_shorthair>
https://xkcd.com/1810/

PLEASE NOTE
The information contained in this email may be confidential or privileged. Any unauthorised use or disclosure is prohibited. If you have received this email in error, please delete it immediately and notify the sender by return email. Thank you. To the extent permitted by law, CSIRO does not represent, warrant and/or guarantee that the integrity of this communication has been maintained or that the communication is free of errors, virus, interception or interference.

Please consider the environment before printing this email.

---

From: Herbert Van de Sompel <[email-masked]>
Date: Sun, 28 Oct 2018 19:30:18 -0600

On Oct 28, 2018, at 17:59, <[email-masked]> <[email-masked]> wrote:
> I’ve looked at both RFCs but neither mentions the other.

Clear overlap, indeed. With Signposting, we promote the use of “describes”. See http://signposting.org/

Cheers

Herbert

> Simon J D Cox
> Research Scientist - Environmental Informatics
> Team Leader – Environmental Information Infrastructure
> CSIRO Land and Water
>  
> E [email-masked] T +61 3 9545 2365 M +61 403 302 672
>    Visit: Central Reception, Research Way, Clayton, Vic 3168  ///honey.zebra.chip
> people.csiro.au/Simon-Cox
> orcid.org/0000-0002-3884-3420
> researchgate.net/profile/Simon_Cox3
> github.com/dr-shorthair
> lov.okfn.org/dataset/lov/agents/Simon%20Cox
> Twitter @dr_shorthair
> Skype dr_shorthair
> https://xkcd.com/1810/
>  
> PLEASE NOTE
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

---

From: Erik Wilde <[email-masked]>
Date: Mon, 29 Oct 2018 07:55:55 +0000

hello simon.

> Is there a succinct explanation of the difference?

like many link relations, 'about' and 'describes' are fuzzy in their 
scope and definition. 'describes' in particular is probably so generic 
that you can use it for pretty much anything. i would find it surprising 
if there was any possible succinct explanation of the difference.

personally, i think that link relations almost always depend on the 
context they're used in. in one API you might find something exposed as 
'about' links, which in a different API is exposed as 'describes' links. 
you have to know the context (the APIs) to understand what they expose, 
and how they do it.

cheers,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |