Subject: Proposal to register Allen's temporal interval relations as relation-types

From: <[email-masked]>
Date: Sun, 25 Nov 2018 22:12:43 +0000

This PR https://github.com/link-relations/registry/pull/5 proposes to register a set of temporal interval relations.

These relations support the assertion of the relative position of time intervals, such as 'before', 'after', 'overlaps', 'during' etc, which are expected to be of interest for web resources. For example, it might be useful to be able to say that a lecture overlaps lunchtime, or that a conference is started by a plenary session.

The relations proposed were defined by Allen last century[1,2], and are broadly accepted as the canonical set required to express all relationships between time intervals. They were recently included in the W3C OWL-Time recommendation [3], and that document is used as the accessible source to be cited in the registry entry.

There has been a little discussion in GitHub here: https://github.com/link-relations/registry/issues/4

Simon Cox

[1] Actions and events in interval temporal logic In: Spatial and Temporal Reasoning. O. Stock, ed., Kluwer, Dordrecht, Netherlands, pp. 205-245.. J.F. Allen; G. Ferguson.1997. URL: http://dx.doi.org/10.1007/978-0-585-28322-7_7
[2] Towards a general theory of action and time. Artificial Intelligence 23, pp. 123-154.. J.F. Allen.1984. URL: http://dx.doi.org/10.1016/0004-3702%2884%2990008-0
[3] https://www.w3.org/TR/owl-time/#time:intervalAfter

Simon J D Cox
Research Scientist - Environmental Informatics<https://research.csiro.au/ei>
Team Leader - Environmental Information Infrastructure
CSIRO Land and Water<http://www.csiro.au/Research/LWF>

E [email-masked]<mailto:[email-masked]> T +61 3 9545 2365 M +61 403 302 672
   Mail: Private Bag 10, Clayton South, Vic 3169
   Visit: Central Reception, Research Way, Clayton, Vic 3168  ///honey.zebra.chip<https://w3w.co/honey.zebra.chip>
   Deliver: Gate 3, Normanby Road, Clayton, Vic 3168
people.csiro.au/Simon-Cox<http://people.csiro.au/Simon-Cox>
orcid.org/0000-0002-3884-3420<http://orcid.org/0000-0002-3884-3420>
researchgate.net/profile/Simon_Cox3<https://www.researchgate.net/profile/Simon_Cox3>
github.com/dr-shorthair<https://github.com/dr-shorthair>
lov.okfn.org/dataset/lov/agents/Simon%20Cox<http://lov.okfn.org/dataset/lov/agents/Simon%20Cox>
Twitter @dr_shorthair<https://twitter.com/dr_shorthair>
Skype dr_shorthair<skype:dr_shorthair>
https://xkcd.com/1810/

PLEASE NOTE
The information contained in this email may be confidential or privileged. Any unauthorised use or disclosure is prohibited. If you have received this email in error, please delete it immediately and notify the sender by return email. Thank you. To the extent permitted by law, CSIRO does not represent, warrant and/or guarantee that the integrity of this communication has been maintained or that the communication is free of errors, virus, interception or interference.

Please consider the environment before printing this email.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 26 Nov 2018 11:15:15 +1100

Hi Simon,

I approved these last week; IANA should act shortly (they've been on holiday, I think).

Cheers,

> On 26 Nov 2018, at 9:12 am, [email-masked] wrote:
> 
> These relations support the assertion of the relative position of time intervals, such as ‘before’, ‘after’, ‘overlaps’, ‘during’ etc, which are expected to be of interest for web resources. For example, it might be useful to be able to say that a lecture overlaps lunchtime, or that a conference is started by a plenary session.
>  
> Research Scientist - Environmental Informatics
> Team Leader – Environmental Information Infrastructure
> CSIRO Land and Water
>  
> E [email-masked] T +61 3 9545 2365 M +61 403 302 672
>    Visit: Central Reception, Research Way, Clayton, Vic 3168  ///honey.zebra.chip
> people.csiro.au/Simon-Cox
> orcid.org/0000-0002-3884-3420
> researchgate.net/profile/Simon_Cox3
> github.com/dr-shorthair
> lov.okfn.org/dataset/lov/agents/Simon%20Cox
> Twitter @dr_shorthair
> Skype dr_shorthair
> https://xkcd.com/1810/
>  
> PLEASE NOTE
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

--
Mark Nottingham   https://www.mnot.net/

---

From: <[email-masked]>
Date: Mon, 26 Nov 2018 01:41:07 +0000

Yes, thanks, saw that. 
I was responding (in parallel) to comments from @dret in the GitHub issue - making sure the list was also in the loop. 

Simon 

-----Original Message-----
From: Mark Nottingham [mailto:[email-masked]] 
Sent: Monday, 26 November, 2018 11:15
To: Cox, Simon (L&W, Clayton) <[email-masked]>
Cc: [email-masked]
Subject: Re: Proposal to register Allen's temporal interval relations as relation-types

Hi Simon,

Cheers,

> There has been a little discussion in GitHub here: 
> https://github.com/link-relations/registry/issues/4
>  
> Simon Cox
>  
> [1] Actions and events in interval temporal logic In: Spatial and 
> Temporal Reasoning. O. Stock, ed., Kluwer, Dordrecht, Netherlands, pp. 
> 205-245.. J.F. Allen; G. Ferguson.1997. URL: 
> http://dx.doi.org/10.1007/978-0-585-28322-7_7
> [2] Towards a general theory of action and time. Artificial 
> Intelligence 23, pp. 123-154.. J.F. Allen.1984. URL: 
> http://dx.doi.org/10.1016/0004-3702%2884%2990008-0
> Research Scientist - Environmental Informatics Team Leader – 
> Environmental Information Infrastructure CSIRO Land and Water
>