Subject: Time interval relations

From: "Cox, Simon (L&W, Clayton)" <[email-masked]>
Date: Sun, 14 Jul 2019 20:49:34 +0000

Allen's Temporal Interval Relations were added to the IANA registry in Dec 2018, following their formal description in the W3C OWL-Time ontology.
However,

(i)                  there was no formal IANA Considerations section in the W3C documents

(ii)                one of the definitions had a bug (intervalMetBy was the same as intervalMeets)

To remediate these, I have now

(i)                  submitted an amendment (erratum) to the W3C document to add an IANA Considerations section - see preview https://rawgit.com/w3c/sdw/time-iana-considerations/time/#iana-links

(ii)                submitted a fix to the erroneous definition - see GitHub PR https://github.com/link-relations/registry/pull/7

I hope these satisfactorily resolve the issues. Processing them now depends on W3C (for (i)) and the custodians of the IANA registry (for (ii)).

Simon Cox

Simon J D Cox
Research Scientist - Environmental Informatics<https://research.csiro.au/ei>
Team Leader - Environmental Information Infrastructure
CSIRO Land and Water<http://www.csiro.au/Research/LWF>

E [email-masked]<mailto:[email-masked]> T +61 3 9545 2365 M +61 403 302 672
   Mail: Private Bag 10, Clayton South, Vic 3169
   Visit: Central Reception, Research Way, Clayton, Vic 3168  ///honey.zebra.chip<https://w3w.co/honey.zebra.chip>
   Deliver: Gate 3, Normanby Road, Clayton, Vic 3168
people.csiro.au/Simon-Cox<http://people.csiro.au/Simon-Cox>
orcid.org/0000-0002-3884-3420<http://orcid.org/0000-0002-3884-3420>
researchgate.net/profile/Simon_Cox3<https://www.researchgate.net/profile/Simon_Cox3>
github.com/dr-shorthair<https://github.com/dr-shorthair>
lov.okfn.org/dataset/lov/agents/Simon%20Cox<http://lov.okfn.org/dataset/lov/agents/Simon%20Cox>
Twitter @dr_shorthair<https://twitter.com/dr_shorthair>
Skype dr_shorthair<skype:dr_shorthair>
https://xkcd.com/1810/

PLEASE NOTE
The information contained in this email may be confidential or privileged. Any unauthorised use or disclosure is prohibited. If you have received this email in error, please delete it immediately and notify the sender by return email. Thank you. To the extent permitted by law, CSIRO does not represent, warrant and/or guarantee that the integrity of this communication has been maintained or that the communication is free of errors, virus, interception or interference.

Please consider the environment before printing this email.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 17 Jul 2019 10:46:55 -0400

Hi Simon,

Thanks for that. It's not strictly necessary that the registration template appear in the specification document, although it is thought to be helpful by some.

For the registry correction, as you're the editor of the document, I'm assuming this is something that represents that community as a whole. 

IANA, could you please update the description of the "intervalMetBy" entry in the Link Relations registry to:

"""
refers to a resource associated with a time interval whose end coincides with the beginning of the time interval associated with the context resource
"""

?

Kind regards,

> On 14 Jul 2019, at 4:49 pm, Cox, Simon (L&W, Clayton) <[email-masked]> wrote:
> 
> Allen’s Temporal Interval Relations were added to the IANA registry in Dec 2018, following their formal description in the W3C OWL-Time ontology.
> However, 
> (i)                  submitted an amendment (erratum) to the W3C document to add an IANA Considerations section – see preview https://rawgit.com/w3c/sdw/time-iana-considerations/time/#iana-links
> (ii)                submitted a fix to the erroneous definition – see GitHub PR https://github.com/link-relations/registry/pull/7
>  
> Research Scientist - Environmental Informatics
> Team Leader – Environmental Information Infrastructure
> CSIRO Land and Water
>  
> E [email-masked] T +61 3 9545 2365 M +61 403 302 672
>    Visit: Central Reception, Research Way, Clayton, Vic 3168  ///honey.zebra.chip
> people.csiro.au/Simon-Cox
> orcid.org/0000-0002-3884-3420
> researchgate.net/profile/Simon_Cox3
> github.com/dr-shorthair
> lov.okfn.org/dataset/lov/agents/Simon%20Cox
> Twitter @dr_shorthair
> Skype dr_shorthair
> https://xkcd.com/1810/
>  
> PLEASE NOTE
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

--
Mark Nottingham   https://www.mnot.net/

---

From: "Cox, Simon (L&W, Clayton)" <[email-masked]>
Date: Wed, 17 Jul 2019 15:28:16 +0000

> For the registry correction, as you're the editor of the document, I'm assuming this is something that represents that community as a whole.

Err - I guess so. It was a silly cut-and-paste but forgot to edit the entry problem. Pretty obvious actually ☹ 

Simon 

-----Original Message-----
From: Mark Nottingham <[email-masked]> 
Sent: Wednesday, 17 July, 2019 07:47
To: Cox, Simon (L&W, Clayton) <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: Time interval relations

Hi Simon,

"""
refers to a resource associated with a time interval whose end coincides with the beginning of the time interval associated with the context resource """

?

Kind regards,

> Research Scientist - Environmental Informatics Team Leader – 
> Environmental Information Infrastructure CSIRO Land and Water
>