Subject: [lisp] Can I get opinions?

From: Dino Farinacci <[email-masked]>
Date: Thu, 28 May 2009 11:11:23 -0700

Since the list has brought up packet formats, I would like to suggest  
this packet format change for draft-ietf-lisp-02.txt (about to release  
draft-ietf-lisp-01.txt):

       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   L / |                      Locator Reach Bits                       |
   I   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   S \ |S|E|rsvd-flags |               Nonce                           |
   P   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

The E-bit is for the echo-nonce idea that Andrew Partan and Noel  
Chiappa came up with. We will document it relatively soon. I'm doing  
an implementation of it right now to see how it works.

What we get from the previous version:

1) 32 loc-reach-bits rather than 31.
2) Set aside flag bits for future use.
3) Settling for a 24-bit nonce rather than a 32-bit nonce. But this is  
only in the data packet header and not in the nonce that is carried in  
UDP port 4342. That nonce remains at 32 bits.

Comments?

Dino

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 28 May 2009 15:56:18 -0400

Looks like an improvement to me.
Joel

Dino Farinacci wrote:
> The E-bit is for the echo-nonce idea that Andrew Partan and Noel Chiappa 
> came up with. We will document it relatively soon. I'm doing an 
> implementation of it right now to see how it works.
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 28 May 2009 14:14:38 -0700

OK, so here is something like what I would propose
for SEAL:

       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |VER|A|R|  RSVD |  Next Header  |         ID Extension          |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

where VER=0 means that there is no segmentation and
reassembly capability, and VER=1 means that segmentation
and reassembly are implemented. (VER=2,3 are reserved for
future use.)

When VER=0, the ITR sets the 'A' bit to request an
explicit acknowledgement from the ETR, and sets the
'R' bit to permit the ETR to report fragmentation.
When VER=1, the 'RSVD' bits are redefined to support
the segmentation and reassembly capability.

LISP xTRs connected to the DFZ would set VER=0.

Fred
[email-masked]

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: Thursday, May 28, 2009 11:11 AM
> To: [email-masked]
> Subject: [lisp] Can I get opinions?
> 
>    I
>    P