Subject: Re: [lisp] Comments about the LISP header

From: [email-masked] (Noel Chiappa)
Date: Thu, 28 May 2009 08:54:50 -0400 (EDT)

> From: "Templin, Fred L" <[email-masked]>

    > ICMPs are only required to carry 8 bytes of the packet in error beyond
    > the IP header. That's only enough to pick up the UDP header and not the
    > LISP nonce.

Which has indeed already proven slightly painful on occasion.

But there is no perfect solution, when dealing with a large, installed base.

	Noel

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 28 May 2009 06:10:31 -0700

> -----Original Message-----
> From: Noel Chiappa [mailto:[email-masked]]
> Sent: Thursday, May 28, 2009 5:55 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [lisp] Comments about the LISP header
> 
> 

Right.

> But there is no perfect solution, when dealing with a large, installed
base.

Maybe not perfect, but pretty darned close. And it only
costs 4 bytes sandwiched between the inner- and outer
IP headers. (Hey - it even puts the IPv6 header on a
quadword alignment when IPv6 is used as the inner!)

Fred
[email-masked]

> 
> 	Noel
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp