Subject: Re: [lisp] Question regarding LISP+ALT

From: [email-masked] (Noel Chiappa)
Date: Fri, 5 Jun 2009 10:32:25 -0400 (EDT)

> From: David Meyer <[email-masked]>

    >> does that imply that the ETR is under control of the user organization
    >> and part of its network?

    > Yes, in the case where LISP is fielded in the site's CPE. One could
    > also imagine a managed service where the SP provides and manages the
    > site's CPE(s).
    > In any event, deploying LISP in CPE-type boxes is expected to be a
    > comon scenaro for LISP.

It's probably worth pointing out that i) LISP will of course work with a
number of different scenarios, ii) the 'typical' scenario would probably
change over time (as it did with, say, Web servers), and iii) different
organizations will prefer different scenarios, depending on their own
particular circumstances.

The one thing we need to be careful of is to make sure that the architecture
doesn't 'lock in' customers to any particular provider. That was a concern
with CONS, but as far as I know, nothing in the current proposed deployment
has that characteritic. However, we do need to keep it in mind with anything
that is changed/added.

	Noel

---

From: David Meyer <[email-masked]>
Date: Fri, 5 Jun 2009 07:58:05 -0700

> particular circumstances.

	Sure, well taken.

> has that characteritic. However, we do need to keep it in mind with anything

	I'll just note that it is a design goal of LISP to
	solve the provider lock-in that arises from PA numbering
	of a site. Separating site numbering from core numbering
	to large extent accomplishes that goal. Of course, you
	would have to renumber your xTRs when changing providers
	(you'd likely change RLOCs), but that is anticipated to
	be a small overhead in comparison to renumbering an
	entire site. 

	Dave

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 5 Jun 2009 08:57:46 -0700

> -----Original Message-----
> From: David Meyer [mailto:[email-masked]]
> Sent: Friday, June 05, 2009 7:58 AM
> To: Noel Chiappa
> Cc: [email-masked]
> Subject: Re: [lisp] Question regarding LISP+ALT
> 

There is a bit more to PI than just changing the RLOCs, and
we have already tackled that in VET and RANGER.

That said, I would go a bit further and say that xTR RLOC
changes would be completely invisible to the site a very
nice architectural feature.

Fred
[email-masked]