Subject: [lisp] Linux lig source code available

From: David Meyer <[email-masked]>
Date: Mon, 6 Jul 2009 13:41:12 -0700

See https://lig.svn.sourceforge.net

	A couple of caveats:

	(i).	It probably won't compile/run on FreeBSD. If
		someone has the time to look at that it would be
		great. 

	(ii).	I just noticed that changed a place where I
		changed an name into an IP address then print the
		IP address (instead of the name); will fix that.

	(iii).	I looked at making one binary understand bot v4
		and v6, which made me understand (at least in
		part) why some people split those (e.g.,
		ping/ping6). 

	Comments greatly apprecated.

	Thanks,

	Dave

	[BTW, if folks have comments on how I set up the
	sourceforge repository, let me know. Thannks again, Dave]

---

From: David Meyer <[email-masked]>
Date: Tue, 7 Jul 2009 09:17:18 -0700

A few people have suggested that I put the source up on 
	github. You can find it here:
	
	http://github.com/davidmeyer/lig/tree/master

	Thanks,

	Dave

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 20 Jul 2009 17:09:26 +0200

On Mon, Jul 06, 2009 at 01:41:12PM -0700,
 David Meyer <[email-masked]> wrote 

> 	See https://lig.svn.sourceforge.net

Are there public map servers on the Internet today, or must I install
one?

% ./lig 192.0.2.254 -m 192.0.2.1
Send map-request to 192.0.2.1 for 192.0.2.254 ...
Send map-request to 192.0.2.1 for 192.0.2.254 ...
Send map-request to 192.0.2.1 for 192.0.2.254 ...
*** No map-reply received ***

---

From: David Meyer <[email-masked]>
Date: Mon, 20 Jul 2009 08:36:52 -0700

Stephane,

	First, please pick up the updated code on

	(thanks Tom P; I like this way better). In any event,
	that code reflects draft-ietf-lisp-03.txt. Second, there
	are a few map-resolvers you can point at:

	titanium-dmm-alt.rloc.lisp4.net:	128.223.156.35
	titanium-ripe.rloc.lisp4.net:		193.0.0.170
	titanium-dmm-ms.rloc.lisp4.net:		128.223.156.139
	titanium-vaf-alt.rloc.lisp4.net:	204.69.200.7

	So something like:

[dmm@m106:]86% lig -d titanium-dmm.lisp4.net -m titanium-ripe.rloc.lisp4.net
Send map-request to titanium-ripe.rloc.lisp4.net (193.0.0.170)
for titanium-dmm.lisp4.net (153.16.10.254) ...
Using source address: 205.167.76.9
Received map-reply from 128.223.156.134 with rtt 0.21400 sec

Mapping entry for EID 153.16.10.254:
153.16.10.0/24, via map-reply, record ttl: 1440, auth, nonce: 0x50fba595
  Locator           State     Priority/Weight
  128.223.156.134   up        1/50      
  207.98.65.94      up        1/50      
[dmm@m106:]87% 

	Thanks, and please let me know if you find bugs or have
	ideas for impovements.

	Writing a man page and a README for the source directory
	is on my queue for today.

	Thanks,

	Dave
----

---

From: David Meyer <[email-masked]>
Date: Mon, 20 Jul 2009 17:05:50 -0700

> 	titanium-vaf-alt.rloc.lisp4.net:	204.69.200.7

	BTW, http://www.lisp4.net/images/lisp_network.png is a
	pretty current picture of network. I see we should
	annotate it with domain names so it would be more useful
	for you when testing all of this stuff.

	Thanks,

	Dave

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 21 Jul 2009 11:15:44 +0200

On Mon, Jul 20, 2009 at 08:36:52AM -0700,
 David Meyer <[email-masked]> wrote 

> [dmm@m106:]86% lig -d titanium-dmm.lisp4.net -m titanium-ripe.rloc.lisp4.net

Does not work for me:

% sudo ./lig -d 192.0.2.1 -m titanium-vaf-alt.rloc.lisp4.net 
Using source address:   208.75.84.80
Using source port:      47357
Send map-request to titanium-vaf-alt.rloc.lisp4.net (204.69.200.7) for 192.0.2.1 (192.0.2.1) ...
Send map-request to titanium-vaf-alt.rloc.lisp4.net (204.69.200.7) for 192.0.2.1 (192.0.2.1) ...
Send map-request to titanium-vaf-alt.rloc.lisp4.net (204.69.200.7) for 192.0.2.1 (192.0.2.1) ...
*** No map-reply received ***

It does not seem to be firewall-related since tcpdump sees the packets
coming in and out:

% tcpdump -n -v host 204.69.200.7 
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
11:11:37.123146 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 92) 208.75.84.80.42656 > 204.69.200.7.4341: UDP, length 64
11:11:37.177246 IP (tos 0xc0, ttl 238, id 3451, offset 0, flags [none], proto UDP (17), length 52) 204.69.200.7.4342 > 208.75.84.80.0: UDP, length 24
11:11:38.610988 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 92) 208.75.84.80.42656 > 204.69.200.7.4341: UDP, length 64
11:11:38.615483 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 92) 208.75.84.80.42656 > 204.69.200.7.4341: UDP, length 64
11:11:38.665215 IP (tos 0xc0, ttl 238, id 3452, offset 0, flags [none], proto UDP (17), length 52) 204.69.200.7.4342 > 208.75.84.80.0: UDP, length 24
11:11:38.670797 IP (tos 0xc0, ttl 238, id 3453, offset 0, flags [none], proto UDP (17), length 52) 204.69.200.7.4342 > 208.75.84.80.0: UDP, length 24

Linux/Gentoo, kernel 2.6.16.29, lig just obtained from github,
compilation done with gcc 4.1.2.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 21 Jul 2009 11:26:39 +0200

On Tue, Jul 21, 2009 at 11:15:44AM +0200,
 Stephane Bortzmeyer <[email-masked]> wrote 

> Does not work for me:

OK, I missed the fact that unknown EID generate *no* reply. Sorry for
the false alarm.

% sudo ./lig -d 153.16.10.254  -m titanium-ripe.rloc.lisp4.net
Using source address:   217.70.190.232
Using source port:      38530
Send map-request to titanium-ripe.rloc.lisp4.net (193.0.0.170) for 153.16.10.254 (153.16.10.254) ...
Received map-reply from 207.98.65.94 with rtt 0.20600 sec

Mapping entry for EID 153.16.10.254:
153.16.10.0/24, via map-reply, record ttl: 1440, auth, nonce: 0x508f13ff
  Locator           State     Priority/Weight
  128.223.156.134   up        1/50      
  207.98.65.94      up        1/50

---

From: David Meyer <[email-masked]>
Date: Tue, 21 Jul 2009 05:30:42 -0700

>   Locator           State     Priority/Weight

Good to see :-)

Dave

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 21 Jul 2009 09:37:37 -0400

I am slightly confused.  Stephane indicates that his problem was that an 
unknown EID generates no reply.  Dave seems to find that reasonable.
But the spec explicitly says that an EID which is not mapped needs a 
negative reply.  (Which seems like a very good idea, particularly since 
there are behaviors that depend upon the ITR knowing this correctly.)
So why is there no reply?

Joel

David Meyer wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: David Meyer <[email-masked]>
Date: Tue, 21 Jul 2009 07:22:01 -0700

> unknown EID generates no reply.  Dave seems to find that reasonable.

	Joel, I did not say that. I said it was "Good to see :-)"
	[0] that it worked it with a known EID. Please quote me
	correctly if find the need to quote me. 

> So why is there no reply?

	Don't know. Maybe its a bug in my code (I'm sure there
	are many). Anyway, we know that Dino's code generates
	negative map-replies. I'll check it out.

	Dave

[0]	See Message-ID: <[email-masked]>

---

From: David Meyer <[email-masked]>
Date: Tue, 21 Jul 2009 07:26:46 -0700

> 	negative map-replies. I'll check it out.

	BTW, I just checked. FWIW:

[root@m106:]48# lig 128.223.156.117 -m titanium-dmm-alt.rloc.lisp4.net
Send map-request to titanium-dmm-alt.rloc.lisp4.net for 128.223.156.117 ...
Received map-reply from 128.223.156.35 with rtt 0.00400 sec

Mapping entry for EID 128.223.156.117:
128.0.0.0/4, record ttl: 1440
  Locator           State     Priority/Weight
[root@m106:]49# 

	I can do a better job of letting folks know this is a
	negative map-reply, but the point is what you can see
	above.

	Dave

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 21 Jul 2009 09:02:55 -0700

And here is an example from my xTR:

titanium-dino# lig 128.223.156.117
Send map-request to 128.223.156.139 for 128.223.156.117 ...
Received map-reply from 128.223.156.139 with rtt 0.041112 secs

Map-cache entry for EID 128.223.156.117:
128.0.0.0/4, uptime: 09:26:40, expires: 23:59:58, via map-reply
   Negative cache entry, action: forward-native

Dino

---

From: David Meyer <[email-masked]>
Date: Tue, 21 Jul 2009 09:54:23 -0700

> And here is an example from my xTR:

	Fixed. Here's what you'll see now:

	For a negative map-reply:

[dmm@wayback:~]7% lig 1.2.3.4 -m titanium-vaf-alt.rloc.lisp4.net
Send map-request to titanium-vaf-alt.rloc.lisp4.net for 1.2.3.4 ...
Received map-reply from 204.69.200.7 with rtt 0.03100 secs

Mapping entry for EID 1.2.3.4:
0.0.0.0/1, record ttl: 1440
  Negative cache entry, action: forward-native
[dmm@wayback:~]8% 

	For a non-negative map-reply:

[dmm@wayback:~]4% lig titanium-dino.lisp4.net -m titanium-dmm-alt.rloc.lisp4.net 
Send map-request to titanium-dmm-alt.rloc.lisp4.net for titanium-dino.lisp4.net ...
Received map-reply from 173.8.188.25 with rtt 0.04000 secs

Mapping entry for EID 153.16.37.1:
153.16.37.0/24, record ttl: 60
  Locator           State     Priority/Weight
  76.246.19.176     up        1/25      
  173.8.188.25      up        1/25      
  173.8.188.26      up        1/25      
  173.8.188.27      up        1/25      
[dmm@wayback:~]5% 

	Updated source on

	Dave