Subject: [lisp] Wednesday updated diff file for the lisp-04 proposed changes

From: Dino Farinacci <[email-masked]>
Date: Wed, 9 Sep 2009 16:29:38 -0700

Here is today's diff file. The only change from the Tuesday diff file  
is to change the 32-bit nonce length from the Map-Request, Map-Reply,  
and Map-Register messages to 64-bits in length.

Thanks,
Dino/Dave/Darrel/Vince

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 9 Sep 2009 19:51:12 -0400

One thing in 5.3 :

   UDP Checksum:  this field MAY be transmitted as zero by an ITR and
      when received by an ETR, MUST accept the packet for decapsulation.

There is something missing here, how about

  when received by an ETR, the ETR MUST accept the packet for  
decapsulation.

      When an ITR transmits a non-zero value, an ETR MAY verify the
      checksum value.  If the checksum is verified, the packet is
      accepted for decapsulation, otherwise, it is silently dropped.

I would do
s/decapsulation,/decapsulation;/
but that is truly a nit.

      Note, even when the UDP checksum is transmitted as zero an
      intervening NAT device can recalculate the checksum and rewrite
      the UDP checksum field to non-zero.  See draft [UDP-TUNNELS] for
      details.

On Sep 9, 2009, at 7:29 PM, Dino Farinacci wrote:

> Here is today's diff file. The only change from the Tuesday diff  
> file is to change the 32-bit nonce length from the Map-Request, Map- 
> Reply, and Map-Register messages to 64-bits in length.
>
> Thanks,
> Dino/Dave/Darrel/Vince
>
> <rfcdiff-lisp-03-to-04.html>
>
>
> <draft-ietf-lisp-04.txt>
>
>
> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 9 Sep 2009 21:23:16 -0700

Consider it changed Marshall.

Dino