Subject: [lisp] A mapping system design-- specification of LISP+ALT

From: "sunletong" <[email-masked]>
Date: Tue, 01 Dec 2009 22:01:25 +0800

Hello All:

I'm a newcomer in this area and please forgive hasty intruding in.  A few days ago rrg collected proposals of Internet scalability solutions, and I raised one based on LISP+ALT which concentrates on how to do EID-to-RLOC mappings. Attached is my proposal. A few summaries listed below:

1. the mapping system  should be run by a neutral body (e.g. public utility), to be independent of ISPs. This is to conform economy incentives and to maximize the system's benefits; besides, any ISP who wants to implement separation could soon benefit from reducing its core routing table by getting map information from the mapping system;

2. a specification of how the mapping system is layered both for IPv4 EID and IPv6 EID: a tradeoff consideration of layer number and node burden is discussed. And two layers with /16 aggregates each layer for IPv4, five layers with /24 aggregates each layer  for IPv6 may be appropriate;

3. two caches in ITR. One for actual mapping cache and the other for map node pointers cache. Note that the later cache is mainly for IPv6 EID. Because in the IPv4 scene, an ITR can afford to store all map nodes (65537 in my proposal). The later cache should greatly decrease the mapping response time and alleviate the upper-layer nodes in the mapping system.

My questions contain:

1. Is it practical to let a neutral body/group run mapping system? They can be another interest group, independent of ISP?

2. One my assertion is that EID prefix should not overlap, for EIDs are assigned to edge sites and they shouldn't be allocated further. Is that correct?

It is too impudent to raising a hand here and if my questions are too naive please forgive me. Any reply will be warmly accepted and i'll be deeply appreciated:)  At last sorry for such long words: )

Best Regards,

Sun Letong

Computer Science and Technology Department of Tsinghua University,
Beijing, China

---

From: David Meyer <[email-masked]>
Date: Tue, 1 Dec 2009 07:53:01 -0800

Sun,

>         I'm a newcomer in this area and please forgive hasty intruding
>    in.  A few days ago rrg collected proposals of Internet scalability
>    solutions, and I raised one based on LISP+ALT which concentrates on how
>    to do EID-to-RLOC mappings.

	Thanks for the thinking on this topic. A few comments:

	First, much of your design seems to key off section 6.2
	("Who contains the actual mappings"). What you say is
	that a multihomed site will with two upstreams will have
	"two ETRs located in different ISPs". I take it you mean
	the ETRs will be in the PEs of those ISPs? If so, we
	looked at this design (and IIRC APT also put the ETRs in
	the PEs). In the LISP+ALT architecture, the ETRs are in
	the CEs. Reasons for siting the ETRs in the CEs include:
	providing the site with control over ingress TE, and the
	issue of who stores which database mappings for the site
	(you raised this one); note that when the ETRs are in the
	site's CE(s), the site can arrange the database mappings
	(and which ETR responds to queries) in any way that
	reaches its policy objctives. This is not the case when
	a site's database mappings are held in its upstream
	provider.

> Attached is my proposal. A few
>    summaries listed below:
> 
>        1. the mapping system  should be run by a neutral body (e.g. public
>    utility), to be independent of ISPs. This is to conform economy
>    incentives and to maximize the system's benefits; besides, any ISP who
>    wants to implement separation could soon benefit from reducing its core
>    routing table by getting map information from the mapping system;

	Yes, though I envision a DNS-like scenario where many
	map-server/resolver providers exist, with some
	distribution mechanism tieing them together (the ALT is
	one example of such a distribution mechanism).

>        2. a specification of how the mapping system is layered both for
>    IPv4 EID and IPv6 EID: a tradeoff consideration of layer number and
>    node burden is discussed. And two layers with /16 aggregates each layer
>    for IPv4, five layers with /24 aggregates each layer  for IPv6 may be
>    appropriate;

	A mapping system like the ALT can have arbritary
	hierarchy. The tradeoff is data-plane fanout (at each
	mapping node) versus the strech that each query
	experienes.  

>        My questions contain:
> 
>       1. Is it practical to let a neutral body/group run mapping system?
>    They can be another interest group, independent of ISP?

	My sense is that this will be driven by economic
	concerns. That is, if someone thinks they can make money
	providing mapping services/infrastructure, they will.

>        2. One my assertion is that EID prefix should not overlap, for EIDs
>    are assigned to edge sites and they shouldn't be allocated further. Is
>    that correct?

	Not sure exactly what you mean here. That said, as long
	as there is interworking required (read: forever), the
	EID and RLOC spaces can not overlap.

>       It is too impudent to raising a hand here and if my questions are
>    too naive please forgive me. 

	Nah, not at all. Its always great for new people to come
	along and question current thinking and have new
	ideas. That is a very good thing that should be
	encouraged.

> Any reply will be warmly accepted and i'll be deeply
>  appreciated:)  At last sorry for such long words: ) 

	No problem, and again, thanks for your thinking on this
	subject.  	

	Dave